Αποστολέας Θέμα: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????  (Αναγνώστηκε 4396 φορές)

joyjohnnickname

  • Φοιτητής στο Τμήμα Μηχανικών Πληροφορικής και Τηλεπικοινωνιών του Πανεπιστημίου Δυτικής Μακεδονίας
  • Οπαδός
  • **
  • Μηνύματα: 17
  • Be the change you want to see in the world
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #15 στις: 02 Απρ 2010, 11:34:07 πμ »
Πάντως για αυτό που είπατε για το βιβλίο, αν σκεφτείτε ότι θεωρείται από τα καλύτερα βιβλία για το Λύκειο, φανταστείτε πως είναι τα άλλα! Πάντως σαν ύλη θεωρείται καλό... Όσο για το θέμα με τα ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ κλπ, συμφωνώ με μία παραπάνω ιδέα... Να βάζουμε σε όλα "Τέλος". Αφού αναφέρουμε το είδος (Αλγόριθμος ή ΠΡΟΓΡΑΜΜΑ) στην αρχή. Έτσι δεν θα μπερδεύονται οι μαθητές και με το διάγραμμα ροής (Πόσες φορές έχω δει στην έλλειψη του τέλους "Τέλος_όνομα_αλγορίθμου"...). Για αυτό που ανέφερε ο κύριος Λάμπρος Μπουκουβάλας πιστεύω πως έχει διορθωθεί, τουλάχιστον σε αυτές τις σελίδες το δικό μου τετράδιο μαθητή γράφει απλά "ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ"  :angel:
Σ.Παπαλουκάς (Μηχανικός Η/Υ και Πληροφορικής): "Βασικά, με τα μωρά,
πριν φτάσουν τα 2 τους χρόνια, δεν μπορείς να κάνεις και πολλά,
γιατί δεν είναι interactive..." (!)


sdancer75

  • Οπαδός
  • **
  • Μηνύματα: 15
  • “I am easily satisfied only with the very best.”
    • Paradox Interactive
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #16 στις: 21 Απρ 2010, 11:03:18 πμ »
Καλημέρα σας!
Είμαι μαθήτρια και καινουργια στο Στέκι!Χαίρομαι πολύ που σας βρήκα γιατί έχω ερωτηση....
Ο καθηγητής στο σχολείο είπε πως βάζουμε όνομα μετα το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ, ενώ ο καθηγητής στο φροντιστήριο μου είπε πως δε βάζουμε.Τελικά τι ισχύει? γιατί μπερδεύτηκα...
Ευχαριστώ

Σε κάθε πρόγραμμα και σε οποιαδήποτε γλώσσα προγραμματισμού υπάρχει αρχή και τέλος. Αν δεν το βάλεις είσαι λάθος διότι οποιοσδήποτε compiler ή interpreter θα σου βγάλει λάθος πριν καν προλάβεις να τρέξεις το πρόγραμμα (δηλαδή κάτι σαν synatax error).
G. Papaioannou

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #17 στις: 21 Απρ 2010, 11:28:20 πμ »
Πάντως η ψευδογλώσσα δεν έχει ΑΡΧΗ
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2787
  • Πύργος Ηλείας
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #18 στις: 21 Απρ 2010, 12:11:47 μμ »
Σε κάθε πρόγραμμα και σε οποιαδήποτε γλώσσα προγραμματισμού υπάρχει αρχή και τέλος. Αν δεν το βάλεις είσαι λάθος διότι οποιοσδήποτε compiler ή interpreter θα σου βγάλει λάθος πριν καν προλάβεις να τρέξεις το πρόγραμμα (δηλαδή κάτι σαν synatax error).

Έχω την εντύπωση ότι η afroditi ρωτάει άλλο πράγμα...: Αν δεξιά από το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ πρέπει να μπαίνει και το όνομα το προγράμματος στη ΓΛΩΣΣΑ...

Λάμπρος Μπουκουβάλας

  • Η παιδεία είναι: στους φτωχούς, ΠΛΟΥΤΟΣ. Στους πλούσιους, ΣΤΟΛΙΔΙ. Στους νέους, ΚΑΙ ΤΑ ΔΥΟ (Διογένης) !
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 1226
    • Το μπλογκάκι μου
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #19 στις: 21 Απρ 2010, 12:20:29 μμ »
Μην μας διαφεύγει κ. Παπαϊωάννου ότι απευθυνόμαστε σε μαθητές, οι οποίοι διδάσκονται μια ψεύτικη γλώσσα απλά για να πάρουν μια ιδέα, χωρίς να έχουν σοβαρό θεωρητικό υπόβαθρο. Συμφωνώ με το Νίκο, η απορία της Αφροδίτης οφείλεται σε ασάφεια του σχολικού βιβλίου.
Λάμπρος Μπουκουβάλας
MSc - MRes

http://blogs.sch.gr/lambrosbouk

Ο Θουκυδίδης  (που τον διαβάζουν οι ξένοι, αλλά όχι εμείς)  έγραφε: «Αταλαίπωρος τοις πολλοίς η ζήτησις της αληθείας, και επί τα ετοίμα μάλλον τρέπονται» (Ι, 20, 3). Οι περισσότεροι δηλαδή αναζητούν αβασάνιστα την αλήθεια και στρέφονται σε ό,τι βρίσκουν έτοιμο. Δεν προβληματίζονται…

sdancer75

  • Οπαδός
  • **
  • Μηνύματα: 15
  • “I am easily satisfied only with the very best.”
    • Paradox Interactive
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ????
« Απάντηση #20 στις: 21 Απρ 2010, 04:52:52 μμ »
Μην μας διαφεύγει κ. Παπαϊωάννου ότι απευθυνόμαστε σε μαθητές, οι οποίοι διδάσκονται μια ψεύτικη γλώσσα απλά για να πάρουν μια ιδέα, χωρίς να έχουν σοβαρό θεωρητικό υπόβαθρο. Συμφωνώ με το Νίκο, η απορία της Αφροδίτης οφείλεται σε ασάφεια του σχολικού βιβλίου.

Δε διαφωνώ μαζί σου, αλλά ακόμη και τη ΓλωσσοΜάθεια να χρησιμοποιήσεις θα βρείς την εντολή ΑΡΧΗ. Δεν είναι βέβαια σε καμία περίπτωση σοβαρό λάθος, αλλά εγώ προσωπικά στην αξιολόγηση των γραπτών αφαιρώ μονάδες για τη συγκεκριμένη παράλληψη από τα γραπτά τα οποία δεν θεωρώ τέλεια. Πάντως σαν συμπέρασμα είναι ότι και να το βάλεις, δεν πρόκειται να χάσεις μονάδες σε καμία περίπτωση οπότε γιατί όχι ? Τώρα αν χρειάζεται το όνομα μετά το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ αυτό είναι προαιρετικό αλλά συνήθως δεν μπαίνει.

G. Papaioannou