Αποστολέας Θέμα: θέμα 2(Γ)&θέμα 3  (Αναγνώστηκε 22566 φορές)

Thanasis Daskaloudis

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #15 στις: 27 Μαΐ 2009, 05:56:59 μμ »
Αν κάποιος μαθητής γράψει στο 2Γ:

Για δ απο 1 μέχρι  (α mod 10)
γ<-γ+β
Τέλος_επανάληψης

πρέπει να είναι σωστό. Χρησιμοποιεί μόνο τις α,β,γ,δ  βγάζει το ίδιο αποτέλεσμα γ.
Τι λέτε;

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #16 στις: 27 Μαΐ 2009, 06:02:56 μμ »
αφου δε χρησιμοποιείται το δ εντός τους βρόχου, σωστό μου φαίνεται

nikosx

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 375
  • ___
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #17 στις: 27 Μαΐ 2009, 06:05:50 μμ »
Για δ απο amod10 μέχρι 0 με_βήμα -1
  Αν δ>0 τότε
    γ <-- γ + β
  Τέλος_αν
Τέλος_επανάληψης

Για αυτή τη λύση ποια είναι η γνώμη σας;
Νίκος Ξένος
Καθηγητής Πληροφορικής
nxenos@sch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #18 στις: 27 Μαΐ 2009, 06:07:38 μμ »
πάλι, νομιζω οτι η τελικη τιμη του γ, είναι η σωστή σε κάθε περίπτωση

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2837
  • Πύργος Ηλείας
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #19 στις: 27 Μαΐ 2009, 06:08:13 μμ »
Για δ απο amod10 μέχρι 0 με_βήμα -1
  Αν δ>0 τότε
    γ <-- γ + β
  Τέλος_αν
Τέλος_επανάληψης

Για αυτή τη λύση ποια είναι η γνώμη σας;

Θα συμφωνήσω...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #20 στις: 27 Μαΐ 2009, 06:26:30 μμ »
Και εγώ συμφωνώ σωστό είναι. Μάλλον σε αυτό το θέμα θα δούμε αρκετές διαφορετικές λύσεις και πρέπει να είμαστε πολύ προσεκτικοί.
Ξαναδίνω κάτω μια άλλη λύση που πόσταρα όταν δεν υπήρχε ακόμα το συγκεκριμένο thread. Νομίζω είναι η πιο σύντομη

Κώδικας: [Επιλογή]
Για δ από 0 μέχρι 0   
    γ <- γ + β*(α mod 10)
       Τέλος_Επανάληψης
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 988
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #21 στις: 27 Μαΐ 2009, 06:33:59 μμ »
Βέβαια το νόημα του αλγορίθμου είναι ο πολλαπλασιασμός χωρίς τον τελεστή * .

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #22 στις: 27 Μαΐ 2009, 06:35:09 μμ »
Α , μη μου το χαλάς τώρα δεν έλεγαν πουθενά ότι δεν μπορώ να χρησιμοποιήσω * στην μετατροπή.
Ας πρόσεχαν ;)

Βέβαια το νόημα του αλγορίθμου είναι ο πολλαπλασιασμός χωρίς τον τελεστή * .
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1150
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #23 στις: 28 Μαΐ 2009, 01:35:20 πμ »
Και μια άλλη λύση που σκέφτηκαν τα παιδιά

α<--α mod 10
Για δ απο α μέχρι 1 με_βήμα -1
γ<--γ+β
Τέλος_Επανάληψης

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 610
    • Ανάπτυξη Εφαρμογών
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #24 στις: 28 Μαΐ 2009, 02:50:34 πμ »
Όταν δίνουμε μία μετατροπή της όσο στη για νομίζω ότι είναι χρήσιμο να ταυτίζεται και η τελική τιμή του δ κάτι που σε πολλές λύσεις που ειπώθηκαν δεν ταυτίζεται. Το δ μετά το τέλος επανάληψης της όσο μπορεί να παίζει μεγάλη σημασία στην εξέλιξη του αλγόριθμου την οποία βέβαια δεν γνωρίζουμε.

Συνάδελφοι καλημέρα
« Τελευταία τροποποίηση: 28 Μαΐ 2009, 03:01:03 πμ από ntzios kostas »
Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

elf

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 312
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #25 στις: 28 Μαΐ 2009, 04:26:47 μμ »
Συμφωνώ, αλλά σε ό,τι αφορά τη βαθμολόγηση δεν νομίζω ότι είναι σωστό να κοπούν μονάδες, αν το αποτέλεσμα είναι το ίδιο. Να τι έδωσε ένας μαθητής μου:

ΓΙΑ δ ΑΠΟ 1 ΜΕΧΡΙ α MOD 10
      γ <- γ+β
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Βέβαια η τιμή του δ δεν είναι η ίδια, αλλά τότε το:

Για δ από (α mod 10)-1 ΅έχρι 0 ΅ε_βή΅α -1
γ←γ+β
Τέλος_επανάληψης

που προτείνουν συνάδελφοι (γιατί η δ<-δ-1 δεν είναι η τελευταία εντολή του βρόγχου αλλά η πρώτη) πρέπει να είναι επίσης λάθος...

Όταν δίνουμε μία μετατροπή της όσο στη για νομίζω ότι είναι χρήσιμο να ταυτίζεται και η τελική τιμή του δ κάτι που σε πολλές λύσεις που ειπώθηκαν δεν ταυτίζεται. Το δ μετά το τέλος επανάληψης της όσο μπορεί να παίζει μεγάλη σημασία στην εξέλιξη του αλγόριθμου την οποία βέβαια δεν γνωρίζουμε.

Συνάδελφοι καλημέρα

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #26 στις: 28 Μαΐ 2009, 04:32:46 μμ »
Κώστα, έχεις δίκιο και είναι ωραία παρατήρηση.

Στον συγκεκριμένο αλγόριθμο, το δ αρχικοποιείται σε νέα επανάληψη, οπ΄τε είναι το ίδιο.

Άλλωστε η εκφώνηση λέει:"Να γράψετε τμήμα αλγορίθμου, που θα έχει το ίδιο αποτέλεσμα με το παρακάτω τμήμα"



Να τι έδωσε ένας μαθητής μου:

ΓΙΑ δ ΑΠΟ 1 ΜΕΧΡΙ α MOD 10
      γ <- γ+β
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

για κάθε τιμή του α ως είσοδο, θα δίνει τα ίδια αποτελέσματα;

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #27 στις: 28 Μαΐ 2009, 04:58:02 μμ »
Οι 2 περιπτώσεις που εξετάζεις δεν είναι το ίδιο. Στην πρώτη περίπτωση έχεις λάθος τελικό αποτελέσμα. Το δ δεν γίνεται μηδέν. Στην 2η περίπτωση η σειρά με την οποία γίνονται οι υπολογισμοί αλλάζει. Εδώ τώρα χωράει πολύ κουβέντα για το αν είναι ολόσωστο, αλλά είναι σίγουρα πιο σωστό από το παραπάνω. Βγάζει τα ίδια σωστά αποτελέσματα.
   Σε συτό πάντως που λες για το δ <- δ -1 ότι αλλάζει σειρά έχεις κάποιο δίκιο, αλλά τα έχουμε ξανασυζητήσει. Όταν δεν ορίζεται με αυστηρότητα η ισοδυναμία αλγορίθμων τότε έχουμε τέτοια προβληματάκια, και αυτό που μας ενδιαφέρει σε πρώτη φάση (και εξετάζουμε) είναι να βγάζει τουλάχιστον το ίδιο αποτέλεσμα

Συμφωνώ, αλλά σε ό,τι αφορά τη βαθμολόγηση δεν νομίζω ότι είναι σωστό να κοπούν μονάδες, αν το αποτέλεσμα είναι το ίδιο. Να τι έδωσε ένας μαθητής μου:

ΓΙΑ δ ΑΠΟ 1 ΜΕΧΡΙ α MOD 10
      γ <- γ+β
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Βέβαια η τιμή του δ δεν είναι η ίδια, αλλά τότε το:
Για δ από (α mod 10)-1 ΅έχρι 0 ΅ε_βή΅α -1
γ←γ+β
Τέλος_επανάληψης
που προτείνουν συνάδελφοι (γιατί η δ<-δ-1 δεν είναι η τελευταία εντολή του βρόγχου αλλά η πρώτη) πρέπει να είναι επίσης λάθος...
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #28 στις: 28 Μαΐ 2009, 05:10:12 μμ »
Άλλωστε η εκφώνηση λέει:"Να γράψετε τμήμα αλγορίθμου, που θα έχει το ίδιο αποτέλεσμα με το παρακάτω τμήμα"

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 610
    • Ανάπτυξη Εφαρμογών
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #29 στις: 28 Μαΐ 2009, 05:44:40 μμ »

Βέβαια η τιμή του δ δεν είναι η ίδια, αλλά τότε το:

Για δ από (α mod 10)-1 ΅έχρι 0 ΅ε_βή΅α -1
γ←γ+β
Τέλος_επανάληψης

που προτείνουν συνάδελφοι (γιατί η δ<-δ-1 δεν είναι η τελευταία εντολή του βρόγχου αλλά η πρώτη) πρέπει να είναι επίσης λάθος...


Νομίζω ότι είναι λάθος και πρέπει να κοπεί κάποιο μόριο και από την απάντηση αυτή.

Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...