Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Δομή επιλογής => Γ΄ Λυκείου => Εντολή ΑΝ => Μήνυμα ξεκίνησε από: Vagelis στις 27 Δεκ 2002, 12:26:29 μμ

Τίτλος: Ασκήσεις στις δομές επιλογής
Αποστολή από: Vagelis στις 27 Δεκ 2002, 12:26:29 μμ
Προτείνετε ασκήσεις... Άλυτες ή λυμένες
Τίτλος: Φ127 - Άσκηση με απλή - σύνθετη επιλογή, κλιμακωτό
Αποστολή από: Sergio στις 21 Ιαν 2003, 11:23:21 μμ
Συνάδελφοι... καλή αρχή :) (στη λίστα τουλάχιστον:) γιατί οι υπόλοιποι... έχουμε καιρό που ... αρχίσαμε  :-/)

Η άσκηση που ακολουθεί, συνδιάζει την απλή και τη σύνθετη επιλογή με τη λογική του 'συσσωρευτικού υπολογισμού' ποσότητας, προκειμένου να δώσει σχετικά απλή αλγοριθμική λύση και να διευκολύνει τους μαθητές να σκέφτονται '.. σπάζοντας το πρόβλημα σε επιμέρους υποπροβλήματα ...'

Σίγουρα δεν είναι η πρώτη - πρώτη άσκηση που θα δείχναμε στους μαθητές μας στις δομές επιλογής, συνδιάζει όμως αρκετές περιπτώσεις (απλή - σύνθετη - κλιμακωτά) σε μία άσκηση σχετικά ... βατή

Είναι δοκιμασμένη στο διερμηνευτή οπότε μπορεί να γίνει copy'n'paste.

Η εκφώνηση συμπεριλαμβάνεται σε σχόλια.
_____________________________________________________________

! - Ε Κ Φ Ω Ν Η Σ Η -
! Το κόστος της πολεοδομικής άδειας για οικοδομή μέχρι 6 ορόφους,
! ανέρχεται σε 500 ευρώ ανά όροφο.
! Αν η οικοδομή ξεπερνάει τους 6 ορόφους, το κόστος γίνεται
! 700 ευρώ για κάθε επιπλέον όροφο.
! Η αμοιβή του μηχανικού που κάνει τη μελέτη είναι 1000 ευρώ
! και 1500 ευρώ αντίστοιχα.
! Σε πολυόροφες οικοδομές (πάνω από 10 ορόφους)
! υπάρχει μία επιπλέον επιβάρυνση 5,000 ευρώ για φόρος πολυτέλειας.
! Κατασκευάστε πρόγραμμα που θα υπολογίζει το κόστος της άδειας,
! την αμοιβή του μηχανικού και τη συνολική δαπάνη και θα τα εμφανίζει
!
! - Υ Λ Ο Π Ο Ι Η Σ Η -
!
Πρόγραμμα Οικοδομή
Μεταβλητές
 ακέραιες: Αριθμός_Ορόφων, Αριθμός_Επιπλέον_Ορόφων
 πραγματικές: Συνολική_Δαπάνη, Κόστος_Άδειας, Αμοιβή_Μηχανικού, Φόρος_Πολυτέλειας
Αρχή
! Ε Ι Σ Ο Δ Ο Σ
!
 Γράψε 'Πόσους ορόφους έχει η οικοδομή'
 Διάβασε Αριθμός_Ορόφων
!
! Ε Π Ε Ξ Ε Ρ Γ Α Σ Ι Α
!
 Συνολική_Δαπάνη <-- 0
!
! Κόστος Άδειας
!
 Αν Αριθμός_Ορόφων > 6 τότε
   Αριθμός_Επιπλέον_Ορόφων <-- Αριθμός_Ορόφων-6
   Κόστος_Άδειας <-- 6*500+Αριθμός_Επιπλέον_Ορόφων*700
 αλλιώς
   Κόστος_Άδειας <-- Αριθμός_Ορόφων*500
 τέλος_αν
 Συνολική_Δαπάνη <-- Συνολική_Δαπάνη+Κόστος_Άδειας
!
! Αμοιβή Μηχανικού
!
 Αν Αριθμός_Ορόφων > 6 τότε
   Αμοιβή_Μηχανικού <-- 1500
 αλλιώς
   Αμοιβή_Μηχανικού <-- 1000
 τέλος_αν
 Συνολική_Δαπάνη <-- Συνολική_Δαπάνη+Αμοιβή_Μηχανικού
!
! Φόρος ... Πολυτέλειας
!
 Αν Αριθμός_Ορόφων > 10 τότε
   Φόρος_Πολυτέλειας <-- 5000
   Συνολική_Δαπάνη <-- Συνολική_Δαπάνη+Φόρος_Πολυτέλειας
 τέλος_αν
!
! Ε Ξ Ο Δ Ο Σ
!
 Γράψε 'Η άδεια θα κοστίσει ', Κόστος_Άδειας, ' ευρώ'
 Γράψε 'Ο μηχανικός θα αμοιφθεί με ', Αμοιβή_Μηχανικού, ' ευρώ'
 Γράψε 'Η συνολική δαπάνη θα είναι ', Συνολική_Δαπάνη, ' ευρώ'
Τέλος_προγράμματος
Τίτλος: Απ: Ασκήσεις στις δομές επιλογής
Αποστολή από: Neo στις 30 Απρ 2006, 02:13:45 μμ
Τρελό ασκησάκι, :) μου άρεσε
Τίτλος: Απ: Ασκήσεις στις δομές επιλογής
Αποστολή από: Sergio στις 30 Απρ 2006, 11:45:33 μμ
Τι μου θύμισες τώρα ρε Μανώλη ... :)

Πού την "ξέθαψες" αυτή την άσκηση; 

Πάντως πλέον, δε θα πρότεινα λύση με αυτό τον τρόπο... τουλάχιστον όσον αφορά στην "φλύαρη" χρήση άχρηστων μεταβλητών (αριθμός_επιπλέον_ορόφων, φόρος_πολυτέλειας κ.λπ)

Πάντως με γύρισες αρκετά πίσω... στις εποχές που οι ημερήσιες επισκέψεις στο στέκι δεν ξεπερνούσαν τις 100 τη μέρα :)
Τίτλος: Απ: Ασκήσεις στις δομές επιλογής
Αποστολή από: droopy στις 24 Σεπ 2007, 05:41:06 μμ
MIA ENΑΛΛΑΚΤΙΚΗ ΛΥΣΗ ΤΗΣ ΑΣΚΗΣΗΣ ΤΟΥ SERGIO

ΦΚ<--0           !ΦΟΡΟΣ ΚΛΗΡΟΝΟΜΙΑΣ
ΔΙΑΒΑΣΕ ΟΡ     !ΟΡΟΦΟΥΣ

ΑΝ ΟΡ<=6 ΤΟΤΕ
        ΚΑ <-- ΟΡ *500    !ΚΑ ΚΟΣΤΟΣ ΑΔΕΙΑΣ
        ΑΜ <-- 1000        !ΑΜ ΑΜΟΙΒΗ ΜΗΧΑΝΙΚΟΥ

ΑΛΛΙΩΣ_ΑΝ ΟΡ<=10
       ΚΑ <-- 6*500 + (ΟΡ-6)*700
       ΑΜ <-- 1500

ΑΛΛΙΩΣ
       ΚΑ <-- 6*500 + (OP-6)*700
       ΑΜ <-- 1500
       ΦΚ <-- 5000
ΤΕΛΟΣ_ΑΝ

ΣΚ <-- ΚΑ + ΑΜ + ΦΚ       !ΣΥΝΟΛΙΚΟ ΚΟΣΤΟΣ

ΕΜΦΑΝΙΣΕ ΚΑ,ΑΜ,ΣΚ