Το Στέκι των Πληροφορικών

Γενικά => Τεχνική υποστήριξη => Linux => Μήνυμα ξεκίνησε από: gmav στις 20 Ιούν 2017, 10:06:54 μμ

Τίτλος: Πρόβλημα σε νέα εγκατάσταση 16.04
Αποστολή από: gmav στις 20 Ιούν 2017, 10:06:54 μμ
Καλησπέρα σε όλους,
έκανα μια εγκατάσταση της 16.04 σε ένα καινούριο σύστημα (Intel core i3, Intel onboard graphics, 8GB RAM), και από την πρώτη κιόλας φορά εμφανίστηκε κατά την εκκίνηση η οθόνη που επισυνάπτω, από όπου δε μπορώ να κάνω τίποτα. Αφού έκανα login με CTRL+ALT+F1 και έτρεξα startx εμφανίστηκε το desktop, από τις ρυθμίσεις είδα ότι επέλεγε να το εμφανίζει παράλληλα σε δυο monitors (εγώ έχω μόνο ένα συνδεδεμένο εννοείται, το άλλο το έλεγε Laptop Monitor ή κάπως έτσι -δεν είμαι μπροστά να το δω). Απενεργοποίησα  το ανύπαρκτο monitor, έριξα και την ανάλυση αλλά ενώ όλα έδειχναν εντάξει, όταν έκανα restart εμφανίστηκε πάλι η ίδια οθόνη.. Επίσης να αναφέρω ότι ο xserver έπεφτε αρκετές φορές, και πως έχω ξανακάνει εκ νέου εγκατάσταση, με τα ίδια πάντα αποτελέσματα.. Δεν είδα να έχει αναφερθεί κάτι αντίστοιχο στο φόρουμ, οπότε αν έχει κάποιος καμιά ιδέα.. (σε ένα γενικότερο ψάξιμο που έκανα πάλι δεν είδα κάτι αντίστοιχο, ή δεν ήξερα κ πως ακριβώς να θέσω το ερώτημα)
Τίτλος: Απ: Πρόβλημα σε νέα εγκατάσταση 16.04
Αποστολή από: alkisg στις 20 Ιούν 2017, 10:56:09 μμ
Για να απενεργοποιήσεις "κεντρικά" το ανύπαρκτο μόνιτορ, δες:
https://alkisg.mysch.gr/steki/index.php?topic=7029.msg79772#msg79772

Για τα κρασαρίσματα του xorg, όταν συμβεί, έλα από το IRC (http://ts.sch.gr/wiki/IRC) στο ακριβώς επόμενο login, να μαζέψουμε τα logs για να το αναφέρουμε.
Τίτλος: Απ: Πρόβλημα σε νέα εγκατάσταση 16.04
Αποστολή από: gmav στις 21 Ιούν 2017, 09:50:31 πμ
Καλημέρα Άλκη,
το πρώτο θέμα λύθηκε, ευχαριστώ για τη βοήθεια, για το άλλο θα περιμένω να δω αν ξανασυμβεί
Τίτλος: Απ: Πρόβλημα σε νέα εγκατάσταση 16.04
Αποστολή από: jim_katsar στις 21 Ιούν 2017, 11:32:26 μμ
Το ίδιο πρόβλημα το συνάντησα σε τερματικά. Να σημειωθεί οτι τα τερματικά είναι καινούρια με uefi και μας ήρθαν μετά τις 15/6 γι' αυτό κ δεν ασχολήθηκα περισσότερο. Από Σεπτέμβρη σκέφτηκα βλέπουμε..
Ομως αφού τέθηκε ως θέμα να ρωτήσω, και εκεί πάλι θα λυθεί με τον ίδιο τρόπο;
Τίτλος: Απ: Πρόβλημα σε νέα εγκατάσταση 16.04
Αποστολή από: alkisg στις 22 Ιούν 2017, 08:19:48 πμ
Οι παράμετροι του πυρήνα (kernel parameters) στον server μπαίνουν με την εντολή sudo dpkg-reconfigure grub-pc, και αποθηκεύονται αυτόματα στα αρχεία /etc/default/grub και /boot/grub/grub.cfg.
Αντίθετα, για τους clients μπαίνουν στο αρχείο /etc/ltsp/update-kernels.conf και μεταφέρονται αυτόματα στο αρχείο /var/lib/tftpboot/ltsp/i386/pxelinux.cfg/default κατά τη δημοσίευση.
Αν θέλουμε ξεχωριστές παραμέτρους για κάθε client, φτιάχνουμε αρχειάκια με βάση τις mac-address τους, στο /var/lib/tftpboot/ltsp/i386/pxelinux.cfg/01-mac-address.

Παρόλα αυτά για το συγκεκριμένο δεν χρειάζεται να κάνουμε κάτι, αφού τους το αναφέραμε και το λύσανε, θα έρθει ως update τον Αύγουστο.
Τίτλος: Απ: Πρόβλημα σε νέα εγκατάσταση 16.04
Αποστολή από: jim_katsar στις 22 Ιούν 2017, 11:47:53 μμ
Για να ξεκαθαρίσω...
Για τον server δίνω την εντολή: sudo dpkg-reconfigure grub-pc, και περνάω την παράμετρο: video=eDP-1:d
Για τους clients πάω στο αρχείο: /etc/ltsp/update-kernels.conf και περνάω την παράμετρο: video=eDP-1:d (ουσιαστικά προσθέτων μία γραμμή με το προηγούμενο) και στη συνέχει 'δημοσίευση εικονικού'

Και για ξεχωριστές παραμέτρους για κάθε client ( με βάση τη mac-address) φτιάχνω αρχειάκια: /var/lib/tftpboot/ltsp/i386/pxelinux.cfg/01-mac-address και περνάω όποια παράμετρο θέλω (όπου 01-mac-address = η mac του κάθε client )

Σωστά; Αν κάνω κάπου λάθος διόρθωσέ με. Ευχαριστώ.
Τίτλος: Απ: Πρόβλημα σε νέα εγκατάσταση 16.04
Αποστολή από: alkisg στις 23 Ιούν 2017, 08:29:32 πμ
Όπως τα λες είναι. Στο αρχείο /etc/ltsp/update-kernels.conf πειράζουμε τη γραμμή CMDLINE_LINUX_DEFAULT="init=/sbin/init-ltsp forcepae video=eDP-1:d".
Στο 01-mac-address, το 01- παραμένει, η mac μπαίνει μετά το 01.