Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γ΄ Λυκείου => Πολυδιάστατοι πίνακες => Μήνυμα ξεκίνησε από: ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ στις 16 Φεβ 2015, 11:06:56 πμ

Τίτλος: ασκησεις στους πινακες
Αποστολή από: ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ στις 16 Φεβ 2015, 11:06:56 πμ
Καλημέρα σε όλους τους συναδέλφους.
Θα ήθελα να ρωτήσω αν είναι λάθος το να υλοποιεί ένα παιδί πολλά ερωτήματα μαζί.

π.χ. θέλουμε να βρόυμε το άθροισμα κατά γραμμές σε ένα δισδιάστατο πίνακα και το max

max<-Γ[1,1]
ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 16
    S<-0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 30
        ΑΝ Γ[i,j]>max ΤΟΤΕ
           max<-Γ[i,j]
        ΤΕΛΟΣ_ΑΝ
        S<-S + Γ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Τίτλος: Απ: ασκησεις στους πινακες
Αποστολή από: petrosp13 στις 16 Φεβ 2015, 11:14:49 πμ
Γιατί να είναι λάθος;;
Απλά προτείνω να τοποθετεί σχόλια δίπλα σε κάποιες γραμμές κώδικα για να είναι εμφανές ότι υλοποιεί διαφορετικά ερωτήματα συγχρόνως
Τίτλος: Απ: ασκησεις στους πινακες
Αποστολή από: bugman στις 22 Σεπ 2015, 12:51:14 μμ
Λείπει η έξοδος (και η είσοδος)...αλλά μπορεί να είναι οκ για την άσκηση...
Δεν εμφανίζει τα αποτελέσματα!