Το Στέκι των Πληροφορικών

Γενικά => Τεχνική υποστήριξη => Linux => Μήνυμα ξεκίνησε από: themelis στις 06 Σεπ 2012, 10:53:55 πμ

Τίτλος: Πρόβλημα με την εκκίνηση των client
Αποστολή από: themelis στις 06 Σεπ 2012, 10:53:55 πμ
Καλημέρα και καλή χρονιά,

έκανα εγκατάσταση το Ubuntu 12.04 μαζί με το sch-scripts, αλλά κανένα από τα τερματικά δεν εκκινούν μέσω δικτύου. Πιο συγκεκριμένα, ενώ είναι ρυθμισμένα να ξεκινούν μέσω δικτύου, προφανώς δε βρίσκουν το ltsp image και στο τέλος εκκινούν από τον εσωτερικό σκληρό δίσκο. Το λειτουργικό που είναι εγκατεστημένο στο σκληρό δίσκο είναι Ubuntu 10.04 και αφού κάνω login βλέπω ότι έχουν πάρει κανονικά ΙΡ της μορφής 10.138.18.χχ και έχουν πρόσβαση στο διαδίκτυο. Στο server έχω βάλει στατική ΙΡ 10.138.18.10, αλλά έχω δοκιμάσει και με δυναμική χωρίς αποτέλεσμα. Κοίταξα το syslog και παρατήρησα ότι  κάθε φορά που ανοίγω ένα τερματικό εισάγεται το παρακάτω μήνυμα

Παράθεση
server dnsmasq-dhcp[4277]: no address range available for DHCP request via eth0

Υπάρχει κάποιο πρόβλημα με την ρύθμιση του dnsmasq?

Ευχαριστώ εκ των προτέρων.

Υ.Γ. Μέχρι το τέλος της προηγούμενης χρονιάς όλα λειτουργούσαν καλά με Ubuntu 10.04 & sch-scripts και δεν έχει γίνει καμιά αλλαγή στο υλικό του εργαστηρίου.
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: elvor στις 06 Σεπ 2012, 11:19:50 πμ
Το ίδιο ακριβώς πρόβλημα έχω και εγώ.
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: odysseas στις 06 Σεπ 2012, 11:30:59 πμ
Στο dnsmasq.conf δοκιμάστε να αποσχολιάσετε τη γραμμή που κάνει το dnsmasq να λειτουργεί ως dhcp proxy:
Κώδικας: [Επιλογή]
dhcp-range=192.168.1.10,proxyκαι να σχολιάσετε την επόμενη γραμμή:
Κώδικας: [Επιλογή]
#dhcp-range=192.168.67.20,192.168.67.250,8h
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: alkisg στις 06 Σεπ 2012, 11:33:45 πμ
Δώστε λίγο την παρακάτω εντολή για να ξαναφτιαχτεί το dnsmasq configuration:
Κώδικας: Text
  1. sudo ltsp-config dnsmasq --overwrite
  2.  

Εάν και μετά από αυτό δεν ξεκινήσουν τα τερματικά, επεξεργαστείτε χειρωνακτικά τις ρυθμίσεις του dnsmasq πηγαίνοντας στο μενού Εξυπηρετητής → Αρχεία ρυθμίσεων → Επεξεργασία ρυθμίσεων dnsmasq. Μας ενδιαφέρουν οι γραμμές που ξεκινάνε από "dhcp-range".

Επίσης, αν κάποιος έχει κάνει αναβάθμιση αντί για καθαρή εγκατάσταση, να δούμε λίγο τι αρχεία ρυθμίσεων έχουν ξεμείνει (του LTSP, του dnsmasq κτλ), τα οποία μπορεί να δημιουργούν προβλήματα.
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: themelis στις 06 Σεπ 2012, 11:46:25 πμ
Έβγαλα το σχόλιο από τη γραμμή

Παράθεση
dhcp-range=10.0.2.2,proxy

και άλλαξα την τιμή σε 10.138.18.2

Επίσης, σχολίασα τη γραμμή:

Παράθεση
#dhcp-range=192.168.67.20,192.168.67.250,8h

Πλέον τα τερματικά εκκινούν κανονικά. Ευχαριστώ πολύ.
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: artemis στις 14 Σεπ 2012, 01:00:11 μμ
Εγώ πάλι έκανα αναβάθμιση από την έκδοση 10.04 στην 12.04 και οι clients δεν ξεκινούν. Απεγκατέστησα από τον server το πακέτο tftpd-hpa, αλλά πάλι οι clients δεν ξεκινούν. Άλλαξα και τις ρυθμίσεις του dnsmasq αλλά πάλι τα ίδια.
Μήπως να έκανα μια καθαρή εγκατάσταση;
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: alkisg στις 14 Σεπ 2012, 02:49:23 μμ
Το πρόβλημα είναι ότι το LTSP κάνει ρυθμίσεις σε διάφορα αρχεία στο server (/etc/ltsp, /etc/nbd-server, /etc/inetd.conf, /etc/dnsmasq.d, /var/lib/tftpboot...), και ότι αυτές οι ρυθμίσεις αλλάζουν αρκετά ανά έκδοση του LTSP. Οπότε σαν πακέτο το LTSP είναι λίγο ζόρικο στα upgrades, γι' αυτό και προτείνονται καθαρές εγκαταστάσεις.

Όμως αν κάποιος έχει κάνει αναβάθμιση, ας με βρει στο IRC, για να δω ακριβώς ποιες εντολές χρειάζονται για να φτιάξει το πρόβλημα, ώστε να τις γράψουμε στο wiki για όσους προτιμήσουν να κάνουν αναβάθμιση.
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: za√‘ag στις 18 Σεπ 2012, 03:54:22 μμ
Κάποιοι clients εμφανίζουν στην εκκίνηση την εικόνα 2 και οι άλλοι (και ο server) την εικόνα 1

Επίσης όλοι οι χρήστες (πλην του teacher) μετά τη σύνδεσή τους ΔΕΝ εμφανίζουν το όνομά τους πάνω δεξιά.

Είναι φυσιολογικά;
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: alkisg στις 18 Σεπ 2012, 04:49:51 μμ
2.jpg: η κάρτα γραφικών του client υποστηρίζει KMS (http://wiki.debian.org/KernelModesetting).
1.jpg: η κάρτα γραφικών του client δεν υποστηρίζει KMS.
Το όνομα δεν εμφανίζεται πάνω δεξιά στους clients: ναι, είναι φυσιολογικό στο LTSP, αν και καλό θα είναι να το φτιάξουμε κάποτε.
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: za√‘ag στις 18 Σεπ 2012, 07:47:22 μμ
2.jpg: η κάρτα γραφικών του client υποστηρίζει KMS (http://wiki.debian.org/KernelModesetting).
1.jpg: η κάρτα γραφικών του client δεν υποστηρίζει KMS.
Το όνομα δεν εμφανίζεται πάνω δεξιά στους clients: ναι, είναι φυσιολογικό στο LTSP, αν και καλό θα είναι να το φτιάξουμε κάποτε.

Ο server υποστηρίζει KMS ... Εχει κάρτα NVIDIA και δεν έχει πρόβλημα

Τα ονόματα εμφανίζονταν με την προηγούμενη έκδοση.

Το κακό είναι ότι το μενού του unity δεν μου αρέσει καθόλου και η μετάβαση των παιδιών σε περιβάλλον linux θα πρέπει να είναι απλή και να μην μπερδεύονται με πολλές αλλαγές. Γιαυτό προτιμώ το "κλασσικό" μενού. Επίσης η παλιά έκδοση είχε τη δυνατότητα να προσθέτεις εργαλεία στην μπάρα και σε όποιο σημείο θέλεις ... κάτι που τώρα δεν γίνεται. Πχ στο server είχα τα γραφικά για τη χρήση cpu, φόρτο συστήματος και χρήση δικτύου ...
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: alkisg στις 18 Σεπ 2012, 10:52:43 μμ
Ο server υποστηρίζει KMS ... Εχει κάρτα NVIDIA και δεν έχει πρόβλημα

Ο nvidia driver δεν υποστηρίζει KMS (αν δηλαδή έβαλες τους drivers της nvidia όταν στο πρότεινε ο σχετικός διάλογος).
O nouveau driver υποστηρίζει KMS (αν πάτησες άκυρο και δεν τους έβαλες).

Γενικά στο server μη βάζετε εμπορικούς drivers nvidia ή ati εκτός κι αν ολόκληρο το εργαστήριο έχει nvidia ή ati.

Για τα υπόλοιπα περί Unity συμφωνώ απόλυτα, ούτε εμένα μου αρέσει γι' αυτό και βάζουμε το gnome-fallback που μοιάζει με το παλιό. Βέβαια μοιάζει, δεν είναι το ίδιο, αφού είναι ξαναγραμμένο εξ' αρχής σε GTK3, ενώ το παλιό ήταν σε GTK2. Γι' αυτό και έχει τις ελλείψεις που επισημαίνεις.
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: za√‘ag στις 18 Σεπ 2012, 11:36:14 μμ
Ο nvidia driver δεν υποστηρίζει KMS (αν δηλαδή έβαλες τους drivers της nvidia όταν στο πρότεινε ο σχετικός διάλογος).
O nouveau driver υποστηρίζει KMS (αν πάτησες άκυρο και δεν τους έβαλες).

Γενικά στο server μη βάζετε εμπορικούς drivers nvidia ή ati εκτός κι αν ολόκληρο το εργαστήριο έχει nvidia ή ati.

...

Θα κοιτάξω ... ό,τι είχα βάλει πέρυσι
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: mkassapakis στις 24 Οκτ 2012, 01:43:39 μμ
Σήμερα πήρα κι εγώ την απόφαση να κάνω νέα-καθαρή εγκατάσταση του 12.04 χρησιμοποιώντας το Live-DVD της Τεχνικής Στήριξης.
Οφείλω να πω ένα ΤΕΡΑΣΤΙΟ ΜΠΡΑΒΟ σε όσους ασχολήθηκαν (έστω και τώρα) γιατί η εγκατάσταση έχει γίνει πλέον παιχνιδάκι και το manual είναι απλά τέλειο. Τόσο κατατοπιστικό που διαβάζεται με... ευχαρίστηση!

Εκεί που έχω κολλήσει είναι η εκκίνηση των clients (thin) μέσω της on-board κάρτας δικτύου (Realtek) PXE.
Διάβασα τα προηγούμενα σχόλια και αυτό που έχω κάνει μέχρι τώρα (χωρίς επιτυχία) είναι:
1) Άλλαξα τη γραμμή dhcp-range σε dhcp-range=10.8.6.10,proxy, καθώς εφάρμοσα static IP στον server. Μόλις κάνω όμως  sudo ltsp-config dnsmasq --overwrite η γραμμή αυτή αλλάζει σε dhcp-range=10.8.6.0,proxy (?)
2) Προσπάθησα να σχολιάσω (#) τη γραμμή dhcp-range=192.168.67.20,192.168.67.250,8h, αλλά μόλις κάνω sudo ltsp-config dnsmasq --overwrite το αρχείο επιστρέφει στην προηγούμενη μορφή του και η γραμμή αποσχολιάζεται (?).

Το μήνυμα λάθους που παίρνω από τους clients είναι:
Gateway IP:10.8.6.1
Boot Server:10.8.6.10
TFTP.
PXE-T01Q file /var/lib/tftboot/ltsp/i386/pxelinux.0 not found
PXE-E3B: TFTP Error - File not found
PXE-M0F: Exiting PXE ROM.

Ψάχνοντας το παραπάνω dierectory είδα ότι όντως δεν υπάρχουν τα απαραίτητα αρχεία εκεί. Γιατί;
Παρακαλώ όποιος γνωρίζει ας προτείνει κάτι, γιατί δεν θέλω έτσι "αβασάνιστα" να προχωρήσω στο plan-b που είναι η εγκατάσταση του loader στα Windows.

Ευχαριστώ!
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: mkassapakis στις 24 Οκτ 2012, 01:57:33 μμ
Συνέχισα λίγο τον πειραματισμό μου...
Βρήκα κάποια αρχεία pxelinux.0, gpxelinux κ.α. σε άλλες τοποθεσίες και τα αντέγραψε στο φάκελο /var/lib/tftboot/ltsp/i386/

Αυτή τη φορά η εκκίνηση των clients προχώρησε λίγο παραπέρα αλλά πάλι σταμάτησε με το παρακάτω μήνυμα:
TFTP prefix: /ltsp/i386/
TRying to load: pxelinux.cfg/default            ok
Could not find kernel image: vmlinuz-3.2.0-32-generic-pae
boot:
και σταματάει εκεί.

Σταματάω κι εγώ, μην τα κάνω χειρότερα τα πράγματα. Περιμένω τους ειδικούς... ???
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: geochatz στις 24 Οκτ 2012, 02:13:11 μμ
Το μήνυμα λάθους που παίρνω από τους clients είναι:
Gateway IP:10.8.6.1
Boot Server:10.8.6.10
TFTP.
PXE-T01Q file /var/lib/tftboot/ltsp/i386/pxelinux.0 not found
PXE-E3B: TFTP Error - File not found
PXE-M0F: Exiting PXE ROM.

Ψάχνοντας το παραπάνω dierectory είδα ότι όντως δεν υπάρχουν τα απαραίτητα αρχεία εκεί. Γιατί;
Παρακαλώ όποιος γνωρίζει ας προτείνει κάτι, γιατί δεν θέλω έτσι "αβασάνιστα" να προχωρήσω στο plan-b που είναι η εγκατάσταση του loader στα Windows.

Ευχαριστώ!

Μάλλον κάτι δεν πηγε καλά με την εγκατάσταση. Λείπουν κάποια αρχεία, π.χ. επειδή είχες επιλέξει να κατεβάσει επιτόπου κατά την εγκατάσταση του λειτουργικού και τις διαθέσιμες ενημερώσεις και δεν κατάφερε να τις κατεβάσει.

Είχα παρόμοιο πρόβλημα και το έλυσα ξαναεγκαθιστώντας τη διανομή.
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: mkassapakis στις 24 Οκτ 2012, 09:41:10 μμ
Παράθεση
Μάλλον κάτι δεν πηγε καλά με την εγκατάσταση. Λείπουν κάποια αρχεία, π.χ. επειδή είχες επιλέξει να κατεβάσει επιτόπου κατά την εγκατάσταση του λειτουργικού και τις διαθέσιμες ενημερώσεις και δεν κατάφερε να τις κατεβάσει.

Είχα παρόμοιο πρόβλημα και το έλυσα ξαναεγκαθιστώντας τη διανομή.

Παρακολουθούσα πάντως την εγκατάσταση και φαινόταν να κατεβαίνουν κανονικά οι ενημερώσεις.
Επίσης αμέσως μετά την εγκατάσταση έκανα ότι ενημερώσεις υπήρχαν.
Δεν θα έπρεπε έτσι να είχε λυθεί το πρόβλημα;  :-\

Ψάχνοντας πάντως στο File System του Ubuntu βρήκα ότι τα αρχεία υπάρχουν στο φάκελο /boot, αλλά όχι στο φάκελο που ψάχνει ο client μέσω του TFTP.
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: alkisg στις 24 Οκτ 2012, 10:50:54 μμ
@mkassapakis: σου λείπει το βήμα 5, "Δημοσίευση εικονικού δίσκου".

http://ts.sch.gr/wiki/Linux/LTSP
Τίτλος: Απ: Πρόβλημα με την εκκίνηση των client
Αποστολή από: mkassapakis στις 25 Οκτ 2012, 10:54:04 πμ
Αβλεψία δικιά μου.... Όλα ρολόι!
Έχω σκουριάσει λίγο καθώς είχα ένα χρόνο να δουλέψω το LTSP λόγω άδειας  ::)

Και πάλι συγχαρητήρια!