Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γενικές εξετάσεις => Γ΄ Λυκείου => Εξετάσεις 2011-2012 => Μήνυμα ξεκίνησε από: Βασίλης Παπαχρήστος στις 19 Ιούν 2012, 07:16:58 μμ

Τίτλος: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: Βασίλης Παπαχρήστος στις 19 Ιούν 2012, 07:16:58 μμ
Αναρτήθηκαν τα θέματα των επαναληπτικών εξετάσεων στην ιστοσελίδα του υπουργείου.
Τίτλος: Θέματα επαναληπτικών
Αποστολή από: PE19 στις 19 Ιούν 2012, 07:19:10 μμ

τα θέματα  των επαναληπτικών εδώ:http://www.minedu.gov.gr/publications/docs2012/them_plir_kat_c_hmer_epan_1206.pdf (http://www.minedu.gov.gr/publications/docs2012/them_plir_kat_c_hmer_epan_1206.pdf)!
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: Laertis στις 19 Ιούν 2012, 07:55:00 μμ
Καλά θεματάκια με μια απλή ανάγνωση ;)
Τίτλος: Απ: Θέματα επαναληπτικών
Αποστολή από: nikosx στις 19 Ιούν 2012, 08:01:56 μμ
πρώτη εντύπωση 'θετικότατη', να πω τώρα και το κλασικό 'καμία σχέση με τις απολυτήριες'
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: Dinos στις 20 Ιούν 2012, 12:32:06 πμ
Αρκετά καλά θέματα (χωρίς να είναι πολύ δύσκολα).
Αν μάλιστα τα συγκρίνουμε με αυτά της κανονικής περιόδου (που ίσως ήταν και προέκυψαν λόγω ασαφειών απο τα χειρότερα ever) μιλάμε για υπέροχα θέματα.

Η τάση για μόνο 5 μονάδες στα Σ-Λ παγιώνεται; Φαντάζομαι θα έχουμε κουβεντούλα για το "μπορεί" και "έξοδο" στο β
Το Α2 με τα τα τρία ΑΝ (εμφωλευμένα) πολύ ωραίο (πρέπει να γίνει και η άρση-μάζεμα του λογικού τελεστή Η)
Το Α3 γνωστό μεν, αλλά και με μια δημιουργική νότα (δώσε παράδειγμα - διόρθωσε το λάθος)
Το Α4 (η θεωρία) που δεν είναι παπαγαλία
Στο Α5 τώρα δε μου άρεσε καθόλου που τα κενά στο 2ο κομμάτι συμπληρώνονταν με τα ίδια που είχε συμπληρώσει κανείς στο 1ο
(θα μπορούσε να υπήρχαν δύο μετρητές ένας να ξεκινά από την αρχή και ο άλλος από το τέλος, μια σύνθετη ΑΝ και οι περιττοί να μπουν με την ανάποδη σειρά που υπάρχαν στον Α)

Όμορφη η τριπλή μετατροπή των Για σε Όσο (και εμφωλευμένες) και δημιουργία διαγράμματος ροής
επίσης όμορφος και εξυπνούλικος (με το Κ<-- Λ[Κ] ή Κ <-- R[Κ]) και ο πίνακας τιμών
ΤΕΛΙΚΑ νομίζω ότι είναι ορθότερο να μοιράζονται οι 20 μονάδες σε διάγραμμα ροής και πίνακα τιμών κι όχι να δίνονται μόνο σε πίνακα τιμών

όσον αφορά στα δύο τελευταία (και τα δύο πίνακες) δε λείπει κάπως η μια ασκησούλα με δομή επανάληψης και χωρίς πίνακες;
ΠΑΝΤΩΣ
το Γ θέμα έξυπνο θέμα με αρκετά υψηλό βαθμό δυσκολίας.
στο Γ1 μπορεί να αρχίσει κάποιος από μπροστά και να ψάχνει 2 κενά ή να αρχίσει από το τέλος.
το Γ2 είτε υλοποιείται με αναζήτηση του κάθε χαρακτήρα στην 1η γραμμή του ΑΒ είτε (είναι δεκτό;;;) με την αφαίρεση: ΚΕΙΜ - 'Α' + 1 αφού στην 1η γραμμή του ΑΒ τα γράμματα είναι με τη σειρά 
και το Γ3 πολύ καλό (υπολογισμός κενών χαρακτήρων μέχρι το τέλος του κειμένου+1) για το πρώτο κομμάτι του υποερωτήματος
και το 2ο κομμάτι πολύ special. Ψάχνουμε για κενό χαρακτήρα (συνεχώς και μόνο μέχρι το τέλος του κειμένου) και μετράμε και μόλις βρούμε κενό συγκρίνουμε, μηδενίζουμε και προχωράμε, ......

Το Δ θέμα εύκολο θέμα (ίδιο έργο με άλλους τίτλους)
Πρόγραμμα με χρήση υποπρογράμματος (συναρτηση), με κλασσικές επεξεργασίες, με πιθανό αγκάθι για τους μαθητές μόνο το Δ5 (συνεχώς αύξηση)
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: Stefevan στις 20 Ιούν 2012, 02:59:20 πμ
Και μένα μου άρεσαν, τζάμπα τα θέματα για λίγα παιδιά.. τέλος πάντων, το θέμα της κρυπτογράφησης είναι κλεμμένο από τα Δίκτυα επαλ :p μη μου πείτε ότι δεν επηρεάστηκαν  :P
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: evry στις 20 Ιούν 2012, 10:50:00 πμ
Γιατί στην περίπτωση της φυσικής γλώσσας κατά βήματα μπορεί να παραβιαστεί η καθοριστικότητα ενώ στις άλλες μορφές αναπαράστασης αλγορίθμου όχι?
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: karaberis στις 20 Ιούν 2012, 03:54:55 μμ
Οι προσωπικές απόψεις για τα θέματα (που σε αρκετά συμπίπτουν με τους προηγούμενους):

Θέμα Α1, πονηρό το ε (όχι για όσους γνωρίζουν την ύπαρξη και τη χρήση του πίνακα ASCII).
Θέμα Α2, δεν ήταν σαφές αν ήθελε εμφωλευμένες ΑΝ (άλλος τρόπος?)
Θέμα Α3, κακή διατύπωση. Το "έχει λάθος" έπρεπε να έχει γραφεί "είναι λανθασμένος". Κάποιος μαθητής μπορεί να σκεφτεί "έχει λάθος = ενικός, άρα έχει ένα ΜΟΝΟ λάθος!!!!!!! Επίσης βάλανε μονά εισαγωγικά που αλλάχτηκαν στα εσπερινά!!!
Θέμα Α4, το βιβλίο δεν περιγράφει αναλυτικά τα προβλήματα των δύο τρόπων αναπαράστασης, άρα οι μαθητές πρέπει να παπαγαλίσουν.
Θέμα Α5, Σχετικά απλό.
Θέμα Β1: Μετατροπή τριπλής εμφωλευμένης ΓΙΑ σε ΔΡ, από λυμένη άσκηση από το τετράδιο μαθητή σελ.21. Δεν ήθελε όμως μετατροπή σε ΟΣΟ (όπως αναφέρει κάποιος προηγούμενος) ή δεν το είδα εγώ καλά;
Θέμα Β2: Πίνακας τιμών, ήθελε προσοχή στην εκτέλεση λόγω πολλών δεδομένων.
Θέμα Γ, Απαιτητικό, αν δε με απατά η μνήμη μου, πρώτη φορά μπήκε πρόβλημα με επεξεργασία χαρακτήρων σε πίνακες (στο σχολικό βιβλίο δεν υπάρχει καμμία σχετική αναφορά, υπάρχουν μερικά παραδείγματα - ασκήσεις σε εξωσχολικά βοηθήματα). Πόσοι έχετε διδάξει τέτοιο παράδειγμα στο σχολείο; Πόσοι καθηγητές πιστεύετε ότι δίδαξαν παρόμοιο παράδειγμα στο σχολείο τους;
Θέμα Δ: Δ1, Δ2 και Δ3 απλά, Δ4 έχει αρκετές υλοποιήσεις, Δ5 απαιτητικό.

Και πάλι απουσία 6ου κεφαλαίου.

Για τα θέματα των εσπερινών υπάρχουν μικρές διαφοροποιήσεις και κάποιες φραστικές αλλαγές:
Θέμα Α1. Αλλάχτηκε η πρόταση δ.
Θέματα Α2 και Α3: Αντιμετάθεση!!! (άραγε για να μπερδέψουν τους αντιγραφείς; γράφουν μαζί με τους μαθητές των ΓΕΛ;)
Θέματα Α4 και Α5: Αντιμετάθεση!!!
Στο Θέμα Α4 των εσπερινών, έκαναν αλλαγές και δεν βγαίνει νόημα στην πρώτη πρόταση!!!! Του αλλάξανε τα φώτα. Η προχειρότητα σε όλο της το μεγαλείο.
Θέμα Β: ίδια με διορθώσεις στα εισαγωγικά (από μονά σε διπλά)
Θέμα Γ: ίδιο με διορθώσεις στα κενά (από μονά σε διπλά και κάποια σβύστηκαν)
Θέμα Δ: διορθώσαν κάποια μονά σε διπλά εισαγωγικά στους αλγόριθμους και βγάλανε τα ερωτήματα Δ1 (τμήμα δηλώσεων) και Δ3 (υποπρόγραμμα) που ήταν εκτός ύλης και μοίρασαν τις μονάδες στα υπόλοιπα ερωτήματα. Άρα ένας μαθητής των εσπερινών θα χάσει από αυτό το (απαιτητικό) ερώτημα 9 αντί 5 μονάδες. Τιμωρία γιατί βαριούνται να βγάλουν σωστά θέματα!

Τέλος, δεν καταλαβαίνω αυτή την πρόσφατη τακτική τα θέματα των εσπερινών να είναι μια περιορισμένη (προσαρμοσμένη) έκδοση των ημερήσιων Λυκείων. Δηλαδή είναι τόσο δύσκολο να βγάλουν διαφορετικά θέματα, ή είναι αποτέλεσμα κακώς εννοούμενης οικονομίας; (δεν πληρώνει δηλαδή το αφεντικό;)
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: Stefevan στις 20 Ιούν 2012, 04:30:55 μμ
-Α1(ε) οι μαθητές θα πρέπει να γνωρίζουν ότι Ζ>Α, αλλιώς πως θα κάνουν ταξινόμηση αλφαβητικά (αν χρειαστεί..)? 2004 όταν έδινα εγώ Σε περίπτωση ισοβαθμίας η σειρά ταξινόμησης των ονομάτων να είναι αλφαβητική.

- Α2 προφανώς αφήνει τον μαθητή να δημιουργήσει.. θα έλεγε όχι εμφωλευμένες αν

- Α3 κάνοντας τις απαραίτητες διορθώσεις γίνεται ακόμη πιο ξεκάθαρο

Θέμα Γ - Το Γ3 μου θυμίζει τους καμένους λαμπτήρες στο ορυχείο :p πολύ καλό ερώτημα. καλό είναι να αιφνιδιάζονται οι μαθητές, τότε θα φανεί αν όντως μπορούν να χρησιμοποιήσουν τα εργαλεία που έχουν μάθει

Θέμα Δ - το Δ5 γιατί μου φαίνεται εύκολο? Το Γ3 είναι ποιο δύσκολο






Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: Παναγιώτης Τσιωτάκης στις 21 Ιούν 2012, 12:02:55 πμ
Απαντήσεις ημερήσια επαναλ. 2012 (http://examsaepp.blogspot.gr/2012/06/2012_4167.html)

Απαντήσεις εσπερινά επαναλ. 2012 (http://examsaepp.blogspot.gr/2012/06/2012_8913.html)


παρακαλώ ενημερώστε με για τυχόν λάθη
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: karaberis στις 21 Ιούν 2012, 12:34:29 πμ
Απαντήσεις ημερήσια επαναλ. 2012 (http://examsaepp.blogspot.gr/2012/06/2012_4167.html)

παρακαλώ ενημερώστε με για τυχόν λάθη

Δύο παρατηρήσεις στο θέμα Δ: στη συνάρτηση έχεις γράψει ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ. Επίσης νομίζω ότι πλέον δεν βάζουμε το όνομα του προγράμματος μετά το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ.
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: Παναγιώτης Τσιωτάκης στις 21 Ιούν 2012, 12:38:43 πμ
thanks!!!

για το όνομα προγράμματος, έχω επιλέξει (γενικά) να ακολουθώ το τετράδιο μαθητή και να το βάζω στο τέλος για ομοιογένεια με την ψευδογλώσσα... άλλο ένα κοινό σημείο του σχολικού διδακτικού πακέτου  :D
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: ikariofil στις 21 Ιούν 2012, 09:29:55 πμ
Στο θέμα Γ δεν έπρεπε να υπάρχει υπόδειξη ότι ο πίνακας ΚΕΙΜ ξεκινάει από γράμμα και όχι από κενό;
ή μήπως μου διαφεύγει κάτι;
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: Παναγιώτης Τσιωτάκης στις 21 Ιούν 2012, 10:37:17 πμ
μάλλον έχεις δίκιο
αν και ξεκινώντας από κενό, δεν πρέπει να έχεις χαρακτήρα στη συνέχεια, άρα δεν έχεις καμία λέξη
επίσης, θα έπρεπε να πει πως δεν μπορούν να μπουν 2 κενά!!

θα τα περιγράψω στην επίλυση σε βιντεο αυτά!!!
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: Βασίλης Παπαχρήστος στις 21 Ιούν 2012, 10:38:17 πμ
Απαντήσεις ημερήσια επαναλ. 2012 (http://examsaepp.blogspot.gr/2012/06/2012_4167.html)

Απαντήσεις εσπερινά επαναλ. 2012 (http://examsaepp.blogspot.gr/2012/06/2012_8913.html)


παρακαλώ ενημερώστε με για τυχόν λάθη

Στο Γ1 κάπου αναφέρεις
Αν ΚΕΙΜ[ i ] = " " επανάλαβε 


Εναλλακτική λύση για το Γ1 που έκανε μια μαθήτρια μου

Για i από 1 μέχρι 500
  Αν ΚΕΙΜ[ i ] <> " " τότε pos ← i
Τέλος_επανάληψης
Αν pos = 500 τότε
  Εμφάνισε "Το μήκος του κειμένου είναι 500"
Αλλιώς
  Εμφάνισε 500 - pos
Τέλος_αν


Επίσης για το Γ3 αρκετά παρόμοιο με αυτό που έκανε ο Παναγιώτης

λ ← 0
μ ← 0
max ← 0
Για i από 1 μέχρι pos
  Αν ΚΕΙΜ[ i ] = " " τότε
    λ ← λ + 1
    μ ← 0
  Αλλιώς
    μ ← μ + 1
    Αν μ > max τότε max ← μ
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε λ+1, "λέξεις"
Εμφάνισε  max, "το πλήθος χαρακτήρων της μεγαλύτερης λέξης"
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: Παναγιώτης Τσιωτάκης στις 21 Ιούν 2012, 10:47:37 πμ
Εναλλακτική λύση για το Γ1 που έκανε μια μαθήτρια μου

Για i από 1 μέχρι 500
  Αν ΚΕΙΜ[ i ] = " " τότε pos ← i
Τέλος_επανάληψης
Αν pos = 500 τότε
  Εμφάνισε "Το μήκος του κειμένου είναι 500"
Αλλιώς
  Εμφάνισε 500 - pos
Τέλος_αν

δε μου φαίνεται σωστό, γιατί κρατάει ΤΟ ΤΕΛΕΥΤΑΙΟ ΚΕΝΟ που θα συναντήσει!! Το κείμενο σταματάει μάλλον λίγο πιο πριν
Αν δεν έχει κενό στο τέλος (χαρακτήρες=500), τότε το pos έχει λάβει τιμή το τελευταίο κενό (πριν την τελευταία λέξη)!
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: Βασίλης Παπαχρήστος στις 21 Ιούν 2012, 11:13:27 πμ
δε μου φαίνεται σωστό, γιατί κρατάει ΤΟ ΤΕΛΕΥΤΑΙΟ ΚΕΝΟ που θα συναντήσει!! Το κείμενο σταματάει μάλλον λίγο πιο πριν
Αν δεν έχει κενό στο τέλος (χαρακτήρες=500), τότε το pos έχει λάβει τιμή το τελευταίο κενό (πριν την τελευταία λέξη)!

Ναι ναι έχεις απόλυτο δίκιο, <> " " ήθελα να γράψω.
Μισό να το διορθώσω, νομίζω με <> δουλεύει.
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: Παναγιώτης Τσιωτάκης στις 22 Ιούν 2012, 08:35:21 μμ
Επίλυση θέματος Γ με βίντεο (http://examsaepp.blogspot.gr/2012/06/2012_22.html)
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: student_anka στις 07 Απρ 2013, 09:42:38 μμ
Καλησπέρα!

Έχω μια απορία που αφορά το 4ο Θέμα με τις μετρήσεις τηλεθέασης...

Συγκεκριμένα, στο ερώτημα Δ3 γιατί δημιουργούμε συνάρτηση κι όχι διαδικασία?
Αφού στην ουσία υπολογίζουμε 5 αποτελέσματα (5 ΜΟ)...

Σας ευχαριστώ για το χρόνο σας!
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: student_anka στις 07 Απρ 2013, 10:05:51 μμ
Θα ήταν λάθος δηλαδή το παρακάτω:

Διαδικασία ΜέσοςΌρος (ΘΕΑΤ, ΜΟ)
Μεταβλητές
     Ακέραιες: i, j, ΘΕΑΤ[5,7], SUM[5]
     Πραγματικές: ΜΟ[5]
Αρχή
     Για i από 1 μέχρι 5
          SUM <-- 0
               Για j από 1 μέχρι 7
                    SUM <-- SUM+ΘΕΑΤ[i, j]
               Τέλος_επανάληψης
          ΜΟ <-- SUM/7
     Τέλος_επανάληψης
Τέλος_Διαδικασίας
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: nikolasmer στις 07 Απρ 2013, 11:01:51 μμ
Δεν θα ήταν λάθος. Με τη διόρθωση βέβαια στον κώδικά σου στο τέλος όπου
ΜΟ <-- SUM/7
να γίνει
ΜΟ[ i ] <-- SUM/7
Όμως στην εκφώνηση βλέπουμε: "Να καλεί για κάθε έναν από τους τηλεοπτικούς σταθμούς κατάλληλο υποπρόγραμμα...".
Επομένως το υποπρόγραμμα θα καλείται επαναληπτικά, κάθε φορά και για διαφορετικό σταθμό. Άρα θα επιστρέφει έναν μέσο όρο από εναν σταθμό. Οπότε ενα αποτέλεσμα=προτιμάται Συνάρτηση.
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: student_anka στις 08 Απρ 2013, 08:56:21 πμ
Ναι, έχετε δίκιο!
Ευχαριστώ πολύ!
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: stark στις 19 Απρ 2014, 01:09:42 μμ
Καλησπέρα στην κοινότητα!Στο ερώτημα Δ3 είναι απαραίτητη η χρήση πίνακα για την εκχώρηση του μέσου πλήθους τηλεθεατών,εφόσον στη συνέχεια δεν υφίσταται κάποια επεξεργασία επί αυτού του πίνακα;Αν ναι,μπορείτε να μου αιτιολογήσετε για ποιο λόγο;Σας ευχαριστώ!
Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: deniaa στις 02 Μάι 2014, 03:21:04 μμ
Έχω κι εγώ μια απορία. Γιατί γράφουμε     
 ΑΝ ΜΟ_σκ>=ΜΟ_καθ+ΜΟ_καθ*10%
 ΤΕΛΟΣ_ΑΝ

και όχι

ΑΝ ΜΟ_σκ>=ΜΟ_καθ*10%
;;;;

Thanks!!!

Τίτλος: Απ: Επαναληπτικές Γενικών Λυκείων 2012
Αποστολή από: petrosp13 στις 02 Μάι 2014, 03:27:40 μμ
Παράδειγμα
Αν ο ΜΟ_καθ είναι 10 τηλεθεατές, θέλεις να δεις αν ο ΜΟ_σκ έχει τουλάχιστον 11, δηλαδή 10% παραπάνω από τον ΜΟ_καθ
Αυτό που ελέγχεις εσύ θα βρει αν ο ΜΟ_σκ είναι πάνω από 1 τηλεθεατής, το 10% του ΜΟ_καθ
Το ποσοστό αναφέρεται σε αύξηση του μέσου όρου, όχι σε μέρος του μέσου όρου