Το Στέκι των Πληροφορικών

Επαγγελματικό Λύκειο => Γενικά => Προγραμματισμός Υπολογιστών => Μήνυμα ξεκίνησε από: Xristos4 στις 13 Οκτ 2009, 09:55:52 μμ

Τίτλος: Απορια με των δομημενο προγραμματισμο και τους αλγοριθμους
Αποστολή από: Xristos4 στις 13 Οκτ 2009, 09:55:52 μμ
Καλησπέρα σε ολους,

Λοιπον ήθελα να ρωτησω αν ο δομημένος προγραμματισμος και γενικα οι αλγοριθμοι μπορεις να τους γραψεις στο γλωσσομαθεια διοτι ας πουμε προσπαθησα και εβαζα των παρακάτω κωδικα

Προγραμμα ταδε
ΑΡΧΗ
ΔΙΑΒΑΣΕ Α,Β
Γ<- Α+Β
ΕΜΦΑΝΙΣΕ Γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

σε καθε περίπτωση το Εμφανισε δεν το αναγνωριζε το γλωσσομαθεια ως εντολή καθώς μου έλεγε επίσης οτι λάθος είναι και το Γ<- Α+Β

Κανονικά έτσι οπως έγραφα των κώδικα έπρεπε να ήταν σωστο δεν ξερω βεβαια άν το γλωσσομαθεια ειναι το ιδιο για αυτες τις εντολές. Πειτε την γνωμη σας
Τίτλος: Απ: Απορια με των δομημενο προγραμματισμο και τους αλγοριθμους
Αποστολή από: sstergou στις 13 Οκτ 2009, 10:40:02 μμ
Η Γλωσσομάθεια είναι βοήθημα για το μάθημα της Ανάπτυξης Εφαρμογών του Γενικού Λυκείου και υλοποιεί την γλώσσα προγραμματισμού που ορίζεται σε αυτό το μάθημα (ΓΛΩΣΣΑ).

Απ'όσο ξέρω δεν υπάρχει βοήθημα για τον ψευδοκώδικα του δομημένου προγραμματισμού των ΕΠΑΛ.
Τίτλος: Απ: Απορια με των δομημενο προγραμματισμο και τους αλγοριθμους
Αποστολή από: Καρκαμάνης Γεώργιος στις 13 Οκτ 2009, 11:50:54 μμ
Η Γλωσσομάθεια είναι βοήθημα για το μάθημα της Ανάπτυξης Εφαρμογών του Γενικού Λυκείου και υλοποιεί την γλώσσα προγραμματισμού που ορίζεται σε αυτό το μάθημα (ΓΛΩΣΣΑ).

Απ'όσο ξέρω δεν υπάρχει βοήθημα για τον ψευδοκώδικα του δομημένου προγραμματισμού των ΕΠΑΛ.

Με μικρές τροποποιήσεις στον αλγόριθμο μπορεί να χρησιμοποιήσει το δικό σου Στάθη.
Για όποιον θελει να δοκιμάσει www.pseudoglossa.gr
Τίτλος: Απ: Απορια με των δομημενο προγραμματισμο και τους αλγοριθμους
Αποστολή από: karinakis στις 16 Οκτ 2009, 06:20:33 μμ
στη γλωσσομάθεια θα πρέπει να κάνεις οπωσδήποτε δήλωση μεταβλητών και αντί για ΕΜΦΑΝΙΣΕ να χρησιμοποιήσεις το ΓΡΑΨΕ. Δοκίμασε το παρακάτω και θα δεις ότι τρέχει κανονικά. Άλλωστε όλους τους αλγορίθμους που έχεις σε ψευδοκώδικα μπορείς να χρησιμοποιείς τη Γλώσσα για να τους τρέχεις


ΠΡΟΓΡΑΜΜΑ ταδε
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, Β, Γ
ΑΡΧΗ
  ΔΙΑΒΑΣΕ Α, Β
  Γ <- Α + Β
  ΓΡΑΨΕ Γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Τίτλος: Απ: Απορια με των δομημενο προγραμματισμο και τους αλγοριθμους
Αποστολή από: Καρκαμάνης Γεώργιος στις 16 Οκτ 2009, 11:16:35 μμ
Καλύτερα δοκίμασε το www.pseudoglossa.gr