Αποστολέας Θέμα: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι  (Αναγνώστηκε 4523 φορές)

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 36
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #15 στις: 26 Μάι 2017, 10:20:33 μμ »
Μία λύση για το Α3 μετά από κάμποση σκέψη:

Για i από 1 μέχρι 6
  Για j από 1 μέχρι 8
    A[i, j] <- (i - i mod 2)*8 + 1 - i mod 2 - (-1)^i * j
  Τέλος_επαναληψης
Τέλος_επαναληψης

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2075
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #16 στις: 26 Μάι 2017, 11:32:22 μμ »
Παραπλήσια με του Ευρυπίδη

x <-- 0
step <-- 1
Για i από 1 μέχρι 6
     Αν i mod 2 = 0 τότε
          begin <-- 1
           end <-- 8
     Αλλιώς
          begin <-- 8
          end <-- 1
     Τέλος_Αν
     Για j από begin μέχρι end με βήμα step
          x <-- x + 1
          A[i,j] <-- x
     Τέλος_Επανάληψης
     step <-- step * (-1)
Τέλος_Επανάληψης   
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

http://petrosp13.blogspot.com/

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 476
  • There can be only one...may it be AEPP.
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #17 στις: 26 Μάι 2017, 11:41:02 μμ »
νομίζω ότι στο εμφωλευμένο ΑΝ θα έπρεπε να τα έχει αντίθετα..... είναι πολύ κοντά πάντως....
Ναι έχετε δίκαιο.
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

DmitrijPyc

  • Νέος
  • *
  • Μηνύματα: 8
    • Barracuda
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #18 στις: 27 Μάι 2017, 08:13:31 μμ »
Το β2)
ΠΡΟΓΡΑΜΜΑ  Α3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι
  ΠΡΑΓΜΑΤΙΚΕΣ: ΜΙΔ,ΡΙΖΑ,Α,Β
  ΛΟΓΙΚΕΣ: ΦΛΑΓ
ΑΡΧΗ
  Ι <-- 0
  ΦΛΑΓ <-- ΨΕΥΔΗΣ
  ΔΙΑΒΑΣΕ Α,Β
  ΜΙΔ <-- (Α+Β)/2
  ΟΣΟ Ι<=100 ΚΑΙ ΦΛΑΓ=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ   
    Ι <-- Ι+1
    ΑΝ 3*ΜΙΔ^2+2*ΜΙΔ-3=0 ΤΟΤΕ
      ΦΛΑΓ <-- ΑΛΗΘΗΣ
      ΡΙΖΑ <-- ΜΙΔ
    ΑΛΛΙΩΣ_ΑΝ (3*ΜΙΔ^2+2*ΜΙΔ-3)*(3*Α^2+2*Α-3)<0 ΤΟΤΕ
      Β <-- ΜΙΔ
    ΑΛΛΙΩΣ
      Α <-- ΜΙΔ
    ΤΕΛΟΣ_ΑΝ
    ΜΙΔ <-- (Α+Β)/2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΦΛΑΓ=ΑΛΗΘΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'ΒΡΕΘΗΚΕ Η ΡΙΖΑ.Η ΡΙΖΑ ΕΙΝΑ=',ΡΙΖΑ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


                                 

epsilonXi

  • Βετεράνος
  • ****
  • Μηνύματα: 75
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #19 στις: 27 Μάι 2017, 08:22:45 μμ »
ας πω κι εγώ την εξυπνάδα μου:

νούμερο1:
για χ από 1 μέχρι 5 με βήμα 2
  μ <-- (χ-1)*8
  χχ <-- χ+1
  ζ <-- χχ*8+1
  για ψ από 1 μέχρι 8
    Α[χ,ψ] <-- μ + ψ
    Α[χχ,ψ] <-- ζ - ψ
  τέλος_επανάληψης
τέλος_επανάληψης


νούμερο2:
τ <-- 0
εδώ <-- 1
εκεί <-- 8
β <-- 1
για χ από 1 μέχρι 6
  για ψ από εδώ μέχρι εκεί με βήμα β
    τ <-- τ + 1
    Α[χ,ψ] <-- τ
  τέλος_επανάληψης
  αντιμετάθεσε εδώ, εκεί
  β <-- -β
τέλος_επανάληψης

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 476
  • There can be only one...may it be AEPP.
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #20 στις: 27 Μάι 2017, 11:55:15 μμ »
Ζητώ συγγνώμη που αναρτω το παρακάτω σε αυτό το θέμα αλλά... για τον παρακάτω πίνακα πως θα ήταν ένας όμορφος κωδικας;

1   2   3   4   5   6   7   8
17   18   19   20   21   22   23   24
33   34   35   36   37   38   39   40
48   47   46   45   44   43   42   41
32   31   30   29   28   27   26   25
16   15   14   13   12   11   10   9
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

epsilonXi

  • Βετεράνος
  • ****
  • Μηνύματα: 75
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #21 στις: 28 Μάι 2017, 12:25:57 πμ »
για κομψότητα δεν ξέρω, αλλά η πρώτη μου σκέψη βασίζεται στην προηγούμενη, οπότε τι λες για τούτο δω:

γ <-- 435261
τ <-- 0
εδώ <-- 1
εκεί <-- 8
β <-- 1
για χ από 1 μέχρι 6
  δ <-- γ mod 10
  για ψ από εδώ μέχρι εκεί με βήμα β
    τ <-- τ + 1
    Α[δ,ψ] <-- τ
  τέλος_επανάληψης
  αντιμετάθεσε εδώ, εκεί
  β <-- -β
  γ <-- γ div 10
τέλος_επανάληψης

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 476
  • There can be only one...may it be AEPP.
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #22 στις: 28 Μάι 2017, 12:32:32 πμ »
για κομψότητα δεν ξέρω, αλλά η πρώτη μου σκέψη βασίζεται στην προηγούμενη, οπότε τι λες για τούτο δω:

γ <-- 435261
τ <-- 0
εδώ <-- 1
εκεί <-- 8
β <-- 1
για χ από 1 μέχρι 6
  δ <-- γ mod 10
  για ψ από εδώ μέχρι εκεί με βήμα β
    τ <-- τ + 1
    Α[δ,ψ] <-- τ
  τέλος_επανάληψης
  αντιμετάθεσε εδώ, εκεί
  β <-- -β
  γ <-- γ div 10
τέλος_επανάληψης
Σ'αγαπώ epsilonXi.....
 Τι λες τώρα;
δ<--γ mod 10
Και πιο πάνω αυτό το υπέροχο γ<--435261
Με αυτό το κόλπο το κάνεις ότι θες!!
Respect

Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

ether

  • Επισκέπτης
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #23 στις: 28 Μάι 2017, 09:25:14 πμ »
Ζητώ συγγνώμη που αναρτω το παρακάτω σε αυτό το θέμα αλλά... για τον παρακάτω πίνακα πως θα ήταν ένας όμορφος κωδικας;

1   2   3   4   5   6   7   8
17   18   19   20   21   22   23   24
33   34   35   36   37   38   39   40
48   47   46   45   44   43   42   41
32   31   30   29   28   27   26   25
16   15   14   13   12   11   10   9
Κώδικας: [Επιλογή]
  τιμη <- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 8
      τιμη <- τιμη + 1
      Α[i, j] <- τιμη
      Α[6 + 1 - i, 8 + 1 - j] <- τιμη + 8
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    τιμη <- τιμη + 8
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ether

  • Επισκέπτης
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #24 στις: 28 Μάι 2017, 10:40:14 πμ »
Μια λύση για το Α3
Κώδικας: [Επιλογή]
  τιμη <- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5 ΜΕ_ΒΗΜΑ 2
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 8
      τιμη <- τιμη + 1
      Α[i, j] <- τιμη
      Α[i + 1, 8 + 1 - j] <- τιμη + 8
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    τιμη <- τιμη + 8
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Και γενικά για πίνακα με ΓΡΑΜΜΕΣ γραμμές και ΣΤΗΛΕΣ στήλες
Κώδικας: [Επιλογή]
  τιμη <- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ (ΓΡΑΜΜΕΣ - 1) + (ΓΡΑΜΜΕΣ mod 2) ΜΕ_ΒΗΜΑ 2
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ ΣΤΗΛΕΣ
      τιμη <- τιμη + 1
      Α[i, j] <- τιμη
      ΑΝ i < ΓΡΑΜΜΕΣ ΤΟΤΕ
        Α[i + 1, ΣΤΗΛΕΣ + 1 - j] <- τιμη + ΣΤΗΛΕΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    τιμη <- τιμη + ΣΤΗΛΕΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

mana

  • Νέος
  • *
  • Μηνύματα: 8
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #25 στις: 28 Μάι 2017, 06:12:13 μμ »
Και του χρόνου με υγεία.
A3
 ΓΙΑ ΓΡ ΑΠΟ 1 ΜΕΧΡΙ 5 ΜΕ_ΒΗΜΑ 2
    ΓΙΑ ΣΤ ΑΠΟ 1 ΜΕΧΡΙ 8
      Π[ΓΡ, ΣΤ] <- (ΓΡ - 1)*8 + ΣΤ
      Π[ΓΡ + 1, ΣΤ] <- (ΓΡ + 1)*8 + 1 - ΣΤ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

mana

  • Νέος
  • *
  • Μηνύματα: 8
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #26 στις: 29 Μάι 2017, 08:45:31 πμ »
για κομψότητα δεν ξέρω, αλλά η πρώτη μου σκέψη βασίζεται στην προηγούμενη, οπότε τι λες για τούτο δω:
ο τρόπος με το γ είναι πολύ όμορφος, γενικός, με μεγάλο εύρος εφαρμογών και εξαιρετικής εκπαιδευτικής αξίας. Συγχαρητήρια.
Παραθέτω μια τροποποίηση που βασίζεται στον δικό σου τρόπο.
! ΠΑΡΑΛΛΑΓΗ
γ ← 435261
τ ← 0
εδώ ← 1
εκεί ← 8
β ← 1
Για χ από 1 μέχρι 6
  δ ← (γ div 10^(χ - 1)) mod 10
  Για ψ από εδώ μέχρι εκεί με βήμα β
    τ ← τ + 1
    α[δ, ψ] ← τ
  Τέλος_επανάληψης
  β ← -β
  εδώ ← εδώ - β*7
  εκεί ← εκεί + β*7
Τέλος_επανάληψης

Και ένα άλλο άσχετο με την προηγούμενη λύση:
 ! Β ΤΡΟΠΟΣ
ΤΙΜΗ ← -16
Για ΓΡ από 1 μέχρι 3
  ΤΙΜΗ ← ΤΙΜΗ + 16
  Για ΣΤ από 1 μέχρι 8
    Π[ΓΡ, ΣΤ] ← ΤΙΜΗ + ΣΤ
    Π[ΓΡ + 3, ΣΤ] ← 49 - Π[ΓΡ, ΣΤ]
  Τέλος_επανάληψης
Τέλος_επανάληψης


nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 476
  • There can be only one...may it be AEPP.
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #27 στις: 29 Μάι 2017, 01:01:19 μμ »
Στο Δ θέμα και στο ερώτημα Δ1.3 όσον αφορά τους 10 καλύτερους, στην τελική κατάταξη μπορεί το ίδιο όνομα να εμφανίζεται και περισσότερες από μία φορές ή θα χρειαστεί να βρούμε μοναδικα ονόματα με τη χρήση συχνοτήτων εμφάνισης;
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

Λάμπρος Παπαδόπουλος

  • Θαμώνας
  • ***
  • Μηνύματα: 42
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #28 στις: 29 Μάι 2017, 02:13:57 μμ »
Όπως το διαβάζω είναι μοναδικά ονόματα. Αλλά πίνακες συχνοτήτων γιατί; Σαν insertion sort μου φαίνεται. Αν μεταφράζω καλά το απευθείας...
« Τελευταία τροποποίηση: 30 Μάι 2017, 12:30:15 πμ από Λάμπρος Παπαδόπουλος »

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 503
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #29 στις: 29 Μάι 2017, 04:52:49 μμ »
Στο Δ θέμα και στο ερώτημα Δ1.3 όσον αφορά τους 10 καλύτερους, στην τελική κατάταξη μπορεί το ίδιο όνομα να εμφανίζεται και περισσότερες από μία φορές ή θα χρειαστεί να βρούμε μοναδικα ονόματα με τη χρήση συχνοτήτων εμφάνισης;
Στους δέκα καλύτερους παίκτες στη διάρκεια του έτους επιτρέπεται ο ίδιος παίκτης να υπάρχει πολλές φορές εφόσον έχει κάνει σκορ τέτοια που να μπαίνουν στο ετήσιο top ten.