Αποστολέας Θέμα: Βοήθεια  (Αναγνώστηκε 483 φορές)

kostasgpap

  • Νέος
  • *
  • Μηνύματα: 2
Βοήθεια
« στις: 12 Μάι 2016, 02:59:00 μμ »
Καλησπέρα, είμαι μαθητής της Γ λυκείου και θα ήθελα μια μικρη βοήθεια σχετικά με τα υποερωτήματα Δ5 και Δ6.
Οι απαντήσεις που έγραψα ειναι :
Στο Δ5 :                                                                            Στο Δ6
Η διαδικασία έχει μεσα :                                                         Για i απο 1 μεχρι 40
Για i απο 1 μεχρι 40                                                                    Διαβασε Στοιβα [ i ]
  διάβασε Στοίβα [ i ]                                                                  Τέλος_επανάληψης
Τέλος_επανάληψης                                                                 Διαβασε top
Διαβασε top                                                                               Αν top > = 1
Διαβασε στοιχείο                                                                       Γραψε "στοιβα[top]
  Αν top < 40 τότε                                                                    top <- top -1
     top <- top +1                                                                      Αλλιως
    Στοίβα[top] <- στοιχείο                                                        Γραψε " Αδεια στοιβα"
     Αλλιως                                                                                    Τελος_αν
Γράψε "Γεμάτη στόιβα"
Τελος_αν