Αποστολέας Θέμα: ΤΑΞΙΝΟΜΗΣΗ  (Αναγνώστηκε 855 φορές)

Porfi7

  • Νέος
  • *
  • Μηνύματα: 3
ΤΑΞΙΝΟΜΗΣΗ
« στις: 01 Απρ 2014, 12:48:34 μμ »
Δινεται το ακολουθο τμημα αλγοριθμου:
   Για ι απο 2 μεχρι 200
     Για j απο 200 μεχρι ι με_βημα -1
       Αν ΜΟ[j-1]<MO[j] τότε
          t<-ΜΟ[j-1]
          ΜΟ[j-1]<-MO[j]
          MO[j]<-t
       Τέλος_αν
     Τέλος_επαναληψης
  Τέλος_επαναληψης

Να μετατραπει με αποκλειστικη χρηση της δομης Αρχη_επαναληψης... Μεχρις_οτου

programmer

  • Θαμώνας
  • ***
  • Μηνύματα: 44
Απ: ΤΑΞΙΝΟΜΗΣΗ
« Απάντηση #1 στις: 14 Φεβ 2015, 04:48:31 πμ »
i <- 2
  j <- 200

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    j <- 200
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ MO[j - 1] < MO[j] ΤΟΤΕ
        t <- MO[j - 1]
        MO[j - 1] <- MO[j]
        MO[j] <- t
      ΤΕΛΟΣ_ΑΝ
      j <- j - 1
    ΜΕΧΡΙΣ_ΟΤΟΥ (j = i - 1)
    i <- i + 1
  ΜΕΧΡΙΣ_ΟΤΟΥ (i = 201)
« Τελευταία τροποποίηση: 14 Φεβ 2015, 05:04:25 πμ από programmer »