Συνδεδεμένες εκδηλώσεις

  • ΑΠΟΡΙΑ ΣΕ ΑΣΚΗΣΗ: 15 Ιαν 2014 - 18 Ιαν 2014

Αποστολέας Θέμα: ΑΠΟΡΙΑ ΣΕ ΑΣΚΗΣΗ  (Αναγνώστηκε 751 φορές)

dionmiha

  • Οπαδός
  • **
  • Μηνύματα: 13
ΑΠΟΡΙΑ ΣΕ ΑΣΚΗΣΗ
« στις: 15 Ιαν 2014, 12:40:43 μμ »
Καλησπέρα,
Χρόνια πολλά και καλή χρονιά.

Βρήκα μια άσκηση, στην οποία με πέδεψε λιγάκι το Ε ερώτημα και θέλω τη βοήθεια σας. Έτσι όπως το τρέχω μου βγάζει σωστά αποτελέσματα (τουλαχιστον με τις πιθανες τιμές που βάζω), αλλά εάν υπάρχει και δεύτερη λύση (ίσως πιο εύκολη??)  παρακαλώ δώστε την...!!

Ευχαριστώ..!

"Το υπουργείο Μεταφορών θέλει να συγκεντρώσει κάποια στοιχεία σχετικά με τις τιμές του διοξειδίου του άνθρακα στην ατμόσφαιρα έτσι ώστε να αποφασίσει για κυκλοφοριακά μέτρας που θα πάρει στο μέλλον. Τα στοιχεία αυτά θα αφορούν τις ημερήσιες τιμές του διοξειδίου του άνθρακα 10 περιοχών στο λεκανοπέδιο της Αττικής για τις 30 ημέρες του μήνα.  Να αναπτύξετε αλγόριθμο ο οποίος:

Α. Να διαβάζει το όνομα κάποιας περιοχής και στη συνέχεια τις 30 τιμές διοξειδίου του άνθρακα που καταμετρήθηκαν το μήνα στη συγκεκριμένη περιοχή. Με ανάλογο τρόπο θα εισαχθούν στο πρόγραμμα τα στοιχεία και για τις δέκα περιοχές.
Β. Θα υπολογίζει τη μέση ημερήσια τιμή διοξειδίου του άνθρακα στο λεκανοπέδιο της Αττικής.
Γ. Θα υπολογίζει αν τις ημέρες που κυκλοφορούν τα αυτοκίνητα με μονό αριθμό κυκλοφορίας εκλύθηκε περισσότερο διοξείδιο του άνθρακα από τις ημέρς που κυκλοφορούν τα αυτοκίνητα με ζυγό αριθμό κυκλοφορίας.
Δ. Θα εμφανίζει το όνομα της πιο μολυσματικής πόλης.
Ε. Θα προσδιορίζει ποια μέρα της εβδομάδας είχε το λεκανοπέδιο το μεγαλύτερο πρόβλημα μόλυνσης, αν η πρώτη του μηνός επέφτε ημέρα Τετάρτη."



ΕΡΩΤΗΜΑ Α
Αλγόριθμος ΛΕΚΑΝΟΠΕΔΙΟ

Για Ι από 1 μέχρι 10
 Διάβασε ΟΝΟΜΑ[Ι]
 Για Κ από 1 μέχρι 30
 Διάβασε ΤΙΜΕΣ[Ι,Κ]
 Τέλος_επανάληψης
Τέλος_επανάληψης

ΕΡΩΤΗΜΑ Β
Για Κ από 1 μέχρι 30
 ΑΘΡΟΙΣΜΑ ← 0
 Για Ι από 1 μέχρι 10
 ΑΘΡΟΙΣΜΑ ← ΑΘΡΟΙΣΜΑ + ΤΙΜΕΣ[Ι,Κ]
 Τέλος_επανάληψης
 ΠΙΝΑΚΑΣ_ΑΘΡΟΙΣΜΑ[Κ] ← ΑΘΡΟΙΣΜΑ
Τέλος_επανάληψης

Για Ι  από 1 μέχρι 30
 ΑΘΡΟΙΣΜΑ ← ΑΘΡΟΙΣΜΑ + ΠΙΝΑΚΑΣ_ΑΘΡΟΙΣΜΑ[Κ]
Τέλος_επανάληψης
ΜΟ_ΗΜΕΡΑΣ ← ΑΘΡΟΙΣΜΑ / 30
Εμφάνισε ΜΟ


ΕΡΩΤΗΜΑ Γ
ΑΘΡΟΙΣΜΑ1 ← 0
ΑΘΡΟΙΣΜΑ2 ← 0
Για Κ από 1 μέχρι 30
 Αν Κ mod 2 = 0 τότε
  ΑΘΡΟΙΣΜΑ1 ← ΑΘΡΟΙΣΜΑ1 + ΠΙΝΑΚΑΣ_ΑΘΡΟΙΣΜΑ[Κ]
 αλλιώς
  ΑΘΡΟΙΣΜΑ2 ← ΑΘΡΟΙΣΜΑ2 + ΠΙΝΑΚΑΣ_ΑΘΡΟΙΣΜΑ[Κ]
 Τέλος_αν
Τέλος_επανάληψης

Αν ΑΘΡΟΙΣΜΑ1 > ΑΘΡΟΙΣΜΑ2 τότε
 Εμφάνισε "ΠΕΡΙΣΣΟΤΕΡΟ ΔΙΟΞΕΙΔΙΟ ΤΙΣ ΖΥΓΕΣ ΗΜΕΡΕΣ"
αλλιώς
 Εμφάνισε "ΠΕΡΙΣΣΟΤΕΡΟ ΔΙΟΞΕΙΔΙΟ ΤΙΣ ΜΟΝΕΣ ΗΜΕΡΕΣ"
Τέλος_αν

ΕΡΩΤΗΜΑ Δ
Για Ι από 1 μέχρι 10
ΑΘΡΟΙΣΜΑ ← 0
 Για Κ από 1 μέχρι 30
 ΑΘΡΟΙΣΜΑ ← ΑΘΡΟΙΣΜΑ + ΤΙΜΕΣ[Ι,Κ]
 Τέλος_επανάληψης
 ΑΘΡΟΙΣΜΑ_ΓΡΑΜΜΕΣ[Ι] ← ΑΘΡΟΙΣΜΑ
Τέλος_επανάληψης

ΜΑΧ ← ΑΘΡΟΙΣΜΑ_ΓΡΑΜΜΕΣ[1]
Για Ι από 2 μέχρι 10
 Αν ΑΘΡΟΙΣΜΑ_ΓΡΑΜΜΕΣ[Ι] > ΜΑΧ τότε
  ΜΑΧ ← ΑΘΡΟΙΣΜΑ_ΓΡΑΜΜΕΣ[Ι]
 Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε ΜΑΧ
ΕΡΩΤΗΜΑ Ε
ΗΜΕΡΑ[1] ← "ΤΕΤΑΡΤΗ"             ! ΑΡΧΙΚΟΠΟΙΩ ΤΟ ΠΙΝΑΚΑ ΗΜΕΡΕΣ
ΗΜΕΡΑ[2] ← "ΠΕΜΠΤΗ"              ! ΣΕ ΣΥΝΔΙΑΣΜΟ ΑΥΤΟ ΠΟΥ ΜΟΥ ΛΕΕΥ Η ΑΣΚΗΣΗ
ΗΜΕΡΑ[3] ← "ΠΑΡΑΣΚΕΥΗ"           ! ΟΤΙ Η 1Η ΤΟΥ ΜΗΝΑ ΠΕΦΤΕΙ ΗΜΕΡΑ ΤΕΤΑΡΤΗ
ΗΜΕΡΑ[4] ← "ΣΑΒΒΑΤΟ"
ΗΜΕΡΑ[5] ← "ΚΥΡΙΑΚΗ"
ΗΜΕΡΑ[6] ← "ΔΕΥΤΕΡΑ"
ΗΜΕΡΑ[7] ← "ΤΡΙΤΗ"

ΘΕΣΗ ← 1
ΜΑΧ ← ΠΙΝΑΚΑΣ_ΑΘΡΟΙΣΜΑ[1]      ! ΒΡΙΣΚΩ ΜΕΣΑ ΣΤΟ ΜΗΝΑ ΤΗ ΜΕΓΑΛΥΤΕΡΗ ΜΟΛΥΝΣΗ
Για Ι από 2 μέχρι 30
 Αν ΠΙΝΑΚΑΣ_ΑΘΡΟΙΣΜΑ[Ι]>ΜΑΧ τότε
  ΜΑΧ ← ΠΙΝΑΚΑΣ_ΑΘΡΟΙΣΜΑ[Ι]
  ΘΕΣΗ ← Ι                    ! ΚΡΑΤΑΩ ΤΗ ΘΕΣΗ ΤΗΣ ΗΜΕΡΑΣ
 Τέλος_αν
Τέλος_επανάληψης

Χ ← ΘΕΣΗ div 7      ! ΜΕ ΕΝΔΙΑΦΕΡΕΙ ΠΕΡΙΣΣΟΤΕΡΟ ΤΟ mod
Υ ← ΘΕΣΗ mod 7

Αν Υ=0 τότε   ! ΥΠΑΡΧΕΙ Η ΠΕΡΙΠΤΩΣΗ Η ΔΙΑΙΡΕΣΗ ΝΑ ΒΓΕΙ ΑΚΡΙΒΩΣ, ΟΠΟΤΕ ΕΠΕΙΔΗ
  Υ ← Υ + 1   !ΓΙΑ ΤΟΝ ΠΙΝΑΚΑ ΗΜΕΡΕΣ ΔΕΝ ΥΠΑΡΧΕΙ Η ΘΕΣΗ 0, ΠΡΟΣΘΕΤΟΥΜΕ + 1 ΓΙΑ
Τέλος_αν      ! ΝΑ ΕΜΦΑΝΙΣΕΙ ΤΗΝ ΑΝΤΙΣΟΙΧΗ ΗΜΕΡΑ ΣΤΟΝ ΠΙΝΑΚΑ

Για Ι από 1 μέχρι 7
 Αν ΗΜΕΡΑ[Ι]=Υ τότε
  Εμφάνισε ΗΜΕΡΑ[Ι]
 Τέλος_αν
Τέλος_επανάληψης

Τέλος ΛΕΚΑΝΟΠΕΔΙΟ


dionmiha

  • Οπαδός
  • **
  • Μηνύματα: 13
Απ: ΑΠΟΡΙΑ ΣΕ ΑΣΚΗΣΗ
« Απάντηση #1 στις: 15 Ιαν 2014, 01:16:13 μμ »
Βέβαια έτσι όπως βλέπω ξανά τον αλγόριθμο με ενδιαφέρει και η πράξη Χ <- ΘΕΣΗ div 7 , σε περίπτωση που βγει ακριβώς η διαίρεση για να κάνει την αντισοιχία με τον πίνακα ΗΜΕΡΕΣ στη θέση 7 δηλαδή "ΤΡΙΤΗ".   Άρα πρέπει να είναι λάθος η δομή επιλογής Αν Υ=0Τι λέτε???