Αποστολέας Θέμα: Πανελλαδικές εξετάσεις 2013  (Αναγνώστηκε 8778 φορές)

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 66
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #30 στις: 29 Μάι 2013, 12:36:14 μμ »
Γιατι μέχρι 99; Αν μείνει το για ι από 1 μέχρι 100, το για j από 101 μέχρι 100 θα εκτελεστεί;
Σωκράτης

nvacalo

  • Οπαδός
  • **
  • Μηνύματα: 12
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #31 στις: 29 Μάι 2013, 12:37:42 μμ »
Σκέψου ότι μια τυχαία σειρά έστω στα πρώτα 7 στοιχεία είναι Α Α Α Ψ Ψ Ψ Α, τότε απλώς όταν θα φτάσει στα 2 τελευταία θα γίνει μία αντιμετάθεση και τα στοιχεία θα πάρουν τη μορφή Α Α Α Ψ Ψ Α Ψ, και εννοείται θα συνεχιστεί ο βρόχος μέχρι το τέλος χωρίς να γυρίσει πίσω για να διορθώσει εκείνες τις θέσεις...Συμφωνώ με τον nvacalo απλώς ο πρώτος βρόχος πρέπει να τρέχει μέχρι το 99, αλλιώς θα ληφθεί υπ' όψιν και το στοιχείο
Κώδικας: [Επιλογή]
Π[100, 100] το οποίο δε θέλουμε...Δηλαδή κάπως έτσι:

Κώδικας: [Επιλογή]

  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 99
    ΓΙΑ  J ΑΠΟ Ι + 1 ΜΕΧΡΙ 100
      ΔΙΑΒΑΣΕ Π[Ι, J]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ



Το στοιχειο 100,100 δεν θα ληφθει υποψην γιατι η ροη δεν μπαινει στην επαναληψη Για j απο 101 μεχρι 100. Οποτε ειναι σωστο ειτε με 100 ειτε με 99.

vanalex

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #32 στις: 29 Μάι 2013, 12:55:13 μμ »
Το στοιχειο 100,100 δεν θα ληφθει υποψην γιατι η ροη δεν μπαινει στην επαναληψη Για j απο 101 μεχρι 100. Οποτε ειναι σωστο ειτε με 100 ειτε με 99.

Συμφωνώ! Μου διέφυγε η τελευταία επανάληψη, είναι σωστό και με 100! Αφού επεξεργάστηκα το ΘΕΜΑ Γ δε νομίζω ότι είναι και πολύ εύκολο τελικά...Μια πρόχειρη έκδοση που έγραψα:

Κώδικας: [Επιλογή]

   Αλγόριθμος ΘΕΜΑ_Γ_2013
ΑΘΡΟΙΣΜΑ_ΚΕΦ ← 0
ΑΘΡΟΙΣΜΑ_ΑΚΡ ← 0

!ΕΡΩΤΗΜΑ Γ1
Για Ι από 1 μέχρι 30
  Διάβασε ΚΩΔ[Ι]
  Για Κ από 1 μέχρι 30
    Διάβασε ΚΕΦ[Ι, Κ], ΑΚΡ[Ι, Κ]
  Τέλος_επανάληψης
Τέλος_επανάληψης

!ΕΡΩΤΗΜΑ Γ2
Για Ι από 1 μέχρι 30
  Για Κ από 1 μέχρι 10
    ΑΘΡΟΙΣΜΑ_ΚΕΦ ← ΑΘΡΟΙΣΜΑ_ΚΕΦ + ΚΕΦ[Ι, Κ]
    ΑΘΡΟΙΣΜΑ_ΑΚΡ ← ΑΘΡΟΙΣΜΑ_ΑΚΡ + ΑΚΡ[Ι, Κ]
  Τέλος_επανάληψης
  ΜΟ[Ι, 1] ← ΑΘΡΟΙΣΜΑ_ΚΕΦ/ 10
  ΜΟ[Ι, 2] ← ΑΘΡΟΙΣΜΑ_ΑΚΡ/ 10
  ΑΘΡΟΙΣΜΑ_ΚΕΦ ← 0
  ΑΘΡΟΙΣΜΑ_ΑΚΡ ← 0
Τέλος_επανάληψης

!ΕΡΩΤΗΜΑ Γ3
!ΕΥΡΕΣΗ ΠΕΔΙΟΥ ΣΤΟ ΟΠΟΙΟ ΑΝΗΚΕΙ ΤΟ ΚΕΦΑΛΙ
Για Ι από 1 μέχρι 30
  Αν ΜΟ[Ι, 1] ≤ 1.8 τότε
    ΠΕΔΙΟ_ΚΕΦ ← 1
  αλλιώς_αν ΜΟ[Ι, 1] ≤ 2 τότε
    ΠΕΔΙΟ_ΚΕΦ ← 2
  αλλιώς
    ΠΕΔΙΟ_ΚΕΦ ← 3
  Τέλος_αν

!ΕΥΡΕΣΗ ΠΕΔΙΟΥ ΣΤΟ ΟΠΟΙΟ ΑΝΗΚΕΙ ΤΟ ΑΚΡΟ
  Αν ΜΟ[Ι, 2] ≤ 3.6 τότε
    ΠΕΔΙΟ_ΑΚΡ ← 1
  αλλιώς_αν ΜΟ[Ι, 1] ≤ 4 τότε
    ΠΕΔΙΟ_ΑΚΡ ← 2
  αλλιώς
    ΠΕΔΙΟ_ΑΚΡ ← 3
  Τέλος_αν

!ΕΥΡΕΣΗ ΓΕΝΙΚΟΥ ΠΕΔΙΟΥ
  Αν ΠΕΔΙΟ_ΚΕΦ ≥ ΠΕΔΙΟ_ΑΚΡ τότε
    ΠΕΔΙΟ ← ΠΕΔΙΟ_ΚΕΦ
  αλλιώς
    ΠΕΔΙΟ ← ΠΕΔΙΟ_ΑΚΡ
  Τέλος_αν

  Αν ΠΕΔΙΟ = 1 τότε
    Εμφάνισε ΚΩΔ[Ι], "ΧΑΜΗΛΟΣ SAR"
  αλλιώς_αν ΠΕΔΙΟ = 2 τότε
    Εμφάνισε ΚΩΔ[Ι], "ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ"
  αλλιώς
    Εμφάνισε ΚΩΔ[Ι], "ΕΚΤΟΣ ΟΡΙΩΝ"
  Τέλος_αν
Τέλος_επανάληψης

!ΕΡΩΤΗΜΑ Γ4
! ΦΘΙΝΟΥΣΑ ΤΑΞΙΝΟΜΗΣΗ ΣΤΗΛΩΝ ΠΙΝΑΚΑ ΜΟ[30, 2]
! ΘΑ ΧΡΕΙΑΣΤΕΙ ΝΑ ΦΤΙΑΞΟΥΜΕ ΕΝΑΝ ΙΔΙΟ ΠΙΝΑΚΑ ΚΩΔ2[30] ΓΙΑ ΤΗΝ ΕΥΡΕΣΗ ΤΩΝ ΣΩΣΤΩΝ ΚΩΔΙΚΩΝ
!ΟΤΑΝ ΤΑΞΙΝΟΜΗΘΕΙ ΚΑΙ Η ΔΕΥΤΕΡΗ ΣΤΗΛΗ (ΘΑ ΕΧΟΥΝ ΗΔΗ ΤΑΞΙΝΟΜΗΘΕΙ ΜΙΑ ΦΟΡΑ ΟΠΟΤΕ ΔΕ ΘΑ ΕΧΟΥΜΕ ΣΩΣΤΑ ΑΠΟΤΕΛΕΣΜΑΤΑ
! ΑΝ ΤΟΥΣ ΑΦΗΣΟΥΜΕ ΟΠΩΣ ΕΙΝΑΙ
Για Ι από 1 μέχρι 30
  ΚΩΔ2[Ι] ← ΚΩΔ[Ι]
Τέλος_επανάληψης

Για Ν από 1 μέχρι 2
  Για Ι από 2 μέχρι 30
    Για Κ από 30 μέχρι Ι με_βήμα -1
      Αν ΜΟ[Κ - 1, Ν] < ΜΟ[Κ, Ν] τότε
        Αντιμετάθεσε ΜΟ[Κ - 1, Ν], ΜΟ[Κ, Ν]
        Αν Ν = 1 τότε
          Αντιμετάθεσε ΚΩΔ[Κ - 1], ΚΩΔ[Κ]
        αλλιώς
          Αντιμετάθεσε ΚΩΔ2[Κ - 1], ΚΩΔ[Κ]
        Τέλος_αν
      Τέλος_αν
    Τέλος_επανάληψης
  Τέλος_επανάληψης
Τέλος_επανάληψης

Εμφάνισε "ΟΙ ΜΑΘΗΤΕΣ ΜΕ ΤΟ ΜΕΓΑΛΥΤΕΡΟ ΜΕΣΟ ΟΡΟ ΣΤΟ ΚΕΦΑΛΙ"
Για Ι από 1 μέχρι 3
  Εμφάνισε ΚΩΔ[Ι], ΜΟ[Ι, 1]
Τέλος_επανάληψης

Εμφάνισε "ΟΙ ΜΑΘΗΤΕΣ ΜΕ ΤΟ ΜΕΓΑΛΥΤΕΡΟ ΜΕΣΟ ΟΡΟ ΣΤΑ ΑΚΡΑ"
Για Ι από 1 μέχρι 3
  Εμφάνισε ΚΩΔ2[Ι], ΜΟ[Ι, 2]
Τέλος_επανάληψης

Τέλος ΘΕΜΑ_Γ_2013

Και το θέμα της υπερίσχυσης του μεγαλύτερου πεδίου το βρίσκω δύσκολο σημείο για τα παιδιά...Αν έχετε την καλοσύνη ρίξτε μια ματιά και πείτε μου αν υπάρχουν λάθη. Το παραθέτω και σε doc για καλύτερη επεξεργασία.
Αλέξης Μιχαλακίδης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 66
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #33 στις: 29 Μάι 2013, 01:03:24 μμ »
Το Γ3 νομίζω πως "βγαίνει" και πιο απλά:

Κώδικας: [Επιλογή]
!ΕΡΩΤΗΜΑ Γ3

Για Ι από 1 μέχρι 30
  Αν ΜΟ[Ι,1]>(ΜΟ[Ι,2]/2) τότε     ! ΕΛΕΓΧΟΣ ΑΝ ΤΟ ΚΕΦΑΛΙ ΒΓΑΖΕΙ ΠΕΡΙΣΣΟΤΕΡΟ SAR
    Αν ΜΟ[Ι, 1] ≤ 1.8 τότε
      εμφάνισε "ΧΑΜΗΛΟΣ SAR"
    αλλιώς_αν ΜΟ[Ι,1] ≤ 2 τότε
      εμφάνισε "ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ"
    αλλιώς
      εμφάνισε "ΕΚΤΟΣ ΟΡΙΩΝ"
    Τέλος_αν
  αλλιώς
    Αν ΜΟ[Ι,2] ≤ 3.6 τότε
      εμφάνισε "ΧΑΜΗΛΟΣ SAR"
    αλλιώς_αν ΜΟ[Ι,2] <= 4 τότε
      εμφάνισε "ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ"
    αλλιώς
      εμφάνισε "ΕΚΤΟΣ ΟΡΙΩΝ"
  Τέλος_αν
Τέλος_επανάληψης
Σωκράτης

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • manosteach.com
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #34 στις: 29 Μάι 2013, 01:04:18 μμ »
ΑΝ ΚΑΠΟΙΟΣ ΕΓΡΑΦΕ ΣΤΟ Β2
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 99
  ΑΝ Π[Ι]= ΨΕΥΔΗΣ ΚΑΙ Π[Ι+1]= ΑΛΗΘΗΣ ΤΟΤΕ
  ΑΝΤΙΜΕΤΑΘΕΣΕ Π[Ι] , Π[Ι+1]
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΣΟΡΥ ΑΝ ΕΙΝΑΙ ΛΑΘΟΣ ΤΟ ΣΚΕΦΤΗΚΑ ΠΡΟΧΕΙΡΑ
Ναι θα ήταν λάθος.
Γιατί αν στο Π[1] και στο Π[2] έχει ψευδή και στο π[3] αληθής, το Π[1] δεν θα αλλάξει
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

olga_2703

  • Οπαδός
  • **
  • Μηνύματα: 13
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #35 στις: 29 Μάι 2013, 01:11:38 μμ »
Στο β2 δε θα μπορούσα να χρησιμοποιήσω ένα επιπλέον πίνακα?
κ<-1
λ<-100
Για ι από 1 μέχρι 100
  Αν Π[ι]=Α τότε
    Β[κ]<-Π[ι]
    κ<-κ +1
 Αλλι'ως
    Β[λ]<-Π[ι]
    λ<-λ-1
  Τ_Αν
Τ_Ε

Για ι από 1 μέχρι 100
  Π[ι]<-Β[ι]
Τ_Ε

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 66
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #36 στις: 29 Μάι 2013, 01:13:52 μμ »
Το
Για ι από 1 μέχρι 50
πρέπει να γίνει
Για ι από 1 μέχρι 100
Σωκράτης

olga_2703

  • Οπαδός
  • **
  • Μηνύματα: 13
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #37 στις: 29 Μάι 2013, 01:15:15 μμ »
Ναι...
Δουλεύει όμως???

olga_2703

  • Οπαδός
  • **
  • Μηνύματα: 13
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #38 στις: 29 Μάι 2013, 01:16:18 μμ »
Στο α4
θα μπορούσε να είναι
Για ι από 1 μέχρι 100
   Διάβασε Π[ι,ι]
Τ_Ε

????

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • manosteach.com
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #39 στις: 29 Μάι 2013, 01:17:31 μμ »
Στο β2 δε θα μπορούσα να χρησιμοποιήσω ένα επιπλέον πίνακα?
κ<-1
λ<-100
Για ι από 1 μέχρι 100
  Αν Π[ι]=Α τότε
    Β[κ]<-Π[ι]
    κ<-κ +1
 Αλλι'ως
    Β[λ]<-Π[ι]
    λ<-λ-1
  Τ_Αν
Τ_Ε

Για ι από 1 μέχρι 100
  Π[ι]<-Β[ι]
Τ_Ε
Πιστεύω πως αυτή η λύση πρέπει να γίνει δεκτή.
Δεν βάζει κάποιο περιορισμό.
Οπότε ΝΑΙ είναι σωστό.
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 66
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #40 στις: 29 Μάι 2013, 01:17:48 μμ »
Σωκράτης

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • manosteach.com
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #41 στις: 29 Μάι 2013, 01:18:51 μμ »
Στο α4
θα μπορούσε να είναι
Για ι από 1 μέχρι 100
   Διάβασε Π[ι,ι]
Τ_Ε

????
Όχι
Γιατί με αυτό που γράφεις, διαβάζεις μονο τα στοιχεία της διαγωνίου
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 66
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #42 στις: 29 Μάι 2013, 01:19:29 μμ »
Στο α4
θα μπορούσε να είναι
Για ι από 1 μέχρι 100
   Διάβασε Π[ι,ι]
Τ_Ε

????

Όχι, διότι το θέμα δεν θέλει την διάβασε για i=j
Σωκράτης

olga_2703

  • Οπαδός
  • **
  • Μηνύματα: 13
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #43 στις: 29 Μάι 2013, 01:22:47 μμ »
Δικό μου λάθος, μπερδέυτηκα με τα Εσπερινα... :-[

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 66
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #44 στις: 29 Μάι 2013, 01:28:06 μμ »
Να ρωτήσω κάτι με τη σειρά μου: το Δ4 βγαίνει σωστά και με όσο και με μέχρις_ότου;
Με άλλα λόγια, αν χρησιμοποιηθεί μέχρις_ότου και η ερώτηση για διακοπή της εισαγωγής μπει στο τέλος του loop, υπάρχει θέμα ως προς την 1η απάντηση του χρήστη;
Επίσης, σε ποια μεταβλητή καταχωρείται η απάντηση δ ή Δ; στη μεταβλητή χώρα ή σε 3η; Το Δ3 είναι σχετικά ασαφές...
« Τελευταία τροποποίηση: 29 Μάι 2013, 01:38:07 μμ από soc_h »
Σωκράτης