Αποστολέας Θέμα: Μεταβάλλω το δείκτη μέσα σε Συνάρτηση και μέσα σε Διαδικασία  (Αναγνώστηκε 1193 φορές)

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 522
  • There can be only one...may it be AEPP.
Επιτρέπεται αυτό
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ Α1
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: I, Χ
ΑΡΧΗ
  ΓΙΑ I ΑΠΟ 0 ΜΕΧΡΙ 9
    Χ <- Σ(I)
    ΓΡΑΨΕ Χ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ Σ(I): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: I
ΑΡΧΗ
  I <- I + 1
  Σ <- I
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Και ΔΕΝ επιτρέπεται αυτό
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ Α2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: I, Χ
ΑΡΧΗ
  ΓΙΑ I ΑΠΟ 0 ΜΕΧΡΙ 9
    ΚΑΛΕΣΕ Δ(I)
    ΓΡΑΨΕ I
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Δ(I)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: I
ΑΡΧΗ
  I <- I + 1
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

(Ακόμα και αν δε μεταβάλλω την πραγματική αλλά την τυπική παράμετρο)
Σωστά;( :D)
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 879
χμμ πολύ πονηρό αυτό...
έχεις δίκιο, γιατί στη 2η περίπτωση μεταβάλλεις το μετρητή της ΓΙΑ
Φιλικά,
Γιώργος Θαλασσινός

Gnirut

  • Επισκέπτης
Μια ακόμα πιο "μπερδεψιάρικη" άσκηση βασισμένη πάνω στα παραπάνω προγράμματα που στείλατε:

Τι θα εμφανίσει στην οθόνη το παρακάτω πρόγραμμα;

Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ Α3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: I, Χ
ΑΡΧΗ
  ΓΙΑ I ΑΠΟ 0 ΜΕΧΡΙ 9
    Χ <- Σ(I)
    ΓΡΑΨΕ Χ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Δ(Χ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ
ΑΡΧΗ
  Χ <- Χ + 1
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ Σ(I): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: I
ΑΡΧΗ
  ΚΑΛΕΣΕ Δ(I)
  Σ <- I
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 522
  • There can be only one...may it be AEPP.
Μια ακόμα πιο "μπερδεψιάρικη" άσκηση βασισμένη πάνω στα παραπάνω προγράμματα που στείλατε:

Τι θα εμφανίσει στην οθόνη το παρακάτω πρόγραμμα;

Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ Α3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: I, Χ
ΑΡΧΗ
  ΓΙΑ I ΑΠΟ 0 ΜΕΧΡΙ 9
    Χ <- Σ(I)
    ΓΡΑΨΕ Χ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Δ(Χ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ
ΑΡΧΗ
  Χ <- Χ + 1
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ Σ(I): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: I
ΑΡΧΗ
  ΚΑΛΕΣΕ Δ(I)
  Σ <- I
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

  :D
Φοβερό! Πάρα πολύ ωραίο Gnirut. Εδώ τώρα μεταβάλλεται ή δε μεταβάλλεται ο δείκτης; :-\
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

ioarvanit

  • Πληροφορικοί Δυτικής Μακεδονίας
  • *
  • Μηνύματα: 14
    • Edutorials
Ο Δείκτης Ι του κυρίου προγράμματος δεν μεταβάλλεται παρά μόνο από την δομή επανάληψης του ίδιου του προγράμματος. Η διαδικασία μεταβάλλει την τιμή της μεταβλητής Ι της συνάρτησης η οποία όμως δεν επιστρέφει στο κυρίως πρόγραμμα