Αποστολέας Θέμα: Θέμα 3ο  (Αναγνώστηκε 2429 φορές)

tomemeto1

  • Θαμώνας
  • ***
  • Μηνύματα: 29
Θέμα 3ο
« στις: 09 Μάρ 2008, 06:29:35 μμ »
Δίνεται πίνακας Π δύο διαστάσεων, που τα στοιχεία του είναι ακέραιοι αριθμοί με Ν γραμμές και Μ στήλες. Να αναπτύξετε αλγόριθμο που να υπολογίζει το ελάχιστο στοιχείο του πίνακα. Μονάδες 20

Λύση

Αλγόριθμος Ελάχιστο_Πίνακα
Δεδομένα // Π, Ν, Μ //
min <- Π[1,1]
Για i από 1 μέχρι Ν
   Για j από 1 μέχρι Μ
   Αν Π[i,j] < min τότε
      min <- Π[i,j]
   Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Ελάχιστο_Πίνακα



Αν κάποιος μαθητής επιλέξει να γράψει πρόγραμμα ή αλγόριθμο και αντί να γράψει

Δεδομένα // Π, Ν, Μ //

γράψει

ΔΙΑΒΑΣΕ Ν,Μ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
     ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ Μ
            ΔΙΑΒΑΣΕ Π[Ι,J]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


θα χάσει μονάδες? Δεν νομίζω απλά για επιβεβαίωση ρωτάω...

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3129
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Θέμα 3ο
« Απάντηση #1 στις: 09 Μάρ 2008, 09:15:00 μμ »
το βιβλίο δεν είναι τόσο ξεκάθαρο, δυστυχώς

μακάρι να τα χρησιμοποιούσαμε "σωστά"...