Αποστολέας Θέμα: Συζήτηση για το 2ο θέμα  (Αναγνώστηκε 6336 φορές)

Dem

  • Θαμώνας
  • ***
  • Μηνύματα: 49
Συζήτηση για το 2ο θέμα
« στις: 31 Μάι 2007, 02:53:05 μμ »
στο δευτερο θεμα ηθελε συγκεκριμενο τροπο που θα χρησιμοποιησει το προγραμμα το υποπρογραμμα???
θα χρησιμοποιησουμε μια τεταρτη μεταβλητη και θα εκχωρησουμε την τιμη απο τη διαδικασια πραξεις(η λυση που βλεπω στα site) η θα στειλουμε και τη μεταβλητη γ στο υποπρογραμμα και θα κανουμε την αν ετσι
αν α>=β τοτε
     γ<-2*α-β
αλλιως
     γ<-2*α+β
τελος_αν
?????????????????????????????????????
« Τελευταία τροποποίηση: 31 Μάι 2007, 03:04:48 μμ από Dem »

kLee

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • Is the Singularity near?
Απ: Συζήτηση για το 2ο θέμα
« Απάντηση #1 στις: 31 Μάι 2007, 02:56:53 μμ »
ΘΕΜΑ 2ο:
α.
ΠΡΟΓΡΑΜΜΑ Υπολογισμοί
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α, β, γ, αποτ 
ΑΡΧΗ
  ΔΙΑΒΑΣΕ α, β
  ΚΑΛΕΣΕ Πράξη(α, β, αποτ)
  γ <-- α + αποτ
  ΓΡΑΨΕ γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Πράξη (χ, ψ, ζ)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: χ, ψ, ζ
ΑΡΧΗ
  ΑΝ χ>=ψ ΤΟΤΕ
    ζ <-- χ-ψ
  ΑΛΛΙΩΣ
    ζ <-- χ+ψ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

β.
ΠΡΟΓΡΑΜΜΑ Υπολογισμοί
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α, β, γ, ζ
ΑΡΧΗ
  ΔΙΑΒΑΣΕ α, β
  ΑΝ α>=β ΤΟΤΕ
    ζ <-- α-β
  ΑΛΛΙΩΣ
    ζ <-- α+β
  ΤΕΛΟΣ_ΑΝ
  γ <-- α + ζ
  ΓΡΑΨΕ γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Ανδροκλής Πολυμένης

Πληροφορικός

Dem

  • Θαμώνας
  • ***
  • Μηνύματα: 49
Απ: Συζήτηση για το 2ο θέμα
« Απάντηση #2 στις: 31 Μάι 2007, 03:01:28 μμ »
ευχαριστω για τις λυσεις αλλα θελω να μου πειτε αν ειναι σωστο αυτο που εκανα!!!!!!
η τελοσπαντων τι νομιζετε εσεις οτι ειναι............

Dem

  • Θαμώνας
  • ***
  • Μηνύματα: 49
Απ: Συζήτηση για το 2ο θέμα
« Απάντηση #3 στις: 31 Μάι 2007, 03:09:55 μμ »
ΠΡΟΓΡΑΜΜΑ ΥΠΟΛΟΓΙΣΜΟΙ
ΜΕΤΑΒΛΗΤΕΣ
    ΠΡΑΓΜΑΤΙΚΕΣ:α,β,γ
ΑΡΧΗ
    ΔΙΑΒΑΣΕ α,β
    ΚΑΛΕΣΕ ΠΡΑΞΕΙΣ(α,β,γ)
    ΓΡΑΨΕ γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΠΡΑΞΕΙΣ(α,β,γ)
ΜΕΤΑΒΛΗΤΕΣ
    ΠΡΑΓΜΑΤΙΚΕΣ:α,β,γ
ΑΡΧΗ
    ΑΝ α>=β τοτε
        γ<-2*α-β
    ΑΛΛΙΩΣ
        γ<-2*α+β
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
??????

kLee

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • Is the Singularity near?
Απ: Συζήτηση για το 2ο θέμα
« Απάντηση #4 στις: 31 Μάι 2007, 03:13:03 μμ »
"α. Να ξαναγράψετε το πρόγραμμα, ώστε να επιτελεί την ίδια λειτουργία χρησιμοποιώντας διαδικασία αντί συνάρτησης."

Δεν ορίζει ρητά να μετατρέψεις τη δεδομένη συνάρτηση σε ισοδύναμη διαδικασία και μετά να τη χρησιμοποιήσεις στο πρόγραμμα. Επιπλέον βγάζεις σωστά αποτελέσματα.

Εγώ θα το έπερνα σωστό, αλλά μάλλον εδώ θα πρέπει να τοποθετηθεί συνάδελφος που διορθώνει γραπτά...
Ανδροκλής Πολυμένης

Πληροφορικός

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1467
  • Δεν αντέχω την (συμ)-πίεσηηη .......
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Συζήτηση για το 2ο θέμα
« Απάντηση #5 στις: 31 Μάι 2007, 03:23:50 μμ »
Φίλε Ανδροκλή,

ήρθε διευκρίνιση στο 2α ώστε να μετατρέπεται και η συνάρτηση σε διαδικασία. Ήταν λοιπόν απαραίτητη η μετατροπή σε διαδικασία
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

Dem

  • Θαμώνας
  • ***
  • Μηνύματα: 49
Απ: Συζήτηση για το 2ο θέμα
« Απάντηση #6 στις: 31 Μάι 2007, 03:25:53 μμ »
δηλαδη το μονο που ηθελε ηταν να γραψουμε αντι για συναρτηση διαδικασια και να χρησιμοποιησουμε μια επιπλεον μεταβλητη στο προγραμμα???
η λυση μου ειναι λαθος δηλαδη????

kLee

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • Is the Singularity near?
Απ: Συζήτηση για το 2ο θέμα
« Απάντηση #7 στις: 31 Μάι 2007, 03:30:27 μμ »
Φίλε Ανδροκλή,

ήρθε διευκρίνιση στο 2α ώστε να μετατρέπεται και η συνάρτηση σε διαδικασία. Ήταν λοιπόν απαραίτητη η μετατροπή σε διαδικασία

Γιώργο καλησπέρα,

Παραθέτω και τη διευκρίνηση:
"Να ξαναγράψετε το πρόγραμμα ώστε να επιτελεί την ίδια λειτουργία χρησιμοποιώντας διαδικασία αντί της συνάρτησης, την οποία διαδικασία και να κατασκευάσετε."

Το πρόβλημα όμως είναι στη μορφή της διαδικασίας - ο "κοινός" νους (κι εγώ επίσης  :D :P) θα έφτιαχνε διαδικασία που θα έκανε ότι και η συνάρτηση. Αλλά εδώ δε διευκρινίζεται κατά τη γνώμη μου τη μορφή ακριβώς θα έχει αυτή η διαδικασία...
Ανδροκλής Πολυμένης

Πληροφορικός

tomtoub

  • Νέος
  • *
  • Μηνύματα: 3
Απ: Συζήτηση για το 2ο θέμα
« Απάντηση #8 στις: 31 Μάι 2007, 03:51:39 μμ »
Στο (γ) υποερώτημα πειράζει που έκανα πίνακα τιμών?

Dem

  • Θαμώνας
  • ***
  • Μηνύματα: 49
Απ: Συζήτηση για το 2ο θέμα
« Απάντηση #9 στις: 31 Μάι 2007, 03:55:28 μμ »
ρε γαμωτο γιατι να μου ερθει να γραψω αυτο..............γιατι να μην σκεφτω ''κοινα''????????????
το προτιμησα γιατι δεν χρησιμοποιω τεταρτη μεταβλητη και γιατι το θεωρησα ''πιο ισοδυναμο''......................

pav_rod

  • Ομάδα διαγωνισμάτων 2008
  • *
  • Μηνύματα: 16
Απ: Συζήτηση για το 2ο θέμα
« Απάντηση #10 στις: 31 Μάι 2007, 04:05:44 μμ »
Συμφωνώ με τον Ανδροκλή. Το ζητούμενο ήταν το πρόγραμμα με τη χρήση της διαδικασίας να κάνει την ίδια λειτουργία με αυτήν που έκανε με τη χρήση της συνάρτησης. H λύση του Dem κάνει την ίδια λειτουργία. Επομένως θεωρώ ότι ότι η απάντηση του Dem είναι απόλυτα σωστή και έτσι πρέπει να ληφθεί.
ΠΕ 19
MSc καθηγητής Πληροφορικής

Peandbal

  • Θαμώνας
  • ***
  • Μηνύματα: 48
  • Αρθρο 16
Απ: Συζήτηση για το 2ο θέμα
« Απάντηση #11 στις: 31 Μάι 2007, 04:22:02 μμ »
Μια ακόμα λύση για το 2ο θέμα με τρεις μεταβλητές

ΘΕΜΑ 2ο:
α.
ΠΡΟΓΡΑΜΜΑ Υπολογισμοί
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α, β, γ
ΑΡΧΗ
  ΔΙΑΒΑΣΕ α, β
  γ <-- 0
  ΚΑΛΕΣΕ Πράξη(α, β, γ)
  γ <-- α + γ
  ΓΡΑΨΕ γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Πράξη (χ, ψ, ζ)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: χ, ψ, ζ
ΑΡΧΗ
  ΑΝ χ>=ψ ΤΟΤΕ
    ζ <-- χ-ψ
  ΑΛΛΙΩΣ
    ζ <-- χ+ψ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

β.
ΠΡΟΓΡΑΜΜΑ Υπολογισμοί
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α, β, γ
ΑΡΧΗ
  ΔΙΑΒΑΣΕ α, β
  γ <-- 0
  ΑΝ α>=β ΤΟΤΕ
    γ <-- α-β
  ΑΛΛΙΩΣ
    γ <-- α+β
  ΤΕΛΟΣ_ΑΝ
  γ <-- α + γ
  ΓΡΑΨΕ γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Dem

  • Θαμώνας
  • ***
  • Μηνύματα: 49
Απ: Συζήτηση για το 2ο θέμα
« Απάντηση #12 στις: 31 Μάι 2007, 04:25:47 μμ »
νομιζω δεν χρειαζεται μηδενισμος του γ
εγω αυτο εκανα μονο την εντολη εκχωρησης γ<-γ+α την εκανα μεσα στην αν της διαδικασιας
 :(  :o

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3181
  • to Iterate is human to Recurse divine
Απ: Συζήτηση για το 2ο θέμα
« Απάντηση #13 στις: 31 Μάι 2007, 06:06:23 μμ »
Βασικά ναι μεν είναι λάθος αυτό που έκανες, αλλά δε νομίζω ότι θα σου κόψουν πολλές μονάδες (το πολύ δυο θα έλεγα). Άσε που πολλοί βαθμολογητές δεν θα το πάρουν και χαμπάρι ;)
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

pav_rod

  • Ομάδα διαγωνισμάτων 2008
  • *
  • Μηνύματα: 16
Απ: Συζήτηση για το 2ο θέμα
« Απάντηση #14 στις: 31 Μάι 2007, 06:19:54 μμ »
Γιατί είναι λάθος αυτό που έκανε ο Dem? Είναι ισοδύναμη η λύση του με την αρχική λειτουργία του προγράμματος.
ΠΕ 19
MSc καθηγητής Πληροφορικής