Αποστολέας Θέμα: ΦΙΛΟΙ ΑΡΙΘΜΟΙ  (Αναγνώστηκε 2958 φορές)

Yuris

  • Νέος
  • *
  • Μηνύματα: 5
ΦΙΛΟΙ ΑΡΙΘΜΟΙ
« στις: 30 Μάρ 2009, 12:28:59 μμ »
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΦΙΛΟΙ_ΑΡΙΘΜΟΙ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Σ1 , Σ2 , Κ1 , Κ2 , Μ , Ν , ΜΕΤ , ΖΕΥ , ΑΠ
ΑΡΧΗ
  ΓΡΑΨΕ 'Πάλι στους Πυθαγόρειους οφείλονται και οι φίλοι αριθμοί.'
  ΓΡΑΨΕ 'Δυο αριθμοί λέγονται φίλοι αν ο καθένας ισούται'
  ΓΡΑΨΕ 'με το άθροισμα των γνήσιων διαιρετών του άλλου.'
  ΓΡΑΨΕ 'Για παράδειγμα το 220 και το 284.'
  ΓΡΑΨΕ 'ΤΟ ΠΡΟΓΡΑΜΜΑ ΑΥΤΟ ΕΛΕΓΧΕΙ ΓΙΑ ΤΥΧΟΝ ΖΕΥΓΑΡΙΑ ΦΙΛΩΝ ΑΡΙΘΜΩΝ'
  ΓΡΑΨΕ 'ΜΕΣΑ ΣΤΑ ΑΚΕΡΑΙΑ ΟΡΙΑ ΠΟΥ ΔΙΝΕΙ Ο ΧΡΗΣΤΗΣ'
  ΓΡΑΨΕ 'ΘΕΛΕΤΕ ΝΑ ΕΚΤΕΛΕΣΕΤΕ ΤΟ ΠΡΟΓΡΑΜΜΑ?'
  ΓΡΑΨΕ ' 1.ΝΑΙ'
  ΓΡΑΨΕ ' 2.ΟΧΙ'
  ΔΙΑΒΑΣΕ ΑΠ
  ΟΣΟ  ΑΠ <> 1 ΚΑΙ ΑΠ <> 2 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ'ΣΥΓΝΩΜΗ ΑΛΛΑ ΔΕΝ ΓΡΑΨΑΤΕ ΜΙΑ ΑΠΟ ΤΙΣ ΕΠΙΛΟΓΕΣ'
    ΔΙΑΒΑΣΕ ΑΠ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΟΣΟ ΑΠ = 1 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΟΝ ΑΡΙΘΜΟ ΑΠΟ ΤΟΝ ΟΠΟΙΟ ΘΑ ΞΕΚΙΝΙΣΕΙ Ο ΕΛΕΓΧΟΣ'
    ΔΙΑΒΑΣΕ Μ
    ΓΡΑΨΕ'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΟΝ ΑΡΙΘΜΟ ΑΠΟ ΤΟΝ ΟΠΟΙΟ ΘΑ ΤΕΛΕΙΩΣΕΙ Ο ΕΛΕΓΧΟΣ'
    ΔΙΑΒΑΣΕ Ν
    ΟΣΟ  Μ >= Ν ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'ΔΩΣΑΤΕ ΑΡΙΘΜΟ ΜΙΚΡΟΤΕΡΟ ΑΠΟ ΤΟΝ ΑΡΙΘΜΟ ΕΝΑΡΞΗΣ.'
      ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΕΝΑΝ ΜΕΓΑΛΥΤΕΡΟ ΤΟΥ ', Μ
      ΔΙΑΒΑΣΕ Ν
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΖΕΥ <-- 0
    ΜΕΤ <-- 1
    ΓΙΑ Χ ΑΠΟ Μ ΜΕΧΡΙ Ν
      ΑΝ Χ <> ΜΕΤ ΤΟΤΕ  !ΤΟ ΕΒΑΛΑ ΑΥΤΟ ΔΙΟΤΙ ΔΙΑΠΙΣΤΩΣΑ ΠΩΣ ΘΑ ΕΜΦΑΝΙΣΕΙ 2 ΦΟΡΕΣ ΤΟ ΖΕΥΓΑΡΙ ΟΤΑΝ !
        Σ1 <-- 1        !ΤΟ Χ ΘΑ ΠΑΡΕΙ ΤΗΝ ΤΙΜΗ ΤΟΥ Υ!
        Κ1 <-- 1
        ΟΣΟ Κ1<=Χ^(1/2) ΕΠΑΝΑΛΑΒΕ
          Κ1 <-- Κ1+1
          ΑΝ Χ MOD Κ1 = 0 ΤΟΤΕ
            Σ1 <-- Σ1+Κ1+ Χ DIV Κ1
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΙΑ Υ ΑΠΟ Μ ΜΕΧΡΙ Ν
          ΑΝ Χ <> Υ ΤΟΤΕ
            Σ2 <-- 1
            Κ2 <-- 1
            ΟΣΟ Κ2<=Υ^(1/2) ΕΠΑΝΑΛΑΒΕ
              Κ2 <-- Κ2+1
              ΑΝ Υ MOD Κ2 = 0 ΤΟΤΕ
                Σ2 <-- Σ2+Κ2+Υ DIV Κ2
              ΤΕΛΟΣ_ΑΝ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΑΝ Σ2 = Χ ΚΑΙ Σ1 = Υ ΤΟΤΕ
              ΓΡΑΨΕ'ΒΡΕΘΗΚΕ ΖΕΥΓΑΡΙ ΦΙΛΩΝ ΑΡΙΘΜΩΝ , ΕΙΝΑΙ ΟΙ',Χ,Υ
              ΖΕΥ <-- ΖΕΥ +1
              ΜΕΤ <-- Υ
            ΤΕΛΟΣ_ΑΝ
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΖΕΥ = 0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΔΕΝ ΒΡΕΘΗΚΑΝ ΖΕΥΓΑΡΙΑ ΣΤΑ ΟΡΙΑ ΠΟΥ ΘΕΣΑΤΕ'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΒΡΕΘΗΚΑΝ', ΖΕΥ , 'ΖΕΥΓΑΡΙΑ'
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ ' ΘΕΛΕΤΕ ΝΑ ΞΑΝΑΚΑΝΕΤΕ ΕΛΕΓΧΟ?'
    ΓΡΑΨΕ'   1.ΝΑΙ'
    ΓΡΑΨΕ'   2.ΟΧΙ'
    ΔΙΑΒΑΣΕ ΑΠ
    ΟΣΟ ΑΠ <> 1 ΚΑΙ ΑΠ <> 2 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ'ΣΥΓΝΩΜΗ ΑΛΛΑ ΔΕΝ ΓΡΑΨΑΤΕ ΜΙΑ ΑΠΟ ΤΙΣ ΔΥΟ ΕΠΙΛΟΓΕΣ'
      ΔΙΑΒΑΣΕ ΑΠ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΑΤΕ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΕΚΤΕΣ ΟΛΕΣ ΟΙ ΠΑΡΑΤΗΡΗΣΕΙΣ ΚΑΙ ΟΙ ΔΙΟΡΘΩΣΕΙΣ  :)
« Τελευταία τροποποίηση: 31 Μάρ 2009, 11:19:19 πμ από Yuris »
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy." -
-- Martin Luther King Jr.