Αποστολέας Θέμα: Θέμα Β  (Αναγνώστηκε 16572 φορές)

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: Θέμα Β
« Απάντηση #30 στις: 27 Μάι 2015, 04:45:38 μμ »
Μόνο το τρίτο είναι σωστό. Τα δύο πρώτα εμφανίζουν τα ίδια αλλά η τιμή του y στο τέλος δεν είναι ίδια με το δοσμένο.

Για ποιον λόγο να με ενδιαφέρει η τιμή του y  μετά την επανάληψη; λέει πουθενά να εμφανίσουμε την τιμή του y μετά;

Θα μπορούσε ο μαθητής εάν θέλει την τιμή του y  μετά την επανάληψη να κάνει το y<-y+2 κάτι που δεν μας ενδιαφέρει στην συγκεκριμένη άσκηση
VR in Computing

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Θέμα Β
« Απάντηση #31 στις: 27 Μάι 2015, 04:47:09 μμ »
Θα ανοίξει πάλι ο ατέρμων διάλογος για την ισοδυναμία 2 επαναλήψεων που ούτε κι εμείς δεν καταλήξαμε εδώ και χρόνια
Γι'αυτό πρόκειται για κακό θέμα, πέρα από το ότι δεν εξετάζει τίποτα χρήσιμο
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: Θέμα Β
« Απάντηση #32 στις: 27 Μάι 2015, 04:57:03 μμ »
Μόνο το τρίτο είναι σωστό. Τα δύο πρώτα εμφανίζουν τα ίδια αλλά η τιμή του y στο τέλος δεν είναι ίδια με το δοσμένο.

Αυτό είναι σωστό ή λάθος;

Αν χ > 1 τότε
  Για i από χ μέχρι 1 με_βήμα -2
    y ← y - 2
    Εμφάνισε y
  Τέλος_επανάληψης
Τέλος_αν

Δεν ζητάει πουθενά να μην χρησιμοποιήσουμε νέες μεταβλητές και εάν το έκανε κάποιος μαθητής το παραπάνω πόσο θα πάρει από τις 8 μονάδες;

Εγώ πάντως θα του έδινα και τις 8
VR in Computing

ολγα

  • Βετεράνος
  • ****
  • Μηνύματα: 86
Απ: Θέμα Β
« Απάντηση #33 στις: 27 Μάι 2015, 05:16:55 μμ »
Θα ανοίξει πάλι ο ατέρμων διάλογος για την ισοδυναμία 2 επαναλήψεων που ούτε κι εμείς δεν καταλήξαμε εδώ και χρόνια
Γι'αυτό πρόκειται για κακό θέμα, πέρα από το ότι δεν εξετάζει τίποτα χρήσιμο
Δεν χρησιμοποίησα τη λέξη ισοδυναμία, που δεν έχουμε καταλήξει τι σημαίνει, ούτε και η εκφώνηση λέει κάτι τέτοιο.
Να το πω αλλιώς. Η εκφώνηση αναφέρεται σε τμήμα αλγορίθμου που πρέπει να το ξαναγράψουμε  με άλλο τρόπο, προφανώς έτσι ώστε ολόκληρος ο αλγόριθμος να δουλεύει όμοια σε κάθε περίπτωση ανεξάρτητα από ό,τι υπάρχει πριν και μετά από αυτό το τμήμα και χωρίς να χρειαστεί να παρέμβουμε στα "πριν" και στα "μετά".  - ακόμα και στην περίπτωση που το "μετά" είναι π.χ. Εμφάνισε y. Γι' αυτό είναι σημαντική κατά τη γνώμη μου και η τελική τιμή του y.
« Τελευταία τροποποίηση: 27 Μάι 2015, 05:30:36 μμ από ολγα »

ολγα

  • Βετεράνος
  • ****
  • Μηνύματα: 86
Απ: Θέμα Β
« Απάντηση #34 στις: 27 Μάι 2015, 05:51:25 μμ »
Αυτό είναι σωστό ή λάθος;

Αν χ > 1 τότε
  Για i από χ μέχρι 1 με_βήμα -2
    y ← y - 2
    Εμφάνισε y
  Τέλος_επανάληψης
Τέλος_αν

Δεν ζητάει πουθενά να μην χρησιμοποιήσουμε νέες μεταβλητές και εάν το έκανε κάποιος μαθητής το παραπάνω πόσο θα πάρει από τις 8 μονάδες;

Εγώ πάντως θα του έδινα και τις 8
Ίσως και γω με την πρώτη ματιά, αλλά με μια προσεκτικότερη ανάγνωση τι γίνεται αν π.χ. το τμήμα αυτό βρίσκεται μέσα σε ένα "Για i από 1 μέχρι 100";
Μπορεί να είμαι εκνευριστικά σχολαστική...

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Θέμα Β
« Απάντηση #35 στις: 27 Μάι 2015, 06:03:15 μμ »
Από το πρωί έχω μιλήσει με δεκάδες παιδιά και μόνο μια κοπέλα το έχει λύσει σωστά
Η πιο συνηθισμένη λύση που συναντώ είναι το
Για ψ από χ-2 μέχρι 0 με βήμα -2
Εμφάνισε ψ

Ας ελπίσουμε να μην κοπούν πάνω από 2-3 μονάδες γι'αυτό..
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Dimi97

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Θέμα Β
« Απάντηση #36 στις: 27 Μάι 2015, 07:07:33 μμ »
Γεια σας,έκανα παρόμοιο ποστ στον γενικό σχολιασμό αλλά νομίζω εδω ταιριάζει καλύτερα.

Εγώ έκανα το Β1 β λιγο διαφορετικά απο ολες νομιζω τις απαντήσεις που ειδα,και αναρωτιέμαι:και σωστό να είναι,υπάρχει περίπτωση ο βαθμολογητής να δει οτι διαφέρει απο ολες τι άλλες απαντήσεις και απευθείας να το θεωρήσει λάθος χωρίς να δώσει μεγαλη προσοχη?

αν χ>1 τότε

για y απο (χ-2) μέχρι 0.1 με_βήμα -2
εμφάνισε y
τέλος_επανάληψης

εμφάνισε y

τέλος_αν

δουλευει κανονικά οταν το μετέφερα στον υπολογιστή και μου φαίνεται πιο σωστό απο τις λύσεις που είδα σε ΟΕΦΕ και γενικα πολλές σελίδες εκτός αυτού του φόρουμ...

lsourtzo

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 131
Απ: Θέμα Β
« Απάντηση #37 στις: 27 Μάι 2015, 08:02:29 μμ »
πραγματικός πονοκέφαλος για τους διορθωτές το θέμα ... η γενική διατύπωση του θα αφήσει δύστυχος πολλές δυνατότητες για υποκειμενική διόρθωση ... έχω την αίσθηση ότι πρέπει να προστατεύσουμε το μάθημα μας και να μην αφήσουμε το θέμα να γίνει για ακόμα μια φορά αφορμή να τσακωθούν οι διορθωτές για το πόσα μόρια πρέπει να κοπούν και πότε ...

προσωπικά σαν λύση έχω δώσει το

Αν χ > 1 τότε
  Για y από χ - 2 μέχρι -1 με_βήμα -2
    Εμφάνισε y
  Τέλος_επανάληψης
Τέλος_αν

γιατί ποιο σημαντικό από το τι τιμή θα έχει το Υ μετά, θεώρησα με την πρώτη ματιά ότι είναι το κομμάτι που αναφέρετε  η άσκηση στην μετατροπή της Μέχρις_Ότου σε Για και όχι στο πείραγμα άλλων εντολών.

άριστος μαθητής μου μου έφερε αυτό σαν λύση

Αν Χ > 1 τότε
  Υ<-- Χ
  Αν Υ mod 2 = 1 τότε
       Κ <-- Υ div 2 +1
  Αλλιώς
       Κ <-- Υ div 2
  Τέλος_Αν
  Για ι από 1 μέχρι κ
       Υ <-- Υ - 2
       Εμφάνισε Υ
  Τέλος_Επανάληψης
Τέλος_Αν

Το θέμα είναι ότι πως θα του πω ότι κάποιος του έκοψε μόρια γιατί .... γιατί ??? δεν λέει πουθενά μην βάλεις νέες μεταβλητές ... δεν λέει να μην πάρει και άλλη δομή επιλογής ... γιατί να κοπούν μόρια οπότε ???

Πραγματικά νομίζω ότι με την ελαφρότητα που έχει η εκφώνηση θα πρέπει τελικά να γίνει αποδεκτή οποιαδήποτε λύση παράγει ισοδύναμα αποτελέσματα.

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 152
Απ: Θέμα Β
« Απάντηση #38 στις: 27 Μάι 2015, 09:26:21 μμ »
Γεια σας,έκανα παρόμοιο ποστ στον γενικό σχολιασμό αλλά νομίζω εδω ταιριάζει καλύτερα.

Εγώ έκανα το Β1 β λιγο διαφορετικά απο ολες νομιζω τις απαντήσεις που ειδα,και αναρωτιέμαι:και σωστό να είναι,υπάρχει περίπτωση ο βαθμολογητής να δει οτι διαφέρει απο ολες τι άλλες απαντήσεις και απευθείας να το θεωρήσει λάθος χωρίς να δώσει μεγαλη προσοχη?

αν χ>1 τότε

για y απο (χ-2) μέχρι 0.1 με_βήμα -2
εμφάνισε y
τέλος_επανάληψης

εμφάνισε y

τέλος_αν

δουλευει κανονικά οταν το μετέφερα στον υπολογιστή και μου φαίνεται πιο σωστό απο τις λύσεις που είδα σε ΟΕΦΕ και γενικα πολλές σελίδες εκτός αυτού του φόρουμ...

όπως σού είπα και στο άλλο post, για χ=2 το δικό σου κάνει 0 επαναλήψεις, ενώ της εκφώνησης κάνει 1 επανάληψη

Dimi97

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Θέμα Β
« Απάντηση #39 στις: 27 Μάι 2015, 09:43:55 μμ »
ναι κάνει μεν 0 επαναληψεις,ωστόσο όμως στο τέλος εμφανίζει τελικά το y σωστά και το y έχει τη σωστή τελικη τιμή όπως και στο αλγοριθμο που δώθηκε...

το οτι δε δουλευει με τον ίδιο τρόπο (δεν κανει τον ιδιο αριθμο επαναλήψεων) είναι πρόβλημα?

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #40 στις: 27 Μάι 2015, 09:49:06 μμ »
Δεν σου ζητάει να γράψεις αλγόριθμο που να εμφανίζει τα ίδια αποτελέσματα
αλλά να ξαναγράψεις τον συγκεκριμένο αλγόριθμο.
Αν το y έχει άλλη τιμή τότε έχεις φτιάξει διαφορετικό αλγόριθμο από αυτόν που σου ζητάει
Για ποιον λόγο να με ενδιαφέρει η τιμή του y  μετά την επανάληψη; λέει πουθενά να εμφανίσουμε την τιμή του y μετά;

Για να μην παρεξηγηθώ δεν λέω ότι πρέπει να κοπούν μόρια διότι αυτό είναι ψιλά γράμματα για τα παιδιά, όμως με βάση την εκφώνηση αυτή η λύση δεν μπορεί να γίνει δεκτή.
Επίσης η έξοδος ενός αλγορίθμου δεν είναι μόνο αυτό που εμφανίζει στην οθόνη αλλά και η τελική κατάσταση της μνήμης, δηλαδή των μεταβλητών του.

Το θέμα θα μπορούσε να διατυπωθεί:
"Να ξαναγράψετε τον αλγόριθμο με χρήση της Για έτσι ώστε να εμφανίζει ακριβώς τα ίδια αποτελέσματα"
Νομίζω αυτό είναι πιο σαφές και εννοεί αυτό που μας βολεύει να εννοούμε όλοι για να μην δημιουργούνται προβλήματα, το οποίο όμως δεν εννοεί η συγκεκριμένη εκφώνηση. :o
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

gkatsion

  • Κατσιώνης Γιώργος - Καθηγητής ΠΕ19
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 149
  • Είμαστε επιστήμη και όχι δεξιότητα!
Απ: Θέμα Β
« Απάντηση #41 στις: 27 Μάι 2015, 09:57:51 μμ »
Συγνώμη επειδή το κοιτάζω αρκετή ώρα και δεν διάβασα κανέναν να το σχολιάζει...
Το y παίρνει αρχική τιμή; Όχι!! Άρα 8 μονάδες σε καμία περίπτωση...


Αυτό είναι σωστό ή λάθος;

Αν χ > 1 τότε
  Για i από χ μέχρι 1 με_βήμα -2
    y ← y - 2
    Εμφάνισε y
  Τέλος_επανάληψης
Τέλος_αν

Δεν ζητάει πουθενά να μην χρησιμοποιήσουμε νέες μεταβλητές και εάν το έκανε κάποιος μαθητής το παραπάνω πόσο θα πάρει από τις 8 μονάδες;

Εγώ πάντως θα του έδινα και τις 8
ΈΞΟΔΟΣ_ΑΠΟ_ΛΥΚΕΙΟ <-- ΑΕΙ + PHD + ΑΣΕΠ

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 152
Απ: Θέμα Β
« Απάντηση #42 στις: 27 Μάι 2015, 10:00:34 μμ »
ναι κάνει μεν 0 επαναληψεις,ωστόσο όμως στο τέλος εμφανίζει τελικά το y σωστά και το y έχει τη σωστή τελικη τιμή όπως και στο αλγοριθμο που δώθηκε...

το οτι δε δουλευει με τον ίδιο τρόπο (δεν κανει τον ιδιο αριθμο επαναλήψεων) είναι πρόβλημα?

εννοείται ότι δεν είδα το «εμφάνισε y» στο τέλος

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: Θέμα Β
« Απάντηση #43 στις: 27 Μάι 2015, 10:16:18 μμ »
Συγνώμη επειδή το κοιτάζω αρκετή ώρα και δεν διάβασα κανέναν να το σχολιάζει...
Το y παίρνει αρχική τιμή; Όχι!! Άρα 8 μονάδες σε καμία περίπτωση...


y<-- x πριν τη ΓΙΑ
VR in Computing

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1059
Απ: Θέμα Β
« Απάντηση #44 στις: 27 Μάι 2015, 10:24:20 μμ »
Αν x > 1 τότε
     Για  y   από  x μέχρι  1  με_βήμα  -2
         Εμφάνισε  y-2
      Τέλος_επανάληψης
Τέλος_αν

Το κομμάτι της Για   "Για  y   από  x"  πώς το "ερμηνεύει - αντιλαμβάνεται" ο μηχανισμός της Για ;;;

Α