Αποστολέας Θέμα: Θέμα Β  (Αναγνώστηκε 16568 φορές)

Loco-3

  • Οπαδός
  • **
  • Μηνύματα: 11
Απ: Θέμα Β
« Απάντηση #15 στις: 27 Μάι 2015, 01:40:07 μμ »
Ναι ρε γαμωτο...και για χ=4 το εκανα εκεινη την ωρα αλλα οχι για χ=3 νομιζω μονο αυτη τη τιμη χανω αρα απο τα 8 μορια που επιανε ποσο μπορει να μου καψουν max ;

tdiam

  • Οπαδός
  • **
  • Μηνύματα: 16
  • Why's the rum gone?
Απ: Θέμα Β
« Απάντηση #16 στις: 27 Μάι 2015, 01:52:56 μμ »
(Μεταφέρω εδώ το μήνυμα μου από το "Γενικός σχολιασμός", ας το διαγράψουν εκείνο οι admin)

Να παρατηρήσω κάτι για το Β1:
Για τους μαθητές που δεν θα σκεφτούν να αλλάξουν την εντολή "Εμφάνισε y" σε "Εμφάνισε y-2" (οι οποίοι θα είναι πολλοί), προκειμένου να λειτουργεί σωστά ο αλγόριθμος με "Εμφάνισε y", θα πρέπει η Για να είναι έτσι:

Παράθεση
Για y από x-2 μέχρι -1 με_βήμα -2

Όμως, απ' ότι έχω ακούσει, στα φυσικώς αδυνάτων οι απαντήσεις που έχουν στο μέχρι τους αριθμούς "-1", "0" ή "1" γίνονται όλες αποδεκτές ως σωστές. Βλέπει κάποιος κάτι που δεν βλέπω;

dubudubuza

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Θέμα Β
« Απάντηση #17 στις: 27 Μάι 2015, 02:03:28 μμ »
Καλησπέρα. Η διαδικασία που ακολουθούμε δεν είναι να μετατρέψουμε πρώτα σε τμήμα με χρήση Όσο και μετά σε Για; Η πρώτη μετατροπή δε συνεπάγεται ότι θα βγάλουμε τις εντολές της επανάληψης και εκτός ώστε να εκτελούνται τουλάχιστον μια φορά όπως στη Μέχρις Ότου; Εγώ έχοντας αυτά υπόψιν έγραψα αυτό:

ΑΝ χ>1 ΤΟΤΕ
y<-x
y<-y-2
ΕΜΦΑΝΙΣΕ y
ΓΙΑ y ΑΠΟ x-2 ΜΕΧΡΙ 0 ΜΕ_ΒΗΜΑ -2
ΕΜΦ y-2
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΑΝ

Εκτός του "ΜΕΧΡΙ 0" έχει άλλο λάθος?

tdiam

  • Οπαδός
  • **
  • Μηνύματα: 16
  • Why's the rum gone?
Απ: Θέμα Β
« Απάντηση #18 στις: 27 Μάι 2015, 02:07:19 μμ »
Καλησπέρα. Η διαδικασία που ακολουθούμε δεν είναι να μετατρέψουμε πρώτα σε τμήμα με χρήση Όσο και μετά σε Για; Η πρώτη μετατροπή δε συνεπάγεται ότι θα βγάλουμε τις εντολές της επανάληψης και εκτός ώστε να εκτελούνται τουλάχιστον μια φορά όπως στη Μέχρις Ότου; Εγώ έχοντας αυτά υπόψιν έγραψα αυτό:

ΑΝ χ>1 ΤΟΤΕ
y<-x
y<-y-2
ΕΜΦΑΝΙΣΕ y
ΓΙΑ y ΑΠΟ x-2 ΜΕΧΡΙ 0 ΜΕ_ΒΗΜΑ -2
ΕΜΦ y-2
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΑΝ

Εκτός του "ΜΕΧΡΙ 0" έχει άλλο λάθος?

Δεν έχεις άλλο λάθος, όπως είπες κι εσύ το "ΜΕΧΡΙ 0" είναι λάθος, θα έπρεπε να είναι "ΜΕΧΡΙ 1".

Vagnes

  • Θαμώνας
  • ***
  • Μηνύματα: 39
Απ: Θέμα Β
« Απάντηση #19 στις: 27 Μάι 2015, 02:11:40 μμ »
Καλησπέρα. Η διαδικασία που ακολουθούμε δεν είναι να μετατρέψουμε πρώτα σε τμήμα με χρήση Όσο και μετά σε Για; Η πρώτη μετατροπή δε συνεπάγεται ότι θα βγάλουμε τις εντολές της επανάληψης και εκτός ώστε να εκτελούνται τουλάχιστον μια φορά όπως στη Μέχρις Ότου;
Θα εκτελεστούν ούτως η άλλως μια φορά γιατί μας λέει οτι το χ είναι θετικός ακέραιος... και το Y παίρνει την τιμή του χ..

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Θέμα Β
« Απάντηση #20 στις: 27 Μάι 2015, 02:26:13 μμ »
To χειρότερο θέμα μετατροπής ever
Τι ακριβώς εξετάζει το συγκεκριμένο θέμα;
Γιατί 8 μονάδες;
Πώς θα αποδοθούν οι 8 μονάδες;
Η μόνη παραφωνία πραγματικά σε ένα ωραίο και βατό διαγώνισμα
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

tdiam

  • Οπαδός
  • **
  • Μηνύματα: 16
  • Why's the rum gone?
Απ: Θέμα Β
« Απάντηση #21 στις: 27 Μάι 2015, 03:30:11 μμ »
Και βγαίνει μετά η ΟΕΦΕ με επίσης λάθος λύση στο Β1.β
Να το χαιρόμαστε το θεματάκι, για ακόμη μια φορά δημιουργούνται ασυνεννοησίες μεταξύ μας και οι εξεταζόμενοι παρακολουθούν απορημένοι.
Θα συμφωνήσω με τον Πέτρο πιο πάνω.

http://www.oefe.gr/panellinies/liseis_plir_kat_c_hmer_no_150527.pdf

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: Θέμα Β
« Απάντηση #22 στις: 27 Μάι 2015, 03:35:26 μμ »
Εμένα οι μαθητές μου έδωσαν μια από τις παρακάτω λύσεις: Νομίζω ότι είναι σωστές και οι τρεις

Αν χ > 1 τότε
  Εμφάνισε χ - 2
  Για y από χ - 4 μέχρι -1 με_βήμα -2
    Εμφάνισε y
  Τέλος_επανάληψης
Τέλος_αν


Αν χ > 1 τότε
  Για y από χ - 2 μέχρι -1 με_βήμα -2
    Εμφάνισε y
  Τέλος_επανάληψης
Τέλος_αν


Αν χ > 1 τότε
  Για y από χ μέχρι 1 με_βήμα -2
    Εμφάνισε y - 2
  Τέλος_επανάληψης
Τέλος_αν
VR in Computing

tdiam

  • Οπαδός
  • **
  • Μηνύματα: 16
  • Why's the rum gone?
Απ: Θέμα Β
« Απάντηση #23 στις: 27 Μάι 2015, 03:41:13 μμ »
Εμένα οι μαθητές μου έδωσαν μια από τις παρακάτω λύσεις: Νομίζω ότι είναι σωστές και οι τρεις

Αν χ > 1 τότε
  Εμφάνισε χ - 2
  Για y από χ - 4 μέχρι -1 με_βήμα -2
    Εμφάνισε y
  Τέλος_επανάληψης
Τέλος_αν


Αν χ > 1 τότε
  Για y από χ - 2 μέχρι -1 με_βήμα -2
    Εμφάνισε y
  Τέλος_επανάληψης
Τέλος_αν


Αν χ > 1 τότε
  Για y από χ μέχρι 1 με_βήμα -2
    Εμφάνισε y - 2
  Τέλος_επανάληψης
Τέλος_αν

Ολόσωστες, το έτρεξα για σιγουριά και σε Ψευδογλώσσα.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Θέμα Β
« Απάντηση #24 στις: 27 Μάι 2015, 03:50:57 μμ »
Και βγαίνει μετά η ΟΕΦΕ με επίσης λάθος λύση στο Β1.β
Να το χαιρόμαστε το θεματάκι, για ακόμη μια φορά δημιουργούνται ασυνεννοησίες μεταξύ μας και οι εξεταζόμενοι παρακολουθούν απορημένοι.
Θα συμφωνήσω με τον Πέτρο πιο πάνω.

http://www.oefe.gr/panellinies/liseis_plir_kat_c_hmer_no_150527.pdf

Και να'ταν μόνο αυτό το λάθος..
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

ολγα

  • Βετεράνος
  • ****
  • Μηνύματα: 86
Απ: Θέμα Β
« Απάντηση #25 στις: 27 Μάι 2015, 03:52:43 μμ »
To χειρότερο θέμα μετατροπής ever
Τι ακριβώς εξετάζει το συγκεκριμένο θέμα;
Γιατί 8 μονάδες;
Δε νομίζω ότι ήταν και τόσο κακό. Ίσως να ήθελαν να ξεχωρίσουν ποιοι δεν κάνουν μετατροπές μηχανικά, ακολουθώντας συνταγολόγιο. Το = στη συνθήκη του μέχρις_ότου είναι αυτό που έκανε τη διαφορά καθώς και η σειρά των εντολών μέσα στην επανάληψη.
Μου θύμισε λιγάκι το Θέμα 1 Δ α από τις επαναληπτικές του 2001, αν και εκείνο ήταν ασύγκριτα πιο δύσκολο γιατί τα Α και  Μ θα μπορούσαν να είναι οτιδήποτε (ακόμα και πραγματικοί θετικοί ή αρνητικοί). Αυτό το θέμα τότε έλεγε:
 Δίνεται το παρακάτω τμήμα αλγορίθμου :

   Χ <-- Α
   Αρχή_επανάληψης
      Χ <-- Χ + 2
      Τύπωσε το Χ
   Μέχρις_ότου Χ>=Μ
   
α. Να δώσετε τη δομή επανάληψης «Για … από … μέχρι… βήμα» η οποία τυπώνει ακριβώς τις ίδιες τιμές με το πιο πάνω τμήμα αλγορίθμου.
Μονάδες 7

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: Θέμα Β
« Απάντηση #26 στις: 27 Μάι 2015, 03:55:55 μμ »
Και βγαίνει μετά η ΟΕΦΕ με επίσης λάθος λύση στο Β1.β
Να το χαιρόμαστε το θεματάκι, για ακόμη μια φορά δημιουργούνται ασυνεννοησίες μεταξύ μας και οι εξεταζόμενοι παρακολουθούν απορημένοι.
Θα συμφωνήσω με τον Πέτρο πιο πάνω.

http://www.oefe.gr/panellinies/liseis_plir_kat_c_hmer_no_150527.pdf


αν δεν κάνω λάθος έχουν και στο Γ  , μήνυμα για την προώθηση σε λάθος δομή επιλογής
VR in Computing

theoL

  • Επισκέπτης
Απ: Θέμα Β
« Απάντηση #27 στις: 27 Μάι 2015, 04:11:51 μμ »
Β1)β)
ΑΝ Χ>1 ΤΟΤΕ
   ΥΧ
   ΓΙΑ Χ ΑΠΟ Υ ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -2
      ΥΥ-2
      ΓΡΑΨΕ Υ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΑΝ

Β2)
1.   Π[1]
2.   2
3.   100
4.   Π
5.   >
6.   Π[i-1]

ολγα

  • Βετεράνος
  • ****
  • Μηνύματα: 86
Απ: Θέμα Β
« Απάντηση #28 στις: 27 Μάι 2015, 04:24:31 μμ »
Εμένα οι μαθητές μου έδωσαν μια από τις παρακάτω λύσεις: Νομίζω ότι είναι σωστές και οι τρεις

Αν χ > 1 τότε
  Εμφάνισε χ - 2
  Για y από χ - 4 μέχρι -1 με_βήμα -2
    Εμφάνισε y
  Τέλος_επανάληψης
Τέλος_αν


Αν χ > 1 τότε
  Για y από χ - 2 μέχρι -1 με_βήμα -2
    Εμφάνισε y
  Τέλος_επανάληψης
Τέλος_αν


Αν χ > 1 τότε
  Για y από χ μέχρι 1 με_βήμα -2
    Εμφάνισε y - 2
  Τέλος_επανάληψης
Τέλος_αν

Μόνο το τρίτο είναι σωστό. Τα δύο πρώτα εμφανίζουν τα ίδια αλλά η τιμή του y στο τέλος δεν είναι ίδια με το δοσμένο.

tdiam

  • Οπαδός
  • **
  • Μηνύματα: 16
  • Why's the rum gone?
Απ: Θέμα Β
« Απάντηση #29 στις: 27 Μάι 2015, 04:32:20 μμ »
Θα συμφωνήσω τελικά με την Όλγα, από αυτή την άποψη όντως οι δύο πρώτοι δεν είναι ισοδύναμοι αλγόριθμοι.