Αποστολέας Θέμα: Πρόβλημα σε άσκηση  (Αναγνώστηκε 1585 φορές)

Georgia98

  • Νέος
  • *
  • Μηνύματα: 8
Πρόβλημα σε άσκηση
« στις: 05 Μάρ 2015, 12:08:24 πμ »
Να συμπληρώσετε τα κενά στο παρακάτω τμήμα αλγορίθμου έτσι ώστε μετά την εκτέλεσή του να εμφανιστούν οι τιμές:
-1, 2, -3, 4, -5, 6, -7

Για i από …….. μέχρι ………
Αν ………………….…………. Τότε

Εμφάνισε …………

Αλλιώς

Εμφάνισε ……….…

Τέλος_αν
Τέλος_επανάληψης

Μου έχει δοθεί αυτή η άσκηση αλλά προβληματίζομαι να την λύσω. Έλυσα κάποιες παρόμοιας μορφής την περασμένη εβδομάδα, αλλά ήταν πιο απλές. Νομίζω ότι κάποιο μπέρδεμα κάνω στις μεταβλητές, αλλά δεν είμαι σίγουρη. Μπορεί κάποιος να βοηθήσει;

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2302
Απ: Πρόβλημα σε άσκηση
« Απάντηση #1 στις: 05 Μάρ 2015, 12:11:17 πμ »
Παρατήρησε ότι εμφανίζονται εναλλάξ αρνητικοί και θετικοί αριθμοί
Φαντάσου ότι έχεις να εμφανίσεις τους αριθμούς 1,2,3,4,5,6,7
Δες ποιοι αριθμοί εμφανίζονται σαν αρνητικοί, σκέψου τι ισχύει για αυτούς και συμπλήρωσε τα κενά...
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Georgia98

  • Νέος
  • *
  • Μηνύματα: 8
Απ: Πρόβλημα σε άσκηση
« Απάντηση #2 στις: 05 Μάρ 2015, 12:23:39 πμ »
Αυτές ήταν οι πρώτες  μου σκέψεις, αλλά δυσκολεύτηκα να τις εφαρμόσω για να φτιάξω επιτυχημένα τον αλγόριθμο. Παρατήρησα ότι οι αριθμοί που είναι αρνητικοί είναι όλοι περιττοί , ενώ οι θετικοί είναι άρτιοι, αλλά κάνω λάθος στην συνθήκη που μάλλον οφείλεται στο γεγονός ότι ακόμα μπερδεύω τις μεταβλητές κ,i κλπ. Αν και ξέρω σε τι χρησιμεύει η καθεμία συχνά στους αλγορίθμους τις μπλέκω μεταξύ τους.

Το πρώτο βήμα είναι (αν δεν κάνω λάθος): "Για i από 1 μέχρι 7" Μετά το χάνω στην συνθήκη.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2302
Απ: Πρόβλημα σε άσκηση
« Απάντηση #3 στις: 05 Μάρ 2015, 12:29:06 πμ »
Το i είναι ουσιαστικά οι αριθμοί που πρέπει να εμφανίσεις είτε σαν θετικούς, είτε σαν αρνητικούς
Εξαρτάται από το αν είναι άρτιο ή περιττό το i
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Georgia98

  • Νέος
  • *
  • Μηνύματα: 8
Απ: Πρόβλημα σε άσκηση
« Απάντηση #4 στις: 05 Μάρ 2015, 12:34:59 πμ »
Δηλαδή η μόνη μεταβλητή θα είναι η i;

tdrivas

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 654
  • κάποτε έκαιγαν βιβλία,τώρα καίνε μυαλά...
Απ: Πρόβλημα σε άσκηση
« Απάντηση #5 στις: 05 Μάρ 2015, 12:38:50 πμ »
Δηλαδή η μόνη μεταβλητή θα είναι η i;

ναι, οπότε εμφάνισε το i και τρέξε την άσκηση..μόλις δεις τα αποτελέσματα θα καταλάβεις τι πρέπει να αλλάξεις (θα κάνεις μια πολύ μικρή αλλαγή...)
Thanassis Drivas
BSc in Computer Science
MSc in Space Science Applications and Technologies

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2302
Απ: Πρόβλημα σε άσκηση
« Απάντηση #6 στις: 05 Μάρ 2015, 12:39:16 πμ »
Αφού το i εκφράζει τους αριθμούς που χρειάζεσαι, ναι
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Georgia98

  • Νέος
  • *
  • Μηνύματα: 8
Απ: Πρόβλημα σε άσκηση
« Απάντηση #7 στις: 05 Μάρ 2015, 01:23:08 πμ »
Συγγνώμη που σας ζαλίζω αλλά εξακολουθώ να κάνω λάθος στις συνθήκες που δοκιμάζω και ή μου εμφανίζουν συνεχώς τον ίδιο αριθμό
ή ο αλγόριθμος δεν έχει τέλος. :-\ Ενδεικτικά η τελευταία προσπάθειά μου:

Αλγόριθμος Ακολουθία
Για i από 1 μέχρι 7
   Αν i>0 τότε
      i←i+1
      i←i*(-1)
      Εμφάνισε i
      αλλιώς
         Εμφάνισε i
   Τέλος_αν
   Τέλος_επανάληψης
Τέλος Ακολουθία      

Έχω δοκιμάσει πολλές διαφορετικές εκδοχές αλλά ποτέ δεν πετυχαίνω το επιθυμητό αποτέλεσμα.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2302
Απ: Πρόβλημα σε άσκηση
« Απάντηση #8 στις: 05 Μάρ 2015, 01:33:57 πμ »
Κατ'αρχάς, δεν επιτρέπεται να αλλάζεις τιμή στον μετρητή της επανάληψης (i) μέσα στην επανάληψη
Το i έχει τις τιμές που πρέπει, δεν χρειάζεται να του αλλάζεις τιμή. Μην ξεχνάς ότι μπορείς να χρησιμοποιείς εκφράσεις στην εντολή Εμφάνισε. Π.χ. Εμφάνισε i*(-1)
Κατά δεύτερο, ανέφερες ότι παίζει ρόλο η άρτια ή περιττή τιμή που έχει το i
Το χρησιμοποίησες κάπου αυτό;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Georgia98

  • Νέος
  • *
  • Μηνύματα: 8
Απ: Πρόβλημα σε άσκηση
« Απάντηση #9 στις: 05 Μάρ 2015, 02:01:33 πμ »
Τώρα κάτι μου λέει ότι βρίσκομαι κοντά αλλά βγάζει άλλα νούμερα

Αλγόριθμος Ακολουθία
Για i από 1 μέχρι 7
   Αν i>0 και i mod 2 = 0 τότε
      Εμφάνισε (i+1)*(-1)
      αλλιώς
         Εμφάνισε i+1
   Τέλος_αν
   Τέλος_επανάληψης
Τέλος Ακολουθία      

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2302
Απ: Πρόβλημα σε άσκηση
« Απάντηση #10 στις: 05 Μάρ 2015, 02:06:42 πμ »
Πειραματίσου λίγο ακόμα
Εφόσον οι αριθμοί σου είναι από 1 μέχρι 7, ποιος ο λόγος να χρησιμοποιείς i+1;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Georgia98

  • Νέος
  • *
  • Μηνύματα: 8
Απ: Πρόβλημα σε άσκηση
« Απάντηση #11 στις: 05 Μάρ 2015, 02:09:34 πμ »
Νομίζω το έλυσα:

Αλγόριθμος Ακολουθία
Για i από 1 μέχρι 7
   Αν i>0 και i mod 2 = 0 τότε
      Εμφάνισε i*(-1)
      αλλιώς
         Εμφάνισε i
   Τέλος_αν
   Τέλος_επανάληψης
Τέλος Ακολουθία         

Ευχαριστώ για τη βοήθειά σας  :)

tdrivas

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 654
  • κάποτε έκαιγαν βιβλία,τώρα καίνε μυαλά...
Απ: Πρόβλημα σε άσκηση
« Απάντηση #12 στις: 05 Μάρ 2015, 08:37:24 πμ »
Νομίζω το έλυσα:

Αλγόριθμος Ακολουθία
Για i από 1 μέχρι 7
   Αν i>0 και i mod 2 = 0 τότε
      Εμφάνισε i*(-1)
      αλλιώς
         Εμφάνισε i
   Τέλος_αν
   Τέλος_επανάληψης
Τέλος Ακολουθία         

Ευχαριστώ για τη βοήθειά σας  :)


είσαι πολύ κοντά..δύο παρατηρήσεις:
1. στους άρτιους ή στους περιττούς θα βάλεις τον τελεστή - ? (τελικά το mod2=0 τί δείχνει?)
2. Περιττή συνθήκη το i>0 (αφού εσύ η ίδια ορίζεις ότι το ι παίρνει τις τιμές 1,2,3...7. Το γεγονός ότι βάζεις - στο Εμφάνισε δεν αλλάζει την τιμή του i.
Thanassis Drivas
BSc in Computer Science
MSc in Space Science Applications and Technologies