Αποστολέας Θέμα: ΘΕΜΑ Γ  (Αναγνώστηκε 15401 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #90 στις: 12 Ιούν 2014, 07:02:31 μμ »
Μου κάνει εντύπωση ότι σε κάτι τέτοιες περιπτώσεις όλοι σκέφτονται τα "παιδάκια" που το έλυσαν με πίνακες και θα χάσουν μονάδες.

Τα παιδάκια που κατάφεραν και το έλυσαν χωρίς πίνακες δεν είδα να τα σκέφτεται κανένας. Τι είπατε?? Α ναι ξέχασα είναι λιγότερα...

Τα παιδάκια που έφτασαν στο Γ4 και δεν το έλυσαν γιατί ήξεραν ότι δεν μπορούν να χρησιμοποιήσουν πίνακες, ποιος τα σκέφτεται?

Ας έχουμε στο μυαλό μας ότι οι εξετάσεις είναι κατατακτήριες, όταν πριμοδοτείς έναν μαθητή αδικείς κάποιον άλλον.

ΥΓ. Παρεμπιπτόντως σήμερα έμαθα από πιο έμπειρους συναδέλφους ότι το Εμφάνισε 1 είναι λάθος γιατί στο εμφάνισε μπαίνουν μόνο εκφράσεις ή μεταβλητές. Αυτά είναι. Όσο μεγαλώνεις μαθαίνεις. Το πρόβλημα είναι ότι ήμουν ο μόνος που υποστήριζε ότι είναι σωστό και δεν κατάφερα να πείσω κανέναν. Άλλος ένας θρίαμβος της δημοκρατίας
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: ΘΕΜΑ Γ
« Απάντηση #91 στις: 12 Ιούν 2014, 08:22:15 μμ »

ΥΓ. Παρεμπιπτόντως σήμερα έμαθα από πιο έμπειρους συναδέλφους ότι το Εμφάνισε 1 είναι λάθος γιατί στο εμφάνισε μπαίνουν μόνο εκφράσεις ή μεταβλητές. Αυτά είναι. Όσο μεγαλώνεις μαθαίνεις. Το πρόβλημα είναι ότι ήμουν ο μόνος που υποστήριζε ότι είναι σωστό και δεν κατάφερα να πείσω κανέναν. Άλλος ένας θρίαμβος της δημοκρατίας

Εμφάνισε 'Πού είσαι ρε μάγκα ftsak'
Εμφάνισε + αλφαριθμητική σταθερά

Άρα σωστό είναι το Εμφάνισε 1
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

arisbasil

  • Θαμώνας
  • ***
  • Μηνύματα: 28
  • 1+1=10
Απ: ΘΕΜΑ Γ
« Απάντηση #92 στις: 12 Ιούν 2014, 08:28:32 μμ »
ΥΓ. Παρεμπιπτόντως σήμερα έμαθα από πιο έμπειρους συναδέλφους ότι το Εμφάνισε 1 είναι λάθος γιατί στο εμφάνισε μπαίνουν μόνο εκφράσεις ή μεταβλητές. Αυτά είναι. Όσο μεγαλώνεις μαθαίνεις.

Πλάκα κάνεις... :o

demy pap

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #93 στις: 12 Ιούν 2014, 11:52:49 μμ »

ΥΓ. Παρεμπιπτόντως σήμερα έμαθα από πιο έμπειρους συναδέλφους ότι το Εμφάνισε 1 είναι λάθος γιατί στο εμφάνισε μπαίνουν μόνο εκφράσεις ή μεταβλητές. Αυτά είναι. Όσο μεγαλώνεις μαθαίνεις. Το πρόβλημα είναι ότι ήμουν ο μόνος που υποστήριζε ότι είναι σωστό και δεν κατάφερα να πείσω κανέναν. Άλλος ένας θρίαμβος της δημοκρατίας

Διακρίνω κάποια δόση "έμπειρης" ειρωνείας;

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3219
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΘΕΜΑ Γ
« Απάντηση #94 στις: 13 Ιούν 2014, 10:50:12 πμ »
ΥΓ. Παρεμπιπτόντως σήμερα έμαθα από πιο έμπειρους συναδέλφους ότι το Εμφάνισε 1 είναι λάθος γιατί στο εμφάνισε μπαίνουν μόνο εκφράσεις ή μεταβλητές. Αυτά είναι. Όσο μεγαλώνεις μαθαίνεις. Το πρόβλημα είναι ότι ήμουν ο μόνος που υποστήριζε ότι είναι σωστό και δεν κατάφερα να πείσω κανέναν. Άλλος ένας θρίαμβος της δημοκρατίας

To

1

δεν είναι έκφραση;;

ΥΓ: θυμάσαι πριν κάποια -πολλά-χρόνια που μου την έλεγες για το topic "αυθεντίες και άλλα;"

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #95 στις: 13 Ιούν 2014, 01:53:02 μμ »
Εγώ??? αποκλείεται. Είσαι σίγουρος?
Μήπως με μπερδεύεις με κανέναν άλλον   :angel:

ΥΓ: θυμάσαι πριν κάποια -πολλά-χρόνια που μου την έλεγες για το topic "αυθεντίες και άλλα;"

αν και τώρα είναι δύσκολοι καιροί για τέτοια topic
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 548
  • There can be only one...may it be AEPP.
Απ: ΘΕΜΑ Γ
« Απάντηση #96 στις: 14 Ιούν 2014, 10:51:13 πμ »
Καλημέρα σε όλους.
Αν κάποιος έδινε τον παρακάτω κώδικα ως λύση στο θέμα Γ (αν εξαιρέσουμε τη χρήση προγράμματος αντί για αλγόριθμο) πόσο θα έχανε ο μαθητής/η μαθήτρια;
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πλ, ι, ΑΡ[10], αριθμός, κωδ, συνολο, copy_συνολο, κ
  ΠΡΑΓΜΑΤΙΚΕΣ: Τ[10], τιμή, σ, μαχ, copy_μαχ
ΑΡΧΗ
  πλ <- 0
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΑΡ[ι] <- 0
    Τ[ι] <- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  copy_μαχ <- -1
  ι <- 1
  ΔΙΑΒΑΣΕ κωδ
  ΟΣΟ κωδ <> 0 ΕΠΑΝΑΛΑΒΕ
    ΔΙΑΒΑΣΕ αριθμός, τιμή
    ΑΡ[ι] <- αριθμός
    Τ[ι] <- τιμή
    σ <- σ + τιμή* αριθμός                                    !για το ερώτημα Γ2
    ΑΝ τιμή > 10 ΤΟΤΕ
      πλ <- πλ + ΑΡ[ι]
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ι = 10 ΤΟΤΕ
      μαχ <- Τ[1]
      ΓΙΑ κ ΑΠΟ 2 ΜΕΧΡΙ 10
        ΑΝ Τ[ι] > μαχ ΤΟΤΕ
          μαχ <- Τ[ι]
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      συνολο <- 0
      ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 10
        ΑΝ Τ[ι] = μαχ ΤΟΤΕ
          συνολο <- συνολο + ΑΡ[ι]
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 10
        ΑΡ[ι] <- 0
        Τ[ι] <- 0
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ copy_μαχ <> μαχ ΤΟΤΕ
        copy_μαχ <- μαχ
        copy_συνολο <- συνολο
      ΑΛΛΙΩΣ
        copy_συνολο <- copy_συνολο + συνολο
      ΤΕΛΟΣ_ΑΝ
      ι <- 1
    ΤΕΛΟΣ_ΑΝ
    ι <- ι + 1
    ΔΙΑΒΑΣΕ κωδ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  μαχ <- Τ[1]
  ΓΙΑ κ ΑΠΟ 2 ΜΕΧΡΙ ι - 1
    ΑΝ Τ[ι] > μαχ ΤΟΤΕ
      μαχ <- Τ[ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  συνολο <- 0
  ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ ι - 1
    ΑΝ Τ[ι] = μαχ ΤΟΤΕ
      συνολο <- συνολο + ΑΡ[ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ copy_μαχ = μαχ ΤΟΤΕ
    copy_συνολο <- copy_συνολο + συνολο
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ πλ                                                           !ερώτημα Γ3
  ΓΡΑΨΕ copy_συνολο                                                  !ερώτημα Γ4
!...συνεχίζουμε με το ερώτημσα Γ2 κατα τα γνωστά
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

NIKODIM

  • Νέος
  • *
  • Μηνύματα: 9
Απ: ΘΕΜΑ Γ
« Απάντηση #97 στις: 14 Ιούν 2014, 11:28:54 πμ »
 :D :D :Dnikolasmer καλό!!!!!  ;D ;D ;D ;Dπολύ καλό!!!!!!
Ας απαντήσει κάποιος ρε παιδιά στο συνάδελφο.

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: ΘΕΜΑ Γ
« Απάντηση #98 στις: 14 Ιούν 2014, 12:59:56 μμ »
Και οι πιθανές σωστές λύσεις που μπορούν να δώσουν οι μαθητές είναι ατελείωτες. Ακόμη και με χρήση πινάκων!!! Αντιγράφω το κομμάτι του υπολογισμού του πλήθους των μεγίστων.

Αλγόριθμος ΘΓ
! Θεωρώ ως μέγιστο μέγεθος πίνακα το 100.
Αρχή_επανάληψης
Διάβασε Ν!στο Ν δίνουμε τη τιμή του μεγέθους του πίνακα που θέλουμε να χρησιμοποιήσουμε
Μέχρις_ότου Ν ≥ 1 και Ν ≤ 100

max_previous ← 0
pmax_previous ← 0
Για κ από 1 μέχρι Ν
  Τ[κ] ← 0
Τέλος_επανάληψης
πλ_επ ← 1
ι ← 1
Διάβασε κωδ
Όσο κωδ ≠ 0 επανάλαβε
  Διάβασε Τ[ι], αρ_τεμ[ι]
  ι ← ι + 1
  Διάβασε κωδ

  Αν ι = πλ_επ* Ν + 1 ή κωδ = 0 τότε
    max ← Τ[1]
    Για κ από 1 μέχρι Ν
      Αν max < Τ[κ] τότε
        max ← Τ[κ]
      Τέλος_αν
    Τέλος_επανάληψης
    pmax ← 0
    Για κ από 1 μέχρι Ν
      Αν max = Τ[κ] τότε
        pmax ← pmax + αρ_τεμ[κ]
      Τέλος_αν
    Τέλος_επανάληψης
    Αν max_previous = max τότε
      pmax_previous ← pmax_previous + pmax
    αλλιώς_αν max_previous < max τότε
      max_previous ← max
      pmax_previous ← pmax
    Τέλος_αν
    Για κ από 1 μέχρι Ν
      Τ[κ] ← 0
    Τέλος_επανάληψης
    ι ← 1
    πλ_επ ← πλ_επ + 1
  Τέλος_αν

Τέλος_επανάληψης
Εμφάνισε pmax_previous
Τέλος ΘΓ

Νομίζω ότι υπάρχει μια παρανόηση σχετικά με τη χρήση πινάκων. Το θέμα είναι πως ο μαθητής θα χρησιμοποιήσει τους πίνακες.
Προφανώς ένας μαθητής που έχει χρησιμοποιήσει πίνακα όπως προτείνει ο aperdos είναι σίγουρα αρκετά καλός για να βρει τη λύση και χωρίς πίνακες.

Συνάδερφοι το θέμα έχει τεθεί παραπάνω και έχει απαντηθεί. Όχι μόνο φέτος αλλά και το 2011. Βέβαια τότε είχε ακουστεί η άποψη ότι είναι απίθανο να το σκεφτεί μαθητής αλλά ακόμη και αν συνέβαινε αυτό ο διορθωτής δεν θα έκοβε τίποτα.

Έχουμε και λέμε λοιπόν
Ερμηνεία 1η: Η επιτροπή θεωρεί την ψευδογλώσσα ΓΛΩΣΣΑ και επιβάλει να είναι γνωστός ο αριθμός των δεδομένων προς επεξεργασία πριν από την εκτέλεση του "αλγορίθμου" για να μπορέσει να χρησιμοποιηθεί πίνακας. Γράφει στην οδηγία της προς τους βαθμολογητές "όσα ερωτήματα βαθμολογήθηκαν με πίνακα δεν πρέπει να βαθμολογηθούν με το σύνολο των μονάδων"
Ερμηνεία 2η: Ο βαθμολογητής πρέπει να ερμηνεύσει την οδηγία ως "όλα τα δεδομένα δεν πρέπει να μπουν σε πίνακα όχι ένα μέρος τους".

Και έτσι λοιπόν γίνεται της ερμηνείας.

Θέλω να κάνω και ένα σχόλιο πολιτικού - κοινωνικού περιεχομένου. Η άγνοια των πολλών ή η παρανόηση που έχουν για κάποιο θέμα δεν είναι μειονέκτημα της δημοκρατίας. Από την άλλη οι "'άριστοι" αν όντως είναι οφείλουν να διαφωτίσουν τους πολλούς.

noname

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 190
Απ: ΘΕΜΑ Γ
« Απάντηση #99 στις: 14 Ιούν 2014, 03:14:55 μμ »
Μου κάνει εντύπωση ότι σε κάτι τέτοιες περιπτώσεις όλοι σκέφτονται τα "παιδάκια" που το έλυσαν με πίνακες και θα χάσουν μονάδες.

Τα παιδάκια που κατάφεραν και το έλυσαν χωρίς πίνακες δεν είδα να τα σκέφτεται κανένας. Τι είπατε?? Α ναι ξέχασα είναι λιγότερα...
Έχω την εντύπωση ότι σε αντίθεση με το 2010 οι περισσότεροι το έλυσαν/προσπάθησαν χωρίς πίνακες.
 
ΥΓ. Παρεμπιπτόντως σήμερα έμαθα από πιο έμπειρους συναδέλφους ότι το Εμφάνισε 1 είναι λάθος γιατί στο εμφάνισε μπαίνουν μόνο εκφράσεις ή μεταβλητές. Αυτά είναι. Όσο μεγαλώνεις μαθαίνεις. Το πρόβλημα είναι ότι ήμουν ο μόνος που υποστήριζε ότι είναι σωστό και δεν κατάφερα να πείσω κανέναν. Άλλος ένας θρίαμβος της δημοκρατίας

ΤΡΑΓΙΚΟ!

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #100 στις: 14 Ιούν 2014, 03:42:23 μμ »
Καλημέρα σε όλους.
Αν κάποιος έδινε τον παρακάτω κώδικα ως λύση στο θέμα Γ (αν εξαιρέσουμε τη χρήση προγράμματος αντί για αλγόριθμο) πόσο θα έχανε ο μαθητής/η μαθήτρια;

Δυο ερωτήσεις πρώτα
1) Την έδωσε αυτή τη λύση μαθητής?
2) Γιατί πρέπει να χάσει? δεν το είδα διεξοδικά αλλά δεν βλέπω κάτι λάθος. Τώρα αν έχει κάποιο λάθος σε κάνενα δείκτη ή άκρο επανάληψης στο τέλος που κοιτάει αυτά που περισσεύουν δεν με ενδιαφέρει, η σκέψη είναι σωστή, οπότε πρέπει να πάρει 20/20

Άλλο όμως το τι πρέπει να πάρει και άλλο το τι θα πάρει, έτσι δεν είναι?
Παίζει απλά που θα πέσει
οπότε εγώ λέω απλά μια εκτίμηση. Αν του κόψουν θα του κόψουν στην χειρότερη περίπτωση μέχρι 5, δεν νομίζω παραπάνω. (προφανώς επειδή δεν έχουν καταλάβει τι λύση, και ούτε θέλουν να την καταλάβουν :-( )
« Τελευταία τροποποίηση: 15 Ιούν 2014, 12:23:28 πμ από evry »
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 548
  • There can be only one...may it be AEPP.
Απ: ΘΕΜΑ Γ
« Απάντηση #101 στις: 14 Ιούν 2014, 04:51:23 μμ »
Δυο ερωτήσεις πρώτα
1) Την έδωσε αυτή τη λύση μαθητής?
2) Γιατί πρέπει να χάσει? δεν το είδα διεξοδικά αλλά δεν βλέπω κάτι λάθος. Τώρα αν έχει κάποιο λάθος σε κάνενα δείκτη ή άκρο επανάληψης στο τέλος που κοιτάει αυτά που περισσεύουν δεν με ενδιαφέρει, η σκέψη είναι σωστή, οπότε πρέπει να πάρει 20/20

Μία μαθήτριά μου έδωσε - κατά τα λεγόμενά της - την παρπάνω λύση με τη χρήση αλγορίθμο φυσικά όπως το λέει η εκφώνηση. Εμπιστεύομαι τον κωσικά της και την σκέψη της. Ήταν μια επιπολαιότητα της στιγμής η χρήση πίνακα στο θέμα της. Επίσης το θέμα Δ το έλυσε με πίνακα 10χ7 μέσα σε μια επανάληψη "Για" για κάθε εβδομάδα. Έχει ξανα θιγεί η λύση αυτή σε άλλο topic. Όπως επίσης και η λύση της σε παρόμοιο μήνυμα του κυρίου Πέρδου πιο πάνω το οποίο δεν το είχα πάρει χαμπάρι.
Τα παιδιά, τώρα που χαλάρωσαν τα πράγματα, αναμοχλεύουν παλιές καταστάσεις για να προβλέψουν αποτελέσματα. Η ίδια έχασε μόνο ενα Σ/Λ. Αυτά και μόνο αυτά χάνει συν το κομμάτι του θέματος Γ. Υπομονή... ότι βγάλει η μαντανία που λένε... άλλωστε θα γίνει μια πολύ καλή ηλεκτρολόγος, το πιστεύω.   
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής