Αποστολέας Θέμα: Άθροισμα στοιχείων κύριας και δευτερεύουσας διαγωνίου  (Αναγνώστηκε 23753 φορές)

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Αυτό είναι  Θωμά και Γιώργο που με προβληματιζει περισσότερο απ΄ όλα. Πριν τόσο καιρό κάναμε αυτή την κουβένται και μιλάγαμε 10 άτομα. Τώρα που το είδαμε στις εξετάσεις εμφανίστηκαν τόσοι πολλοί. Που ήταν τόσο καιρό όλος αυτός ο κόσμος;
Αν είχαμε την μισή συμμετοχή από αυτή που υπάρχει στο αντίστοιχο θέμα με τα 100 και βάλε posts, τα πράγματα θα ήταν διαφορετικά τώρα.
Δε βαριέσαι και μόνο από την όλη επιχειρηματολογία κάτι μπορεί να βγει για μας και για το μάθημα. Κάποιοι για παράδειγμα ανακάλυψαν το www.pseudoglossa.gr (Στάθη ετοίμαζε σιγά-σιγά cluster με servers) προβλέπω έκρηξη στην επισκεψιμότητα  :D



 Νομίζω ότι ο Θωμάς που άνοιξε το θέμα δεν πρέπει να ασχολείται άλλο με αυτό... :)


Νομίζω πάλι πας να ξεφύγεις από την ερώτηση  ;D Ντεζα βου!  :D
Πραγματικά αυτά που γράφω στις τέσσερις λύσεις σε βρίσκουν όλα σύμφωνο;
Εννοείται ότι ισχύει και για τους άλλους η ερώτηση.  :)
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2814
  • Πύργος Ηλείας
Κώστα, το πρόβλημα ήταν γνωστό εδώ και χρόνια.
....
Από τότε συχνά πυκνά, όπως συνέβη στο παρών θέμα, ξανασυζητήθηκε το ίδιο ακριβώς πράγμα, με το ίδιο ακριβώς αποτέλεσμα (αδιέξοδο).

Επίσης σε συζητήσεις που είχαμε σχετικά με τις ασάφειες το θέμα είχε αναφερθεί ξανά. Δεν ήταν κάτι που έπεσε από τον ουρανό την Παρασκευή.

Αυτό που καταλαβαίνω εγώ είναι ότι ένα εκ των δύο συνέβη :
α) Στην επιτροπή δεν είχαν ιδέα για το πρόβλημα , δεν ασχολούνται με το στέκι, τις ασάφειες.
β) Ήξεραν το πρόβλημα (οπότε και τις αντίθετες απόψεις) και αποφάσισαν να επιβάλλουν την άποψή τους μέσα από τις πανελλήνιες, πράγμα ηθικά απαράδεκτο. Εκτός του ότι στηρίζεται στις πλάτες των μαθητών, μειώνει την άποψη των διαφωνούντων, δείχνει και έναν κομπλεξισμό από πλευράς της επιτροπής λες και αυτοί τα ξέρουν όλα και εμείς από κάτω καλά θα κάνουμε να τους ακούμε...

Συγγνώμη, αλλά όταν η κοινότητα διαφωνεί για κάτι, αυτό δεν πρέπει να εξετάζεται.
...

Αυτό έλεγα κι εγώ σε άλλα post μου. Τα ζητήματα αυτά κουβεντιάζονται συνεχώς στο Στέκι. Δεκτές οι διαφωνίες αλλά δεν μπορεί να πέφτει κάτι πάνω σε κάτι που απασχολεί ακόμα τους συναδέλφους. Μπορεί για κάποιους να είναι ξεκάθαρο στο μυαλό τους αλλά αυτό δεν αποδεικνύει ότι είναι και σωστό ή ότι δεν υπάρχει ασάφεια στο βιβλίο. Δεν νομίζω ότι οι επιτροπές δεν διαβάζουν το Στέκι. Υπάρχουν ενδείξεις μέσα από τα θέματα ότι το διαβάζουν και λαμβάνουν υπόψη τους τις απόψεις... Ούτε θεωρώ ότι το έκαναν επίτηδες... Για αυτό μίλησα για αστοχία του θέματος... Απλά η περιβόητη διευκρίνηση χειροτέρεψε τα πράγματα...

George

  • Θαμώνας
  • ***
  • Μηνύματα: 42
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Άθροισμα στοιχείων κύριας και δευτερεύουσας διαγωνίου
« Απάντηση #47 στις: 01 Ιούν 2010, 10:45:46 πμ »
{1}
Κώδικας: [Επιλογή]
Αλγόριθμος αριθμοί
   Δεδομένα//Ν//
   α<-0
   Για ι από 1 μέχρι Ν
        Διάβασε Χ
        α<-α+Χ
   Τέλος_επανάληψης
   Εμφάνισε α
Τέλος αριθμοί

1. Υλοποιήσιμος σε ΓΛΩΣΣΑ
2. Υλοποιήσιμος σε C++, JAVA κλπ
3. Καλή απόδοση
4. Το πλήθος των αριθμών θεωρείται δεδομένο τη στιγμή έναρξης εκτέλεσης του αλγορίθμου


{2}
Κώδικας: [Επιλογή]
Αλγόριθμος αριθμοί
   Διάβασε Ν
   α<-0
   Για ι από 1 μέχρι Ν
        Διάβασε Χ
        α<-α+Χ
   Τέλος_επανάληψης
   Εμφάνισε α
Τέλος αριθμοί

1. Υλοποιήσιμος σε ΓΛΩΣΣΑ
2. Υλοποιήσιμος σε C++, JAVA κλπ
3. Καλή απόδοση
4. Το πλήθος των αριθμών δίνεται από το χρήστη κατά τη διάρκεια της εκτέλεσης



Να υποθέσω δηλαδή οτι το ΔΕΔΟΜΕΝΑ // Ν //  σε έναν αλγόριθμο είναι αντίστοιχο του ΔΙΑΒΑΣΕ  Ν   σε ένα πρόγραμμα?
Αν η απάντησή σου είναι :
α) ΝΑΙ.   Τότε το αντίστοιχο του ΔΕΔΟΜΕΝΑ //Ν, Χ πίνακας ακεραίων μεγέθους Ν//  ποιό είναι???
β) ΟΧΙ .  Τότε τι ακριβως κάνει το ΔΕΔΟΜΕΝΑ // Ν // ??

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: Άθροισμα στοιχείων κύριας και δευτερεύουσας διαγωνίου
« Απάντηση #48 στις: 01 Ιούν 2010, 10:55:01 πμ »
Τα Δεδομένα // Ν // σχετίζονται με τα υποπρογράμματα.

Να υποθέσω δηλαδή οτι το ΔΕΔΟΜΕΝΑ // Ν //  σε έναν αλγόριθμο είναι αντίστοιχο του ΔΙΑΒΑΣΕ  Ν   σε ένα πρόγραμμα?
Αν η απάντησή σου είναι :
α) ΝΑΙ.   Τότε το αντίστοιχο του ΔΕΔΟΜΕΝΑ //Ν, Χ πίνακας ακεραίων μεγέθους Ν//  ποιό είναι???
β) ΟΧΙ .  Τότε τι ακριβως κάνει το ΔΕΔΟΜΕΝΑ // Ν // ??

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Άθροισμα στοιχείων κύριας και δευτερεύουσας διαγωνίου
« Απάντηση #49 στις: 01 Ιούν 2010, 12:52:31 μμ »
Να υποθέσω δηλαδή οτι το ΔΕΔΟΜΕΝΑ // Ν //  σε έναν αλγόριθμο είναι αντίστοιχο του ΔΙΑΒΑΣΕ  Ν   σε ένα πρόγραμμα?
Αν η απάντησή σου είναι :
α) ΝΑΙ.   Τότε το αντίστοιχο του ΔΕΔΟΜΕΝΑ //Ν, Χ πίνακας ακεραίων μεγέθους Ν//  ποιό είναι???
β) ΟΧΙ .  Τότε τι ακριβως κάνει το ΔΕΔΟΜΕΝΑ // Ν // ??

Η απάντηση είναι ΟΧΙ. Θα έλεγα το αντίστοιχο του:

Κώδικας: [Επιλογή]
Αλγόριθμος αριθμοί   
   Δεδομένα//Ν//   
   α<-0   
   Για ι από 1 μέχρι Ν       
      Διάβασε Χ       
      α<-α+Χ   
   Τέλος_επανάληψης   
   Εμφάνισε α
Τέλος αριθμοί

θα ήταν κάπως έτσι:

Κώδικας: [Επιλογή]
ΥΠΟΠΡΟΓΡΑΜΜΑ αριθμοί (Ν)
ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: Ν
ΑΡΧΗ
   α<-0   
   ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ Ν       
      ΔΙΑΒΑΣΕ Χ       
      α<-α+Χ   
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΓΡΑΨΕ α
ΤΕΛΟΣ_ΥΠΟΠΡΟΓΡΑΜΜΑ

Το υποπρόγραμμα μπορεί να είναι διαδικασία ή συνάρτηση ανάλογα με το ποιο είναι καταλληλότερο.

Οπότε το Δεδομένα//Ν// είναι κάτι σαν τις παραμέτρους των υποπρογραμμάτων. Τώρα αν με ρώταγες "Και αν έχουμε μόνο κυρίως πρόγραμμα"; Θα σου απαντούσα σε αυτή την περίπτωση είναι κάτι σαν τα ορίσματα της γραμμής εντολών.

Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

George

  • Θαμώνας
  • ***
  • Μηνύματα: 42
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Άθροισμα στοιχείων κύριας και δευτερεύουσας διαγωνίου
« Απάντηση #50 στις: 01 Ιούν 2010, 01:08:28 μμ »
Η απάντηση είναι ΟΧΙ. Θα έλεγα το αντίστοιχο του:

Κώδικας: [Επιλογή]
Αλγόριθμος αριθμοί   
   Δεδομένα//Ν//   
   α<-0   
   Για ι από 1 μέχρι Ν       
      Διάβασε Χ       
      α<-α+Χ   
   Τέλος_επανάληψης   
   Εμφάνισε α
Τέλος αριθμοί

θα ήταν κάπως έτσι:

Κώδικας: [Επιλογή]
ΥΠΟΠΡΟΓΡΑΜΜΑ αριθμοί (Ν)
ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: Ν
ΑΡΧΗ
   α<-0   
   ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ Ν       
      ΔΙΑΒΑΣΕ Χ       
      α<-α+Χ   
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΓΡΑΨΕ α
ΤΕΛΟΣ_ΥΠΟΠΡΟΓΡΑΜΜΑ

Το υποπρόγραμμα μπορεί να είναι διαδικασία ή συνάρτηση ανάλογα με το ποιο είναι καταλληλότερο.

Οπότε το Δεδομένα//Ν// είναι κάτι σαν τις παραμέτρους των υποπρογραμμάτων. Τώρα αν με ρώταγες "Και αν έχουμε μόνο κυρίως πρόγραμμα"; Θα σου απαντούσα σε αυτή την περίπτωση είναι κάτι σαν τα ορίσματα της γραμμής εντολών.


Οπότε  μπορώ να υποθέσω οτι το ΔΕΔΟΜΕΝΑ // Ν, Χ //  είναι κάπως έτσι??


ΥΠΟΠΡΟΓΡΑΜΜΑ αριθμοί (Ν, Χ )
ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: Ν, Χ[ ? ]
ΑΡΧΗ
   α<-0   
   ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ Ν       
      ΔΙΑΒΑΣΕ Χ [ι]       
      α<-α+Χ [ι] 
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΓΡΑΨΕ α
ΤΕΛΟΣ_ΥΠΟΠΡΟΓΡΑΜΜΑ


tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Άθροισμα στοιχείων κύριας και δευτερεύουσας διαγωνίου
« Απάντηση #51 στις: 01 Ιούν 2010, 02:26:13 μμ »
Οπότε  μπορώ να υποθέσω οτι το ΔΕΔΟΜΕΝΑ // Ν, Χ //  είναι κάπως έτσι??

ΥΠΟΠΡΟΓΡΑΜΜΑ αριθμοί (Ν, Χ )
ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: Ν, Χ[ ? ]
ΑΡΧΗ
   α<-0   
   ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ Ν       
      ΔΙΑΒΑΣΕ Χ [ι]       
      α<-α+Χ [ι] 
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΓΡΑΨΕ α
ΤΕΛΟΣ_ΥΠΟΠΡΟΓΡΑΜΜΑ

ΝΑΙ κάπως έτσι...

ΥΠΟΠΡΟΓΡΑΜΜΑ αριθμοί (Ν, Χ )
ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: Ν, Χ[ ?N ]
ΑΡΧΗ
   α<-0   
   ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ Ν       
      ΔΙΑΒΑΣΕ Χ [ι]       
      α<-α+Χ [ι] 
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΓΡΑΨΕ α
ΤΕΛΟΣ_ΥΠΟΠΡΟΓΡΑΜΜΑ

Ας πούνε και οι άλλοι την άποψη τους... Η ουσία είναι ότι η Δεδομένα //Ν// δεν ορίζεται επαρκώς στο βιβλίο!
« Τελευταία τροποποίηση: 02 Ιούν 2010, 07:08:45 μμ από tom »
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

mpoufi

  • Νέος
  • *
  • Μηνύματα: 1
Ελάχιστα θα έκοβα... αφού το ζητούμενο είναι λίγο εξεζητημένο...

Κώστα γιατί θα έκοβες για το Διάβασε Ν;

πρέπει να κάψει το Ν δεν μπορεί να το διαβάσει.. δεν ειναι ένας αριθμός αλλα ειναι οι φυσικοί αριθμοί όλοι τους... στους δισδιάστατους πίνακες ο μόνος τρόπος για να διαβάσεις το Ν ειναι μεσα απο τα Δεδομένα.. δηλαδη
Δεδομενα //Α, Ν// :)