Αποστολέας Θέμα: Επαναληπτικές  (Αναγνώστηκε 14355 φορές)

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #75 στις: 11 Ιούν 2011, 02:45:50 πμ »
θεμα 4 πέραν δ4 (δεν έχω προλάβει) τυποποιημένα και βατά

Για το Δ4 αν e[20], τα ονόματα των εταιριών και k[20,5] τα κέρδη των εταιριών για την πενταετία, θα το έλυνα ως εξής:

Κώδικας: [Επιλογή]
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
     μεγ <- -1
     ετμεγ <- 0
     πρωτετμεγ <- 0
     ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 4
       ΑΝ k[i, j - 1] + k[i, j] + k[i, j + 1] > μεγ ΤΟΤΕ
         μεγ <- k[i, j - 1] + k[i, j] + k[i, j + 1]
         ετμεγ <- i
         πρωτετμεγ <- j - 1
       ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΡΑΨΕ e[ετμεγ], " ", πρωτετμεγ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

Αυτό που δεν  καταλαβαίνω καλά στο ΘΕΜΑ Δ είναι το Δ3.

α. η συνάρτηση θα υπολογίζει  μόνο το συνολικό κέρδος της εταιρίας στην πενταετία ή και το μέσο ετήσιο κέρδος του ομίλου;
β. τι είναι το "μέσο ετήσιο κέρδος του ομίλου"; Ο μ.ο. κερδών όλων των εταιριών για κάθε έτος (5 αποτελέσματα) ή μ.ο. κερδών όλων των εταιριών για όλα τα έτη; (1 αποτέλεσμα)
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3514
  • to Iterate is human to Recurse divine
Απ: Επαναληπτικές
« Απάντηση #76 στις: 11 Ιούν 2011, 09:13:27 πμ »
Λέει το μέσο ετήσιο κέρδος του ομίλου, άρα άθροισμα κερδών και μετά διά 5. Αυτό είναι και το δύσκολο, γιατί με την κλήση της συνάρτησης για κάθε εταιρία ο μαθητής βρίσκει το άθροισμα των γραμμών. Οπότε στο τέλος θα διαιρέσει διά 20 (από συνήθεια).
Μέχρι στιγμής σε 1-2 φροντιστήρια που είδα έχουν ανεβάσει λύσεις με αυτό το λάθος.


Αυτό που δεν  καταλαβαίνω καλά στο ΘΕΜΑ Δ είναι το Δ3.

α. η συνάρτηση θα υπολογίζει  μόνο το συνολικό κέρδος της εταιρίας στην πενταετία ή και το μέσο ετήσιο κέρδος του ομίλου;
β. τι είναι το "μέσο ετήσιο κέρδος του ομίλου"; Ο μ.ο. κερδών όλων των εταιριών για κάθε έτος (5 αποτελέσματα) ή μ.ο. κερδών όλων των εταιριών για όλα τα έτη; (1 αποτέλεσμα)
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #77 στις: 11 Ιούν 2011, 11:41:52 πμ »
Λέει το μέσο ετήσιο κέρδος του ομίλου, άρα άθροισμα κερδών και μετά διά 5. Αυτό είναι και το δύσκολο, γιατί με την κλήση της συνάρτησης για κάθε εταιρία ο μαθητής βρίσκει το άθροισμα των γραμμών. Οπότε στο τέλος θα διαιρέσει διά 20 (από συνήθεια).
Μέχρι στιγμής σε 1-2 φροντιστήρια που είδα έχουν ανεβάσει λύσεις με αυτό το λάθος.
Οπότε η συνάρτηση θα δέχεται ως όρισμα κάθε φορά την εταιρία και τον πίνακα;
Κάπως έτσι;

Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΔ
 ΣΤΑΘΕΡΕΣ
   ετ = 20
 !Δ1
 ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: i, j, k[ετ, 5], μεγ, ετμεγ, πρωτετμεγ
   ΠΡΑΓΜΑΤΙΚΕΣ: συνκερδομ
   ΧΑΡΑΚΤΗΡΕΣ: e[ετ]
 ΑΡΧΗ
 !Δ2
   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ ετ
     ΔΙΑΒΑΣΕ e[i]
     ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
       ΔΙΑΒΑΣΕ k[i, j]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 !Δ3
   συνκερδομ <- 0
   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ ετ
     συνκερδομ <- συνκερδομ + συνκερδετ5(i, k)
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΓΡΑΨΕ συνκερδομ/5
 !Δ4
   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ ετ
     μεγ <- -1
     ετμεγ <- 0
     πρωτετμεγ <- 0
     ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 4
       ΑΝ k[i, j - 1] + k[i, j] + k[i, j + 1] > μεγ ΤΟΤΕ
         μεγ <- k[i, j - 1] + k[i, j] + k[i, j + 1]
         ετμεγ <- i
         πρωτετμεγ <- j - 1
       ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΡΑΨΕ e[ετμεγ], " ", πρωτετμεγ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 !Δ5
 ΣΥΝΑΡΤΗΣΗ συνκερδετ5(et, p): ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: j, et, p[20, 5], s
 ΑΡΧΗ
   s <- 0
   ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
     s <- s + p[et, j]
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   συνκερδετ5 <- s
 ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ 

Δεν ξέρω δεν είμαι σίγουρος αν έχω καταλάβει καλά... :-\
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: Επαναληπτικές
« Απάντηση #78 στις: 11 Ιούν 2011, 11:42:20 πμ »
Λέει το μέσο ετήσιο κέρδος του ομίλου, άρα άθροισμα κερδών και μετά διά 5. Αυτό είναι και το δύσκολο, γιατί με την κλήση της συνάρτησης για κάθε εταιρία ο μαθητής βρίσκει το άθροισμα των γραμμών. Οπότε στο τέλος θα διαιρέσει διά 20 (από συνήθεια).
Μέχρι στιγμής σε 1-2 φροντιστήρια που είδα έχουν ανεβάσει λύσεις με αυτό το λάθος.


Ναι πολύ σωστός ο evry γιατί ουσιαστικά είναι το άθροισμα του δισδιάστατου πίνακα δια 5.

Για το Δ4 αν e[20], τα ονόματα των εταιριών και k[20,5] τα κέρδη των εταιριών για την πενταετία, θα το έλυνα ως εξής:

Κώδικας: [Επιλογή]
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
     μεγ <- -1
     ετμεγ <- 0
     πρωτετμεγ <- 0
     ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 4
       ΑΝ k[i, j - 1] + k[i, j] + k[i, j + 1] > μεγ ΤΟΤΕ
         μεγ <- k[i, j - 1] + k[i, j] + k[i, j + 1]
         ετμεγ <- i
         πρωτετμεγ <- j - 1
       ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΡΑΨΕ e[ετμεγ], " ", πρωτετμεγ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 


Θωμά που ακριβώς αποσκοπεί η χρήση της μεταβλητής ετμεγ; Δεν είναι το ίδιο το i; Μου διαφεύγει κάτι;

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #79 στις: 11 Ιούν 2011, 11:53:53 πμ »
Θωμά που ακριβώς αποσκοπεί η χρήση της μεταβλητής ετμεγ; Δεν είναι το ίδιο το i; Μου διαφεύγει κάτι;
Όχι, το i είναι.
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3514
  • to Iterate is human to Recurse divine
Απ: Επαναληπτικές
« Απάντηση #80 στις: 11 Ιούν 2011, 12:06:40 μμ »
ακριβώς
καλείς τη συνάρτηση όπως λέει η εκφώνηση για τα συνολικά κέρδη κάθε εταιρίας και μετά τα προσθέτεις όλα αυτά σε μια μεταβλητή που είναι το συνολικό κέρδος του ομίλου.
Από ότι φαίνεται η εκφώνηση δεν τα δίνει όλα στο πιάτο. Θέλει αρκετή σκέψη πριν ξεκινήσει κάποιος τη λύση.
Επίσης είναι από τις λίγες φορές που μπαίνει υποπρόγραμμα για το οποίο θα πρέπει οι μαθητές να σκεφτούν μόνοι τους ποιες είναι οι παράμετροι. Δεν λέει πουθενά τι δέχεται.

Οπότε η συνάρτηση θα δέχεται ως όρισμα κάθε φορά την εταιρία και τον πίνακα;
Κάπως έτσι;

What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #81 στις: 11 Ιούν 2011, 12:15:55 μμ »
ακριβώς
καλείς τη συνάρτηση όπως λέει η εκφώνηση για τα συνολικά κέρδη κάθε εταιρίας και μετά τα προσθέτεις όλα αυτά σε μια μεταβλητή που είναι το συνολικό κέρδος του ομίλου.
Από ότι φαίνεται η εκφώνηση δεν τα δίνει όλα στο πιάτο. Θέλει αρκετή σκέψη πριν ξεκινήσει κάποιος τη λύση.
Επίσης είναι από τις λίγες φορές που μπαίνει υποπρόγραμμα για το οποίο θα πρέπει οι μαθητές να σκεφτούν μόνοι τους ποιες είναι οι παράμετροι. Δεν λέει πουθενά τι δέχεται.
Δεν ξέρω κατά πόσο δικαιολογείται η επιλογή χρήσης συνάρτησης σε αυτή την περίπτωση. Δε θα μπορούσε να γίνει με μια διπλή επανάληψη στο κυρίως πρόγραμμα; Άσε που δεν  μου κάθεται καλά  να στέλνει κάθε φορά ολόκληρο πίνακα ως όρισμα, ενώ χρησιμοποιεί, μόνο τα πέντε στοιχεία του...
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3514
  • to Iterate is human to Recurse divine
Απ: Επαναληπτικές
« Απάντηση #82 στις: 11 Ιούν 2011, 12:27:22 μμ »
Δεν έχει σημασία ότι είναι 5, θα μπορούσαν να είναι περισσότερα. Απλά η ιδέα είναι ότι περνάει σαν παράμετρο έναν πίνακα και τον αριθμό γραμμής ή στήλης που θέλουμε να επεξεργαστεί. Απλά τυχαίνει και τα στοιχεία προς επεξεργασία είναι λίγα σε σχέση με το μέγεθος των ορισμάτων, για αυτό σου φαίνεται άσχημα. Προφανώς σαν προγραμματιστική τεχνική δεν είναι και ότι καλύτερο, αλλά ο σκοπός είναι μάλλον διδακτικός/εξεταστικός θα έλεγα.

Δεν ξέρω κατά πόσο δικαιολογείται η επιλογή χρήσης συνάρτησης σε αυτή την περίπτωση. Δε θα μπορούσε να γίνει με μια διπλή επανάληψη στο κυρίως πρόγραμμα; Άσε που δεν  μου κάθεται καλά  να στέλνει κάθε φορά ολόκληρο πίνακα ως όρισμα, ενώ χρησιμοποιεί, μόνο τα πέντε στοιχεία του...
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2806
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #83 στις: 11 Ιούν 2011, 07:34:57 μμ »
ΘΕΜΑ Β1.γ:

Κώδικας: [Επιλογή]
...
  μαχμθ← -9999999
...

Στη συγκεκριμένη περίπτωση (μεγαλύτερος κατ' απόλυτη τιμή ...) ο μαχθ θα μπορούσε να πάρει  σαν αρχική τιμή το 0 ή οποιαδήποτε μικρότερη από το 0. Το αναφέρω γιατί μπορεί κάποιος να μπερδευτεί προσπαθώντας να καταλάβει γιατί πήρε την τιμή -9999999.

Καμιά άποψη για το παρακάτω, κανείς ;;;;;
(αναφέρομαι στο Β1: http://dide.ilei.sch.gr/keplinet/education/docs/them_plir_kat_c_hmer_epan_1106.pdf)

Μόλις μου δημιουργήθηκε η εξής απορία: Ζητάνε διαφορετικά τμήματα αλγορίθμων ή όλα σε ένα; Αν ζητάνε διαφορετικά τότε γιατί στο α) δίνουν 4 μονάδες και στο β) μόνο 2 μονάδες;  :laugh:

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3302
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Επαναληπτικές
« Απάντηση #84 στις: 11 Ιούν 2011, 09:36:58 μμ »
και σε κάποιο θέμα Γ ή Δ, δίνονται μόρια σε κάθε ερώτημα αλλά ζητάει ενιαίο αλγόριθμο.

Θεωρώ οτι ζητάει ενιαίο κώδικα, και αυτό ενισχύεται και από το ότι κάποιες μεταβλητές ενός ερωτήματος χρειάζονται στο επόμενο.
Θεωρώ οτι αν κάποιος μαθητής έδωσε διαφορετικές κωδικοποιήσεις δε θα χάσει καμία μονάδα...

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1515
  • Sky's the limit
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Επαναληπτικές
« Απάντηση #85 στις: 11 Ιούν 2011, 10:00:24 μμ »
Αρκετά καλά τα θέματα ... Θα προτιμούσα λίγο προσεκτικότερες διατυπώσεις στο Β1 και στο Δ3.
Θα ήθελα να δω τι θα γινόταν αν έμπαιναν στις κανονικές των ημερησίων ...
Για όσους συναδελφους ενδιαφέρονται οι λύσεις και τα θέματα σε doc μορφή βρίσκονται από σήμερα και εδώ :

http://users.sch.gr/gnikola/
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

ikariofil

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 128
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές
« Απάντηση #86 στις: 11 Ιούν 2011, 10:38:07 μμ »
Γιώργο στο θέμα Γ πρέπει να λείπει η εντολή...


Διάβασε Καύσιμο
Αν Ποσότητα >= Καύσιμο τότε
          Ποσότητα ← Ποσότητα – Καύσιμο
          Πλήθος_Επιβατηγών ← Πλήθος_Επιβατηγών + 1
          Σύνολο_Επιβατηγών ← Σύνολο_Επιβατηγών + Καύσιμο
          Οχήματα 0
Αλλιώς
          Οχήματα ← Οχήματα + 1
Τέλος_αν

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1515
  • Sky's the limit
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Επαναληπτικές
« Απάντηση #87 στις: 12 Ιούν 2011, 07:15:56 μμ »
Σωστά Ηλία, ευχαριστώ πολύ για την υπόδειξη. Θα το διορθώσω αύριο με την επιστροφή μου  ;)
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

pgrontas

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 1426
  • There are always possibilities...
Απ: Επαναληπτικές
« Απάντηση #88 στις: 12 Ιούν 2011, 10:00:11 μμ »
Ωραία θεματάκια.
Σε ό,τι αφορά το Β1, που επισημαίνει ο Νίκος εγώ το εξέλαβα ως 3 διαφορετικοί αλγόριθμοι. Μπορεί να έκανα και λάθος.
Επίσης, αν θέλουμε να είμαστε απόλυτα σωστοί, νομίζω ότι στο Δ4 χρειαζόταν διευκρίνηση ότι η τριετία είναι συνεχόμενη. Αλλιώς το θέμα γίνεται αρκετά ενδιαφέρον. >:D

Γενικό ερώτημα: Ωραία δεν θα ήταν όλες οι πανελλήνιες να ξεκινούσαν στις 17:00  ;)

ΥΓ: Τώρα είδα ότι έχει ξανατεθεί το θέμα με τα συνεχόμενα ή όχι χρόνια της τριετίας.
« Τελευταία τροποποίηση: 12 Ιούν 2011, 10:22:20 μμ από pgrontas »
Programs must be written for people to read, and only incidentally for machines to execute - Harold Abelson

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Επαναληπτικές
« Απάντηση #89 στις: 13 Ιούν 2011, 10:21:08 πμ »
Επίσης, αν θέλουμε να είμαστε απόλυτα σωστοί, νομίζω ότι στο Δ4 χρειαζόταν διευκρίνηση ότι η τριετία είναι συνεχόμενη. Αλλιώς το θέμα γίνεται αρκετά ενδιαφέρον. >:D

Αν η εκφώνηση θεωρούσε ότι οι τριετίες δεν είναι συνεχόμενες τότε δεν θα ζητούσε το πρώτο έτος. Για παράδειγμα οι τριετίες με πρώτο το 2001 είναι 6. Αν εμφανιστεί μόνο το 2001 σε ποια από τις έξι μοναδικές αναφέρεται; Επίσης τα χρόνια από τις τριετίες πρέπει να εμφανίζονται σε αύξουσα σειρά; Δηλαδή τα 2002, 2001 και 2003 είναι ή όχι αποδεκτή τριετία.

Νομίζω ότι η εκφώνηση ήταν μια χαρά. Ένα "συνεχόμενη" μπορεί να την έκανε πιο πλήρη αλλά και πάλι εκτιμώ ότι αν δεν γινόταν όλες αυτές οι συζητήσεις στο στέκι δεν θα ήμαστε τόσο υποψιασμένοι. Επίσης το θέμα δεν γίνεται απλά ενδιαφέρον αλλά γίνεται πολύ δύσκολο εώς αδύνατο για μαθητές Γ Λυκείου να δώσουν λύση στο ασφυκτικό πλαίσιο των εξετάσεων.