Αποστολέας Θέμα: Θέμα Δ  (Αναγνώστηκε 7105 φορές)

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: Θέμα Δ
« Απάντηση #30 στις: 24 Μάι 2011, 08:49:35 πμ »

Αυτό είναι ένα μεγάλο θέμα, που θα ήταν προτιμότερο να συζητηθεί σύμφωνα με συγκεκριμένο πλαίσιο και όχι σύμφωνα με μία προσπάθεια να μετρήσουμε την "γνώση" (αν μπορεί να μετρηθεί) των εκπαιδευτικών.

Στην έρευνα που έγινε πέρσι, στην οποία συμμετείχαν 1127 άτομα (που έχουν διδάξει ή διδάσκουν το μάθημα) και πολλοί από αυτούς είναι συνάδελφοι που διαβάζουν το forum, οι εκπαιδευτικοί βάσει ενός ερωτηματολογίου με 29 ερωτήσεις δήλωναν (εκτός των άλλων) την αυτεπάρκειά τους στη γνώση του αντικειμένου που καλούνται να διδάξουν. Από την έρευνα αναδεικνύεται ότι οι εκπαιδευτικοί δηλώνουν στο δείκτη της γνώσης τους αντικειμένου που καλούνται να διδάξουν την μεγαλύτερη αυτεπάρκεια.
(περισσότερα: http://dide.ilei.sch.gr/keplinet/education/docs/syn_icicte2010_doukakis.pdf)

Ωστόσο, αυτό προφανώς δεν καταδεικνύει την γνώση των εκπαιδευτικών στο αντικείμενο που καλούνται να διδάξουν, αλλά το τι πιστεύουν οι ίδιοι.

Κατά την γνώμη μου, δεν προσφέρουμε υπηρεσία (αν πράγματι αυτό θεωρούμε ότι κάνουμε όσοι πληκτρολογούμε γραπτά κείμενα σε αυτό το χώρο που δημιούργησε και συντηρεί ο Άλκης και εμείς αξιοποιούμε για να μην πω εκμεταλλευόμαστε και γράφουμε τα εσώψυχά μας και μερικές φορές ακόμα περισσότερα) σε κανέναν και για τίποτα συζητώντας αν ο εκπαιδευτικός γνωρίζει το τάδε ζήτημα ή δεν το γνωρίζει. Αυτό που χρειάζεται τις περισσότερες φορές είναι η διερεύνηση των αντιλήψεων, των στάσεων, της επιστημολογίας που "κουβαλάμε" συμμετέχοντας ενεργά στα συμβαίνοντα του μικρόκοσμου του μαθήματος που λέγεται ΑΕΠΠ. Βάσει αυτών είναι χρήσιμο να δούμε τα αποτελέσματα της διδασκαλίας του αντικείμενου στη δευτεροβάθμια εκπαίδευση (http://www.iticse2011.tu-darmstadt.de/wgs/wg2).

και για να κλείσω:
Κάποτε (στη δεκαετία 1970) ρώτησαν οι φοιτητές του μαθηματικού του ΑΠΘ τον πανεπιστημιακό που έδινε διάλεξη στο αμφιθέατρο την ακόλουθη ερώτηση:
- Τι χρειάζεται κάποιος για να γίνει καλός δάσκαλος των μαθηματικών
Ο πανεπιστημιακός απάντησε:
- Τρία πράγματα
1. Να ξέρει μαθηματικά
2. Να ξέρει μαθηματικά
3. Να είναι έντιμος άνθρωπος (αντιγραφή από άρθρο του κ. Θωμαΐδη που δημοσιεύτηκε πρόσφατα στο συνέδριο της ΕΜΕ).

Ευτυχώς, έχουμε ξεπεράσει αυτή την περίοδο και έχουμε αρχίσει να μιλάμε και για άλλα είδη γνώσης (παιδαγωγική και τεχνολογική γνώση) και τον συνδυασμό τους (http://youtu.be/q7HN85lHNFA).

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 801
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Θέμα Δ
« Απάντηση #31 στις: 24 Μάι 2011, 09:20:46 πμ »
..αναδεικνύεται ότι οι εκπαιδευτικοί δηλώνουν στο δείκτη της γνώσης τους αντικειμένου που καλούνται να διδάξουν την μεγαλύτερη αυτεπάρκεια..Ωστόσο, αυτό προφανώς δεν καταδεικνύει την γνώση των εκπαιδευτικών στο αντικείμενο που καλούνται να διδάξουν, αλλά το τι πιστεύουν οι ίδιοι..
.
..δεν προσφέρουμε υπηρεσία .. σε κανέναν και για τίποτα συζητώντας αν ο εκπαιδευτικός γνωρίζει το τάδε ζήτημα ή δεν το γνωρίζει..
.
Αυτό που χρειάζεται τις περισσότερες φορές είναι η διερεύνηση των αντιλήψεων, των στάσεων, της επιστημολογίας που "κουβαλάμε"..

+1

Ενισχύοντας τα παραπάνω, να προσθέσω κάποια επιπλέον σημεία που εκτιμώ ότι είναι εξίσου χρήσιμα και έπονται της απαιτούμενης διερεύνησης που ανφέρει ο Σπύρος:
1) να έχουμε τη διάθεση να αμφισβητήσουμε τα όσα ξέρουμε, να παραδεχόμαστε όποια λάθη μας και να συνεχίσουμε να μαθαίνουμε
2) να εστιάζουμε τις όποιες κριτικές και θέσεις που διατυπώνουμε, στις απόψεις που ακούγονται και όχι στα πρόσωπα που τις διατυπώνουν ώστε να συντηρούμε ένα κλίμα δημιουργικής αντιπαράθεσης στα ζητήματα που προκύπτουν
3) αφού δεν υπάρχει συστηματική δράση επιμόρφωσης, να επιδιώξουμε (έστω εκ των ενόντων) να υποστηρίξουμε μόνοι μας αυτή την ανάγκη
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2260
Απ: Θέμα Δ
« Απάντηση #32 στις: 24 Μάι 2011, 09:29:50 πμ »
Επειδή βλέπω σχεδόν σε όλες τις προτεινόμενες λύσεις την εντολή "Αντιμετάθεσε", νομίζω ότι θα πρέπει να ανοίξουμε κουβέντα και γι'αυτή κάποια στιγμή
Το ξέρω ότι υπάρχει στο βιβλίο, αλλά η χρήση της είναι σαν ένα μαύρο πρόβατο ανάμεσα σε ένα κοπάδι λευκά
Γιατί λέμε π.χ. Αντιμετάθεσε (Α[j-1], A[j])
και δεν μπορούμε να πούμε Σάρωσε Πίνακα Α(1..Ν), Πρόσθεσε (α+β-5);
Δεν είναι υποκριτικό;

Γενικά, η άποψη μου είναι ότι η εντολή Αντιμετάθεσε δεν πρέπει να χρησιμοποιείται γιατί και αυτή ανοίγει τους ασκούς του Αιόλου
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 801
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Θέμα Δ
« Απάντηση #33 στις: 24 Μάι 2011, 09:48:18 πμ »
Η ελευθερία που υπάρχει στην ψευδογλώσσα είναι αρκετά παρεξηγημένη..

Διαταράσσει τη δική μας ανάγκη / συνήθεια για αυστηρότητα στην έκφραση αλλά επιτρέπει την εστίαση στην ανάπτυξη του αλγόριθμου χωρίς τους ιδιαίτερους τεχνικούς περιορισμούς μια γλώσσας προγραμματισμού.

Και ασφαλώς, η αναγνώριση του "σημείου ισορροπίας" μεταξύ ελευθερίας και σαφήνειας εδεν είναι εύκολη δουλειά, ιδιαίτερα για τους διδάσκοντες που στη συντρηπτική τους πλειοψηφία έχουν έμτονη προγραμματιστική εμπειρία με αποτέλεσμα να δυσκολεύονται να ελέγξουν ή να αξιολογήσουν αυτή τη χαλαρότητα που επιτρέπει η διατύπωση αλγορίθμων σε ψευδογλώσσα..

Παραπέμπω και στη σελίδα 72 του βιβλίου καθηγητή που είναι αρκετά χρήσιμη πηγή.. Παρά τα όσα λέγονται εκεί, δε νομίζω πως πολλοί επιτρέπουμε στους μαθητές μας τη χρήση γραμμών κλάσματος, ή άλλων μαθηματικών συμβολισμών όπως η απόλυτη τιμή ή η τετραγωνική ρίζα..

Σε ανώτερα επίπεδα ιεραρχικης σχεδίασης του αλγόριθμού μας, νομίζω ότι η χρήση "λέξεων" σαν αυτές που αναφέρθηκαν
Σάρωσε Πίνακα Α(1..Ν), Πρόσθεσε (α+β-5);
δεν δημιουργεί πρόβλημα.

Εν τούτοις, όταν φτάσουμε στα κατώτερα επίπεδα του ιεραρχικού μας σχεδιασμού και διατυπώσουμε την τελική μορφή του αλγόριθμου, θα πρέπει να φροντίζουμε για την καθοριστικότητα και την αποτελεσματικότητα των βημάτων που περιγράφουμε.

Αναγνωρίζω πως υπάρχει μια δυσδιάκριτη γραμμή (ή περιοχή) ανάμεσα στο σαφές και το ασαφές και αυτή είναι η διδακτική πρόκληση που, όντως δεν υπάρχει στον προγραμματισμό, όμως αυτό είναι το κέρδος από τη διδασκαλία σε ψευδογλώσσα που την αναδεικνύει σε παιδαγωγικά χρήσιμο εργαλείο για την επίτευξη των πραγματικών στόχων του μαθήματος μέσα από την προτεινόμενη σπειροειδή προσέγγιση.
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3243
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #34 στις: 24 Μάι 2011, 10:00:36 πμ »
πιθανώς παρεξηγημένος είναι και ο 3ος γενικός στόχος του μαθήματος (σελίδα 14 βιβλίου καθηγητή), που η ίδια η συγγραφική ομάδα διατύπωσε (Πέτρο δεν αναφέρομαι στο μήνυμά σου αλλά γενικότερα)

- να καλλιεργήσουν και να εθιστούν στην αυστηρότητα και σαφήνεια της έκφρασης και της διατύπωσης

Βρακόπουλος Αθανάσιος Λ.

  • Θαμώνας
  • ***
  • Μηνύματα: 35
Απ: Θέμα Δ
« Απάντηση #35 στις: 24 Μάι 2011, 12:40:27 μμ »
Παρουσιάζω δυο διαφορετικές εκδοχές λύσεων του Δ4 που πρέπει να εκτιμηθούν και να βαθμολογηθούν εξίσου σωστά από τους βαθμολογητές.
Δεν στηρίζονται σε πίνακες.


! Δ4 ερώτημα

MAX<--22
K<--0
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          Ι<--0
          ΑΡΧΗ_ ΕΠΑΝΑΛΗΨΗΣ
          Ι<--Ι+1
         ΜΕΧΡΙΣ_ΟΤΟΥ Σ_ΨΗΦΟΙ[Ι]=ΜΑΧ Η  Ι=22
         ΑΝ Σ_ΨΗΦΟΙ[Ι]=ΜΑΧ ΤΟΤΕ
               ΕΜΦΑΝΙΣΕ Σ_ΨΗΦΟΙ[Ι], Ι
               Κ<--Κ+1
         ΤΕΛΟΣ_ΑΝ
         ΜΑΧ<-- ΜΑΧ-1
ΜΕΧΡΙΣ _ ΟΤΟΥ Κ=3

! Δ4 ερώτημα

ΜΑΧ1<--0,Θ1<--0
ΜΑΧ2<--0,Θ2<--0
ΜΑΧ3<--0,Θ3<--0

ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 22
   ΑΝ Σ_ΨΗΦΟΙ[Ι]>ΜΑΧ1 ΤΟΤΕ
   ΜΑΧ3<--ΜΑΧ2, Θ3<--Θ2
   ΜΑΧ2<--ΜΑΧ1,Θ2<--Θ1
   ΜΑΧ1<-- Σ_ΨΗΦΟΙ[Ι], Θ1<--Ι
    ΑΛΛΙΩΣ_ΑΝ Σ_ΨΗΦΟΙ[Ι]>ΜΑΧ2 ΤΟΤΕ
   ΜΑΧ3<--ΜΑΧ2, Θ3<--Θ2
   ΜΑΧ2<-- Σ_ΨΗΦΟΙ[Ι], Θ2<--Ι
    ΑΛΛΙΩΣ_ΑΝ Σ_ΨΗΦΟΙ[Ι]>ΜΑΧ3 ΤΟΤΕ
   ΜΑΧ3<-- Σ_ΨΗΦΟΙ[Ι], Θ3<--Ι
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ Ο[Θ1],Θ1
ΓΡΑΨΕ Ο[Θ2],Θ2
ΓΡΑΨΕ Ο[Θ3],Θ3


P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3243
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #36 στις: 24 Μάι 2011, 12:47:50 μμ »
η πρώτη λύση Θανάση με καθήλωσε
είναι εκπληκτική και δε μπορώ να εκφράσω λόγια για το μαθητή που την παρουσίασε

spantoulis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 109
Απ: Θέμα Δ
« Απάντηση #37 στις: 24 Μάι 2011, 01:47:00 μμ »

! Δ4 ερώτημα

MAX<--22
K<--0
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          Ι<--0
          ΑΡΧΗ_ ΕΠΑΝΑΛΗΨΗΣ
          Ι<--Ι+1
         ΜΕΧΡΙΣ_ΟΤΟΥ Σ_ΨΗΦΟΙ[Ι]=ΜΑΧ Η  Ι=22
         ΑΝ Σ_ΨΗΦΟΙ[Ι]=ΜΑΧ ΤΟΤΕ
               ΕΜΦΑΝΙΣΕ Σ_ΨΗΦΟΙ[Ι], Ι
               Κ<--Κ+1
         ΤΕΛΟΣ_ΑΝ
         ΜΑΧ<-- ΜΑΧ-1
ΜΕΧΡΙΣ _ ΟΤΟΥ Κ=3


Μου θυμίζει τον τρόπο που ορίζανε παλιότερα απουσιολόγους τμήματος.
20 βγάζει κανείς?
19,9 βγάζει κανείς?
19,8 βγάζει κανείς?
 ...........

Η απλότητα σε όλο της το μεγαλείο....
Η χρήση υπολογιστών ΔΕΝ είναι πληροφορική

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 801
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Θέμα Δ
« Απάντηση #38 στις: 24 Μάι 2011, 02:31:49 μμ »
η πρώτη λύση Θανάση με καθήλωσε
είναι εκπληκτική και δε μπορώ να εκφράσω λόγια για το μαθητή που την παρουσίασε


+1
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 914
Απ: Θέμα Δ
« Απάντηση #39 στις: 25 Μάι 2011, 09:03:04 πμ »
Πράγματι, είναι ένας τρόπος σκέψης τόσο απλός που εκπλήσσει !
Και η ομορφιά του είναι στο ότι είναι διαφορετικός από τους άλλους.
Συγχαρητήρια στο μαθητή που το σκέφτηκε, ειδικά μέσα στις συνθήκες που λειτουργούσε.
Βέβαια, αυτή η μέθοδος στερείται γενικότητας. Εδώ δείχνει εφαρμόσιμη επειδή το εύρος των αναμενόμενων τιμών είναι μικρό (0 ως 22).  Αν όμως το εύρος ήταν ακόμα και της τάξης του 1000, τότε ... "τρέχα γύρευε".

Ένας ακόμα τρόπος που είδα και δεν θα είχα σκεφτεί να κάνω είναι ο εξής:
(καλά όχι ότι είναι πρωτότυπος. Χρησιμοποιεί πολύ τετριμμένες γνώσεις αλλά τις έχει χρησιμοποιήσει διαμορφωμένες κατάλληλα που δείχνει ότι έχει κατανοήσει τη λειτουργία τους)
Κώδικας: [Επιλογή]
 
! βρίσκω max1 και θέση1
  Max1 <- -1
  Για i από 1 μέχρι 22
      Αν ΕΛΑΒΑΝ[ i ]>max1 τότε
         Max1<- ΕΛΑΒΑΝ[ i ]
         Θ_max1 <- i
      Τέλος_αν
  Τέλος_επανάληψης

  ! βρίσκω max2 και θέση2
  Max2 <- -1
  Για i από 1 μέχρι 22
      Αν i <> θ_max1 και ΕΛΑΒΑΝ[ i ]>max2 τότε
         Max2 <- ΕΛΑΒΑΝ[ i ]
         Θ_max1 <- i
      Τέλος_αν 
  Τέλος_επανάληψης

  ! βρίσκω max3 και θέση3
  Max3 <- -1
  Για i από 1 μέχρι 22
      Αν i <> θ_max1 και i <> θ_max2 και ΕΛΑΒΑΝ[ i ]>max3 τότε
         Max3 <- ΕΛΑΒΑΝ[ i ]
         Θ_max3 <- i
      Τέλος_αν
  Τέλος_επανάληψης

Εμφάνισε Θ_max1, max1
Εμφάνισε Θ_max2, max2
Εμφάνισε Θ_max3, max3
Φιλικά,
Γιώργος Θαλασσινός

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3243
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #40 στις: 25 Μάι 2011, 09:09:56 πμ »
Γιώργο και λοιποί φίλοι, ο τρόπος και η σκέψη είναι απλά
η υλοποίηση όχι τόσο, πρόσεξε κάθε μεταβλητή πού πρέπει να αρχικοποιηθεί και πού να τροποποιηθεί...