Αποστολέας Θέμα: Άσκηση ΔΕ3, σελ 96 τετραδίου  (Αναγνώστηκε 3482 φορές)

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 946
Άσκηση ΔΕ3, σελ 96 τετραδίου
« στις: 24 Φεβ 2011, 03:14:19 μμ »
Μπορεί κάποιος να μου εξηγήσει τι λέει και τι ζητάει αυτή η άσκηση;
(ουσιαστικά τι λέει η ΔΕ4 σελ  81 !!! )
Φιλικά,
Γιώργος Θαλασσινός

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 802
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Άσκηση ΔΕ3, σελ 96 τετραδίου
« Απάντηση #1 στις: 24 Φεβ 2011, 03:41:12 μμ »
Απ' ότι καταλαβαίνω Γιώργο, αφού στο παράδειγμα 2 (σελ.90) που αναφέρεται η " Άσκηση ΔΕ3, σελ 96 τετραδίου", έχουμε υπολογίζει τα 4 μέσα επίπεδα θορύβου (ένα για κάθε μοντέλο), τώρα μας ζητάει να ταξινομήσουμε τα μοντέλα, με κριτήριο το μέσο επίπεδο θορύβου.

Κάτι σαν:

Κώδικας: [Επιλογή]
Για ι από 2 μέχρι 4
   Για κ από 4 μέχρι ι με_βήμα -1
      Αν ΜΕΘ[κ] < ΜΕΘ[κ-1] τότε
         Αντιμετάθεσε ΜΕΘ[κ], ΜΕΘ[κ-1]
         Αντιμετάθεσε Μοντέλο[κ], Μοντέλο[κ-1]
         Για λ από 1 μέχρι 5
            Αντιμετάθεσε Θόρυβος[κ, λ], Θόρυβος[κ-1, λ]
         Τέλος_επανάληψης
      Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης

Εγώ έτσι το καταλαβαίνω..

Τι σε προβληματίζει ;
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 802
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Άσκηση ΔΕ3, σελ 96 τετραδίου
« Απάντηση #2 στις: 24 Φεβ 2011, 03:42:22 μμ »
(ουσιαστικά τι λέει η ΔΕ4 σελ  81 !!! )

Αυτή δε νομίζω πως έχει κάποια σχέση με την "Άσκηση ΔΕ3, σελ 96 τετραδίου"..
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 946
Απ: Άσκηση ΔΕ3, σελ 96 τετραδίου
« Απάντηση #3 στις: 02 Μάρ 2011, 01:47:15 πμ »
Ωχ, συγγνώμη Σέργιε!
Δεν είχα δει την απάντηση τόσες μέρες!
Στο τετράδιο μαθητή που έχω (ηλεκτρονική και έντυπη έκδοση) η ΔΕ3 στη σελ. 96 λέει αυτά. (Μήπως έχει καταργηθεί; )
Φιλικά,
Γιώργος Θαλασσινός

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 802
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Άσκηση ΔΕ3, σελ 96 τετραδίου
« Απάντηση #4 στις: 02 Μάρ 2011, 02:27:36 πμ »
Φτου..

Λάθος άσκηση κοιτούσα :(  Μπερδεύτηκα με το ΔΕ4 που είχες στην παρένθεση, και κοίταξα την ΔΕ4 της σελίδας 96.. Τεσπα..

Η ΔΕ4 της σελ.81, απ ότι καταλαβαίνω, ζητάει το εξής:



Ας πούμε για τον ένα από τους δύο ρύπους.. Αφού έχουμε 5 σταθμούς, και για απο ένα σταθμό παίρνουμε κάθε ώρα 6 διαφορετικές μετρήσεις, θέλει:

α. να υπολογίζει τη μέση τιμή κάθε ρύπου ανά ώρα και ανά σταθμό: να υπολογίσουμε δηλαδή τη μέση τιμή του ρύπου για κάθε μία από τις 24 ώρες της μέρας, σε κάθε ένα από τους 5 σταθμούς.  Με την επιπλέον απαίτηση της ΔΕ3 της σελ.96 (χρησιμοποιόντας πίνακες για την αποθήκευση των τιμών καθώς και των ονομάτων των σταθμών μέτρησης) αυτούς τους μέσους όρους, να τους φυλάξουμε σε πίνακα.. ΜΟ[5,24]

Υποθέτω κάτι της μορφής:

Κώδικας: [Επιλογή]
Για ι από 1 μέχρι 5        ! για κάθε σταθμό
   Διάβασε Ον[5]
   Για κ από 1 μέχρι 24    ! για κάθε ώρα
      Σ <- 0
      Για λ από 1 μέχρι 6  ! για κάθε μέτρηση
         Διάβασε Τιμή
         Σ <- Σ + Τιμή
      Τέλος_επανάληψης
      ΜΟ[ι, κ] <- Σ / 6
   Τέλος_επανάληψης
Τέλος_επανάληψης

β. να βρίσκει τη μέγιστη μέση τιμή για κάθε ρύπο: υποθέτω πως αναφέρεται σε εκείνες τις μέσες τιμές που υπολογίσαμε παραπάνω.. επομένως πρέπει να βρούμε τη μέγιστη τιμή του δισδιάστατου

γ. να ελέγχει τις μέγιστες αυτές τιμές με τα όρια που δόθηκαν: υποθέτω πως αναφέρεται στα όρια που δίνονται στο παράδειγμα 1 της σελ.72, επομένως αφού βρούμε τη μέγιστη τιμή (παραπάνω) και για τους δυο ρύπους (2 δισδιάστατοι και, αντίστοιχα, 2 μέγιστα), θα κάνουμε την πολλαπλή επιλογή της σελίδας 72-73 εξετάζοντας τα δυο μέγιστα, προκειμένου να τυπώνουμε το αντίστοιχο μήνυμα (σύμφωνα με τον πίνακα της σελ.72)


Νομίζω..
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 946
Απ: Άσκηση ΔΕ3, σελ 96 τετραδίου
« Απάντηση #5 στις: 02 Μάρ 2011, 03:23:17 πμ »
Νομίζω ... ότι καλά νομίζεις  :)
όμως, ή πάει να μας βάλει να γράφουμε ηλιθιωδώς τον ίδιο κώδικα, μια φορά για τον ένα ρύπο και μία για τον άλλο
ή πάει να μας βάλει να κάνουμε ... τρισδιάστατο πίνακα !

(ακόμα, πού βρήκες ότι το θέλει αυτό για 24 ώρες ;;;  )
Φιλικά,
Γιώργος Θαλασσινός

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 802
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Άσκηση ΔΕ3, σελ 96 τετραδίου
« Απάντηση #6 στις: 02 Μάρ 2011, 08:08:40 πμ »
όμως, ή πάει να μας βάλει να γράφουμε ηλιθιωδώς τον ίδιο κώδικα, μια φορά για τον ένα ρύπο και μία για τον άλλο
ή πάει να μας βάλει να κάνουμε ... τρισδιάστατο πίνακα !

Να σου πω... κανενα παραδειγματάκι με τρισδιάστατο δεν θα ήταν κακό  >:D  Έτσι για να .. φανούν ευκολότεροι οι δισδιάστατοι μετά  :D  Αν και θα μπορούσαμε να τον ..  "γλυτώσουμε" κάνοντας :

Κώδικας: [Επιλογή]
Για ι από 1 μέχρι 5        ! για κάθε σταθμό
   Διάβασε Ον[5]
   Για ρ από 1 μέχρι 2
     Για κ από 1 μέχρι 24    ! για κάθε ώρα
        Σ <- 0
        Για λ από 1 μέχρι 6  ! για κάθε μέτρηση
           Διάβασε Τιμή
           Σ <- Σ + Τιμή
        Τέλος_επανάληψης
        Αν ρ = 1 τότε
          ΜΟΟ[ι, κ] <- Σ / 6
        Αλλιώς
          ΜΟΝ[ι, κ] <- Σ / 6
        Τέλος_Αν
     Τέλος_επανάληψης
Τέλος_επανάληψης

Αφού οι ρύποι είναι μόνο δύο..
Όμως ο τρισδιάστατος θα είχε πιό πολύ .. πλάκα ;D
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 802
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Άσκηση ΔΕ3, σελ 96 τετραδίου
« Απάντηση #7 στις: 02 Μάρ 2011, 08:11:20 πμ »
(ακόμα, πού βρήκες ότι το θέλει αυτό για 24 ώρες ;;;  )

Πολύ καλά .. κρυμμένο στη φράση ..Το πρόγραμμα να εκτελεστεί με δεδομένα τις πραγματικές τιμές ρύπων που μετρήθηκαν τη χθεσινή μέρα.. Άλλη μια περίπτωση άσκησης που η κατανόηση των .. προδιαγραφών.. θέλει κέφι και φαντασία :D
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 946
Απ: Άσκηση ΔΕ3, σελ 96 τετραδίου
« Απάντηση #8 στις: 02 Μάρ 2011, 09:52:49 πμ »
Α, ωραίο. Το χειρίζεσαι με μια ΑΝ
Ωραία, σ' ευχαριστώ Σέργιε για τη βοήθεια.
Φιλικά,
Γιώργος Θαλασσινός

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 802
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Άσκηση ΔΕ3, σελ 96 τετραδίου
« Απάντηση #9 στις: 02 Μάρ 2011, 11:21:28 πμ »
Παρακαλώ :)  Και μένα σε καλό μου βγήκε.. Δεν είχε τραβήξει την προσοχή μου αυτή η άσκηση  :-[
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)