Αποστολέας Θέμα: Μπορειτε να βοηθησετε?  (Αναγνώστηκε 1619 φορές)

Alexis_vti

  • Νέος
  • *
  • Μηνύματα: 6
Μπορειτε να βοηθησετε?
« στις: 21 Μάρ 2009, 04:18:47 μμ »
Θα ήθελα αν μπορειτε να με βοηθήσετε με αυτήν την ασκηση

Ευχαριστω πολύ!!!

Υ.Γ. Η προσπαθεια σας είναι πολύτιμη!!!


nikosx

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 368
  • ___
Απ: Μπορειτε να βοηθησετε?
« Απάντηση #1 στις: 21 Μάρ 2009, 05:20:33 μμ »
ΠΡΟΓΡΑΜΜΑ A1
ΣΤΑΘΕΡΕΣ
  Ν=27
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,ΟΡ[Ν],Κ,Τ
  ΠΡΑΓΜΑΤΙΚΕΣ:ΕΜΒ[Ν],Τ1
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'ΔΩΣΕ ΟΡΟΦΟ ΔΙΑΜΕΡΙΣΜΑΤΟΣ'
      ΔΙΑΒΑΣΕ ΟΡ[Ι]
    ΜΕΧΡΙΣ_ΟΤΟΥ ΟΡ[Ι]>=1 ΚΑΙ ΟΡ[Ι]<=5 ΚΑΙ Α_Μ(ΟΡ[Ι])=ΟΡ[Ι]
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'ΔΩΣΕ ΕΜΒΑΔΟΝ ΔΙΑΜΕΡΙΣΜΑΤΟΣ'
      ΔΙΑΒΑΣΕ ΕΜΒ[Ι]
    ΜΕΧΡΙΣ_ΟΤΟΥ ΕΜΒ[Ι]>=20
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ Ν
    ΓΙΑ Κ ΑΠΟ Ν ΜΕΧΡΙ Ι ΜΕ ΒΗΜΑ -1
      ΑΝ ΟΡ[Κ]<ΟΡ[Κ-1] ΤΟΤΕ
        Τ <-- ΟΡ[Κ]
        ΟΡ[Κ] <-- ΟΡ[Κ-1]
        ΟΡ[Κ-1] <-- Τ
        Τ1 <-- ΕΜΒ[Κ]
        ΕΜΒ[Κ] <-- ΕΜΒ[Κ-1]
        ΕΜΒ[Κ-1] <-- Τ1
      ΑΛΛΙΩΣ_ΑΝ ΟΡ[Κ]=ΟΡ[Κ-1] ΤΟΤΕ
        ΑΝ ΕΜΒ[Κ]>ΕΜΒ[Κ-1] ΤΟΤΕ
          Τ1 <-- ΕΜΒ[Κ]
          ΕΜΒ[Κ] <-- ΕΜΒ[Κ-1]
          ΕΜΒ[Κ-1] <-- Τ1
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ 'ΔΙΑΜΕΡΙΣΜΑ',Ι,'ΤΟΥ',ΟΡ[Ι],'ΟΡΟΦΟΥ',ΕΜΒ[Ι],'Τ.Μ'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Νίκος Ξένος
nkxenos@yahoo.gr

Alexis_vti

  • Νέος
  • *
  • Μηνύματα: 6
Απ: Μπορειτε να βοηθησετε?
« Απάντηση #2 στις: 21 Μάρ 2009, 05:25:15 μμ »
Ευχαριστώ πολύ!!!!!! Με βοηθησατε πολυ!