Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Δομή επιλογής => Γ΄ Λυκείου => Εντολή ΑΝ => Μήνυμα ξεκίνησε από: Obelix στις 16 Μάι 2017, 10:02:44 πμ

Τίτλος: Απορία
Αποστολή από: Obelix στις 16 Μάι 2017, 10:02:44 πμ
Σε μία ερώτηση Σ/Λ στο Τετράδιο Μαθητή (κεφ. 8, σελ.81) αναφέρεται:

'Κάθε εντολή ΑΝ πρέπει να έχει την αντίστοιχη εντολή ΤΕΛΟΣ_ΑΝ.'

Το παραπάνω είναι ψευδές μόνο για ψευδογλώσσα;
 
Σε αρκετές εκφωνήσεις έχει υπάρξει ΑΝ χωρίς την αντίστοιχη ΤΕΛΟΣ_ΑΝ, αλλά απ'ότι κατάλαβα η ΓΛΩΣΣΟΜΑΘΕΙΑ δεν δέχεται κάτι τέτοιο.
Άρα το δεχόμαστε ως Σ ή Λ;

Τίτλος: Απ: Απορία
Αποστολή από: Sergio στις 16 Μάι 2017, 12:31:20 μμ
Η πρόταση είναι ΣΩΣΤΗ στη ΓΛΩΣΣΑ, όπως ορίζεται στο κεφάλαιο 8, και ΛΑΘΟΣ στην Ψευδογλώσσα (Κεφ.2)
Τίτλος: Απ: Απορία
Αποστολή από: petrosp13 στις 16 Μάι 2017, 09:48:33 μμ
Ανούσια πρόταση..
Τίτλος: Απ: Απορία
Αποστολή από: Obelix στις 20 Μάι 2017, 12:56:18 μμ
Όντως...ευχαριστώ!
Τίτλος: Απ: Απορία
Αποστολή από: Sergio στις 21 Μάι 2017, 03:35:09 μμ
Ανούσια πρόταση..

Στο κεφάλαιο 2 επιχειρείται μια εισαγωγή των μαθητών στην αλγοριθμική σκέψη, με τρόπο λιγότερο τυπικό αλλά χωρίς να δημιουργεί εμφανή εμπόδια στην "επόμενη" φάση διδασκαλίας, αυτή του "δομημένου προγραμματισμού" με ΓΛΩΣΣΑ.  Όπως το αντιλαμβάνομαι, οι συγγραφείς επέλεξαν να δώσουν (σε αυτό το κεφάλαιο) ΚΑΙ τη μορφή την απλής ΑΝ (χωρίς τελος_αν) για λόγους :
- απλότητας στη σκέψη,
- συνέχειας από προηγούμενες τάξεις ,
- (ίσως) ομοιότητας με κάποιες γλώσσες που μπορεί ήδη να έχουν ασχοληθεί.

Στο κεφάλαιο 8 απ' την άλλη, η ύπαρξη του ΤΕΛΟΣ_ΑΝ σε ΚΑΘΕ εντολή επανάληψης, επιχειρεί να υποστηρίξει το "χαρακτηριστικό" που αναφέρεται για το δομημένο προγραμματισμό "κάθε ενότητα προγράμματος έχει μια είσοδο και μια έξοδο" (που με "κακή" διατύπωση ουσιαστικά εννοεί "ένα ΣΗΜΕΙΟ εισόδου και ένα ΣΗΜΕΙΟ εξόδου")

Επομένως, δεν θεωρώ την πρόταση που συζητάμε ανούσια.
Τίτλος: Απ: Απορία
Αποστολή από: thanasisgr στις 06 Νοέ 2019, 01:23:57 μμ
Στην ψευδογλωσσα επιτρέπεται αυτή η μορφή.
Εγώ λέω στους μαθητές να χρησιμοποιούν την μορφή της αν που έχει το τέλος αν. Είναι πιο δομημένη
Σε μία ερώτηση Σ/Λ στο Τετράδιο Μαθητή (κεφ. 8, σελ.81) αναφέρεται:

'Κάθε εντολή ΑΝ πρέπει να έχει την αντίστοιχη εντολή ΤΕΛΟΣ_ΑΝ.'

Το παραπάνω είναι ψευδές μόνο για ψευδογλώσσα;
 
Σε αρκετές εκφωνήσεις έχει υπάρξει ΑΝ χωρίς την αντίστοιχη ΤΕΛΟΣ_ΑΝ, αλλά απ'ότι κατάλαβα η ΓΛΩΣΣΟΜΑΘΕΙΑ δεν δέχεται κάτι τέτοιο.
Άρα το δεχόμαστε ως Σ ή Λ;
Τίτλος: Απ: Απορία
Αποστολή από: Νίκος Αδαμόπουλος στις 06 Νοέ 2019, 03:58:30 μμ
Στην ψευδογλωσσα επιτρέπεται αυτή η μορφή.
Εγώ λέω στους μαθητές να χρησιμοποιούν την μορφή της αν που έχει το τέλος αν. Είναι πιο δομημένη

Ναι αλλά να γνωρίζουν και την ύπαρξη της άλλης μορφής στην ψευδογλώσσα, γιατί μπορεί να την δουν μπροστά τους σε Θέμα Β, όπως έχει γίνει και στο παρελθόν!
Τίτλος: Απ: Απορία
Αποστολή από: akalest0s στις 07 Νοέ 2019, 01:16:51 πμ
Κάποιοι θα πουν ότι κάνω την τρίχα τριχιά... αλλά μόνο εγώ παρατηρώ στους μαθητές μου να προκαλείται σύγχυση, όταν την μια τους λεω έτσι και την άλλη γιουβέτσι; Με τέτοιες επιλογές, άστοχες κατά τη γνώμη μου, δεν πετυχαίνεις απλότητα, αλλά μεγαλύτερη πολυπλοκότητα. Όταν τους εξηγώ γιατί εκεί το γράφει έτσι, ενώ παρακάτω αλλιώς, με κοιτούν σα χάνοι, σε στυλ "πλάκα μας κάνετε;". Και νομίζω δεν έχουν εντελώς άδικο.
Η απλότητα είναι μεγάλο ζητούμενο αυτού του ταλαιπωρημένου μαθήματος. Δυστυχώς, ο τρόπος που υπάρχει η ψευδογλώσσα, δε προσφέρει τελικά τίποτε ουσιαστικό, παρά αυξάνει την πολυπλοκότητα του πράγματος.
Τίτλος: Απ: Απορία
Αποστολή από: George Eco στις 07 Νοέ 2019, 01:54:28 πμ
Κάποιοι θα πουν ότι κάνω την τρίχα τριχιά... αλλά μόνο εγώ παρατηρώ στους μαθητές μου να προκαλείται σύγχυση, όταν την μια τους λεω έτσι και την άλλη γιουβέτσι; Με τέτοιες επιλογές, άστοχες κατά τη γνώμη μου, δεν πετυχαίνεις απλότητα, αλλά μεγαλύτερη πολυπλοκότητα. Όταν τους εξηγώ γιατί εκεί το γράφει έτσι, ενώ παρακάτω αλλιώς, με κοιτούν σα χάνοι, σε στυλ "πλάκα μας κάνετε;". Και νομίζω δεν έχουν εντελώς άδικο.
Η απλότητα είναι μεγάλο ζητούμενο αυτού του ταλαιπωρημένου μαθήματος. Δυστυχώς, ο τρόπος που υπάρχει η ψευδογλώσσα, δε προσφέρει τελικά τίποτε ουσιαστικό, παρά αυξάνει την πολυπλοκότητα του πράγματος.
ΟΧΙ. Είναι γενικό το φαινόμενο κι έχεις απόλυτο δίκιο. Κι η ΓΛΩΣΣΑ είναι θεωρητική γλώσσα προγραμματισμού που λέγεται "ΓΛΩΣΣΑ" και ομοιάζει με τη ΨΕΥΔΟΓΛΩΣΣΑ, που δε πρέπει να μπερδεύεται με τη ΓΛΩΣΣΑ... βλέπεις που πάει αυτό; Λες και βγήκε από διάλογο κομωδίας.
Και ναι δεν έχουν άδικο. Καθόλου άδικο.