Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Β΄ Λυκείου => Μήνυμα ξεκίνησε από: theoni στις 26 Ιαν 2020, 01:32:41 μμ

Τίτλος: Ερώτηση σε ασκηση
Αποστολή από: theoni στις 26 Ιαν 2020, 01:32:41 μμ
Καλημέρα σας μια ερώτηση πάνω σε μια άσκηση θα ήθελα να κάνω!! Λέει η εκφώνηση να διαβαστεί ένας αριθμός να βρεθεί και να εκτυπωθεί ολογράφως το ακέραιο υπόλοιπο της διαίρεσης του με το 3!! Έχω κολλήσει στο ολογράφως μήπως κάποιος μπορεί να βοηθήσει???
Τίτλος: Απ: Ερώτηση σε ασκηση
Αποστολή από: Λαμπράκης Μανώλης στις 26 Ιαν 2020, 01:45:41 μμ
Καλημέρα ...

υποθέτω, επειδή το υπόλοιπο με το 3 μπορεί να είναι 0,1 ή 2, αρχικά βρίσκεις το υπόλοιπο και στη συνέχεια

ΑΝ υπόλοιπο=0 τότε
   γράψε 'μηδέν'

..........................

Τίτλος: Απ: Ερώτηση σε ασκηση
Αποστολή από: evry στις 26 Ιαν 2020, 02:09:33 μμ
Κώδικας: Python
  1. Διάβασε α
  2. υπόλοιπο[0]="μηδέν"
  3. υπόλοιπο[1]="ένα"
  4. υπόλοιπο[2]="δύο"
  5. Γράψε υπόλοιπο[ α mod 3 ]
Τίτλος: Απ: Ερώτηση σε ασκηση
Αποστολή από: theoni στις 26 Ιαν 2020, 04:49:21 μμ
Ευχαριστώ !!!και μια άλλη άσκηση που δεν μπορώ να ολοκληρώσω.Να διαβαστεί η ώρα σε 24ωρη μορφή σαν ένας τετραψήφιος  αριθμός,όπως για παράδειγμα 1452,να βρεθεί αν παριστάνει σωστή ένδειξη χρόνου και αν ναι να εμφανιστεί η ώρα στην αντίστοιχη 12ωρη μορφή της για παράδειγμα 02:52 μ.μ.
Διάβασε Χ
Α<--χ div 100
Β<--χ mod 100
AΝ χ≤24 καιβ<60 τοτε
     Γράψε 'εγκυρη ώρα ',χ-12 και β
Αλλιώς
     Γράψε 'οχι εγκυρη'
Τέλος αν
Η ερώτηση μου είναι η εξής τι πρέπει να αλλάξω ώστε να εμφανίζει μ.μ και π.μ???
Τίτλος: Απ: Ερώτηση σε ασκηση
Αποστολή από: evry στις 26 Ιαν 2020, 05:00:55 μμ
To 24:00 δεν είναι έγκυρη ώρα!! :D
Τίτλος: Απ: Ερώτηση σε ασκηση
Αποστολή από: theoni στις 26 Ιαν 2020, 06:09:44 μμ
Έχω κολλήσει δεν με βοηθάει αυτό να καταλάβω
Τίτλος: Απ: Ερώτηση σε ασκηση
Αποστολή από: Λαμπράκης Μανώλης στις 26 Ιαν 2020, 06:19:20 μμ
υποθέτω αυτό που λέει  ο Ευρυπίδης είναι πως η τελευταία "έγκυρη ώρα" είναι το 23:59 ...  επίσης το χ-12 νομίζω δεν είναι σωστό, αν δώσεις πχ 0550 θα δώσει αρνητικό αποτέλεσμα... θα πρέπει να βάλεις επιπλέον δομή επιλογής για να το τσεκάρεις αυτό .. για το πμ και μμ επίσης δομή επιλογής ... πχ μέχρι τις 11 είναι πμ και μετά είναι μμ  (αν έχω καταλάβει σωστά τα δεδομένα)
Τίτλος: Απ: Ερώτηση σε ασκηση
Αποστολή από: theoni στις 26 Ιαν 2020, 06:21:36 μμ
Μήπως μπορώ να έχω κι ενδεικτική απάντηση???
Τίτλος: Απ: Ερώτηση σε ασκηση
Αποστολή από: Λαμπράκης Μανώλης στις 26 Ιαν 2020, 06:31:49 μμ
Διάβασε κ
Αν κ>=0001 και κ<=2359 τότε
    ώρες<--κdiv100
    λεπτά<-- κmod100
    Αν ώρες<=11 τότε
       Γράψε ώρες, ':', λεπτά , 'πμ'
    Αλλιώς 
       Αν ώρες = 12 τότε ! επειδή το 12 δεν θέλει -12 αλλά είναι μμ
               Γράψε ώρες, ':', λεπτά , 'μμ'
       Αλλιώς
               ΓΡΑΨΕ ώρες-12, ':', λεπτά , 'μμ'
       Τέλος_αν
     Τέλος_αν
Αλλιώς
  γράψε 'λάθος ώρα'
τέλος_αν

κάπως έτσι, ετοιμάζομαι για το Ιωνικός - ΑΡΗΣ (Αριανάρα μάχη παραμονής ) και το γράφω στο πόδι   :angel: >:D :laugh: :police:
Τίτλος: Απ: Ερώτηση σε ασκηση
Αποστολή από: Λαμπράκης Μανώλης στις 26 Ιαν 2020, 06:35:43 μμ
Βασικά μπορείς να βάλεις και ένα αν κ=0000 τότε γράψε '00:00'

 :angel: >:D :laugh: :police:
Τίτλος: Απ: Ερώτηση σε ασκηση
Αποστολή από: petrosp13 στις 27 Ιαν 2020, 10:41:49 πμ
Κώδικας: Python
  1. Διάβασε α
  2. υπόλοιπο[0]="μηδέν"
  3. υπόλοιπο[1]="ένα"
  4. υπόλοιπο[2]="δύο"
  5. Γράψε υπόλοιπο[ α mod 3 ]

Έχουμε δομή Επίλεξε κι εσύ γράφεις αυτό;;
 :D :D :D

Διάβασε α
Επίλεξε α mod 3
Περίπτωση 0
Γράψε 'Μηδέν'
...

 :angel: :angel: