Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γ΄ Λυκείου => Μήνυμα ξεκίνησε από: ΣΧΟΙΝΑΣ ΚΩΣΤΑΣ στις 02 Σεπ 2019, 11:46:47 μμ

Τίτλος: Η αρχικοποίηση του ΠΛ_ΜΑΧ αρχικοποιείται στο 0 ή στο 1
Αποστολή από: ΣΧΟΙΝΑΣ ΚΩΣΤΑΣ στις 02 Σεπ 2019, 11:46:47 μμ
   ΠΡΟΓΡΑΜΜΑ  ΕΥΡΕΣΗ_ΣΥΧΝΟΤΗΤΑΣ_ΜΕΓΙΣΤΟΥ

Να γράψετε πρόγραμμα το οποίο χωρίς χρήση πίνακα θα διαβάζει 5 θετικούς ακέραιους  αριθμούς και θα υπολογίζει  τη συχνότητα  του max



ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:I ,X,ΜΑΧ ,ΠΛ_ΜΑΧ
ΑΡΧΗ                               

  ΜΑΧ ← -1
  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ   5
    ΔΙΑΒΑΣΕ   X
    ΑΝ X>   ΜΑΧ  ΤΟΤΕ
      ΜΑΧ  ←  X           
      ΠΛ_ΜΑΧ  ←1   
    ΑΛΛΙΩΣ
      ΑΝ ΜΑΧ=X  ΤΟΤΕ
        ΠΛ_ΜΑΧ ←ΠΛ_ΜΑΧ +1
      ΤΕΛΟΣ_ΑΝ       
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ   ΜΑΧ , ' ΜΕ ΣΥΧΝΟΤΗΤΑ',   ΠΛ_ΜΑΧ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ   

ΔΥΟ     ΕΡΩΤΗΜΑΤΑ
                   
Η παραπάνω λύση είναι σωστή; Επίσης σε ποιες εκφωνήσεις ασκήσεων το πλήθος  εμφάνισης της μέγιστης τιμής max αρχικοποιείται στο 0 και όχι στο 1
Τίτλος: Απ: Η αρχικοποίηση του ΠΛ_ΜΑΧ αρχικοποιείται στο 0 ή στο 1
Αποστολή από: Λαμπράκης Μανώλης στις 03 Σεπ 2019, 08:48:25 πμ
Καλημερα..

1) αν δεν μου ξεφεύγει κάτι, σωστή είναι η λύση
2) δεν ξέρω αν κατάλαβα σωστά το ερωτημα με την αρχικοποίηση, αλλά στην συγκεκριμένη άσκηση δεν χρειαζεται καν αρχικοποίηση έξω από την επανάληψη... Από Ν αριθμούς θα έχουμε σίγουρα ενα αριθμό που είναι μεγαλύτερος... Κάθε φορά που βρίσκουμε νέο μέγιστο αρχικοποιουμε στο 1, αν ειναι ίσος με το μέγιστο αυξάνουμε 1...μια χαρά μου φαινεται..
Τίτλος: Απ: Η αρχικοποίηση του ΠΛ_ΜΑΧ αρχικοποιείται στο 0 ή στο 1
Αποστολή από: bugman στις 03 Σεπ 2019, 09:59:40 πμ
Επειδή η άσκηση λέει για θετικούς αριθμούς, χωρίς έλεγχο, με αρχικοποίηση με αρνητικό για ΜΑΧ, είναι εντάξει.
Αν θέλαμε 20 οποιουσδήποτε αριθμούς, θα ξεχωρίσαμε την εικοσάδα σε 1 και 19. Το πρώτο θα το διαβάζαμε στο ΜΑΧ και θα βάζαμε ΠΛ_ΜΑΧ το 1. Μετά θα κάναμε την επανάληψη για τα υπόλοιπα εισαγόμενα στοιχεία.
Τίτλος: Απ: Η αρχικοποίηση του ΠΛ_ΜΑΧ αρχικοποιείται στο 0 ή στο 1
Αποστολή από: Καρκαμάνης Γεώργιος στις 05 Σεπ 2019, 12:09:43 πμ
Ο κώδικας εύρεσης του πλήθους του μεγαλύτερου δουλεύει σωστά, δεν έχει πρόβλημα