Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γ΄ Λυκείου => Θεωρία => Μήνυμα ξεκίνησε από: ds_10 στις 09 Ιαν 2012, 05:02:30 μμ

Τίτλος: εμφωλευμενη ΑΝ
Αποστολή από: ds_10 στις 09 Ιαν 2012, 05:02:30 μμ
αν εχω δυο συνθηκες, με υποσυνθήκες Π.Χ αν εχω τις α,χ,ψ :
Α τρόπος
Αν α>5 ΚΑΙ χ=5 τοτε
       εντολή
αλλιώς αν α>5 ΚΑΙ ψ=5 τοτε
       εντολή 2
Τέλος_αν


Β τρόπος
Αν Α>5 τότε
       αν χ=5 τότε
             εντολή
       αλλιώς_αν ψ=5 τότε
             εντολή 2
        τέλος_αν
Τέλος_αν

σε τέτοιου τύπου ασκήσεις είναι λάθος ο α τρόπος?
Τίτλος: Απ: εμφωλευμενη ΑΝ
Αποστολή από: Laertis στις 09 Ιαν 2012, 05:07:05 μμ
Κατηγορηματικά ΟΧΙ
Τίτλος: Απ: εμφωλευμενη ΑΝ
Αποστολή από: Νίκος Αδαμόπουλος στις 09 Ιαν 2012, 09:28:31 μμ
Επίσης, θα μπορούσαν αποτελούν ασκήσεις οι αντίστοιχες μετατροπές: εμφωλευμένη επιλογή --> πολλαπλή επιλογή, πολλαπλή επιλογή  --> εμφωλευμένη επιλογή
Τίτλος: Απ: εμφωλευμενη ΑΝ
Αποστολή από: gpapargi στις 09 Ιαν 2012, 11:15:05 μμ
Από που προκύπτει όμως αυτή η ανασφάλεια; Εφόσον ο κώδικας είναι σωστός γιατί να σου κόψουν βαθμό;
Τίτλος: Απ: εμφωλευμενη ΑΝ
Αποστολή από: Καρκαμάνης Γεώργιος στις 12 Ιαν 2012, 10:40:10 πμ
Όπως αναφέρει ο Γιώργος, γιατί να υπάρχει τέτοια ανασφάλεια;
Κανέις δεν κόβει τόσο έυκολα μονάδες ή ελέγχει τόσο επιπόλαια ένα γραπτό.

Νομίζω ότι έχει δημιουργηθεί, ένας  μύθος  γύρω από τη βαθμολόγηση (ο μύθος της αυστηρής απάνθρωπης, ανελέητης βαθμολόγησης) που δεν είναι πραγματικός