Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γ΄ Λυκείου => Μήνυμα ξεκίνησε από: alkisg στις 19 Απρ 2006, 08:27:40 πμ

Τίτλος: Με [code=ΓΛΩΣΣΑ]Πρόγραμμα ...[/code] χρωματίζεται ο κώδικας
Αποστολή από: alkisg στις 19 Απρ 2006, 08:27:40 πμ
Όταν στέλνετε κάποιον κώδικα προγράμματος, για να χρωματίζεται αυτόματα μπορείτε να τον εσωκλείετε σε
[cοde=ΓΛΩΣΣΑ]ΠΡΟΓΡΑΜΜΑ όνομα...[/cοde]

Αν στέλνετε αλγόριθμο, μπορείτε να χρησιμοποιείτε
[cοde=Ψευδογλώσσα]Αλγόριθμος όνομα...[/cοde]

Αν όμως στέλνετε ολοκληρωμένη άσκηση και όχι τμήμα κώδικα, τότε καλύτερα να το στέλνετε σαν συνημμένο, όπως αναφέρεται σε αυτό το θέμα (https://alkisg.mysch.gr/steki/index.php?topic=900).

Προσοχή, για να φαίνονται τα παραπάνω έβαλα ελληνικό όμικρον στο code οπότε μην κάνετε αντιγραφή-επικόλληση.

Παραδείγματα:
Κώδικας: ΓΛΩΣΣΑ
  1. !Το παράδειγμα της σελίδας 106 του τετραδίου μαθητή.
  2. ΠΡΟΓΡΑΜΜΑ ΠύργοιΤουΑνόι
  3. ΣΤΑΘΕΡΕΣ
  4.   Στύλος1 = 'Α'
  5.   Στύλος2 = 'Β'
  6.   Στύλος3 = 'Γ'
  7. ΜΕΤΑΒΛΗΤΕΣ
  8.   ΑΚΕΡΑΙΕΣ: Ν
  9. ΑΡΧΗ
  10.   ΓΡΑΨΕ 'Δώσε τον αριθμό των δίσκων:  '
  11.   ΔΙΑΒΑΣΕ Ν
  12.   ΚΑΛΕΣΕ Μετακίνησε(Ν, Στύλος1, Στύλος2, Στύλος3)
  13. ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
  14.  
  15. ΔΙΑΔΙΚΑΣΙΑ Μετακίνησε(Ν, ΣτύλοςΑ, ΣτύλοςΒ, ΣτύλοςΓ)
  16. ΜΕΤΑΒΛΗΤΕΣ
  17.   ΑΚΕΡΑΙΕΣ: Ν
  18.   ΧΑΡΑΚΤΗΡΕΣ: ΣτύλοςΑ, ΣτύλοςΒ, ΣτύλοςΓ
  19. ΑΡΧΗ
  20.   ΑΝ Ν = 1 ΤΟΤΕ
  21.     ΓΡΑΨΕ 'Μετακίνησε από τον ', ΣτύλοςΑ, ' στον ', ΣτύλοςΓ
  22.   ΑΛΛΙΩΣ
  23.     ΚΑΛΕΣΕ Μετακίνησε(Ν - 1, ΣτύλοςΑ, ΣτύλοςΓ, ΣτύλοςΒ)
  24.     ΓΡΑΨΕ 'Μετακίνησε από τον ', ΣτύλοςΑ, ' στον ', ΣτύλοςΓ
  25.     ΚΑΛΕΣΕ Μετακίνησε(Ν - 1, ΣτύλοςΒ, ΣτύλοςΑ, ΣτύλοςΓ)
  26.   ΤΕΛΟΣ_ΑΝ
  27. ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Κώδικας: Ψευδογλώσσα
  1. Αλγόριθμος Sequential_Search
  2. !Σελίδα 64 του βιβλίου μαθητή
  3. Δεδομένα // n, table, key //
  4. done ψευδής
  5. position 0
  6. i 1
  7. Όσο (done = ψευδής) και (i <= n) επανάλαβε
  8.   Αν table[i] = key τότε
  9.     done αληθής
  10.     position i
  11.   αλλιώς
  12.     i i + 1
  13.   Τέλος_αν
  14. τέλος_επανάληψης
  15. Αποτελέσματα // done, position //
  16. Τέλος Sequential_Search
Τίτλος: Απ: Με [code=ΓΛΩΣΣΑ]Πρόγραμμα ...[/code] χρωματίζεται ο κώδικας
Αποστολή από: Vangelis στις 21 Απρ 2006, 01:28:22 μμ
Άλκη το πλαίσιο πως το φτιάχνουμε π.χ όταν θέλουμε να εμφανίζουμε ένα τμήμα απο την απάντηση ενός άλλου συναδέλφου;
 
Τίτλος: Απ: Με [code=ΓΛΩΣΣΑ]Πρόγραμμα ...[/code] χρωματίζεται ο κώδικας
Αποστολή από: alkisg στις 21 Απρ 2006, 02:36:57 μμ
Τα γράφω με τη σειρά που τα κάνω τώρα που σου απαντάω:
1) Πατάω το κουμπί Προεπισκόπηση, για με βγάλει στον editor κανονικής απάντησης, όχι στης γρήγορης
2) Στη νέα σελίδα που έβγαλε, κάτω από το κουτί που γράφω, υπάρχουν όλα τα προηγούμενα μηνύματα, και πάνω-δεξιά τους ένα link για "Εισαγωγή παράθεσης". Πατάω αυτό από το δικό σου μήνυμα.
3) Μου έβγαλε αυτόματα τα εξής:
[quοte author=Vangelis link=topic=405.msg2635#msg2635 date=1145615302]
Άλκη το πλαίσιο πως το φτιάχνουμε π.χ όταν θέλουμε να εμφανίζουμε ένα τμήμα απο την απάντηση ενός άλλου συναδέλφου;
[/quοte]
Αυτό θα είναι το κουτί παράθεσης.
4) Αν δε θέλω όλο το κείμενό σου, απλά σβήνω και κρατάω το κομμάτι που θέλω, π.χ. σβήνω το όνομά μου από την απάντησή σου:
το πλαίσιο πως το φτιάχνουμε π.χ όταν θέλουμε να εμφανίζουμε ένα τμήμα απο την απάντηση ενός άλλου συναδέλφου;
Τίτλος: Απ: Με [code=ΓΛΩΣΣΑ]Πρόγραμμα ...[/code] χρωματίζεται ο κώδικας
Αποστολή από: filippos στις 09 Μάι 2006, 11:43:24 μμ
Άλκη,

μήπως θα ήταν πιό "σωστό" να λέμε:
[cοde=ΨΕΥΔΟΓΛΩΣΣΑ] αντι του
[cοde=ΑΛΓΟΡΙΘΜΟΣ] ;;

Εξ' άλλου και στις δύο "περιπτώσεις" αλγόριθμο ΚΩΔΙΚΟποιούμε.. τη μία σε ψευδογλώσσα και την άλλη σε ΓΛΩΣΣΑ

Τι λές;
Τίτλος: Απ: Με [code=ΓΛΩΣΣΑ]Πρόγραμμα ...[/code] χρωματίζεται ο κώδικας
Αποστολή από: alkisg στις 10 Μάι 2006, 12:45:44 μμ
Δίκιο έχεις... θα το αλλάξω κατά πάσα πιθανότητα μέσα στο ΣΚ.

Merci!

edit: Έτοιμο!
Κάλλιο αργά παρά ποτέ! :^)
Τίτλος: Απ: Με [code=ΓΛΩΣΣΑ]Πρόγραμμα ...[/code] χρωματίζεται ο κώδικας
Αποστολή από: alkisg στις 13 Απρ 2020, 11:15:42 πμ
Ξαναέφτιαξα το mod και δουλεύει πάλι ο χρωματισμός των code=ΓΛΩΣΣΑ και code=Ψευδογλώσσα, αν και έχει λίγα προβληματάκια (case sensitive κλπ), θα το ξανακοιτάξω στην επόμενη έκδοση του SMF που θα έχει και διάφορες άλλες αλλαγές.

Κώδικας: ΓΛΩΣΣΑ
  1. ΠΡΟΓΡΑΜΜΑ Χρωματισμός
  2. ΑΡΧΗ
  3.   ΓΡΑΨΕ "Ναι! Δουλεύει!"
  4. ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Τίτλος: Απ: Με [code=ΓΛΩΣΣΑ]Πρόγραμμα ...[/code] χρωματίζεται ο κώδικας
Αποστολή από: evry στις 13 Απρ 2020, 11:23:45 πμ
Για να το δοκιμάσω να δω  :D

Κώδικας: ΓΛΩΣΣΑ
  1. Κ <- Σ <- 0
  2. ΔΙΑΒΑΣΕ Ν
  3. ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ N
  4.    ΔΙΑΒΑΣΕ Α
  5.    ΑΝ Α=0 ΤΟΤΕ
  6.         Ι <- 1001
  7.    ΤΕΛΟΣ_ΑΝ
  8.    Σ <- Σ + Α
  9.    Κ <- Κ + 1
  10. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  11. ΑΝ Κ=0 ΤΟΤΕ
  12.    ΓΡΑΨΕ 'ΔΕΝ ΕΔΩΣΕΣ ΑΡΙΘΜΟΥΣ'
  13. ΑΛΛΙΩΣ
  14.    ΜΟ <- Σ/Κ
  15.   ΓΡΑΨΕ 'ΜΟ = ', ΜΟ
  16. ΤΕΛΟΣ_ΑΝ

Μια χαρά δουλεύει  :)
Άλκη υποστηρίζει και R ?
Τίτλος: Απ: Με [code=ΓΛΩΣΣΑ]Πρόγραμμα ...[/code] χρωματίζεται ο κώδικας
Αποστολή από: alkisg στις 13 Απρ 2020, 12:11:18 μμ
Ναι, με code=rsplus:

Κώδικας: R / S+
  1. convert_kelvin_to_celsius <- function(temp) {
  2.   celsius <- temp - 273.15
  3.   return(celsius)
  4. }
  5.  
  6. #absolute zero in Celsius
  7. convert_kelvin_to_celsius(0)
Τίτλος: Απ: Με [code=ΓΛΩΣΣΑ]Πρόγραμμα ...[/code] χρωματίζεται ο κώδικας
Αποστολή από: evry στις 13 Απρ 2020, 12:23:37 μμ
Δουλεύει...
Κώδικας: R / S+
  1. i <- 0 ; S <- 0
  2.    if (i==10)
  3.       break
  4.    A <- readline("A = ")
  5.    if (A == "ΤΕΛΟΣ")
  6.       break
  7.    N <- as.numeric(readline("N = "))
  8.    S <- S + N
  9.    if (S > 1000)
  10.       break
  11.    print("keep going")
  12.    i <- i + 1
  13. }