Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Δομή επανάληψης => Γ΄ Λυκείου => Εντολή ΓΙΑ...ΑΠΟ...ΜΕΧΡΙ => Μήνυμα ξεκίνησε από: dozb στις 29 Μάρ 2006, 04:00:36 μμ

Τίτλος: Εμφωλευμένες και πίνακας τιμών
Αποστολή από: dozb στις 29 Μάρ 2006, 04:00:36 μμ
Καλησπέρα σας...
Κι κεί που πήγαινα με τη σιγουριά του νικητή.....είδα κάτι λύσεις ασκήσεων πίνακα τιμών της εντολής ΓΙΑ και έμεινα...

Στην παρακάτω επανάληψη π.χ.

ΓΙΑ i από 1 μέχρι 3 με_βήμα 1
      α<- i +5

ΠΟΙΑ θα είναι η σωστή απάντηση?

Αρχική  : i =1
1η :  α=6, i=2 
2η :  α=7,i=3
3η :  α=8, i=4    (σύμφωνα με τα διαγράμματα ροής ΤΟΥ ΒΙΒΛΙΟΥ βεβαίως βεβαίως,  αυτή θεωρώ σα σωστή).

ή

1η :  α=6, i=1 
2η :  α=7,i=2
3η :  α=8, i=3

Και δεύτερη ερώτηση :όταν η άσκηση ζητάει "εμφωλευμένη επιλογή", πρέπει να αλλαχθούν όλες οι επιλογές σε εμφωλευμένες ή αρκεί να το δείξουν μία φορά και να συνεχίσουν με ... π.χ. πολλαπλή επιλογή , ή ακόμα και με πολλές  απλές;
(Εννοείται ότι

Τίτλος: Απ: Εμφωλευμένες και πίνακας τιμών
Αποστολή από: Christos στις 29 Μάρ 2006, 04:43:28 μμ
Γεια σου.

Ή εντολή επανάληψης Για..από...μέχρι  πραγματοποιεί την μεταβολή του μετρητή πάντα σαν τελευταία εντολή, δηλαδή :

Για i από 1 μέχρι 12 με_βήμα 2
χ<-- Χ+2
Τέλος_επανάληψης (i<--i+2)

Κατά συνέπεια, στην άσκηση που προανέφερες :

ΓΙΑ i από 1 μέχρι 3 με_βήμα 1
      α<- i +5
Τέλος_επανάληψης (i<--i+1)

η εκτέλεση έχει ως εξής :  1)i=1 και α=6 (Στο τέλος της επανάληψης i=2)
                                         2)i=2 και α=7 (Στο τέλος της επανάληψης i=3)
                                         3)i=3 και α=8 (Στο τέλος της επανάληψης i=4)

Τι εννοείς οτι η άσκηση ζητάει <<εμφωλευμένη επιλογή>> και πρέπει να αλλαχθούν όλες οι επιλογές ;
Τίτλος: Απ: Εμφωλευμένες και πίνακας τιμών
Αποστολή από: dozb στις 29 Μάρ 2006, 06:29:28 μμ
Αρα λές ότι η σωστή απάντηση στην ερώτηση: "Ποια είναι η τιμή του i στην πρώτη επανάληψη?" είναι
i = 1 κι όχι i = 2, έτσι?

Εμφωλευμένες εννοώ πχ στην περίπτωση που ζητούν να αλλαχτεί το παρακάτω σε εμφωλευμένη επιλογή
Επέλεξε χ
Περίπτωση < 2
ΓΡΑΨΕ 'ΜΕΤΡΙΑ'
Περίπτωση <4
ΓΡΑΨΕ 'ΚΑΛΑ'
Περίπτωση < 6
ΓΡΑΨΕ 'ΠΟΛΥ  ΚΑΛΑ'
Περίπτωση <10
ΓΡΑΨΕ 'ΑΡΙΣΤΑ'
Περίπτωση αλλιώς
ΓΡΑΨΕ 'ΜΠΡΑΒΟ'

αυτό μπορεί να γίνει με εμφωλευμένη
Αν χ<2 Τοτε
     ΓΡΑΨΕ 'ΜΕΤΡΙΑ'
Αλλιώς
     Αν χ<4 Τοτε
         ΓΡΑΨΕ 'ΚΑΛΑ'
    Αλλιώς_αν  χ<6 Τοτε
         ΓΡΑΨΕ 'ΠΟΛΥ ΚΑΛΑ'
.
.
.
.
    Τέλος_Αν
Τέλος_Αν

ή ΠΡΕΠΕΙ ΝΑ ΤΑ ΑΛΛΑΞΟΥΜΕ ΟΛΑ ΣΕ ΕΜΦΩΛΕΥΜΕΝΑ ΑΝ????


Ευχαριστώ πολύ
Τίτλος: Απ: Εμφωλευμένες και πίνακας τιμών
Αποστολή από: Christos στις 29 Μάρ 2006, 09:15:59 μμ
Στην πρώτη επανάληψη το i ξεκινάει από 1 και στο τέλος γίνεται 2.
 
Με εμφωλευμένη επιλογή το τμήμα κώδικα που δίνεις θα γινόταν :

Αν χ<2 τότε
     ΓΡΑΨΕ 'ΜΕΤΡΙΑ'
Αλλιώς
     Αν χ<4 τότε
         ΓΡΑΨΕ 'ΚΑΛΑ'
    Αλλιώς
         Αν χ<6 τότε
         ΓΡΑΨΕ 'ΠΟΛΥ ΚΑΛΑ'
         Αλλιώς
                Αν χ<10 τότε
                ΓΡΑΨΕ 'ΑΡΙΣΤΑ'
                Αλλιώς
                ΓΡΑΨΕ 'ΜΠΡΑΒΟ'
                Τέλος_αν
       Τέλος_αν
    Τέλος_Αν
Τέλος_Αν

Τίτλος: Απ: Εμφωλευμένες και πίνακας τιμών
Αποστολή από: dozb στις 29 Μάρ 2006, 10:02:51 μμ
Οκ, για το δεύτερο κι ευχαριστώ , αλλά για το πρώτο δε μου απαντάς τελικά.
Η απάντηση είναι 1 ή 2? . Δεν μπορείς να βάλεις και τα δύο στον πίνακα τιμών!
Τίτλος: Απ: Εμφωλευμένες και πίνακας τιμών
Αποστολή από: Christos στις 30 Μάρ 2006, 12:08:18 πμ
To i είναι 1 στην πρώτη επανάληψη, αν εννοείς αυτό. Όταν ξεκινά η δεύτερη είναι 2 και όταν ξεκινά η τρίτη είναι 3.
Τίτλος: Απ: Εμφωλευμένες και πίνακας τιμών
Αποστολή από: nekis στις 30 Μάρ 2006, 08:49:42 πμ
ΠΡΟΣΟΧΗ !!!
ΜΕΓΑΛΥΤΕΡΗ ΠΑΤΑΤΑ ΣΕ ΑΣΚΗΣΗ ΔΕΝ ΘΑ ΜΠΟΡΟΥΣΕΣ ΝΑ ΔΕΙΣ
ΕΔΩ ΛΕΜΕ ΝΑ ΑΠΟΦΕΥΓΟΥΜΕ ΤΗ ΜΕΤΑΒΟΛΗ ΤΟΥ ΜΕΤΡΗΤΗ ΣΕ ΕΠΑΝΑΛΗΨΗ ΓΙΑ  ΟΠΩΣ Ο ΔΙΑΒΟΛΟΣ ΤΟ ΛΙΒΑΝΙ ΚΑΙ ΚΑΠΟΙΟΙ ... ΕΞΥΠΝΟΙ ΒΑΖΟΥΝ ΤΕΤΟΙΕΣ ΑΣΚΗΣΕΙΣ!!!
ΑΠΟΚΛΕΙΕΤΑΙ ΝΑ ΔΕΙΣ ΤΕΤΟΙΟ ΘΕΜΑ ΣΤΙΣ ΕΞΕΤΑΣΕΙΣ!!
(ΣΥΓΝΩΜΗ ΓΙΑ ΤΑ ΚΕΦΑΛΑΙΑ, ΑΛΛΑ ... ΕΧΑΣΑ ΤΡΙΧΕΣ ΑΠΟ ΤΟ ΚΕΦΑΛΙ ΜΟΥ)
ΝΚυριακου
Τίτλος: Απ: Εμφωλευμένες και πίνακας τιμών
Αποστολή από: xaidi στις 30 Μάρ 2006, 09:37:53 πμ
"...ΛΕΜΕ ΝΑ ΑΠΟΦΕΥΓΟΥΜΕ ΤΗ ΜΕΤΑΒΟΛΗ ΤΟΥ ΜΕΤΡΗΤΗ ΣΕ ΕΠΑΝΑΛΗΨΗ ..." δεν νομίζω ότι μεταβάλεται η τιμή του μετρητή ...εδώ χρησιμοποιούμε την τρέχουσα τιμή για κάτι άλλο
Τίτλος: Απ: Εμφωλευμένες και πίνακας τιμών
Αποστολή από: Christos στις 30 Μάρ 2006, 10:00:16 πμ
Τι σημαίνει <<ΕΔΩ ΛΕΜΕ ΝΑ ΑΠΟΦΕΥΓΟΥΜΕ ΤΗ ΜΕΤΑΒΟΛΗ ΤΟΥ ΜΕΤΡΗΤΗ ΣΕ ΕΠΑΝΑΛΗΨΗ ΓΙΑ  >> ;

Δηλαδή ο μετρητής σε μία Για..από..μέχρι δεν μεταβάλλεται ποτέ ; Μάλλον εννοείς να μην μεταβάλλεται το βήμα του μετρητή γιατί αλλιώς δεν έχει νόημα. Δεν μπορεί ο μετρητής να μένει σταθερός. Το βήμα πρέπει να είναι σταθερό όμως.

Σαν θέμα έχουμε δει στις εξετάσεις παρόμοιο.

π.χ. Το 2005

Σ<--0
Για i από 1 μέχρι 100 με_βήμα 2
Σ<--Σ+i
Τέλος_επανάληψης
Εμφάνισε Σ

Να μετατραπεί σε Όσο και Αρχή_επανάληψης
(Το link είναι http://www.ypepth.gr/themata/them_plir_kat_c_hmer_no_0605.pdf)

Πως θα το μετατρέψεις αν δεν θεωρείς δεδομένη την  μεταβολή του μετρητή ; (i<--i+2)
Τίτλος: Απ: Εμφωλευμένες και πίνακας τιμών
Αποστολή από: xaidi στις 30 Μάρ 2006, 10:22:21 πμ
Αυτό εννώ ότι στο παράδειγμα εντός της επανάληψης δεν μεταβάλεται η τρέχουσα τιμή του μετρητή, όπως διαμορφώνεται από το βήμα. αυτά που έγραψα είναι σχόλια στην παραπάνω απάντηση εντός ""
Τίτλος: Απ: Εμφωλευμένες και πίνακας τιμών
Αποστολή από: andreas_p στις 30 Μάρ 2006, 01:05:17 μμ
το λάθος

Αρχική  : i =1
1η :  α=6, i=2  
2η :  α=7,i=3
3η :  α=8, i=4    (σύμφωνα με τα διαγράμματα ροής ΤΟΥ ΒΙΒΛΙΟΥ βεβαίως βεβαίως,  αυτή θεωρώ σα σωστή).

και

το σωστό

1η :  α=6, i=1  
2η :  α=7,i=2
3η :  α=8, i=3
Τίτλος: Απ: Εμφωλευμένες και πίνακας τιμών
Αποστολή από: nekis στις 30 Μάρ 2006, 01:10:21 μμ
Συγνώμη απο βιασύνη νόμιζα ι <- ι +2
Λάθος ολκής!!!!
 
Τίτλος: Απ: Εμφωλευμένες και πίνακας τιμών
Αποστολή από: andreas_p στις 30 Μάρ 2006, 01:18:16 μμ
Σαν θέμα έχουμε δει στις εξετάσεις παρόμοιο.

π.χ. Το 2005

Σ<--0
Για i από 1 μέχρι 100 με_βήμα 2
Σ<--Σ+i
Τέλος_επανάληψης
Εμφάνισε Σ

Να μετατραπεί σε Όσο και Αρχή_επανάληψης

Πώς θα το μετατρέψεις ;

Σ<--0
i <- 1
Όσο i<=100 επανάλαβε
  Σ<--Σ+i
  i <- i+2
Τέλος_επανάληψης
Εμφάνισε Σ

Σ<--0
i <- 1
Αρχή_επανάληψης
  Σ<--Σ+i
  i <- i+2
Μέχρις_ότου i > 100
Εμφάνισε Σ




Τίτλος: Απ: Εμφωλευμένες και πίνακας τιμών
Αποστολή από: dozb στις 01 Απρ 2006, 07:51:08 μμ
Ευχαριστώ παιδιά