Το Στέκι των Πληροφορικών

Γενικά => Γενικά Παιδαγωγικά, Επιστημονικά και Τεχνικά Θέματα => Παιδαγωγικά Θέματα => Μήνυμα ξεκίνησε από: Stavros στις 03 Σεπ 2007, 03:50:50 μμ

Τίτλος: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 03 Σεπ 2007, 03:50:50 μμ
Τόσο καιρό που ασχολούμαι με τον προγραμματισμό (στα 3 χρόνια του Γυμνασίου) βλέπω ότι μου αρέσει πολύ όμως ασχολούμαι μόνο με την ψευδογλώσσα. Δεν λέω, ενδιαφέρον είναι αλλά....
Φέτος θα μπορούσα να ασχοληθώ με μία γλώσσα προγραμματισμού που ήθελα. Τα παράτησα όμως αφού σκέφτηκα ότι για να μπεις σε ένα πανεπιστήμιο δεν χρειάζεται γλώσσα προγραμματισμού αλλά μόνο ψευδογλώσσα που μπορώ να πω ότι ξέρω αρκετά.(μπορώ να λύσω τις ασκήσεις των πανελληνίων αλλά από θεωρία...... σχεδόν τίποτα, αλλά θα τα μάθω αργότερα, έχω χρόνο.)
Καλά έκανα που δεν ασχολούμαι με γλώσσα προγραμματισμού;;;;;;;
Πάντως καλό θα ήταν να είχα κάποια ιδέα (εδώ που τα λέμε έχω αφού έχω τη Visual Basic)

Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: pgrontas στις 03 Σεπ 2007, 04:37:36 μμ
Αν κατάλαβα καλά τώρα θα πας στην Α' Λυκείου.

Ίσως δεν είχες το κατάλληλο κίνητρο για να ασχοληθείς με μια γλώσσα προγραμματισμού. Κατά την γνώμη μου καλό θα ήταν αν ενδιαφέρεσαι  να σπουδάσεις Πληροφορική  να δεις και πώς είναι οι πραγματικές γλώσσες προγραμματισμού. Έπιπλέον έτσι εκτός των άλλων αποκτάς και ένα 'εμπορεύσιμο' προσόν.

Στην περίπτωση που ξέρεις καλά Αγγλικά  θα σου πρότεινα να ασχοληθείς με το ΧΝΑ, το οποίο είναι ένα 'πακέτο' της Microsoft που σκοπεύει να κάνει τον προγραμματισμό παιχνιδιών εύκολο ακόμα και για αρχάριους προγραμματιστές. To αν το καταφέρνει είναι αμφίβολο, κατά την γνώμη μου, οπότε σε προειδοποιώ ότι θα έχεις να μάθεις πολλά και θα πρέπει να ρίξεις πολύ χρόνο σε αυτό.

Χρησιμοποιεί την γλώσσα C#, μια εξέλιξη της C, η οποία δεν είναι και το πιο εύκολο πράγμα για μαθητές. Όλα τα εργαλεία που χρειάζονται για να φτιάξεις παιχνίδια είναι δωρεάν. Τα παιχνίδια παίζουν και σε PC και με κάποιες τροποποιήσεις και σε XBOX.

Στο Web υπάρχει πάρα πολύ υλικό, αλλά όπως προανέφερα πρέπει να ξέρεις καλά Αγγλικά.

Μπορείς να ξεκινήσεις από εδώ: http://blogs.msdn.com/coding4fun/archive/tags/gaming/default.aspx - Υπάρχουν εισαγωγικά άρθρα και αρκετές οδηγίες.
Κάποια κεφάλαια από ένα βιβλίο θα βρείς εδώ: http://www.robmiles.com/xna-book-downloads/

Μπορείς να μας ενημερώσεις αν θες πως σου φάνηκε.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 04 Σεπ 2007, 10:47:29 πμ
Για να καταλάβετε τις γνώσεις μου στον προγραμματισμό έχω ολοκληρώσει όλα τα κεφάλαια του Χώρου δραστηριοτήτων με τον διερμηνευτή της γλώσσας. Έχω κατεβάσει από τι Internet τη γλώσσα C Explorer (ή κάπως έτσι) αλλά μόνο τα παράθυρα των αρχείων μπορούσα να φτιάξω  :)
Όσον αφορά τα Αγγλικά που δεν τα συμπαθώ καθόλου εεε, κάτι κάνω.  :-\
Πάντως για να μπεις στο πανεπιστήμιο χρειάζεται μόνο η ψευδογλώσσα και αυτό με συμφέρει πολύ. Όπως έχω πει οι ασκήσεις λύνονται.
Α τέλος θα δοκιμάσω και αυτά τα links που μου δώσατε και θα ενημερώσω σύντομα.

Υ.Γ Ναι Α λυκείου θα πάω.
 
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: evry στις 04 Σεπ 2007, 01:08:19 μμ

  Για να μπεις στο πανεπιστήμιο πράγματι χρειάζεται η ψευδογλώσσα, το θέμα όμως είναι να βγεις κιόλας. Οπότε εγώ θα σου πρότεινα να ρίξεις μια ματιά στη C. Το καλύτερο βιβλίο που υπάρχει αυτή τη στιγμή είναι αυτό
http://www.papasotiriou.gr/product.gbook.asp?pfid=565309&prid=253730&deid=0 (http://www.papasotiriou.gr/product.gbook.asp?pfid=565309&prid=253730&deid=0)

Επίσης υπάρχουν μερικοί σύνδεσμοι για εκμάθηση της C στα ελληνικά όπως και δωρεάν online βιβλία τα οποία έχω μαζέψει εδώ
http://users.kyk.sch.gr/evripides/forum/viewforum.php?f=3 (http://users.kyk.sch.gr/evripides/forum/viewforum.php?f=3)

Ένα πολύ καλό περιβάλλον για να ξεκινήσεις είναι εδώ (το όποιο είναι δωρεάν)
http://www.bloodshed.net/dev/devcpp.html (http://www.bloodshed.net/dev/devcpp.html)

και τέλος ένα από τα καλύτερα εισαγωγικά πανεπιστημιακά μαθήματα στον προγραμματισμό από όπου μπορείς να κατεβάσεις κάποιο υλικό είναι εδώ
http://cgi.di.uoa.gr/~ip/ (http://cgi.di.uoa.gr/~ip/) αλλά είναι κάπως υψηλού επιπέδου

Η γνώμη μου είναι ότι αν πράγματι θες να ασχοληθείς στον προγραμματισμό θα πρέπει να ξεκινήσεις με μια γλώσσα όπως η C. Είναι η βάση για γλώσσες όπως η C++, C# και Java. Τώρα για τη C# έχω κάποιους ενδοιασμούς γιατί εκτός του ότι αποτελεί ένα κακέχτυπο αντίγραφο της Java από τη Microsoft αν θες να χρησιμοποιήσεις όλες τις δυνατότητές της θα πρέπει να έχεις το Visual Studio το όποιο είναι καθαρά εμπορικό ενώ γενικά η C, C++ και η Java υποστηρίζονται πολύ από τις κοινότητες ανοιχτού λογισμικού.

Φυσικά όλα αυτά προϋποθέτουν ότι έχεις πολύ υπομονή και χρόνο να διαθέσεις
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: pgrontas στις 04 Σεπ 2007, 03:52:04 μμ
Χωρίς να θέλω να ξεκινήσω flame war (κάτι που δεν ταιριάζει σε αυτό το χώρο-απλά υπάρχει και αντίλογος), υπάρχουν πολλοί που υποστηρίζουν ότι η C# είναι η Java Done Right!
Έχοντας χρησιμοποίησει και τις δύο, η σύνταξη της C# μου είναι πάρα πολύ πιο εύχρηστη (προσωπική άποψη) και εξελίσσεται πολύ καλύτερα, ενσωματώνοντας στις τελευταίες εκδόσεις της, ακόμα και έννοιες από functional προγραμματισμό. Το μόνο θετικό της Java είναι η κοινότητα ανοικτού λογισμικού που συνεισφέρει ενεργά σε αυτήν πάρα πολλά πράγματα.
Για τον προγραμματισμό σε C# δίνεται τέλος δωρεάν το Visual Studio Express που παρέχει όλες τις δυνατότητες που  μπορεί να χρειαστεί κάποιος - συν το ΧΝΑ που προανέφερα το οποίο έχει ως στόχο τον εύκολο προγραμματισμό παιχνιδιών, πράγμα που θεωρώ ότι είναι ιδιαίτερα χρήσιμο ενδιαφέρον για τους μαθητές.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: evry στις 05 Σεπ 2007, 12:25:13 πμ

 Ίσως σε μερικά σημεία η C# να είναι καλύτερη από τη Java, αλλά υπάρχουν πολλά στα οποία (ίσως και σκοπίμως) είναι πίσω όπως ας πούμε το θέμα της μεταφερσιμότητας σε διάφορα λειτουργικά συστήματα, το ότι δε μπορείς να καλέσεις δυναμικά μια κλάση (dynamic class loading) και άλλα μικροπράγματα. Ουσιαστικά όμως οι δυο γλώσσες είναι ίδιες αφού η Microsoft αντέγραψε στεγνά τις ιδέες που έφερε η Java ( πήρε και κάποιες από τη Smalltalk) όταν είδε ότι η Java έχει απήχηση. Το μεγάλο πλεονέκτημα της C# είναι ότι περιλαμβάνεται στο Visual Studio που σαν περιβάλλον είναι πολύ καλό για ανάπτυξη εφαρμογών. Αυτό όμως πρέπει να το αγοράσεις:-)
     Το Visual Studio Express (που ζητάει windows 2000 sp4 και διάφορα σπαστικά registrations) είναι μια ωραία προσπάθεια της Microsoft να αναγκάσει πολύ κόσμο να μετακινηθεί στη δική της πλατφόρμα και να πληρώσεις για το VS.NET.

Επίσης το ότι η C# σου φάνηκε πολύ εύχρηστη οφείλεται στην εμπειρία που έχεις ενδεχομένως από άλλες αντίστοιχες γλώσσες όπως Η C++ και η Java και στο πολύ πλούσιο API απο το όποιο κάποιος εντυπωσιάζεται. Ωστόσο δεν ξέρω αν είναι καλή γλώσσα για να ξεκινήσει κανείς προγραμματισμό. Μπορεί λόγω των βιβλιοθηκών να δίνει στον χρήστη (όπως και η Java) πολλές δυνατότητες για να κάνει πολλά ωραία πράγματα (windows, forms, γραφικά) από πολύ νωρίς. Το ερώτημα όμως είναι αν μαθαίνει ο νέος προγραμματιστής σε βάθος. Για να γίνει αυτό θα πρέπει να κατέχει τις βασικές ιδιότητες του αντικειμενοστρεφούς προγραμματισμού. Πρώτα όμως θα πρέπει να κατανοήσει και να αφομοιώσει τις βασικές αλγοριθμικές έννοιες σε μια διαδικαστική γλώσσα προγραμματισμού όπως είναι η Pascal ή η C. Πιστεύω ότι ο καλύτερος τρόπος να ξεκινήσει κανένας είναι πρώτα με C μετά C++ και μετά Java ή C#.
    Πολλά τμήματα πληροφορικής σε Ευρώπη και Αμερική βιάστηκαν να βάλουν τη Java πρώτη γλώσσα και το μετάνιωσαν πικρά αφού είδαν ότι ελάχιστοι φοιτητές κατανοούσαν σε βάθος τι έκαναν και κυρίως τι λειτουργίες επιτελούνταν πίσω από τις κλήσεις των μεθόδων των αντικειμένων για παράδειγμα. Τα περισσότερα τμήματα το έχουν γυρίσει σε C, και μάλιστα ένα στη Φινλανδία αν θύμαμαι καλά (στο όποιο υπάρχουν αρκετοί καλοί ερευνητές στην περιοχή της Διδακτικής της Πληροφορικής) γύρισε πίσω στην Pascal.

   Τέλος πάντων όλα αυτά είναι δικές μου απόψεις και ίσως να κάνω λάθος ή να είμαι αρνητικά προκατειλημένος με την Microsoft(το πιθανότερο:-) αλλά πιστεύω ότι στην εκπαιδευτική διαδικασία πρέπει όσο μπορούμε να χρησιμοποιούμε λογισμικό δωρεάν και ανοικτού κώδικα.
Δεν νομίζω ότι υπάρχει θέμα flame war αλλά λίγος διάλογος σε τέτοια θέματα δεν κάνει κακό.

Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 05 Σεπ 2007, 10:47:42 πμ
Παράθεση
Για να μπεις στο πανεπιστήμιο πράγματι χρειάζεται η ψευδογλώσσα, το θέμα όμως είναι να βγεις κιόλας. Οπότε εγώ θα σου πρότεινα να ρίξεις μια ματιά στη C. Το καλύτερο βιβλίο που υπάρχει αυτή τη στιγμή είναι αυτό
http://www.papasotiriou.gr/product.gbook.asp?pfid=565309&prid=253730&deid=0

Επίσης υπάρχουν μερικοί σύνδεσμοι για εκμάθηση της C στα ελληνικά όπως και δωρεάν online βιβλία τα οποία έχω μαζέψει εδώ
http://users.kyk.sch.gr/evripides/forum/viewforum.php?f=3

Ένα πολύ καλό περιβάλλον για να ξεκινήσεις είναι εδώ (το όποιο είναι δωρεάν)
http://www.bloodshed.net/dev/devcpp.html

και τέλος ένα από τα καλύτερα εισαγωγικά πανεπιστημιακά μαθήματα στον προγραμματισμό από όπου μπορείς να κατεβάσεις κάποιο υλικό είναι εδώ
http://cgi.di.uoa.gr/~ip/ αλλά είναι κάπως υψηλού επιπέδου

Η γνώμη μου είναι ότι αν πράγματι θες να ασχοληθείς στον προγραμματισμό θα πρέπει να ξεκινήσεις με μια γλώσσα όπως η C. Είναι η βάση για γλώσσες όπως η C++, C# και Java. Τώρα για τη C# έχω κάποιους ενδοιασμούς γιατί εκτός του ότι αποτελεί ένα κακέχτυπο αντίγραφο της Java από τη Microsoft αν θες να χρησιμοποιήσεις όλες τις δυνατότητές της θα πρέπει να έχεις το Visual Studio το όποιο είναι καθαρά εμπορικό ενώ γενικά η C, C++ και η Java υποστηρίζονται πολύ από τις κοινότητες ανοιχτού λογισμικού.

Φυσικά όλα αυτά προϋποθέτουν ότι έχεις πολύ υπομονή και χρόνο να διαθέσεις

Ευχαριστώ για όλο το χρόνο σας.
Το πρόβλημα σε όλα αυτά είναι τα Αγγλικά. Δεν νομίζω να μπορώ να διαβάσω στα Αγγλικά ένα βιβλίο δεν θα ξέρω καλά και το περιεχόμενο ή τουλάχιστον δεν θα καταλάβω 100% όπως απαιτεί η περίσταση.
Στα ελληνικά κανένα free βιβλίο υπάρχει για εκμάθηση;;;;; Στα αγγλικά πάντως υπάρχουν πολλά όπως είδα. Αλλιώς μάλλον θα αναγκαστώ να αγοράσω εκείνο το βιβλίο με 42 Ευρώ από τον Παπασωτηρίου.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: evry στις 05 Σεπ 2007, 02:04:54 μμ
Το βιβλίο είναι καλό και πιστεύω ότι αξίζει τα λεφτά του, μάλιστα μου έκανε εντύπωση η τιμή του γιατί η αγγλική έκδοση από το Amazon κάνει 115$ !!!!.
 Πάντως όσον αφορά τα Αγγλικά μην τα αποφεύγεις γιατί θα τα βρεις σίγουρα μπροστά σου. Ξεκίνα σιγά σιγά και ας είσαι με το λεξικό στο χέρι, δεν πειράζει, καλύτερα σιγά σιγά από τώρα γιατί στο πανεπιστήμιο θα σου φαίνονται βουνό.  Αν και πολλά καλά βιβλία μεταφράζονται στα ελληνικά υπάρχει μεγάλο μέρος της βιβλιογραφίας που θα το βρεις μόνο στα Αγγλικά
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: pgrontas στις 05 Σεπ 2007, 05:04:11 μμ
evry, έχεις πάντως απόλυτο δίκιο σε ό,τι αφορά την διδασκαλία της Java αντί για την C σε πολλά πανεπιστήμια (μιλάω και ως παθών).

Σχετικά πρόσφατα διάβασα ένα κείμενο που περιγράφει με 'γλαφυρό' τρόπο τα μειονεκτήματα της παραπάνω προσέγγισης και άλλα, το οποίο μπορείτε να το βρείτε εδώ (http://www.joelonsoftware.com/articles/ThePerilsofJavaSchools.html).
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 06 Σεπ 2007, 10:19:44 πμ
Παράθεση
Το βιβλίο είναι καλό και πιστεύω ότι αξίζει τα λεφτά του, μάλιστα μου έκανε εντύπωση η τιμή του γιατί η αγγλική έκδοση από το Amazon κάνει 115$ !!!!.
 Πάντως όσον αφορά τα Αγγλικά μην τα αποφεύγεις γιατί θα τα βρεις σίγουρα μπροστά σου. Ξεκίνα σιγά σιγά και ας είσαι με το λεξικό στο χέρι, δεν πειράζει, καλύτερα σιγά σιγά από τώρα γιατί στο πανεπιστήμιο θα σου φαίνονται βουνό.  Αν και πολλά καλά βιβλία μεταφράζονται στα ελληνικά υπάρχει μεγάλο μέρος της βιβλιογραφίας που θα το βρεις μόνο στα Αγγλικά

Γιατί όμως όσο περνάει ο καιρός μισώ και περισσότερο τα Αγλικά;;;; :(
Το να έχω ένα λεξικό στο χέρι και να διαβάζω ένα Αγγλικό κείμενο θα μου πάρει πάρα πολύ χρόνο... και επίσης έχω ακούσει μία άλλη πλευρά που λέει ότι αν θες να περάσεις πληροφορική μην δίνεις πολύ έμφαση στην ίδια αλλά στα άλλα μαθήματα (Μαθηματικά, Φυσική κτλ.) Τώρα όσον αφορά τα βιβλία που υπάρχουν μόνο στα Αγγλικά, ε τότε θα κάθομαι με το λεξικό στο χέρι. Αν κάνω όμως κάτι από όλα τα προηγούμενα που μου είπατε ποιο θα πρέπει να επιλέξω, Αγγλικό free βιβλίο ή Ελληνικό των 40 Ευρώ.

ΥΓ. Για την μετάφραση έχω το Systran αλλά τζάμπα δουλειά, όλο χαζομάρες γράφει, πάντως ένα νοημα μπορείς να το βγάλεις.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: gpapargi στις 06 Σεπ 2007, 11:14:10 πμ
Σταύρο, η επίσημη γλώσσα του κόσμου είναι τα «κακά αγγλικά». Πρέπει να μάθεις να μιλάς «άπταιστα» τα «κακά αγγλικά».
Όποιος δεν μπορεί να διαβάσει αγγλικά έστω και με ένα λεξικό στο χέρι θα έχει μια σοβαρή αναπηρία γιατί δεν έχει πλήρη πρόσβαση στα βιβλία και στη γνώση. Άσε που σε διάφορες εταιρείες στην Ελλάδα η γλώσσα γραπτής επικοινωνίας με mail είναι τα αγγλικά (στέλνεις επαγγελματικό mail στον διπλανό σου στα αγγλικά). Το πρόβλημα αυτό θα το αντιμετωπίσεις κάποτε γι αυτό καλό είναι να μην το αποφεύγεις.

Μη σε φοβίζουν οι άγνωστες λέξεις. Τα τεχνικά βιβλία έχουν κάποια ορολογία η οποία επαναλαμβάνεται. Στην αρχή που βλέπεις για πρώτη φορά τις λέξεις είναι η δυσκολία. Είναι πολύ διαφορετικό το να διαβάζεις ένα βιβλίο φυσικής, μαθηματικών, πληροφορικής στα αγγλικά από το να διαβάζεις πχ λογοτεχνία ή νομικά. Στα δικά μας, η γλώσσα είναι σχετικά απλή. Ένα λογοτεχνικό βιβλίο όμως έχει πλούσιο λόγο και είναι σαφώς δυσκολότερο. Εκεί πρέπει να ξέρεις καλά αγγλικά. Στα δικά μας όμως δεν είναι έτσι τα πράγματα. Οπότε μην ψαρώνεις. Αποκλείεται να μισείς τα αγγλικά περισσότερο από εμένα  ;) Ξεκίνα με το λεξικό και σύντομα θα στρώσει το πράμα. Αν το αφήσεις θα σε κυνηγάει συνέχεια σε σπουδές και δουλειά.

Εγώ πάντως αν είχα χρόνο για να διαθέσω στην πληροφορική θα έμπαινα πιο βαθιά στους αλγορίθμους και στον τρόπο σκέψης τους. Θα δοκίμαζα να πάρω τα βιβλία της Γ (βιβλίο και τετράδιο μαθητή) και θα κοίταγα να ασχοληθώ σταδιακά με τις ασκήσεις του τετραδίου (τα εντός ύλης). Μου φαίνεται δύσκολο να έχεις φτάσει μόνος σου στο επίπεδο να ξεπεράσεις το τετράδιο μαθητή. Θα ήταν προτιμότερο (κατά τη γνώμη μου) αυτό από το να ασχοληθείς με κάποιο αληθινό περιβάλλον και μετά να δυσκολευτείς στη Γ. Θα ήταν κρίμα να πεις στη Γ ότι αφού διέθεσες το χρόνο θα ήταν καλύτερα να το είχες κάνει με διαφορετικό τρόπο.



Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 06 Σεπ 2007, 11:33:33 πμ
Εντάξει με πείσατε θα πάρω ένα Αγγλικό βιβλίο αλλά δεν κατάλαβα την εξής παράγραφο και ειδικότερα τις τελευταίες γραμές.
Παράθεση
Εγώ πάντως αν είχα χρόνο για να διαθέσω στην πληροφορική θα έμπαινα πιο βαθιά στους αλγορίθμους και στον τρόπο σκέψης τους. Θα δοκίμαζα να πάρω τα βιβλία της Γ (βιβλίο και τετράδιο μαθητή) και θα κοίταγα να ασχοληθώ σταδιακά με τις ασκήσεις του τετραδίου (τα εντός ύλης). Μου φαίνεται δύσκολο να έχεις φτάσει μόνος σου στο επίπεδο να ξεπεράσεις το τετράδιο μαθητή. Θα ήταν προτιμότερο (κατά τη γνώμη μου) αυτό από το να ασχοληθείς με κάποιο αληθινό περιβάλλον και μετά να δυσκολευτείς στη Γ. Θα ήταν κρίμα να πεις στη Γ ότι αφού διέθεσες το χρόνο θα ήταν καλύτερα να το είχες κάνει με διαφορετικό τρόπο.

Τι θέλετε να μου πείτε;;;;
Το μόνο που μπορώ να σας πω είναι ότι λύνω τις ασκήσεις τις Γ λυκείου που έχετε αμφιβολίες. Αφού αυτό το πρόγραμμα της αλγοριθμικής ήταν πολύ καλό, πραγματικά.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: gpapargi στις 06 Σεπ 2007, 12:23:04 μμ
Εννοώ το τετράδιο μαθητή της Γ λυκείου
http://www.pi-schools.gr/download/lessons/computers/lykeio/books/anaptyxh.html
Εσύ αν κατάλαβα καλά έλυσες το τετράδιο μαθητή της Αλγοριθμικής
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 06 Σεπ 2007, 09:10:23 μμ
Α ωραία ευχαριστώ θα λύσω όλες αυτές τις ασκήσεις και μετά θα πάμε σε γλώσσα προγραμματισμού. Πάντως η ψευδογλώσσα μου αρέσει πολύ δεν θέλω να την αποχωριστώ... :'( :)
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: gpapargi στις 07 Σεπ 2007, 10:00:11 πμ
Α ωραία ευχαριστώ θα λύσω όλες αυτές τις ασκήσεις και μετά θα πάμε σε γλώσσα προγραμματισμού.
Μεγάλη κουβέντα είπες Σταύρο  :) Σου ευχόμαστε πάντως καλή επιτυχία.
Το καλό είναι ότι θα σου πάρει λίγο καιρό ακόμα μέχρι να αποχωριστείς την ψευδογλώσσα.

Ξεκίνα και όπου κολλήσεις εμείς θα είμαστε δίπλα  ;)
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 07 Σεπ 2007, 12:50:56 μμ
Παράθεση
Μεγάλη κουβέντα είπες Σταύρο  Smiley Σου ευχόμαστε πάντως καλή επιτυχία.
Το καλό είναι ότι θα σου πάρει λίγο καιρό ακόμα μέχρι να αποχωριστείς την ψευδογλώσσα.

Ξεκίνα και όπου κολλήσεις εμείς θα είμαστε δίπλα  Wink

Γιατί να αποχωριστώ την ψευδογλώσσα;;;; Αφού το βιβλίο τη Γ λυκείου εκεί στηρίζεται.
Όσο για το ότι είπα μεγάλη κουβέντα μου αρέσει αρκετά. Μου αρέσει να λέω πράγματα που είναι όμως μέσα στις δυνατότητες μου, ίσως στα άκρα δεν λέω αλλά με τη βοήθεια του χρόνου και τη δικιά σας θα αγωνιστώ :D
Όταν πήγα πάντως να κατεβάσω π.χ. το 2ο κεφάλαιο για να δω πως είναι από το τετράδιο του μαθητή ήταν σε μορφή ZIP αλλά επειδή μου έχει λήξει το πρόγραμμα το αποσυμπίεσα με το RAR των Windows και όταν ανοίγω το αρχείο PDF που υπάρχει τα γράμματα είναι αλαμπουρνέζικα ??? Φταίει μήπως το πρόγραμμα ή κάποια ρύθμιση από τον browser;;; Θα ξαναπροσπαθήσω για να σας πω.
Σας ευχαριστώ. 
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: gpapargi στις 07 Σεπ 2007, 02:18:49 μμ
Καλοί μαθητές και έξυπνοι υπάρχουν αρκετοί. Αλλά αυτός που θα γίνει πραγματικά σπουδαίος κατά τη γνώμη φαίνεται από το πώς αντιδράει μπροστά στα δύσκολα προβλήματα και στις αληθινές προκλήσεις. Υπάρχουν άνθρωποι έξυπνοι και ικανοί που μετά από λίγη ταλαιπωρία πάνω στο δύσκολο θέμα λένε «άστο βαρέθηκα». Υπάρχουν άλλοι που όταν βρεθούν μπροστά σε κάτι τέτοιο γυαλίζει το μάτι τους. Σκυλιάζουν. Δεν ανέχονται να μην το λύσουν. Αυτοί θα γίνουν σπουδαίοι. Άρα καλά το πας.

Μια που τώρα θα πας Α λυκείου και μια που εμείς παίρνουμε τα παιδιά στα χέρια μας πολύ αργά (στη Γ), θα ήθελα να σου πω/προτείνω τα εξής:
1) Έχε υπόψη σου ότι κάποιος που είναι χαβαλές στις 2 πρώτες τάξεις δεν γίνεται ξαφνικά καλός στη Γ. Θέλει από τώρα να μάθεις να δουλεύεις.
2) Να είσαι κοντά στη φυσική και τα μαθηματικά και να δουλεύεις με κατανόηση. Ίσως θα ήταν χρήσιμο να πάρεις και κανένα βοήθημα για να βλέπεις και ασκήσεις που ενδεχομένως δεν τις κάνουν στην τάξη. Ο τρόπος σκέψης στιςθετικές επιστήμες είναι κοινός.
3) Ασχολήσου με τα ψυχαγωγικά μαθηματικά (δηλαδή αυτό που λέμε γρίφους λογικής). Στην ηλικία σου έχεις χρόνο. Θα δυναμώσει το μυαλό σου πάρα πολύ καθώς τα προβλήματα αυτά δεν εντάσσονται σε στάνταρ μεθοδολογίες. Θέλουν σκέψη. Θέλουν τη μεγάλη ιδέα. Μπορεί κάποιος να είναι άριστος μαθητής και να μην μπορεί να λύσει το γρίφο. Έτσι εξασκείται το μυαλό σου στις πραγματικές προκλήσεις. Εκεί θα δεις τι πάει να πει να «γυαλίζει το μάτι». Και όλα αυτά παίζοντας… χωρίς το άγχος του βαθμού. Τελικά το μυαλό σου θα δυναμώσει πολύ και στις θετικές επιστήμες.

Να μια σελίδα με τέτοια που δυστυχώς έχει ατονήσει:

http://anekdota.dyndns.org/quiz/

Φιλικά
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 07 Σεπ 2007, 02:40:24 μμ
Ευχαριστώ πολύ για την σελίδα με τους γρίφους. Εξαιρετικά ενδιαφέρον θέμα. Άρα στον ελεύθερο χρόνο μου θα λύνω τέτοια και θα κάνω ασκήσεις από το τετράδιο μαθητή της Γ λυκείου αν καταφέρω να το ανοίξω. ʼρα για γλώσσα προγραμματισμού από τώρα δεν παίζει τίποτα;;;
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Vangos στις 08 Σεπ 2007, 04:53:14 μμ
Κοίτα...

Αν κατάλαβα καλά, ο προγραμματισμός είναι περισσότερο "διασκέδαση" και λιγότερο "μάθημα" για σένα, σωστά; Αν είναι όντως έτσι, τότε (κατά την γνώμη μου) δεν θα έχεις πρόβλημα μαθαίνοντας μια άλλη γλώσσα προγραμματισμού. Προτείνω Java ή C.

Όμως, ΠΡΟΣΟΧΗ: Σε πρώτη μοίρα πρέπει να είναι πάντοτε τα μαθήματά σου. Δεν πρέπει να παραμελήσεις τα Μαθηματικά ή τη Φυσική για χάρη του Προγραμματισμού. Μην ανησυχείς, μπαίνοντας σε σχολή Πληροφορικής, θα μπουχτίσεις να γράφεις κώδικα!

Σχετικά με τα Αγγλικά: Κι εγώ έβγαζα σπυράκια διαβάζοντάς τα. Τα απεχθανόμουν τόσο πολύ που ούτε αγγλικές ομάδες στο ποδόσφαιρο δεν υποστήριζα! Με το ζόρι κατάφερα να πάρω ένα Προφίσιενσυ πριν τη Γ' Λυκείου. Η αναγκαιότητά τους, όμως, φάνηκε όταν πέρασα στο Πανεπιστήμιο... Τα συγγράματα που μας δίνουν είναι πολλές φορές άθλια κι έτσι πρέπει να αναζητώ αλλού βιβλιογραφία. Ή πρέπει να ψάχνω στα αγγλικά για άλλα θέματα που με ενδιαφέρουν... Και κάτι ακόμα: Οι περισσότεροι όροι της Πληροφορικής είναι αγγλικοί. Δε μιλάω μόνο για το συντακτικό των γλωσσών προγραμματισμού (if, else, for, while, κλπ), αλλά και για τις διάφορες έννοιες της επιστήμης.

Αποτέλεσμα: Τώρα μαθαίνω προγραμματισμό κυρίως διαβάζοντας ξενόγλωσση βιβλιογραφία και επισκεπτόμενος ξενόγλωσσα σάιτ (επίσης, έγινα οπαδός της Μάντσεστερ Γιουνάιτεντ - αλήθεια). Λεξικό χρησιμοποιώ πολύ σπάνια. Μην ανησυχείς, δε θα χρειαστεί να λιώσεις πάνω στα φροντιστηριακά βιβλία αγγλικών ούτε να μάθεις όλες τις περίεργες (συχνά λογοτεχνικές) λέξεις που σου δίδασκαν. Βέβαια, δεν ξέρω σε τι επίπεδο βρίσκεσαι, δηλαδή πόσο καλά κατέχεις την Αγγλική...

Επαναλαμβάνω: Πρώτη προτεραιότητα τα σχολικά μαθήματα και μετά ο προγραμματισμός. Και, φυσικά, την ψευδογλώσσα πρέπει να τη μάθεις καλά αφού σε αυτήν θα εξεταστείς στο τέλος.

Καλή επιτυχία, ό,τι κι αν κάνεις. Εμείς εδώ θα είμαστε 8).
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: gpapargi στις 10 Σεπ 2007, 10:04:51 πμ
Δεν απαγορεύεται να ασχοληθείς από τώρα με γλώσσα. Απλά άλλο πράγμα ο τρόπος σκέψης για την κατασκευή αλγορίθμου και άλλο η εκμάθηση μιας συγκεκριμένης γλώσσας. Το δεύτερο είναι  εκμάθηση κάποιας τεχνολογίας και είσαι σχετικά εύκολο. Σε λίγες εβδομάδες μαθαίνεται. Το πρώτο είναι επιστήμη και είναι το πραγματικό ζητούμενο. Απαιτεί πολύ κόπο. Η ψευδογλώσσα ουσιαστικά έχει φτιαχτεί έτσι ώστε να μειώνει στο ελάχιστο το μέρος εκμάθησης της γλώσσας για να μπορείς να εστιάσεις στον τρόπο σκέψης. Μην ξεχνάμε άλλωστε ότι ο αλγόριθμος είναι ανεξάρτητος από τη γλώσσα. Το πρόγραμμα σε κάποια γλώσσα είναι απλά η μετατροπή του αλγορίθμου σε μια διάλεκτο κατανοητή (εμμέσως) από τον υπολογιστή. Αλγόριθμοι προϋπήρχαν των υπολογιστών (πχ ο αλγόριθμος του Ευκλείδη για μέγιστο κοινό διαιρέτη και κόσκινο του Ερατοσθένη για εύρεση πρώτων είχαν φτιαχτεί από την αρχαιότητα).

Εγώ ανέφερα τα παραπάνω μόνο και μόνο επειδή μπορεί να δυσκολευτείς στη Γ λυκείου λύνοντας το τετράδιο μαθητή. Και τότε μπορεί να πεις: «Θα ήταν καλύτερα να είχα διαθέσει το χρόνο μαθαίνοντας κατασκευή αλγορίθμου παρά μαθαίνοντας κάποια γλώσσα αφού η κατασκευή αλγορίθμου είναι αυτή που εξετάζεται». Φυσικά θα κάνει καλό και κάποια γλώσσα. Απλά δεν είναι η πρώτη προτεραιότητα. Βέβαια μπορεί παίζοντας με αληθινή γλώσσα να πωρωθείς φτιάχνοντας αληθινά πράγματα και τελικά έτσι να μάθεις περισσότερα. 
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: koniordos στις 10 Σεπ 2007, 05:24:05 μμ
Εγώ δεν θα σου πρότεινα να ξεκινήσεις από C.
100% όμως θα σου πρότεινα να περάσεις σε αυτήν αφού έχεις αποκτήσει τριβή σε ζητήματα τμηματικού προγραμματισμού, σύνθετων δομών δεδομένων, διαχέιριση αρχείων κα, μέσω μιας πιο 'απλής' γλώσσας.

Δεδομένου ότι η 'ΓΛΩΣΣΑ' στηρίζεται σε μεγάλο βαθμό σε αυτήν, αλλά και επειδή την θεωρώ την πιο εύπεπτη εκπαιδευτικού χαρακτήρα γλώσσα Δομημένου Προγραμματισμού, θα πρότεινα να ξεκινήσεις από PASCAL.

Βιβλιαράκι
ZAKS, Εισαγωγή στην PASCAL & την TURBO PASCAL (μεταφρασμένο όπως κατάλαβες)
Νομίζω εξακολουθείς να το βρίσκεις στον Παπασωτηρίου.


Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 11 Σεπ 2007, 03:30:22 μμ
Σόρι που είχα καιρό να απαντήσω αλλά αρχίζουν και τα σχολεία.... ;) :)
Πρέπει να σας πω (για να καταλάβετε επίπεδο) ότι λύνω τις ασκήσεις προγραμματισμού των πανελληνίων από το 2000 και μετά. Μόνο όμως ασκήσεις. Γι` αυτό συνεχίζω να ασχολούμαι με ψευδογλώσσα αφού την έχω συνηθίσει. Ίσως αργότερα να ασχοληθώ με μία γλώσσα προγραμματισμού (απ` όσα έχω ακούσει C) και φυσικά διάβασμα στα Αγγλικά :D

ΥΓ.
Πρώτη μέρα στο σχολείο ελπίζω να αποκτήσουμε  καλές σχέσεις με τον πληροφορικό.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: gpapargi στις 12 Σεπ 2007, 08:33:50 πμ
Έχει υπόψη σου και τα διαγωνίσματα που φτιάχτηκαν από το forum στη σελίδα
https://alkisg.mysch.gr/steki/index.php?topic=566.0

Το επαναληπτικό προσομοίωσης θα έλεγα να το δοκιμάσεις.
https://alkisg.mysch.gr/steki/index.php?topic=945.0

ΑΠό ότι θυμάμαι υπήρχαν θέματα προχωρημένης δυσκολίας στα 2 διαγωνίσματα των εντολών επανάληψης,
https://alkisg.mysch.gr/steki/index.php?topic=847.0
https://alkisg.mysch.gr/steki/index.php?topic=848.0

Στο Διαγώνισμα 1 των πινάκων
https://alkisg.mysch.gr/steki/index.php?topic=851.0

Και στο διαγώνισμα 2 των υποπρογραμμάτων
https://alkisg.mysch.gr/steki/index.php?topic=870.0

Επίσης πολύ καλά ήταν τα θέματα των επαναληπτικών του 2007 (δεν ξέρω αν τα έχεις δει ή έχεις ασχοληθεί μόνο με τις εξετάσεις του Μαίου)
https://alkisg.mysch.gr/steki/index.php?topic=1018.0

Όλα αυτά δίνουν μια καλή ιδέα του επιπέδου που πρέπει να φτάσει κάποιος για να πούμε ότι είναι γερά πρετοιμασμένος. Τα θέματα των πανελληνίων μέχρι στιγμής θεωρούνται γενικά απλά.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 12 Σεπ 2007, 05:38:41 μμ
Παράθεση
Έχει υπόψη σου και τα διαγωνίσματα που φτιάχτηκαν από το forum στη σελίδα
https://alkisg.mysch.gr/steki/index.php?topic=566.0

Το επαναληπτικό προσομοίωσης θα έλεγα να το δοκιμάσεις.
https://alkisg.mysch.gr/steki/index.php?topic=945.0

ΑΠό ότι θυμάμαι υπήρχαν θέματα προχωρημένης δυσκολίας στα 2 διαγωνίσματα των εντολών επανάληψης,
https://alkisg.mysch.gr/steki/index.php?topic=847.0
https://alkisg.mysch.gr/steki/index.php?topic=848.0

Στο Διαγώνισμα 1 των πινάκων
https://alkisg.mysch.gr/steki/index.php?topic=851.0

Και στο διαγώνισμα 2 των υποπρογραμμάτων
https://alkisg.mysch.gr/steki/index.php?topic=870.0

Επίσης πολύ καλά ήταν τα θέματα των επαναληπτικών του 2007 (δεν ξέρω αν τα έχεις δει ή έχεις ασχοληθεί μόνο με τις εξετάσεις του Μαίου)
https://alkisg.mysch.gr/steki/index.php?topic=1018.0

Ω ευχαριστώ θα δω ποια δεν έχω κάνει και θα πωρωθώ!!! (στα υποπρογράμματα θέλω λίγη δουλειά αν και στις Πανελλήνιες μέχρι τώρα (από αυτά που έχω δει) δεν τα χρησιμοποιούν.

Παράθεση
Όλα αυτά δίνουν μια καλή ιδέα του επιπέδου που πρέπει να φτάσει κάποιος για να πούμε ότι είναι γερά πρετοιμασμένος. Τα θέματα των πανελληνίων μέχρι στιγμής θεωρούνται γενικά απλά.

Αυτό τώρα γιατί μου το λέτε, για να δυσαρεστηθώ; Δεν ξέρω τι λέτε αλλά νιώθω περήφανος 8)
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: gpapargi στις 13 Σεπ 2007, 09:32:34 πμ
Αυτό τώρα γιατί μου το λέτε, για να δυσαρεστηθώ;

Όχι βέβαια. Το λέω για να μην επαναπαυτείς. Σκέψου ότι θα μπορούσε κάποιος μαθητής να μείνει ήσυχος από το γεγονός ότι λύνει τα θέματα των πανελληνίων νομίζοντας ότι αυτά είναι δύσκολα. Κάτι τέτοιο θα ήταν μια επικίνδυνη παρεξήγηση που θα στοίχιζε πολύ.
Προφανώς είναι πολύ σημαντικό αυτό που κάνεις. Δεν έχεις πάει ακόμα λύκειο και αντιμετωπίζεις θέματα πανελληνίων. Σκέψου να ωριμάσει κι άλλο η σκέψη σου. Χρόνος υπάρχει πολύς και αφού έχεις και τη διάθεση να ασχοληθείς πρέπει να τον αξιοποιήσεις σωστά.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Vangos στις 14 Σεπ 2007, 05:33:10 μμ
Δεδομένου ότι η 'ΓΛΩΣΣΑ' στηρίζεται σε μεγάλο βαθμό σε αυτήν, αλλά και επειδή την θεωρώ την πιο εύπεπτη εκπαιδευτικού χαρακτήρα γλώσσα Δομημένου Προγραμματισμού, θα πρότεινα να ξεκινήσεις από PASCAL.
Επειδή η ΓΛΩΣΣΑ αποτελεί μια "μετάφραση" της Πασκάλ, δε θα πρότεινα τη συγκεκριμένη γλώσσα προγραμματισμού. Είναι σαν να συνεχίζεις την εκμάθηση της ψευδογλώσσας μαθαίνοντας μία νεκρή γλώσσα...

Κοινώς, η Πασκάλ δε θα σε βοηθήσει να προχωρήσεις ιδιαίτερα. Το πολύ να μάθεις να χειρίζεσαι και αρχεία. Από κει και πέρα, η ίδια η γλώσσα Πασκάλ δε βοηθά τον προγραμματιστή να φτιάξει γρήγορα ένα πρόγραμματα, τα records της είναι δυσλειτουργικά και, γενικώς, από ένα σημείο και μετά αρχίζει να γίνεται κουραστική. Αν ξέρεις καλά την ψευδογλώσσα, το βρίσκω άσκοπο να μαθαίνες Πασκάλ.

Προσωπική άποψη, για να μην παρεξηγούμαι :angel:
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 15 Σεπ 2007, 07:33:44 μμ
Παράθεση
Όχι βέβαια. Το λέω για να μην επαναπαυτείς. Σκέψου ότι θα μπορούσε κάποιος μαθητής να μείνει ήσυχος από το γεγονός ότι λύνει τα θέματα των πανελληνίων νομίζοντας ότι αυτά είναι δύσκολα. Κάτι τέτοιο θα ήταν μια επικίνδυνη παρεξήγηση που θα στοίχιζε πολύ.
Προφανώς είναι πολύ σημαντικό αυτό που κάνεις. Δεν έχεις πάει ακόμα λύκειο και αντιμετωπίζεις θέματα πανελληνίων. Σκέψου να ωριμάσει κι άλλο η σκέψη σου. Χρόνος υπάρχει πολύς και αφού έχεις και τη διάθεση να ασχοληθείς πρέπει να τον αξιοποιήσεις σωστά.

Ευχαριστώ για την προειδοποίηση. Ίσως πραγματικά να είχα επαναπαυτεί. πάντως θα κάνω και τις επιπλέον ασκήσεις γιατί οι διαδικασίες ΠΡΑΓΜΑΤΙΚΑ με δυσκολεύουν.  >:(
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 25 Οκτ 2007, 10:15:55 πμ
λοιπόν άρχισα να κάνω αυτές τις <<δύσκολες>> ασκήσεις και έχω να κάνω μία παρατήρηση.
Βασικά άρχισα από τα τεστ με τους πίνακες και παρατήρησα ότι μπορούν να λυθούν με αρκετούς τρόπους. Επηρεάζεται ο βαθμός αν το λύσεις με έναν ας τον πω <<χαζό>> τρόπο αλλά ολόσωστο. Εννοώ δηλαδή να γράψεις κάπου 10 γραμμές ενώ γίνεται και με 5 ας πούμε. Σύντομα θα τις ανεβάσω και εδώ να τις δείτε λίγο αλλά να φανταστείτε ότι (δεν ξέρω αν θυμάστε) εκείνη η άσκηση με την βαθμολογία των μαθητών, να βρω τον μέσο όρο, ποιοι συμπλήρωσαν βαθμολογία 100 κτλ την έκανα κάπου στις 90 σειρές!!! Πάντως το έτρεξα και δούλευε ΡΟΛΟΪ και δεν φαντάζεστε τι χαρά που πήρα. Δεν ξέρω αλλά όταν λύνω μία άσκηση πωρώνομαι όπως και στα μαθηματικά σαν να κάνω κάτι σπουδαίο :D ;D
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: gpapargi στις 25 Οκτ 2007, 10:30:38 πμ
Το βασικό στην πληροφορική δεν είναι το πλήθος των γραμμών κώδικα που γράφεις εσύ αλλά το πλήθος των βημάτων που κάνει ο υπολογιστής για να φτ΄σει στη λύση. Βέβαια στο επίπεδο του λυκειακού μαθήματος αυτό δε βαθμολογείται δυστυχώς. Ο συμπαγής κώδικας (αυτό που λες εσύ 5 γραμμές αντί για 10) είναι και αυτό κάτι ενδιαφέρον και καλό (είναι πιο κομψή λύση) αλλά δεν είναι το πρώτο ζητούμενο.   Οι προγραμματιστές βέβαια αρέσκονται στον συμπαγή και κομψό κώδικα.

Αλλά μιλάμε στον αέρα. Πες για ποια εκφώνηση μιλάς και ανέβασε τη λύση σου να σχολιάσουμε.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 28 Οκτ 2007, 07:21:08 μμ
Συγγνώμη που καθυστερώ να σας ανεβάσω τις λύσεις αλλά δεν έχω χρόνο αυτό το διάστημα. Βασικά βαριέμαι να μεταφέρω τις λύσεις από τον έναν υπολογιστή στον άλλον και γι` αυτό κάνω αρκετές ασκήσεις και έτσι θα έχουμε μπόλικο πράγμα για συζήτηση.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: alexis_zoure στις 30 Οκτ 2007, 02:14:48 μμ
Ενα πραγμα να πω...Ο Σταυρος ειναι ακομα 15 χρονων,αυτο σημαινει οτι εχει μπροστα του 2μιση χρονια για να δωσει...Εχει κανει εξαιρετικη δουλεια μονο και μονο αμα σκεφτει καποιος οτι εχει διαβασει μονος του!!!Προσωπικα πιστευω οτι αν συνεχισει ετσι μπορει να (για μην πω σιγουρα οτι θα) γραψει καθαρο 100!!!
Αλλα αυτο που θελω να πω ειναι:Γιατι δεν το καταλαβαινει κανενας(εννοω απο τους υπευθυνους...) οτι πρεπει να διδασκεται το μαθημα απο μικροτερη ηλικια? ???
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: P.Tsiotakis στις 30 Οκτ 2007, 03:53:19 μμ
Στη Γ γυμνασίου προβλέπεται η διδασκαλία προγραμματισμού, όπως και στο μάθημα επιλογής της Α λυκείο. Όλοι ξέρουμε σε πιο βαθμό συμβαίνει αυτό.

Και γω θα ήθελα την ΑΕΠΠ να απλώνεται στη Β και Γ λυκείου και φυσικά να είναι μάθημα γενικής παιδείας (τουλάχιστον στη Β λυκείου) όπου είναι και η φυσική του θέση. Αυτό όμως δε δικαιολογεί αυτό που συμβαίνει στο παρόν.

ΥΓ: βέβαια πλέον στη Γ γυμνασίου θα ασχολούνται με χελωνίτσες
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: alexis_zoure στις 30 Οκτ 2007, 04:47:49 μμ
Τι εννοειται αυτο που συμβαινει στο παρον κυριε Τσιωτακη?
Παντως γενικοτερα στην Πληροφορικη δεν δινουν σε τιποτα εμφαση αφου μας αφηναν να παιζουμε και να μπαινουμε Ιντερνετ, αν και στην Γ γυμνασιου επειδη διναμε στο τελος ολο και κατι μας ελεγαν αλλα και αυτο παρα πολυ γενικα!
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: P.Tsiotakis στις 30 Οκτ 2007, 05:05:59 μμ
Αυτό ακριβώς εννοώ, Αλέξανδρε.

Ενώ προβλέπεται να κάνετε προγραμματισμό εμείς (οι καθηγητές) δεν ακολουθούμε τα προβλεπόμενα προγράμματα σπουδών...
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: gpapargi στις 31 Οκτ 2007, 03:07:50 μμ
Αλλα αυτο που θελω να πω ειναι:Γιατι δεν το καταλαβαινει κανενας(εννοω απο τους υπευθυνους...) οτι πρεπει να διδασκεται το μαθημα απο μικροτερη ηλικια?

Μεγάλη κουβέντα είπες Αλέξη.

Σαφώς και η κατασκευή αλγορίθμου ως μάθημα έχει θέση σε μικρότερες τάξεις. Πέρα από το ότι μαθαίνει τρόπο σκέψης στους μαθητές, οι σχολές που την έχουν σαν αντικείμενό της έχουν τις υψηλότερες βάσεις. Θα έπρεπε λοιπόν να υπάρχει μια γνωριμία με το αντικείμενο νωρίτερα από τη Γ λυκείου, έτσι ώστε να τη δουν οι μαθητές και να αποφασίσουν.

Υπάρχουν πολλά θετικά μυαλά που δεν έρχονται στην τεχνολογική κατεύθυνση νομίζοντας ότι η ΑΕΠΠ είναι κάτι σαν χειρισμός υπολογιστών και προτιμούν τη χημεία (σε αυτό φταίει σε μεγάλο βαθμό και η «καθοδήγηση» μερικών καθηγητών). Υπάρχουν άλλοι που δεν κάνουν για αλγορίθμους και μόλις το δουν μετανιώνουν την ώρα και τη στιγμή που διάλεξαν τεχνολογική κατεύθυνση νομίζοντας ότι θα πάρουν το εύκολο 18 (κάθε χρόνο έχω τέτοιους μαθητές).

Από κάθε άποψη θα έπρεπε η διδασκαλία της κατασκευής αλγορίθμου και του προγραμματισμού να διδάσκονται νωρίτερα στα σχολεία. Δυστυχώς όμως, όπως θα δεις μεγαλώνοντας, στη λήψη αποφάσεων για την παιδεία (και όχι μόνο) συνήθως αυτό που μετράει λιγότερο είναι το ποιο είναι το ηθικά σωστό και ποιο το λάθος.

Αυτό που συνήθως γίνεται είναι το εξής:
Ο καθένας ασκεί τις πιέσεις του με όποιο τρόπο μπορεί και όποιος έχει τη μεγαλύτερη εξουσία και ισχύ… περνάει (επιβάλει) την άποψή του.

Να μερικά παραδείγματα χοντρά παραδείγματα:

Καταρχήν το φαιδρό μάθημα των θρησκευτικών δεν έπρεπε να υπάρχει. Από τη μια θέλουμε να μάθουμε τα παιδιά να σκέφτονται σαν επιστήμονες (δηλαδή να αναζητούν ισχυρές ενδείξεις και ατράνταχτα επιχειρήματα προκειμένου να αποδεχτούν κάποια άποψη) και από την άλλη εισάγουμε ευθέως τον ανορθολογισμό και τη μεταφυσική μέσω του ίδιου του σχολείου. Μετά αναρωτιόμαστε γιατί οι μαθητές ασχολούνται με τα ζώδια και δεν έχουν άμυνες απέναντι σε κάποιον που εμφανώς προσπαθεί να τους παραπλανήσει. Όταν βλέπω μαθητές του 18 να με ρωτάνε τι ζώδιο είμαι με πιάνει απελπισία. Για να είναι μαθητές του 18, σημαίνει ότι πήραν αυτά που είχε να τους δώσει στο σχολείο. Και τότε… που θα έπρεπε να μάθουν ότι όλα αυτά είναι ανοησίες;

Άλλο παράδειγμα:

Όταν ήμουν μικρός (σαν και εσάς) είχα 2 ερωτήματα που με βασάνιζαν. Το ένα ήταν το πώς δημιουργήθηκε ο κόσμος (το σύμπαν). Υπήρχε πάντοτε ή προέκυψε ξαφνικά;
Το δεύτερο είναι το πώς δημιουργήθηκε η ζωή και ο άνθρωπος;

Είναι λυπηρό ότι και στα 2 ερωτήματα πήρα «απάντηση» από το μάθημα των θρησκευτικών. Το 1985 αποσύρθηκε το βιβλίο της ιστορίας γιατί ανέφερε απλώς ότι ο τρόπος που προέκυψε ο άνθρωπος περιγράφεται από την εξελικτική θεωρία του Δαρβίνου. Η ιερά σύνοδος απαίτησε την «κάθαρση ή την απόσυρση του βλάσφημου βιβλίου» και πέτυχε την απόσυρση.

http://www.iospress.gr/ios2000/ios20000730a.htm
http://www.iospress.gr/ios2000/ios20000730b.htm

Για να διδαχθεί κάτι στην ελλάδα θα πρέπει να πάρει και την έγκριση της εκκλησίας. Καθόλου παράξενο όταν το υπουργείο λέγεται «Υπουργείο παιδείας ΚΑΙ ΘΡΗΣΚΕΥΜΑΤΩΝ».

Και ο φουκαράς ο συνάδελφος ο Θάνος Καψάλης τρέχει να μαζέψει υπογραφές για να εισαχθεί μια από της σοβαρότερες επιστημονικές θεωρίες που έχουμε στα σχολεία.

http://users.att.sch.gr/thanoscapsalis/form.htm

Δεν διδάσκουμε τη θεωρία της εξέλιξης στα σχολεία. Και διδάσκουμε θρησκευτικά.

Αν εμείς μιλάμε για διδασκαλία αλγορίθμων νωρίτερα… τι να πουν οι ταλαίπωροι οι βιολόγοι. Τους κατάπιε κυριολεκτικά η εκκλησιαστική εξουσία.

ʼλλο παράδειγμα επιβολής του ισχυρού:

Το μάθημά μας, αν και είναι καθαρά επιστημονικό, είναι το μοναδικό το οποίο το διδάσκει κυριολεκτικά οποιοσδήποτε. Κανονικά θα έπρεπε ο διδάσκων να έχει σπουδές πάνω στο αντικείμενο. Αντίθετα τα συμφέροντα κράτησαν έξω τους πληροφορικούς (με αστείες προφάσεις) και διόρισαν στα σχολεία ανθρώπους που έχουν σπουδάσει οτιδήποτε και έμαθαν πληροφορική από σεμινάρια. Κάποιοι κλάδοι που ήταν πιο ισχυροί εκμεταλλεύτηκαν την εξουσία τους και πέτυχαν το διορισμό των δικών τους  αδιόριστων σε βάρος των πληροφορικών, σε βάρος των μαθητών και βέβαια σε βάρος της παιδείας και της επιστήμης. Τώρα πια διορίζονται αυτοί που πρέπει. Αλλά η ζημιά έγινε και στους κόλπους μας υπάρχει κάθε καρυδιάς καρύδι. 

Να πως λαμβάνονται οι αποφάσεις στην Ελλάδα.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: alkisg στις 31 Οκτ 2007, 03:54:44 μμ
Όταν ήμουν μικρός (σαν και εσάς) είχα 2 ερωτήματα που με βασάνιζαν. Το ένα ήταν το πώς δημιουργήθηκε ο κόσμος (το σύμπαν). Υπήρχε πάντοτε ή προέκυψε ξαφνικά;
Το δεύτερο είναι το πώς δημιουργήθηκε η ζωή και ο άνθρωπος;

[offtopic]
Να 'σαι καλά βρε Γιώργο τι μου θύμισες... Η δικιά μου ήταν, "Γιατί ο Θεός δημιούργησε το σύμπαν;" και η σαφέστατη απάντηση που πήρα από τον θεολόγο μου ήταν "από αγάπη"...
Καλό είναι να διδάσκονται τα παιδιά την ιστορία των διαφόρων θρησκειών, αλλά να βγει ο Δαρβίνος... απαράδεκτο.
[/offtopic]
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Kurt Godel στις 31 Οκτ 2007, 05:24:08 μμ
gpapargi, λες :

Παράθεση
Υπάρχουν πολλά θετικά μυαλά που δεν έρχονται στην τεχνολογική κατεύθυνση νομίζοντας ότι η ΑΕΠΠ είναι κάτι σαν χειρισμός υπολογιστών και προτιμούν τη χημεία (σε αυτό φταίει σε μεγάλο βαθμό και η «καθοδήγηση» μερικών καθηγητών).

Πολύ σωστό! Και δεν είναι μόνο η έλλειψη πρότερης πείρας ως προς τον προγραμματισμό, αλλά και οι ανακρίβειες από τις οποίες είναι γεμάτο το ίδιο το μάθημα έτσι όπως το δημιούργησαν. Για να μην κάνω λόγο για κεφάλαια, όπως το 6ο ας πούμε, τα οποία θα έπρεπε ως αδιαίρετες μονάδες να βρεθούν με μιας στον κάδο ανακύκλωσης!

Παράθεση
Υπάρχουν άλλοι που δεν κάνουν για αλγορίθμους και μόλις το δουν μετανιώνουν την ώρα και τη στιγμή που διάλεξαν τεχνολογική κατεύθυνση νομίζοντας ότι θα πάρουν το εύκολο 18 (κάθε χρόνο έχω τέτοιους μαθητές)

Πόσο δίκιο έχεις....αυτό το ρημάδι το "εύκολο 18". Αυτό είναι ίσως το μεγαλύτερο πρόβλημα αυτού που καλούμε "Τεχνολογική Κατεύθυνση". Θυμάμαι από τη δική μου ακόμα χρονιά ως μαθητής, ότι οι βαθμολογικά χαμηλότεροι μαθητές του σχολείου, έβρισκαν πάντα φιλόξενες τις ώρες της ΑΕΠΠ και των ΑΟΔΕ. Και δυστυχώς αυτό συμβαίνει ακόμα. Ένας καλός μαθητής δύσκολα θα ρισκάρει να αφήσει την πεπατημένη Χημεία/Βιολογία για να δοκιμάσει, στην κρισιμότερη μαθητική του χρονιά, την κακογραμμένη και ανοργάνωτη ΑΕΠΠ, ειδικά όταν αυτό θα σημάνει τη συμμετοχή του σε μια τάξη-καφενείο.

Παράθεση
Κάποιοι κλάδοι που ήταν πιο ισχυροί εκμεταλλεύτηκαν την εξουσία τους και πέτυχαν το διορισμό των δικών τους  αδιόριστων σε βάρος των πληροφορικών, σε βάρος των μαθητών και βέβαια σε βάρος της παιδείας και της επιστήμης.

Επειδή μάλλον αναφέρεσαι στους Μαθηματικούς (πως φαίνεται ο έχων τη μύγα), θα σου πω ότι έχω δει Μαθηματικούς με ένα MSc στην Πληροφορική να ζωγραφίζουν στην τάξη, την ώρα που απόφοιτοι καθαρόαιμων πληροφορικών τμημάτων δεν μπορούσαν να ολοκληρώσουν έναν αλγόριθμο με εμφωλευμένες "Αν..." χωρίς τη βοήθεια των μαθητών τους.Οπότε το "σε βάρος των μαθητών και βέβαια σε βάρος της παιδείας και της επιστήμης" ας το αφήσουμε στην άκρη.

Όσο για το "σε βάρος των πληροφορικών" θα συμφωνήσω εν μέρει. Είναι όμως ένα μεγάλο θέμα που απαιτεί ξεχωριστό topic όπου και θα χαρώ να συμμετάσχω.

Φιλικά,
Kurt Godel

ΥΓ:
 Κι ένα Link που πιστεύω πως θα βρεις ενδιαφέρον :
http://en.wikipedia.org/wiki/Richard_Dawkins (http://en.wikipedia.org/wiki/Richard_Dawkins)
(ψάξε και για υλικό του στο YouTube)

Συγγνώμη αν βγαίνω τελείως Offtopic ή αν "σπαμάρω" το thread. Απλά θεώρησα σωστό, μιας που ο gpapargi έθεσε δημόσια τον προβληματισμό, να παραθέσω κι εγώ δημόσια τo link και να τo μοιραστούμε με όσους παρακολουθούν το thread.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: pgrontas στις 31 Οκτ 2007, 05:50:14 μμ
Μπράβο Γιώργο Παπαργύρη, καταπληκτικό post. Με βρίσκεις 100% σύμφωνο.

Το πρώτο σχόλιο, που έχω να κάνω είναι ότι εκπλήσσομαι πρώτα από όλα γιατί κορόιδευα τους Αμερικάνους με την διαμάχη τους μεταξύ εξελικτικών και δημιουργηστών. Πού να ήξερα ο έρημος ότι κάτι τέτοιο συνέβη και στην Ελλάδα.

Συστήνω ανεπιφύλακτα σε όλους το βιβλίο του Dawkins "Η αυταπάτη του Θεού" . Το διάβασα το καλοκαίρι και έχει μέσα καταπληκτικά επιχειρήματα στο συγκεκριμένο θέμα.

Σε ότι αφορά τους μαθηματικούς και τις άλλες ειδικότητες αλεξιπτωτιστές:
Πρέπει να έχουμε ως αρχή (κάτι που προκύπτει και από την μαθηματική σκέψη) να μην κάνουμε άτοπες γενικεύσεις. Το μέρος δεν περιγράφει με ακρίβεια το όλον.  Δεν πρέπει τα παραδείγματα κακών συναδέλφων να χαρακτηρίζουν τον κλάδο. Είμαι σίγουρος ότι κακοί καθηγητές υπάρχουν σε όλες τις ειδικότητες και μάλιστα στατιστικά στο ίδιο ποσοστό.

Ένα παράδειγμα στο οποίο κατά την γνώμη μου φταίνε εν μέρει είναι η κατάντια των μαθημάτων εφαρμογών που θεωρούνται  ως 'η ώρα  του παιδιού.' Θεωρώ ότι οι αρχικοί αλεξιπτωτιστές δεν μπορούσαν να σταθούν στην τάξη (κάτι που απαιτούσε εκτός από απλά Word Excel γενικότερες γνώσεις αλλά και πάθος για την πληροφορική) και γι αυτό δημιουργήθηκε μια αρνητική παράδοση που καλούμαστε να σπάσουμε. Μεγαλύτερο βάρος βέβαια σε αυτό έχει το υπουργείο, με το πλαίσιο που έχει ορίσει στο συγκεκριμένο μάθημα.

Επιπλέον ας μην ξεχνάμε ότι ο σημαντικότερος ρόλος του καθηγητή είναι να εμπνεύσει τους μαθητές. Κατά πόσο μπορεί αυτό να γίνει από κάποιον που δεν έχει πλήρη γνώση του αντικειμένου, το αφήνω στην κρίση σας.

Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: P.Tsiotakis στις 31 Οκτ 2007, 06:51:15 μμ
Τα  θρησκευτικά είναι 2ώρες/βδομάδα στις Α και Β και 1 ώρα/βδομάδα στη Γ. Στη Γ υπάρχουν Βιολογία Γενικής και Βιολογία κατεύθυνσης 1 και 2 ώρες/βδομάδα αντίστοιχα. Στο γυμνάσιο δεν έψαξα.
Αν το πρόβλημα της εκπαίδευσης είναι οι παραπάνω ώρες που αφιερώνονται στα θρησκευτικά, παρεμποδίζοντας τη διδασκαλία της Βιολογίας, τότε να τις βγάλουμε.

Και παρεπιπτόντως, εγώ δεν έλκω την καταγωγή μου από τον πίθηκο

Παράθεση
Ένας άθεος καθηγητής της φιλοσοφίας συζητά ΅ε έναν φοιτητή του, για την σχέση ΅εταξύ επιστή΅ης και πίστης στον Θεό.

Καθηγητής: Λοιπόν, πιστεύεις στον Θεό;
Φοιτητής: Βεßαίως, κύριε.

Καθ.: Είναι καλός ο Θεός;
Φοιτ.: Φυσικά.

Καθ.: Είναι ο Θεός παντοδύνα΅ος;
Φοιτ.: Ναι

Καθ.: Ο αδερφός ΅ου πέθανε από καρκίνο παρότι παρακαλούσε τον Θεό να τον γιατρέψει και προσευχόταν σε Αυτόν. Οι περισσότεροι από ε΅άς θα προσπαθούσαν να ßοηθήσουν αυτούς που έχουν την ανάγκη τους.Πού είναι η καλοσύνη του Θεού λοιπόν;
Φοιτ.: ..

Καθ.: Δεν ΅πορείς να απαντήσεις, έτσι δεν είναι; Ας ξαναρχίσου΅ε ΅ικρέ ΅ου. Είναι καλός ο Θεός;
Φοιτ.: Ναι.

Καθ.: Είναι καλός ο διάßολος;
Φοιτ.: Όχι.

Καθ.: Ποιος δη΅ιούργησε τον διάßολο;
Φοιτ.: Ο...Θεός...

Καθ.: Σωστά. Πες ΅ου παιδί ΅ου, υπάρχει κακό σ' αυτόν τον κόσ΅ο;
Φοιτ.: Ναι.

Καθ.: Το κακό ßρίσκεται παντού, έτσι δεν είναι; Και ο Θεός έπλασε τα πάντα,σωστά;
Φοιτ.: Ναι.

Καθ.: Άρα λοιπόν ποιος δη΅ιούργησε το κακό;
Φοιτ.: ..

Καθ.: Υπάρχουν αρρώστιες; Ανηθικότητα; Μίσος; Ασχή΅ια; Όλα αυτά τα τρο΅ερά στοιχεία υπάρχουν σ' αυτόν τον κόσ΅ο, έτσι δεν είναι;
Φοιτ.: Μάλιστα.

Καθ.: Λοιπόν, ποιός τα δη΅ιούργησε;
Φοιτ.: ..

Καθ.: Η επιστή΅η λέει ότι χρησι΅οποιείς τις 5 αισθήσεις σου για να αναγνωρίζεις το περιßάλλον γύρω σου και να προσαρ΅όζεσαι σε αυτό. Πες ΅ου παιδί ΅ου, έχεις δει ποτέ τον Θεό;
Φοιτ.: Όχι, κύριε.

Καθ.: Έχεις ποτέ αγγίξει το Θεό; Έχεις ποτέ γευτεί το Θεό, ΅υρίσει το Θεό σου; Και τέλος πάντων, έχεις ποτέ αντιληφθεί ΅ε κάποια από τις αισθήσεις σου το Θεό;
Φοιτ.: ..Όχι, κύριε. Φοßά΅αι πως όχι.

Καθ.: Και παρόλα αυτά πιστεύεις ακό΅α σε Αυτόν;
Φοιτ.: Ναι.

Καθ.: Σύ΅φωνα ΅ε ε΅πειρικό, ελεγχό΅ενο και ΅ε δυνατότητα ΅ελέτης των αποτελεσ΅άτων ενός φαινο΅ένου πρωτόκολλο, η επιστή΅η υποστηρίζει ότι ο Θεός σου δεν υπάρχει. Τι έχεις να απαντήσεις σε αυτό, παιδί ΅ου;
Φοιτ.: Τίποτα. Εγώ έχω ΅όνο την πίστη ΅ου.

Καθ.: Ναι, η πίστη. Και αυτό είναι το πρόßλη΅α της επιστή΅ης.

Φοιτ: Καθηγητά, υπάρχει κάτι που το ονο΅άζου΅ε θερ΅ότητα;
Καθ.: Ναι.

Φοιτ.: Και υπάρχει κάτι που το ονο΅άζου΅ε κρύο;
Καθ.: Ναι.

Φοιτ.: Όχι, κύριε. Δεν υπάρχει. Μπορεί να έχεις ΅εγάλη θερ΅ότητα, ακό΅α περισσότερη θερ΅ότητα, υπερθερ΅ότητα, καύσωνα, λίγη θερ΅ότητα ή καθόλου θερ΅ότητα. Αλλά δεν υπάρχει τίποτα που να ονο΅άζεται κρύο. Μπορεί να χτυπήσου΅ε 458 ßαθ΅ούς υπό το ΅ηδέν, που ση΅αίνει καθόλου θερ΅ότητα, αλλά δεν ΅πορού΅ε να πά΅ε πιο κάτω από αυτό. Δεν υπάρχει τίποτα που να ονο΅άζεται «κρύο». «Κρύο» είναι ΅όνο ΅ια λέξη, που χρησι΅οποιού΅ε για να περιγράψου΅ε την απουσία θερ΅ότητας. Δεν ΅πορού΅ε να ΅ετρήσου΅ε το κρύο. Η θερ΅ότητα είναι ενέργεια. Το κρύο δεν είναι το αντίθετο της θερ΅ότητας, κύριε, είναι απλά η απουσία της.

Στην αίθουσα επικρατεί σιγή...

Φοιτ.: Σκεφτείτε το σκοτάδι, καθηγητά. Υπάρχει κάτι που να ονο΅άζου΅ε σκοτάδι;
Καθ.: Ναι, τι είναι η νύχτα αν δεν υπάρχει σκοτάδι;

Φοιτ.: Κάνετε και πάλι λάθος, κύριε καθηγητά. Το «σκοτάδι» είναι η απουσία κάποιου άλλου παράγοντα. Μπορεί να έχεις λιγοστό φως, κανονικό φως, λα΅περό φως, εκτυφλωτικό φως... Αλλά, όταν δεν έχεις φως, δεν έχεις τίποτα και αυτό το ονο΅άζου΅ε σκοτάδι, έτσι δεν είναι; Στην πραγ΅ατικότητα το σκοτάδι απλά δεν υπάρχει. Αν υπήρχε θα ΅πορούσες να κάνεις το σκοτάδι σκοτεινότερο.
Καθ.: Που θέλεις να καταλήξεις ΅ε όλα αυτά, νεαρέ;

Φοιτ.: Κύριε, ότι η φιλοσοφική σας σκέψη είναι ελαττω΅ατική.
Καθ.: Ελαττω΅ατική!; Μήπως ΅πορείς να ΅ου εξηγήσεις γιατί;

Φοιτ.: Καθηγητά, σκέφτεστε ΅έσα στα όρια της δυαδικότητας. Υποστηρίζετε ότι υπάρχει η ζωή και ΅ετά υπάρχει και ο θάνατος, ένας καλός Θεός και ένας κακός Θεός. Βλέπετε την έννοια του Θεού σαν κάτι τελικό, κάτι που ΅πορεί να ΅ετρηθεί. Κύριε, η επιστή΅η δεν ΅πορεί να εξηγήσει ούτε κάτι τόσο απλό όπως την σκέψη. Χρησι΅οποιεί την ηλεκτρική και ΅αγνητική ενέργεια, αλλά δεν έχει δει ποτέ, πόσο ΅άλλον να καταλάßει απόλυτα αυτήν την ενέργεια. Το να ßλέπεις το θάνατο σαν το αντίθετο της ζωής είναι σαν να αγνοείς το γεγονός ότι ο θάνατος δεν ΅πορεί να υπάρξει αυτόνο΅ος. Ο θάνατος δεν είναι το αντίθετο της ζωής: είναι απλά η απουσία της. Τώρα πείτε ΅ου, καθηγητά. Διδάσκετε στους φοιτητές σας ότι εξελίχτηκαν από ΅ια ΅αϊ΅ού;
Καθ.: Εάν αναφέρεσαι στην φυσική εξελικτική πορεία, τότε ναι, και ßέßαια.

Φοιτ.: Έχετε ποτέ παρακολουθήσει ΅ε τα ΅άτια σας την εξέλιξη;
Καθ.: ..

Φοιτ.: Εφόσον κανένας δεν παρακολούθησε ποτέ την διαδικασία εξέλιξης επιτόπου και κανένας δεν ΅πορεί να αποδείξει ότι αυτή η διαδικασία δεν στα΅ατά ποτέ, τότε διδάσκεται την προσωπική σας άποψη επί του θέ΅ατος. Τότε ΅ήπως δεν είστε επιστή΅ονας, αλλά απλά ένας κήρυκας;
Καθ.: ..

Φοιτ.: Υπάρχει κάποιος στην τάξη που να έχει δει τον εγκέφαλο του καθηγητή; Που να έχει ακούσει ή νιώσει ή ακου΅πήσει ή ΅υρίσει τον εγκέφαλο του καθηγητή; Κανένας. ʼρα σύ΅φωνα ΅ε τους κανόνες του ε΅πειρικού, ελεγχό΅ενου και ΅ε δυνατότητα προßολής πρωτόκολλου, η επιστή΅η ισχυρίζεται ότι δεν έχετε εγκέφαλο, κύριε. Και αφού είναι έτσι τα πράγ΅ατα, τότε, ΅ε όλο τον σεßασ΅ό, πώς ΅πορού΅ε να ε΅πιστευτού΅ε αυτά που διδάσκετε, κύριε;
Καθ.: Μου φαίνεται ότι απλά θα πρέπει να στηριχτείς στην πίστη σου, παιδί ΅ου.

Φοιτ.: Αυτό είναι, κύριε... Ο σύνδεσ΅ος ΅εταξύ του ανθρώπου και του Θεού είναι η ΠΙΣΤΗ. Αυτή είναι που κινεί τα πράγ΅ατα και τα κρατάει ζωντανά.
Αυτός ο νεαρός φοιτητής ήταν ο ALBERT EINSTEIN...
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 31 Οκτ 2007, 08:11:47 μμ
Πολύ ωραία αυτή η παράθεση κ. Τσιωτάκη.

Αν ξαναγυρίσω λίγο στα παλιά έχω να πω ότι το μάθημα εντάξει αρχίζει από την Γ Γυμνασίου αλλά μαθαίνεις μόνο τα βασικά Γράψε, Διάβασε και την ΑΝ. Ε αυτά τώρα είναι ψίχουλα. Αληθινά θα μπορούσε να διδάσκεται και από μικρότερες ηλικίες αλλά υπάρχει το πρόβλημα που το είχα παρατηρήσει και στην τάξη μου (δεν κατηγορώ πάντως τους παλιούς συμμαθητές μου ;)) ότι οι περισσότεροι βλέπουν το μάθημα ως η ώρα του παιδιού. Λένε α ωραία πληροφορική να μπούμε λίγο στο Internet. Δεν ξέρω αν δεν είχα κι εγώ Internet ίσως έτσι να έκανα....
Όταν λοιπόν δεν μπορούν να μάθουν αυτά τα απλά γιατί ο καθηγητής να σπάει το κεφάλι του για κάτι δυσκολότερο;;;
Συμφωνώ για το ότι πρέπει να γίνεται το μάθημα από μικρότερη ηλικία αρκεί να αλλάξει η προκατάληψη (αν μου επιτρέπεται η έκφραση) που υπάρχει. Γιατί όταν λες Πληροφορική=Internet, αυτοκίνητα κτλ. πιστεύω πως μειώνεις την πληροφορική.   
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Kurt Godel στις 31 Οκτ 2007, 10:09:09 μμ
pgrontas, αν ξαναδιαβάσεις το παράδειγμα που έφερα θα δεις ότι λέμε ακριβώς το ίδιο!

Ανέφερα τις συγκεκριμένες (υπαρκτές) περιπτώσεις καθηγητών για να δείξω πως είναι λάθος να λέμε ότι οποιοσδήποτε απόφοιτος Πληροφορικής είναι ικανότερος στη διδασκαλία της ΑΕΠΠ από οποιονδήποτε απόφοιτο άλλου Φυσικομαθηματικού Τμήματος.

Αυτή την ίδια ολιστική αντιμετώπιση που καταγγέλεις αποδοκιμάζω κι εγώ !

Τώρα, το κατά πόσο είναι ορθό σε ηθικό ή συντεχνιακό (με την καλή έννοια της λέξης "συντεχνία") επίπεδο να διδάσκεται η Πληροφορική από μη-πληροφορικούς, είναι μια κουβέντα στην οποία θα έμπαινα ευχαρίστως.

Αυτά για τώρα γιατί, ως γνήσιος υποστηρικτής του Dawkins, είναι η ώρα να φάω την μπανάνα μου ;-)

Φιλικά,
Kurt Godel

ΥΓ1: Θα μπορούσες να μου εξηγήσεις σε παρακαλώ ποιες είναι αυτές οι "ειδικότητες αλεξιπτωτιστές" στις οποίες εντάσσεις και τους Μαθηματικούς ;
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Michael στις 31 Οκτ 2007, 10:38:57 μμ
Νομίζω πως κάπου έχω ξανασυναντήσει το κείμενο που παρέθεσε ο Παναγιώτης. Από πού προκύπτει ότι πρόκειται για πραγματικό περιστατικό, και όχι απλώς για έναν ακόμη σύγχρονο μύθο?
Όχι ότι έχει και μεγάλη σημασία φυσικά... Einstein ή όχι, προσωπικά, δεν με πείθει η συλλογιστική του φοιτητή (και ως ένα βαθμό, ούτε του καθηγητή). Για παράδειγμα, νομίζω πως ο φοιτητής δεν έχει ξεκαθαρίσει στο μυαλό του τις διαφορές ανάμεσα στους όρους "θερμότητα" και "θερμοκρασία" (και φυσικά, ούτε ο καθηγητής κάνει κάποια προσπάθεια να άρει αυτήν την παρερμηνεία).

Και, μιας και κατά τη γνώμη μου τα θέματα "ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ" και "Εξελικτική Βιολογία" ταυτίζονται ( :o), θα ήθελα να εκφράσω ορισμένες προσωπικές απόψεις:
1) Το ότι δεν διδάσκεται η Εξελικτική Βιολογία στα Ελληνικά σχολεία, το θεωρώ την μεγαλύτερη πληγή της εκπαίδευσης στον τόπο μας. Είναι σαν να μην διδάσκονται οι νόμοι του Newton. Είναι σαν να μην διδάσκεται η επίλυση τριωνύμου.
2) Ο τελευταίος που θα έλεγε ότι έλκει την καταγωγή του από τους πιθήκους, θα ήταν ένας εξελικτικός βιολόγος.
3) Δεν βρίσκω ότι υπάρχει πρόβλημα με τις ώρες των θρησκευτικών στα σχολεία. Αν ήταν περισσότερες, ακόμα καλύτερα! Με μια απλή δήλωση, θα μπορούσε όποιος θέλει να πάρει απαλλαγή από το μάθημα και να αφιερώσει τις extra ώρες στο διάβασμα της ΑΕΠΠ! (Ή, να πάει απλώς για καφέ. Ακόμη κι αυτό θα ήταν καλύτερο.)
4) Μιας και αναφέρθηκε το όνομα του Richard Dawkins, ας πω κι εγώ ότι τον θεωρώ ίσως έναν από τους κορυφαίους εν ζωή επιστήμονες.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: pgrontas στις 31 Οκτ 2007, 10:40:37 μμ
Αγαπητέ Kurt,
στο αρχικό σου μήνυμα, ανέφερες εντέχνως μαθηματικούς με MSc στην πληροφορική να διδάσκουν πληροφορική. Η περίπτωση αυτή είναι η ιδανική (από τις υπόλοιπες της κατηγορίας το μη χείρον βέλτιστον).
Έχεις την ίδια άποψη και για τους συναδέλφους με σεμινάρια 30 ωρών;

Και σε ότι αφορά την ερώτηση σου: Αλεξιπτωτιστές είναι αυτοί που διδάσκουν πληροφορική, παρόλο που έχουν τόση σχέση με αυτήν όσο και με το αλεξίπτωτο. Και ναι κατά τη γνώμη μου οι μαθηματικοί με σεμινάρια 30 ωρών είναι αλεξιπτωτιστές.

Ήθελα να ήξερα τι θα κάνετε αν μπουν θέματα στα οποία δεν έχετε εμπειρία όπως στη θεωρία αλγορίθμων που έχετε κάποια εμπειρία.
Ή θα φροντίσετε να μην μπούν; Ή για τον λόγο αυτό δεν έχουν μπει;

Και να σου πω και κάτι άλλο; Ένας πληροφορικός είναι κατά την γνώμη μου απόλυτα ικανός να διδάξει μαθηματικά στο Γυμνάσιο και λιγότερο ή περισσότερο ικανός-  ανάλογα με τις γνώσεις του καθενός, να διδάξει μαθηματικά στο Λύκειο.

Θεωρείς ότι πρέπει?
Για να μην ρωτήσω αν θα τον αφήσετε.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Kurt Godel στις 01 Νοέ 2007, 01:43:36 πμ
Φίλε Pgrontas,
δεν έφερα έντεχνα ,όπως λες, τα παραδείγματα του Μαθηματικού με MSc στην Πληροφορική και της αποφοίτου Πληροφορικής για να εκμαιεύσω συμπεράσματα. Έφερα αυτά τα συγκεκριμένα παραδείγμα διότι αυτά συνάντησα μπροστά μου ως μαθητής Τεχνολογικής Κατεύθυνσης στη Γ' Λυκείου. Τη μεν απόφοιτο Πληροφορικής την είχα καθηγήτρια από τον Σεπτέμβρη και για περίπου 2 μήνες (δεν άντεξε περισσότερο), ο δε Μαθηματικός έμεινε μαζί μας μέχρι το τέλος του χρόνου οπότε και επέστρεψε στο Γυμνάσιο από το οποίο είχε έρθει με απόσπαση, η κάτι τέτοιο. Επίσης, ο προηγούμενος καθηγητής πληροφορικής που είχε το σχολείο ήταν και αυτός Μαθηματικός.

Αυτές τις προσλαμβάνουσες έχω, αυτά τα παραδείγματα φέρνω. Λόγω τιμής, δεν αποσκοπώ κάπου.

Παράθεση
Ήθελα να ήξερα τι θα κάνετε αν μπουν θέματα στα οποία δεν έχετε εμπειρία όπως στη θεωρία αλγορίθμων που έχετε κάποια εμπειρία.

Έχω υλοποιήσει και διαχειριστεί AVL δέντρα σε (Ansi) C. Νομίζεις ότι δυσκολεύομαι -πέρα από τις ασάφειες του βιβλίου- να διδάξω ΑΕΠΠ ή να λύσω οποιοδήποτε θέμα;
Όσοι δυσκολεύονται ας περάσουν μια βόλτα από τα βιβλιοπωλεία του κέντρου ή ας κάτσουν στο σπίτι τους.

Παράθεση
Ή θα φροντίσετε να μην μπούν; Ή για τον λόγο αυτό δεν έχουν μπει;

Όσοι έχουν ασχοληθεί (ανεξαρτήτως ειδικότητας) δεν έχουν να φοβούνται τίποτα. Και μη νομίζεις οτι είναι λίγοι και οι Πληροφορικοί που θα τα βρουν σκούρα αν μπουν βαρβάτα θέματα.

Παράθεση
Και να σου πω και κάτι άλλο; Ένας πληροφορικός είναι κατά την γνώμη μου απόλυτα ικανός να διδάξει μαθηματικά στο Γυμνάσιο και λιγότερο ή περισσότερο ικανός-  ανάλογα με τις γνώσεις του καθενός, να διδάξει μαθηματικά στο Λύκειο.

Θεωρείς ότι πρέπει?

Φτάσαμε λοιπόν και στο ζητούμενο.
Αν συμφωνώ στο ότι ένας (διαβασμένος) Πληροφορικός δύναται να διδάξει Μαθηματικά; Ναι.
Αν συμφωνώ στο ότι ένας (διαβασμένος) Μαθηματικός δύναται να διδάξει ΑΕΠΠ; Ναι.

Αν συμφωνώ στο ότι ένας (διαβασμένος) Πληροφορικός δικαιούται (ηθικά και συντεχνιακά) να διδάσκει Μαθηματικά ; Όχι.
Αν συμφωνώ στο ότι ένας (διαβασμένος) Μαθηματικός δικαιούται (ηθικά και συντεχνιακά) να διδάσκει Πληροφορική ; Όχι.

Όταν όμως υπάρχουν τόσοι Πληροφορικοί οι οποίοι κάνουν ιδιαίτερα Μαθηματικά-Φυσική-Χημεία-κοκ. σε παιδιά Γυμνασίου-Λυκείου γιατί εγώ θα πρέπει να αρνηθώ την προσφορά ενός ιδιοκτήτη φροντιστηρίου ή ενός γονιού να αναλάβω ένα τμήμα ή ένα ιδιαίτερο την στιγμή που οι γνώσεις μου είναι παραπάνω από αρκετές;

Παράθεση
Για να μην ρωτήσω αν θα τον αφήσετε.

Καλέ φίλε, αν ήξερες πόσα έχουμε περάσει από συναδέλφους σου που δεν ήθελαν να μπούμε στα χωράφια τους. Δες πόσο πρόχειρη, ανοργάνωτη και βλακώδης είναι η διδασκαλία του προγραμματισμού (για όσους ασχολούνται) σε Μαθηματικά τμήματα και μετά μίλα μου για "ισχυρούς κλάδους" και "ποιος αφήνει ποιόν". Δες τι καθηγητές-μαργαριτάρια στέλνουν τα τμήματα Πληροφορικής να διδάξουν σε Μαθηματικά τμήματα.

Αν ήξερες πόσα χρήματα ξοδέψαμε για να αγοράσουμε αξιοπρεπή βιβλία, πόσα μαθήματα κάναμε με φοιτητές Πληροφορικής γιατί οι δικοί μας καθηγητές αρνούνταν να μας διδάξουν σωστά και να μας εξηγήσουν. Πόσες φορές κατεβήκαμε σε εξεταστικές και απορούσαμε "μπήκαμε σε λάθος μάθημα;".

Και μιλάμε για ανθρώπους που θέλουν να μάθουν για τον εαυτό τους, χωρίς να απειλούν κανέναν επαγγελματικά! Δεν θα κερδίζαμε δικαιώματα από αυτό!

Το ποιος αφήνει ποιον λοιπόν είναι μια πονεμένη ιστορία...

Για να κλείσω: μην κατηγορείτε τους Φυσικομαθηματικούς. Κάντε μια γύρα από τα ιδιωτικά σχολεία και μαζέψτε όλους τους Γεωπόνους-Βιολόγους-Νηπιαγωγούς-Αρχαιολόγους κλπ. που διδάσκουν Πληροφορική ελέω θείου Διευθυντή.

Κάντε μια γύρα από τα δημόσια σχολεία και μαζέψτε όλους τους συναδέλφους σας που πήραν πτυχίο νύχτα και διορίστηκαν με δόξα και τιμή. Πείτε τους ότι με το να πληκτρολογούν κείμενα νεοελληνικής λογοτεχνίας οι μαθητές δεν εξοικοιώνονται με τον προγραμματισμό.

Αυτοί σας φταίνε. Όχι εμείς.

Ερώτηση: Γνωρίζει κανείς από ποιά τμήματα προήλθαν τα πρώτα μέλη ΔΕΠ του τμήματος Πληροφορικής του Καποδιστριακού ;

Aπάντηση : http://www.di.uoa.gr/gr/info.php (http://www.di.uoa.gr/gr/info.php)

Φιλικά,
Kurt Godel

Τίτλος: Απ: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: pgrontas στις 01 Νοέ 2007, 08:30:06 πμ
Έχω υλοποιήσει και διαχειριστεί AVL δέντρα σε (Ansi) C. Νομίζεις ότι δυσκολεύομαι -πέρα από τις ασάφειες του βιβλίου- να διδάξω ΑΕΠΠ ή να λύσω οποιοδήποτε θέμα;

Θεωρώ ότι η Πληροφορική είναι περισσότερα πράγματα από προγραμματισμός και ακριβώς εκεί νομίζω ότι οι μαθηματικοί θα τα βρούν σκούρα.(ας μην πούμε για τους υπόλοιπους).
Δεν αναφερόμουν συγκεκριμένα στην ΑΕΠΠ.

Καλέ φίλε, αν ήξερες πόσα έχουμε περάσει από συναδέλφους σου που δεν ήθελαν να μπούμε στα χωράφια τους. Δες πόσο πρόχειρη, ανοργάνωτη και βλακώδης είναι η διδασκαλία του προγραμματισμού (για όσους ασχολούνται) σε Μαθηματικά τμήματα και μετά μίλα μου για "ισχυρούς κλάδους" και "ποιος αφήνει ποιόν". Δες τι καθηγητές-μαργαριτάρια στέλνουν τα τμήματα Πληροφορικής να διδάξουν σε Μαθηματικά τμήματα.

Αν ήξερες πόσα χρήματα ξοδέψαμε για να αγοράσουμε αξιοπρεπή βιβλία, πόσα μαθήματα κάναμε με φοιτητές Πληροφορικής γιατί οι δικοί μας καθηγητές αρνούνταν να μας διδάξουν σωστά και να μας εξηγήσουν. Πόσες φορές κατεβήκαμε σε εξεταστικές και απορούσαμε "μπήκαμε σε λάθος μάθημα;".

Και μιλάμε για ανθρώπους που θέλουν να μάθουν για τον εαυτό τους, χωρίς να απειλούν κανέναν επαγγελματικά! Δεν θα κερδίζαμε δικαιώματα από αυτό!

Σε αυτό θα συμφωνήσω απόλυτα μαζί σου.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: gpapargi στις 01 Νοέ 2007, 09:01:58 πμ
Kurt Godel

Ένα μαθηματικό ή φυσικό με μεταπτυχιακά ή διδακτορικό στην πληροφορική τον θεωρώ πληροφορικό. Άλλωστε λόγω του ότι η πληροφορική είναι νέα επιστήμη οι καθηγητές των τμημάτων πληροφορικής ανήκουν σε αυτή την κατηγορία.

Αλεξιπτωτιστές θεωρώ τους σκέτους μαθηματικούς και φυσικούς χωρίς κάποιο τίτλο σπουδών πληροφορικής επιπέδου πάνω από το λύκειο που έμαθαν πληροφορική από σεμινάρια. Στην ίδια κατηγορία ανήκουν οι φιλόλογοι, οι κοινωνιολόγοι και οι ψυχολόγοι που απέκτησαν το δικαίωμα να διδάσκουν πληροφορική κάνοντας σεμινάρια.

Όταν μιλάω για διδασκαλία ΑΕΠΠ εννοώ σχολεία. Στα φροντιστήρια και στα ιδιαίτερα ο καθένας κρίνεται από τα αποτελέσματά του. Στο δημόσιο σχολείο όμως πρέπει να υπάρχουν ενιαίοι κανόνες μια που όποιος διοριστεί στην Ελλάδα είναι ακλόνητος.

Πιστεύω ακράδαντα ότι όσοι διόρισαν αυτούς που παραπάνω αναφέρω ως «αλεξιπτωτιστές» δε λειτούργησαν  με βάση κάποια ηθική. Απλά εξυπηρέτησαν συντεχνιακά συμφέροντα.

Να το γιατί:

Κράτησαν έξω τους πληροφορικούς με το επιχείρημα ότι δεν έχουν πάρει παιδαγωγικά μαθήματα. Την ίδια στιγμή διόρισαν άλλες ειδικότητες επειδή η σχολή τους έχει παιδαγωγικά μαθήματα. Το ωραίο είναι σε κάποιες σχολές τα παιδαγωγικά μαθήματα δεν ήταν υποχρεωτικά. Έτσι κάποιος πληροφορικός δεν θεωρήθηκε παιδαγωγικά επαρκής επειδή δεν είχε η σχολή του παιδαγωγικά μαθήματα. Την ίδια στιγμή κάποιος φυσικός θεωρήθηκε παιδαγωγικά επαρκής επειδή η σχολή του είχε παιδαγωγικά μαθήματα κι ας μην τα παρακολουθήσει ποτέ ο ίδιος.

Πέρα από αυτό, το πιο σημαντικό είναι κανείς δεν ασχολήθηκε με την «πληροφορική» επάρκεια των διοριζόμενων. Κανείς δεν αναρωτήθηκε αν έχουν γνώσεις πληροφορικής όλοι αυτοί για να διδάξουν στη Γ λυκείου. Η παιδαγωγική επάρκεια τους άγχωσε.

Εγώ αυτά τα λέω σκάνδαλα.

Την ίδια στιγμή ένας πληροφορικός και ένα φυσικός (μόνο με το πτυχίο τους) γνωρίζουν πολύ καλύτερα μαθηματικά από την πληροφορική που γνωρίζει ένας σκέτος μαθηματικός (μόνο με το πτυχίο του) ειδικά όταν αυτός είναι στα 50 (σαν μερικούς που διορίστηκαν). Ας δει κάποιος τον οδηγό σπουδών ενός φυσικού και ενός πληροφορικού για να δει αυτά που λέω. Παρόλα αυτά ο φυσικός και πληροφορικός είναι αδιανόητο να διδάξει μαθηματικά. Αντίθετα θεωρούμε εντελώς φυσιολογικό το να διδάσκει κάποιος 50ρης σκέτος μαθηματικός πληροφορική.

Τονίζω στα παραπάνω ότι μιλάμε για μέσες συμπεριφορές. Πολλοί έχουν αναφέρει ότι ξέρουν θεολόγους με σεμινάρια που είναι καλύτεροι από πληροφορικούς με πτυχίο. Δεν το αμφισβητώ. Αλλά τα μεμονωμένα παραδείγματα δεν προσφέρονται για ασφαλείς γενικεύσεις.

Θεωρώ λοιπόν ότι όσοι έκαναν τους παραπάνω διορισμούς έκριναν με 2 μέτρα και 2 σταθμά.

Το πώς γεννήθηκε το τμήμα πληροφορικής του πανεπιστημίου Αθηνών, εγώ προσωπικά το ξέρω καλά γιατί ήμουν στην πρώτη χρονιά που μπήκε με εξετάσεις. Θυμάμαι την αντιπάθεια του Ρεσβάνη για το Φιλοκύπρου και τον Καρούμπαλο καθώς κα τις καταλήψεις στα κτίρια ΤΥΠΑ. Ήταν μια κίνηση που έπρεπε να γίνει και που κάποια στιγμή θα γινόταν. Σκέψου ότι σήμερα έχουν φυτρώσει παντού πανεπιστημιακά τμήματα, ΤΕΙ και ΙΕΚ πληροφορικής. Δεν μπορούσε το Καποδιστριακό να μείνει πίσω.

Αλλά κανείς δεν αμφισβητεί την προέλευση και τη σχέση της πληροφορικής με τα μαθηματικά και τη φυσική. Προφανώς από μαθηματικούς και πληροφορικούς γεννήθηκε. Ενώ πολλά σύγχρονα μεγάλα ονόματα προέρχονται από εκεί.
http://en.wikipedia.org/wiki/Donald_Knuth
http://en.wikipedia.org/wiki/Dijkstra

Τουλάχιστον εγώ είμαι από αυτούς που εδώ μέσα έχω υπηρετήσει πιστά τη σχέση με τα μαθηματικά και τη φυσική. Και κάθε χρόνο τονίζω στους μαθητές μου ότι η φύση της ΑΕΠΠ είναι μαθηματική και δεν σχετίζεται με κάποια τεχνολογία των PC.

Το μόνο το οποίο λέω είναι ότι πριν από λίγα χρόνια, χρησιμοποιήθηκαν 2 μέτρα και 2 σταθμά, καταπάτησαν τα ηθικά δικαιώματα των πληροφορικών και εξυπηρέτησαν συνειδητά  τα συμφέροντα άλλων ειδικοτήτων λόγω του ότι είχαν μεγαλύτερη ισχύ.

Για το Dawkins σαφώς και τον ξέρω πολύ καλά. Πριν από λίγο καιρό τελείωσα τον τυφλό ωρολογοποιό που πραγματεύεται την εξέλιξη. Αυτή τη στιγμή είμαι στη μέση του εγωιστικού γονιδίου. Η «Περί Θεού αυταπάτη» είναι στο ράφι μου και περιμένει τη σειρά της. Μετά μάλλον έχει σειρά το Godel incompleteness theorems του  Raymond Smullyan. Για την ώρα έχω μείνει στα βιβλία γρίφων του τελευταίου λόγω της εκτενούς ενασχόλησης μου με το άθλημα. Ειλικρινά το λέω, νομίζω πως δε διαφωνούμε σε τίποτα.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: gpapargi στις 01 Νοέ 2007, 09:54:24 πμ
Παναγιώτη (Τσιωτάκη) το γνωρίζω πολύ καλά το κείμενο που έστειλες. Είναι κάποιο κλασσικό urban legent (μύθος) και κυκλοφορεί εδώ και καιρό.
Είναι μετάφραση του παρακάτω:
http://www.snopes.com/religion/einstein.asp
 
Θα μπορούσα να απαντήσω σε αυτά που λέει ο υποτιθέμενος φοιτητής αλλά θα πάμε αλλού. Στη μετάφραση πάντως βγάζει μάτι αυτό το «458 βαθμοί κάτω από το μηδέν» που προφανώς δεν υπάρχει αφού στο -273 είναι το απόλυτο μηδέν. Προφανώς το αρχικό κείμενο θα μίλαγε σε Φαρενάιτ.

Ο Einstein πίστευε στο Θεό του Σπινόζα που δεν έχει καμία σχέση με τον δικό μας ιουδαιοχριστιανικό Θεό. Για τον Σπινόζα Θεός ήταν η φύση δηλαδή το σύνολο των φυσικών νόμων. Πχ αν πηδήξω από το κτίριο η βαρύτητα θα με κάνει να πέσω και αυτό είναι κάτι πάνω από τον άνθρωπο. Το σύνολο αυτών των φυσικών νόμων θεωρούσε Θεό ο Σπινόζα υπό την έννοια ότι είναι πάνω από τον άνθρωπο.

Δεν πίστευε δηλαδή σε κάποιο Θεό με βούληση που ασχολείται με τον άνθρωπο. Του έδινε ιδιότητες διαφορετικές από αυτές που του δίνουν οι θρησκείες. Πολλοί χαρακτήριζαν άθεο το Σπινόζα αλλά ο ίδιος δε θεωρούσε τον εαυτό του άθεο. Ουσιαστικά όμως οι ιδιότητες που έδινε στο θεό του ήταν σαφώς πιο κοντά στην αθεΐα παρά σε κάποια θρησκεία. Μόνο η λέξη «Θεός» ήταν η ίδια. Επί της ουσίας διαφωνούσε.

Δυστυχώς εγώ διδάχθηκα θρησκευτικά από την πρώτη δημοτικού μέχρι τη Γ λυκείου (12 χρόνια). Βιολογία διδάχθηκα μόνο στη Γ γυμνασίου. Πρόσφατα διάβασα τον τυφλό ωρολογοποιό του Dawkins. Ήταν η πρώτη φορά που μόλις τελείωσα κάποιο βιβλίο ένιωσα στεναχωρημένος. Πως μπορούν και μας κρύβουν τέτοια πράγματα στο σχολείο;

Το πρόβλημα με τα θρησκευτικά δεν είναι οι χαμένες ώρες που η διδασκαλία τους συνεπάγεται. Είναι ότι έρχεται ευθέως σε αντίθεση με την επιστημονική μέθοδο.

Η επιστήμη δεν είναι ένα σύνολο απόψεων. Είναι μια μέθοδος αναζήτησης της αλήθειας. Σύμφωνα με την επιστημονική μέθοδο για να δεχτείς κάποια άποψη χρειάζεσαι ακλόνητα στοιχεία. Για τα μαθηματικά αυτό το ρόλο τον έχουν οι αποδείξεις. Για τη φυσική αυτό το ρόλο τον έχουν εκτός από τις μαθηματικές αποδείξεις και τα πειράματα. Θεωρία που διαφωνεί με το πείραμα αναθεωρείται. Καμία θεωρία δεν είναι ασφαλής από το πείραμα. Όλα είναι υπό συνεχή αναθεώρηση. Αυτή είναι η ικανότητα αυτοδιόρθωσης που έχει η επιστήμη και είναι το πιο ισχυρό της όπλο.

Αν κάποιο πείραμα δείξει ότι μια θεωρία μας είναι λάθος τότε κανείς δε διστάσει να απορρίψει τη θεωρία και να προβεί στις απαιτούμενες διορθώσεις. Αντίθετα στο μάθημα των θρησκευτικών υπάρχουν ιερές αλήθειες (δόγματα) που δεν επιτρέπεται να αμφισβητηθούν.   Ακόμα κι αν η θρησκεία με την επιστήμη λένε ακριβώς τα ίδια πράγματα διαφέρουν ως προς τις μεθόδους τους. Ο επιστήμονας θα απορρίψει μια άποψη όταν αυτή αποδειχθεί λανθασμένη. Ο πιστός δε θα απορρίψει ποτέ τη θρησκεία του γιατί είναι απλά πιστός.

Ο φυσικός στο σχολείο προσπαθεί να εξηγήσει στην επιστημονική μέθοδο στο μαθητή δηλαδή να στηρίζει σε ακλόνητα στοιχεία τις απόψεις του. Τα θρησκευτικά έρχονται λοιπόν και μιλάνε για «αλήθειες» πέρα από κάθε αμφισβήτηση. Υποχρεώνει τον κόσμο να δεχτεί  «θαύματα» που παραβιάζουν τη λογική και τους φυσικούς νόμους. Δεν δίνει κανένα στοιχείο για αυτό. Αντίθετα θεωρεί αμαρτία και βλάσφημη σκέψη κάθε υγιή αμφιβολία που μπορεί να έχει κάποιος. Με απλά λόγια γκρεμίζει αυτό που προσπαθούν να χτίσουν οι θετικές επιστήμες… την αναζήτηση τεκμηρίων για τις απόψεις μας.

Άσε και το άλλο. Αν υπάρχει Θεός, τότε υπάρχει και διάβολος. Τότε υπάρχουν και επικλήσεις στο διάβολο δηλαδή μαύρη μαγεία. Τότε υπάρχουν και μάγοι. Τότε υπάρχουν και άνθρωποι με «άλλες» μεταφυσικές δυνάμεις. Τότε υπάρχουν και αστρολόγοι, μέντιουμ και κεφαντζούδες. Από την ίδια πόρτα που περνάει η θρησκεία, περνάνε και οι αστρολόγοι και οι διάφοροι γραφικοί τύποι που εμφανίζει ο Χαρδαβέλλας στην εκπομπή του κάθε σαββατόβραδο.

Πως μπορώ λοιπόν να απαιτώ από το μαθητή να ζητάει στοιχεία από τους αστρολόγους και τους διάφορους τσαρλατάνους και την ίδια στιγμή να δέχεται χωρίς κανένα στοιχείο ένα κάρο μεταφυσικά πράγματα όπως απαιτεί το ασόβαρο μάθημα των θρησκευτικών; Δεν είναι ίδια μέτρα και σταθμά αυτό!

ʼσε μου σε κάθε χώρα διδάσκονται και διαφορετικά πράγματα στα θρησκευτικά. Όλοι οι μαθητές της γης κάνουν την ίδια φυσική. Στα θρησκευτικά μόνο διδάσκεται ως απόλυτη αλήθεια κάτι που στις υπόλοιπες χώρες θεωρείται παραμυθάκι (γύρω στο 3.5% του πληθυσμού της γης είμαστε χριστιανοί ορθόδοξοι).

Τα παιδιά στο σχολείο θα πρέπει να διδάσκονται βιολογία και εξέλιξη. Τα παιδιά στο σχολείο θα πρέπει να διδάσκονται κάτι από ερασιτεχνική αστρονομία και να βλέπουν από τηλεσκόπιο (έχετε δει ποτέ τους δακτυλίους του Κρόνου από τηλεσκόπιο ερασιτέχνη;)
Αλλά κυρίως τα παιδιά θα πρέπει να διδάσκονται τρόπο σκέψης, την επιστημονική μέθοδο και τον ορθολογισμό/σκεπτικισμό.

Δε νομίζω όμως πως το υπουργείο παιδείας ΚΑΙ ΘΡΗΣΚΕΥΜΑΤΩΝ θα επιτρέψει ποτέ κάτι τέτοιο για προφανείς λόγους.   
Τίτλος: Απ: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: evry στις 01 Νοέ 2007, 02:45:00 μμ

  Αυτό δεν είναι επιχείρημα, γιατί τότε δεν υπήρχαν τμήματα πληροφορικής. Για δες όμως τώρα όλους τους νέους καθηγητές πληροφορικής. Αυτοί από ποια τμήματα είναι? Κανένας από αυτούς δεν προέρχεται από τμήμα μαθηματικών ή τμήμα φυσικής. Είναι όλοι οι μηχανικοί υπολογιστών ή πληροφορικοί.
   Επίσης κάτι άλλο σχετικά με το ποιος μπορεί να διδάξει τι. Σίγουρα κάποιοι μαθηματικοί μπορούν να διδάξουν πολύ καλά το μάθημα της ΑΕΠΠ, ενώ κάποιοι με πτυχίο πληροφορικής δεν ξέρουν που πάνε τα τέσσερα. Με το ίδιο σκεπτικό όμως μπορώ να σου βρω και εγώ άτομα με απολυτήριο ΤΕΕ ή Λυκείου που ξέρουν πολύ καλά προγραμματισμό και μπορούν να διδάξουν και αυτοί το μάθημα της ΑΕΠΠ. Ποια είναι όμως η ειδοποιός διαφορά μεταξύ τους? Κάθε ένας που έχει σπουδάσει μια επιστήμη έχει σφαιρική γνώση για αυτή. Ένας μαθηματικός με διδακτορικό στην Πολυπλοκότητα και τους Αλγορίθμους ίσως να μπορεί να διδάξει μέχρι κάποιο σημείο το μάθημα της ΑΕΠΠ, έχει όμως τη σφαιρική γνώση που πρέπει να έχει ένας καθηγητής πληροφορικής? Έχει καθίσει να υλοποιήσει έναν compiler? (όχι όπως ο άλκης φυσικά :-) αλλά χρησιμοποιώντας κάποιο εργαλείο έτσι για να πάρει μια γεύση), έχει ασχοληθεί με παραλληλία και κατανεμημένα συστήματα? με αρχιτεκτονική υπολογιστών? με βάσεις δεδομένων? με τεχνητή νοημοσύνη? με εξόρυξη γνώσης? με δίκτυα και τηλεποικοινωνίες? με μηχανές αναζήτησης? με επεξεργασία σήματος και εικόνας? Με γλώσσες προγραμματισμού? C, C++, Prolog, Lisp, ώστε να έχει μια πλήρη εικόνα του τι συμβαίνει?
   Σίγουρα όχι, για αυτό και όλοι αυτοί οι καθηγητές που προανέφερες δεν έχουν σφαιρική γνώση αλλά μόνο εξειδικευμένη γνώση για ένα αντικείμενο. Το ότι ένας μαθηματικός μπορεί να έχει τις γνώσεις για να διδάξει πληροφορική στο Γυμνάσιο ή στο Λύκειο δε σημαίνει ότι μπορεί να πάρει τη θέση κάποιου με βασικές σπουδές πληροφορικής, γιατί με το σκεπτικό αυτό και ένας πληροφορικός μπορεί να διδάξει μαθηματικά σε όλες τις βαθμίδες του Λυκείου, έχει τις γνώσεις. Δε γνωρίζει όμως την επιστήμη των μαθηματικών σφαιρικά.
   
    Δεν το εξετάζω από την πλευρά των επαγγελματικών δικαιωμάτων, άλλωστε εμείς οι πληροφορικοί είμαστε οι μοναδικοί που έχουμε μηδέν επαγγελματικά δικαιώματα. Δε μπορείς όμως να εξισώνεις τα 10-12 μαθήματα ενός μεταπτυχιακού με τα 40 του προπτυχιακού.
    Αν πάμε με το σκεπτικό ότι ένας μαθηματικός μπορεί να διδάξει πληροφορική τότε και άλλες ειδικότητες θα μπορούν να διδάξουν μαθήματα άλλων ειδικοτήτων και θα ανοίξει το κουτί της πανδώρας, όλοι θα διδάσκουν όλα.

   

Ερώτηση: Γνωρίζει κανείς από ποιά τμήματα προήλθαν τα πρώτα μέλη ΔΕΠ του τμήματος Πληροφορικής του Καποδιστριακού ;

Aπάντηση : http://www.di.uoa.gr/gr/info.php (http://www.di.uoa.gr/gr/info.php)

Φιλικά,
Kurt Godel


Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Kurt Godel στις 02 Νοέ 2007, 02:13:47 μμ
Καλό μήνα ! (έστω και με μια μέρα καθυστέρηση)

Απαντώ σε γενικές γραμμές λόγω έλλειψης χρόνου:

α) Συμφωνώ στο ότι η πληροφορική δεν είναι μόνο προγραμματισμός (Τουλάχιστον έτσι φαντάζομαι, δεν γνωρίζω ακριβώς τι είναι πληροφορική και τι όχι). Προφανώς και ένας Μαθηματικός δεν είναι πληροφορικός. Δεν μιλάω όμως γενικά για πληροφορική, αλλά για την ΑΕΠΠ.

β) Ασφαλώς και δεν βρίσκω σωστό να διορίζονται άλλοι κλάδοι ως Πληροφορικοί στα σχολία (ακόμα και Μαθηματικοί με διδακτορικό στην Πληροφορική). Όταν μιλάμε για επαγγέλματα μπαίνει στο τραπέζι το θέμα της επιβίωσης και της ποιότητας ζωής των ανθρώπων. Εδώ δεν γίνονται εκπτώσεις. Δεν μου αρέσει να παίρνω το ψωμί άλλων, όπως δεν μου αρέσει να παίρνουν το δικό μου.
Στη ζούγκλα της παραπαιδείας όμως θα πάρω το ιδιαίτερο από τον Πληροφορικό με την ίδια άνεση που εκείνος πήρε το δικό μου.

γ) Αν κάποια στιγμή δυσκολέψουν τα πράγματα στην ΑΕΠΠ και δω ότι δεν μπορώ να ανταποκριθώ στις απαιτήσεις του μαθήματος θα είμαι ο πρώτος που θα κρεμάσει τα προγραμματιστικά του γάντια. Αυτό άραγε θα το κάνουν και κάποιοι καθαρόαιμοι Πληροφορικοί που αποφεύγουν τον προγραμματισμό όπως ο διάβολος το λιβάνι;

δ) Το ότι η Πληροφορική του ΕΚΠΑ ιδρύθηκε απο καθηγητές της τότε ΦΜΣ δεν το ανέφερα ώς απόδειξη του ότι θα πρέπει να μας πληρώνετε προστασία, αλλά ως ένδειξη του ότι αν ένας ΦΜΣίτης πραγματικά θέλει μπορεί να μάθει προγραμματισμό.

Συγγνώμη για το τηλεγραφικό μήνυμα, καλό ΣΚ.

Φιλικά,
Kurt Godel

Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Stavros στις 06 Νοέ 2007, 09:50:05 πμ
Λοιπόν αποφάσισα τελικά να ανεβάσω κάποιες λύσεις. Κάποιες από αυτές τις λύσεις μπορεί να είναι λάθος αφού τις είχα διορθώσει αλλά δεν είμαι σίγουρος αν αυτά ήταν τα τελικά αρχεία.
Να κατασκευαστεί αλγόριθμος ή πρόγραμμα το οποίο θα κάνει τα ακόλουθα:

i.   Θα διαβάζει τα ονόματα 30 μαθητών και θα τα αποθηκεύει σε κατάλληλο μονοδιάστατο πίνακα.
                              (Μονάδες 1)
ii.   Θα διαβάζει τις απαντήσεις όλων των μαθητών σε 20 ερωτήσεις Σωστού-Λάθους και θα τις καταχωρεί σε κατάλληλο δισδιάστατο πίνακα.                   (Μονάδες 2)

iii.   Θα διαβάζει έναν πίνακα Γ ο οποίος περιέχει τις σωστές απαντήσεις των ερωτήσεων.
                              (Μονάδες 1)
iv.   Με την βοήθεια του πίνακα Γ θα κατασκευάζει έναν μονοδιάστατο πίνακα Δ ο οποίος θα περιέχει τον βαθμό κάθε μαθητή αν γνωρίζουμε ότι κάθε Σωστή απάντηση παίρνει 5 μόρια και κάθε Λάθος αφαιρεί από τον μαθητή 2 μόρια.
                              (Μονάδες 6)
v.   Να υπολογίζει τον μέσο όρο της τάξης και να εμφανίζει το όνομα του μαθητή του οποίου ο βαθμός είναι πιο κοντά στο μέσο όρο της τάξης
                              (Μονάδες 6)
                           
vi.   Να εμφανίζει μήνυμα για το αν υπάρχει ή όχι μαθητής ή μαθητές που να έπιασε το άριστα (100) καθώς και το όνομά  ή τα ονόματά τους.


Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΣΩΣΤΟ_ΛΑΘΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, Κ, ΒΑΘΜΟΣ[30], ΑΘΡΟΙΣΜΑ, Λ, πρόχειρο_β
  ΠΡΑΓΜΑΤΙΚΕΣ: Μ_Ο, ΔΙΑΦΟΡΑ[30], πρόχειρο
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟΜΑ[30], ΑΠΑΝΤΗΣΗ[30, 20], ΣΩΣΤΗ_ΑΠΑΝΤΗΣΗ[20], ΠΡΟΧΕΙΡΟ_Ο
  ΛΟΓΙΚΕΣ: βρέθηκε
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30 ΜΕ_ΒΗΜΑ 1
    ΓΡΑΨΕ 'Δώσε το όνομα του ', Ι, 'ου μαθητή'
    ΔΙΑΒΑΣΕ ΟΝΟΜΑ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30 ΜΕ_ΒΗΜΑ 1
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20 ΜΕ_ΒΗΜΑ 1
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'Δώσε την απάντηση του ', Ι, 'ου μαθητή στην ', Κ, 'η ερώτηση'
        ΔΙΑΒΑΣΕ ΑΠΑΝΤΗΣΗ[Ι, Κ]
      ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠΑΝΤΗΣΗ[Ι, Κ] = 'Σωστό' Η ΑΠΑΝΤΗΣΗ[Ι, Κ] = 'Λάθος'
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20 ΜΕ_ΒΗΜΑ 1
    ΓΡΑΨΕ 'Δώσε την απάντηση της', Κ, 'ης ερώτησης'
    ΔΙΑΒΑΣΕ ΣΩΣΤΗ_ΑΠΑΝΤΗΣΗ[Κ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30 ΜΕ_ΒΗΜΑ 1
    ΒΑΘΜΟΣ[Ι] <- 0
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20 ΜΕ_ΒΗΜΑ 1
      ΑΝ ΑΠΑΝΤΗΣΗ[Ι, Κ] = ΣΩΣΤΗ_ΑΠΑΝΤΗΣΗ[Κ] ΤΟΤΕ
        ΒΑΘΜΟΣ[Ι] <- ΒΑΘΜΟΣ[Ι] + 5
      ΑΛΛΙΩΣ
        ΒΑΘΜΟΣ[Ι] <- ΒΑΘΜΟΣ[Ι] - 2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30 ΜΕ_ΒΗΜΑ 1
    ΓΡΑΨΕ 'Ο μαθητής ', Ι, ' παίρνει ', ΒΑΘΜΟΣ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΘΡΟΙΣΜΑ <- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30 ΜΕ_ΒΗΜΑ 1
    ΑΘΡΟΙΣΜΑ <- ΑΘΡΟΙΣΜΑ + ΒΑΘΜΟΣ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Μ_Ο <- ΑΘΡΟΙΣΜΑ/30
  ΓΡΑΨΕ 'Το μέσο όρο της τάξης είναι: ', Μ_Ο
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30 ΜΕ_ΒΗΜΑ 1
    ΔΙΑΦΟΡΑ[Ι] <- ΒΑΘΜΟΣ[Ι] - Μ_Ο
    ΑΝ ΔΙΑΦΟΡΑ[Ι] < 0 ΤΟΤΕ
      ΔΙΑΦΟΡΑ[Ι] <- ΔΙΑΦΟΡΑ[Ι]*(-1)
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 30 ΜΕΧΡΙ 2 ΜΕ_ΒΗΜΑ -1
    ΑΝ ΔΙΑΦΟΡΑ[Ι] <= ΔΙΑΦΟΡΑ[Ι - 1] ΤΟΤΕ
      πρόχειρο <- ΔΙΑΦΟΡΑ[Ι]
      ΔΙΑΦΟΡΑ[Ι] <- ΔΙΑΦΟΡΑ[Ι - 1]
      ΔΙΑΦΟΡΑ[Ι - 1] <- πρόχειρο
     
      ΠΡΟΧΕΙΡΟ_Ο <- ΟΝΟΜΑ[Ι]
      ΟΝΟΜΑ[Ι] <- ΟΝΟΜΑ[Ι - 1]
      ΟΝΟΜΑ[Ι - 1] <- ΠΡΟΧΕΙΡΟ_Ο
     
      πρόχειρο_β <- ΒΑΘΜΟΣ[Ι]
      ΒΑΘΜΟΣ[Ι] <- ΒΑΘΜΟΣ[Ι - 1]
      ΒΑΘΜΟΣ[Ι - 1] <- πρόχειρο_β
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Λ <- 0
  βρέθηκε <- ΨΕΥΔΗΣ
  ΟΣΟ Ι <= 30 ΚΑΙ βρέθηκε = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    ΑΝ ΔΙΑΦΟΡΑ[Ι] <> ΔΙΑΦΟΡΑ[Ι + 1] ΤΟΤΕ
      Λ <- Λ + 1
      βρέθηκε <- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Ο/Οι μαθητές που είναι πιο κοντά από όλους στον μέσο όρο είναι ο/οι εξής'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Λ ΜΕ_ΒΗΜΑ 1
    ΓΡΑΨΕ ΟΝΟΜΑ[Ι], 'με βαθμό: ', ΒΑΘΜΟΣ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Μιας και ο μέσος όρος όπως είπαμε είναι: ', Μ_Ο
  Λ <- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30 ΜΕ_ΒΗΜΑ 1
    ΑΝ ΒΑΘΜΟΣ[Ι] = 100 ΤΟΤΕ
      Λ <- Λ + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Λ = 0 ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχουν μαθητές που να έχουν βαθμολογία 100'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'υπάρχουν μαθητές που έχουν βαθμολογία 100 και ο αριθμός τους είναι: ', Λ
    ΑΝ Λ = 1 ΤΟΤΕ
      ΓΡΑΨΕ 'Το όνομά του/της είναι '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα ονόματά τους είναι '
    ΤΕΛΟΣ_ΑΝ
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30 ΜΕ_ΒΗΜΑ 1
      ΑΝ ΒΑΘΜΟΣ[Ι] = 100 ΤΟΤΕ
        ΓΡΑΨΕ ΟΝΟΜΑ[Ι]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Άλλο: Η αρμόδια επιτροπή του Υπουργείου Υγείας διενεργεί έρευνα σε 20 ορνιθοτροφεία της ευρύτερης περιοχής της Αττικής τα οποία έχουν 300 πουλερικά το καθένα.
Δίνεται μονοδιάστατος πίνακας Ο[20]στον οποίο είναι καταχωρισμένα τα ονόματα των ορνιθοτροφείων
Επίσης δίνεται δισδιάστατος πίνακας Υ[20,300] στον οποίο είναι καταχωρισμένη η κατάσταση υγείας των πουλερικών. Αν το πουλερικό πάσχει από τη νόσο τότε στον πίνακα  η τιμή είναι Αληθής,. σε διαφορετική περίπτωση η τιμή είναι ψευδής.

Να γίνει αλγόριθμος ο οποίος, δεδομένων των παραπάνω πινάκων:

α) Θα υπολογίζει και θα εμφανίζει το όνομα κάθε ορνιθοτροφείου και το αντίστοιχο ποσοστό των άρρωστων πουλερικών
(Μονάδες 8)

β) Στη συνέχεια, αν το ποσοστό των άρρωστων πουλερικών είναι 0 να εμφανίζει μήνυμα 'Δεν υπάρχει κρούσμα της νόσου'. Αν το ποσοστό είναι κάτω από 30 % και όχι 0 % τότε να εμφανίζεται μήνυμα 'πρέπει να κληθεί ανώτερο κλιμάκιο υγείας'. Σε περίπτωση που το ποσοστό είναι πάνω από 50 % τότε το μήνυμα που θα εμφανίζεται είναι 'Το ορνιθοτροφείο πρέπει να κλείσει άμεσα'.
(Μονάδες 6)

γ)Να εμφανίζει τα ονόματα των 5 ορνιθοτροφείων με τα υψηλότερα ποσοστά άρρωστων πουλερικών.

Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΕΥ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: Ο[3], προχειρο_Ο , Υ[3,5]
  ΑΚΕΡΑΙΕΣ: Ι, Π[3], Κ
  ΠΡΑΓΜΑΤΙΚΕΣ: Τ[3], πρόχειρο
  ΛΟΓΙΚΕΣ: ΠΡ[3,5]
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 3 ΜΕ_ΒΗΜΑ 1
    ΓΡΑΨΕ 'Δώσε το όνομα του ' ,Ι,'ου ορνιθοτροφείου'
    ΔΙΑΒΑΣΕ Ο[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 3 ΜΕ_ΒΗΜΑ 1
    Π[Ι] <- 0
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 5 ΜΕ_ΒΗΜΑ 1
      ΓΡΑΨΕ 'Πείτε αν πάσχει το ',Κ,'ο πουλερικό από το ',Ι,'ο ορνιθοτροφείο'
      ΔΙΑΒΑΣΕ Υ[Ι, Κ]
      ΑΝ Υ[Ι,Κ]='ναι' ΤΟΤΕ
        ΠΡ[Ι,Κ] <- ΑΛΗΘΗΣ
        Π[Ι] <- Π[Ι]+1
      ΑΛΛΙΩΣ
        ΠΡ[Ι,Κ] <- ΑΛΗΘΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 3
    Τ[Ι] <- (Π[Ι]*100)/5
    ΓΡΑΨΕ 'ΤΟ ', Ο[Ι],' έχει ποσοστό άρρωστων πουλερικών:', Τ[Ι]
    ΑΝ Τ[Ι]= 0 ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν υπάρχει κρούσμα νόσου'
    ΑΛΛΙΩΣ_ΑΝ Τ[Ι] < 30 ΤΟΤΕ
      ΓΡΑΨΕ 'πρέπει να κλειθεί ανώτερο κλιμάκειο υγείας'
    ΑΛΛΙΩΣ_ΑΝ Τ[Ι] > 50 ΤΟΤΕ
      ΓΡΑΨΕ 'Το ορνιθοτροφείο πρέπει να κλείσει άμεσα'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 3 ΜΕΧΡΙ 2 ΜΕ_ΒΗΜΑ -1
    ΑΝ Τ[Ι] > Τ[Ι-1] ΤΟΤΕ
      πρόχειρο <- Τ[Ι]
      Τ[Ι] <- Τ[Ι-1]
      Τ[Ι-1] <- πρόχειρο

      προχειρο_Ο <- Ο[Ι]
      Ο[Ι] <- Ο[Ι-1]
      Ο[Ι-1] <- προχειρο_Ο
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Τα 5 μεγαλύτερα κρούσματα άρρωστων πουλερικών εμφανίζονται στα εξής ορνιθοτροφεία'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 2 ΜΕ_ΒΗΜΑ 1
    ΓΡΑΨΕ Ο[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Σε ένα δισκοπωλείο έχει εγκατασταθεί ένα πρόγραμμα το οποίο εκτελεί τις εξής λειτουργίες :

a.   Καταγράφει τους 100 τίτλους των CD’s  που βρίσκονται σε προσφορά για μία εβδομάδα, καθώς και τις αρχικές τους τιμές. Το ποσοστό της έκπτωσης είναι 50%.      

b.   Ζητάει από τον πελάτη να δηλώσει τους τίτλους των CD’s  που θέλει να αγοράσει. Ο πελάτης μπορεί να δηλώσει μέχρι και 3 τίτλους.      
         
c.   Ενημερώνει τον πελάτη για το πόσοι τίτλοι από αυτούς που δήλωσε ανήκουν στους τίτλους που βρίσκονται σε προσφορά. Επίσης τον ενημερώνει για το ποιοι είναι αυτοί οι τίτλοι και ποια η τιμή τους με την  έκπτωση, στην περίπτωση που υπάρχουν.       

Να γράψετε τον αλγόριθμο που υλοποιεί την παραπάνω λειτουργία  .   


Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΨΔ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, ΕΠΙΛΟΓΗ, Κ, Π, θέση[3]
  ΠΡΑΓΜΑΤΙΚΕΣ: ΑΡΧΙΚΗ_ΤΙΜΗ[5], ΠΟΣΟΣΤΟ_ΕΚ
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟΜΑ[5], ΟΝΟΜΑ_CD_Π[3]
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5 ΜΕ_ΒΗΜΑ 1
    ΓΡΑΨΕ 'Δώσε το όνομα από το ', Ι, 'ο CD που είναι σε προσφορά'
    ΔΙΑΒΑΣΕ ΟΝΟΜΑ[Ι]
    ΓΡΑΨΕ 'Δώσε την αρχική τιμή του CD'
    ΔΙΑΒΑΣΕ ΑΡΧΙΚΗ_ΤΙΜΗ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΠΟΣΟΣΤΟ_ΕΚ <- (50/100)
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Πόσα CD θέλετε να αγοράσετε >=1 και <=3'
    ΔΙΑΒΑΣΕ ΕΠΙΛΟΓΗ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠΙΛΟΓΗ = 1 Η ΕΠΙΛΟΓΗ = 2 Η ΕΠΙΛΟΓΗ = 3
  ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ ΕΠΙΛΟΓΗ ΜΕ_ΒΗΜΑ 1
    ΓΡΑΨΕ 'Ποιο είναι το όνομα του CD που θέλετε να αγοράσετε'
    ΔΙΑΒΑΣΕ ΟΝΟΜΑ_CD_Π[Κ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Ι <- 1
  Π <- 0
  ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ ΕΠΙΛΟΓΗ ΜΕ_ΒΗΜΑ 1
    ΟΣΟ Ι <= 5 ΕΠΑΝΑΛΑΒΕ
      ΑΝ ΟΝΟΜΑ_CD_Π[Κ] = ΟΝΟΜΑ[Ι] ΤΟΤΕ
        θέση[Κ] <- Ι
        Π <- Π + 1
        Ι <- Ι + 1
      ΑΛΛΙΩΣ
        Ι <- Ι + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Από τους τίτλους που διαλέξατε υπάρχουν ', Π, ' σε προσφορά'
  ΓΡΑΨΕ 'Οι τίτλοι που διαλέξατε που έχουν προσφορά είναι οι εξής:'
  ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ Π ΜΕ_ΒΗΜΑ 1
    ΓΡΑΨΕ 'ΟΝΟΜΑ:', ΟΝΟΜΑ[θέση[Κ]]
    ΓΡΑΨΕ 'ΑΡΧΙΚΗ_ΤΙΜΗ:', ΑΡΧΙΚΗ_ΤΙΜΗ[θέση[Κ]]
    ΓΡΑΨΕ 'ΤΕΛΙΚΗ_ΤΙΜΗ:', ΑΡΧΙΚΗ_ΤΙΜΗ[θέση[Κ]] - (ΑΡΧΙΚΗ_ΤΙΜΗ[θέση[Κ]]*ΠΟΣΟΣΤΟ_ΕΚ)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Τα αποτελέσματα των αγώνων του Eurobasket (νίκη ή ήττα) καθώς και η διαφορά πόντων για τον όμιλο που ήταν και η Εθνική μας περιέχονται στους παρακάτω πίνακες:
   Τα ονόματα των ομάδων σε μονοδιάστατο πίνακα ΟΝ[6]
   Τον χαρακτηρισμό κάθε αγώνα (″Ν″ ή ″Η″) σε δισδιάστατο πίνακα Α[6,6]
   Τη διαφορά πόντων κάθε αγώνα σε δισδιάστατο πίνακα Π[6,6]
Να γραφεί πρόγραμμα που διαβάζει τα δεδομένα στους παραπάνω πίνακες και εκτυπώνει τη τελική βαθμολογία του ομίλου (ονόματα και βαθμούς) ξεκινώντας από τον καλύτερο
Σημείωση: Σε περίπτωση ισοβαθμίας προηγείται η ομάδα που έχει την καλύτερη διαφορά πόντων από τις ισόβαθμες. Αν έχουν την ίδια διαφορά πόντων, τότε η κατάταξη γίνεται ονομαστικά.
Για παράδειγμα οι πίνακες θα έχουν τη μορφή
ΠΙΝΑΚΑΣ Α   Γερμανία   Ελλάδα   Σερβία   Ιταλία   Ρωσία   Γαλλία
Γερμανία                  
Ελλάδα   Ν               
Σερβία   Η   Η            
Ιταλία   Ν   Ν   Η         
Ρωσία   Η   Η   Η   Ν      
Γαλλία   Ν   Ν   Ν   Ν   Η   

ΠΙΝΑΚΑΣ Π   Γερμανία   Ελλάδα   Σερβία   Ιταλία   Ρωσία   Γαλλία
Γερμανία                  
Ελλάδα   5               
Σερβία   6   7            
Ιταλία   3   4   8         
Ρωσία   8   6   9   9      
Γαλλία   1   8   2   2   7   

ΠΙΝΑΚΑΣ ΟΝ   Γερμανία   Ελλάδα   Σερβία   Ιταλία   Ρωσία   Γαλλία

Κάθε κελί αντιστοιχεί σε έναν αγώνα μεταξύ της ομάδας που αντιστοιχεί στη γραμμή και της ομάδας που αντιστοιχεί στη στήλη.
Το αποτέλεσμα ″Ν″ ή ″Η″ σημαίνει ότι η ομάδα που αντιστοιχεί στη γραμμή νίκησε ή αντίστοιχα έχασε από την ομάδα που αντιστοιχεί στη στήλη. Ο αριθμός δείχνει τη διαφορά πόντων. Π.χ. η Ελλάδα νίκησε τη Γερμανία με 5 πόντους διαφορά ενώ η Σερβία ηττήθηκε από την Ελλάδα με 7 πόντους διαφορά.
Τα στοιχεία της κύριας διαγωνίου δεν περιέχουν καμία πληροφορία αφού καμία ομάδα δεν παίζει με τον εαυτό της.
Ο πίνακας περιέχει στοιχεία μόνο κάτω από τη διαγώνιό του, είναι δηλαδή τετραγωνικός.
Για κάθε αγώνα η νικήτρια ομάδα παίρνει 2 βαθμούς και η ηττημένη 1 βαθμό.

Παρατηρήσεις: Πρώτον δεν ήξερα για διαγώνιους και το έκανα κάπως περίεργα. Αλήθεια θα ήθελα κάποιος να μου πει πως ασ` πούμε δηλώνουμε μία διαγώνιο του πίνακα σε έναν άλλο μονοδιάστατο πίνακα
Δεύτερον υπάρχει ένα λάθος που είδα, ότι δηλαδή προς το τέλος ψάχνει μόνο για να βρει αν υπάρχει ισοβαθμία στην αρχή και όχι σε όλον τον πίνακα(κι αυτό γιατί έτσι νόμιζα στην αρχή αλλά μετά δεν ήθελα να το αλλάξω)
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΕΥΡΩΜΠΑΣΚΕΤ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, Κ, Π[6, 6], ΠΑ[6], πρόχειρο, Χ, ΑΘΡ[6], Ψ
  ΧΑΡΑΚΤΗΡΕΣ: Ον[6], Α[6, 6], πρ_ο
  ΛΟΓΙΚΕΣ: βρέθηκε
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 6 ΜΕ_ΒΗΜΑ 1
    ΓΡΑΨΕ 'Δώσε το όνομα της ', Ι, 'ης ομάδας'
    ΔΙΑΒΑΣΕ Ον[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 6
      ΑΝ Ι <> Κ ΚΑΙ Ι + 1 <> Κ ΚΑΙ Ι + 2 <> Κ ΚΑΙ Ι + 3 <> Κ ΚΑΙ Ι + 4 <> Κ ΚΑΙ Ι + 5 <> Κ ΤΟΤΕ
        ΓΡΑΨΕ 'Δώσε το αποτέλεσμα του παιχνιδιού ', Ον[Ι], ' εναντίον της ομάδας ', Ον[Κ]
        ΔΙΑΒΑΣΕ Α[Ι, Κ]
      ΑΛΛΙΩΣ
        Α[Ι, Κ] <- '-'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 6
      ΑΝ Ι <> Κ ΚΑΙ Ι + 1 <> Κ ΚΑΙ Ι + 2 <> Κ ΚΑΙ Ι + 3 <> Κ ΚΑΙ Ι + 4 <> Κ ΚΑΙ Ι + 5 <> Κ ΤΟΤΕ
        ΓΡΑΨΕ 'Δώσε την διαφορά στο παιχνίδι ', Ον[Ι], ' εναντίων ', Ον[Κ]
        ΔΙΑΒΑΣΕ Π[Ι, Κ]
      ΑΛΛΙΩΣ
        Π[Ι, Κ] <- 0
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 6
    ΠΑ[Ι] <- 0
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 6
      ΑΝ Α[Ι, Κ] = 'Ν' ΤΟΤΕ
        ΠΑ[Ι] <- ΠΑ[Ι] + 2
      ΑΛΛΙΩΣ
        ΠΑ[Ι] <- ΠΑ[Ι] + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Κ ΑΠΟ 2 ΜΕΧΡΙ 6
    ΓΙΑ Ι ΑΠΟ 6 ΜΕΧΡΙ Κ ΜΕ_ΒΗΜΑ -1
      ΑΝ ΠΑ[Ι] > ΠΑ[Ι - 1] ΤΟΤΕ
        πρόχειρο <- ΠΑ[Ι]
        ΠΑ[Ι] <- ΠΑ[Ι - 1]
        ΠΑ[Ι - 1] <- πρόχειρο
       
        πρ_ο <- Ον[Ι]
        Ον[Ι] <- Ον[Ι - 1]
        Ον[Ι - 1] <- πρ_ο
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Χ <- 1
  βρέθηκε <- ΨΕΥΔΗΣ
  Ι <- 1
  ΟΣΟ Ι <= 5 ΚΑΙ βρέθηκε = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    ΑΝ ΠΑ[Ι] = ΠΑ[Ι + 1] ΤΟΤΕ
      Χ <- Χ + 1
      βρέθηκε <- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
    Ι <- Ι + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Χ = 1 ΤΟΤΕ
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ Ι, 'ος: ', Ον[Ι], ' με ', ΠΑ[Ι], ' βαθμούς'
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΛΛΙΩΣ
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 6
      ΑΘΡ[Ι] <- 0
      ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 6
        ΑΘΡ[Ι] <- ΑΘΡ[Ι] + Π[Ι, Κ]
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ Κ ΑΠΟ 2 ΜΕΧΡΙ Χ
      ΓΙΑ Ι ΑΠΟ Χ ΜΕΧΡΙ 2 ΜΕ_ΒΗΜΑ-1
        ΑΝ ΠΑ[Ι] > ΠΑ[Ι - 1] ΤΟΤΕ
          πρόχειρο <- ΠΑ[Ι]
          ΠΑ[Ι] <- ΠΑ[Ι - 1]
          ΠΑ[Ι - 1] <- πρόχειρο
         
          πρ_ο <- Ον[Ι]
          Ον[Ι] <- Ον[Ι - 1]
          Ον[Ι - 1] <- πρ_ο
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Ψ <- 1
    βρέθηκε <- ΨΕΥΔΗΣ
    Ι <- 1
    ΟΣΟ Ι <= Χ ΚΑΙ βρέθηκε = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΑΝ ΠΑ[Ι] = ΠΑ[Ι + 1] ΤΟΤΕ
        Ψ <- Ψ + 1
        βρέθηκε <- ΑΛΗΘΗΣ
      ΑΛΛΙΩΣ
        Ι <- Ι + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ Ψ = 1 ΤΟΤΕ
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 6
        ΓΡΑΨΕ Ι, 'ος: ', Ον[Ι], ' με ', ΠΑ[Ι], ' βαθμούς'
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΛΛΙΩΣ
      ΓΙΑ Κ ΑΠΟ 2 ΜΕΧΡΙ Ψ
        ΓΙΑ Ι ΑΠΟ Ψ ΜΕΧΡΙ 2 ΜΕ_ΒΗΜΑ-1
          ΑΝ Ον[Ι] > Ον[Ι - 1] ΤΟΤΕ
            πρόχειρο <- ΠΑ[Ι]
            ΠΑ[Ι] <- ΠΑ[Ι - 1]
            ΠΑ[Ι - 1] <- πρόχειρο
           
            πρ_ο <- Ον[Ι]
            Ον[Ι] <- Ον[Ι - 1]
            Ον[Ι - 1] <- πρ_ο
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 6
        ΓΡΑΨΕ Ι, 'ος: ', Ον[Ι], ' με ', ΠΑ[Ι], ' βαθμούς'
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Και το τελευταίο  ::)
Έχασα την εκφώνηση αλλά νομίζω είναι ένα πρόσφατο πρόγραμμα που ανέβασε κάποιος:

Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΤΟΞΟΒΟΛΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, Κ
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟΜΑ[10], προχ_ο
  ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΘΜΟΛΟΓΙΑ[10,5], ΜΕΓ[10], ΕΛΑΧ[10], προχ, ΣΥΝΟΛΟ[10]
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10 ΜΕ_ΒΗΜΑ 1
    ΓΡΑΨΕ 'Δώσε το όνομα του ', Ι,'ου διαγωνιζόμενου'
    ΔΙΑΒΑΣΕ ΟΝΟΜΑ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 5
      ΓΡΑΨΕ 'Δώσε τη βαθμολογία του ', Ι,'ου διαγωνιζόμενου στην ', Κ,'η βολή'
      ΔΙΑΒΑΣΕ ΒΑΘΜΟΛΟΓΙΑ[Ι,Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 10
    ΓΙΑ Κ ΑΠΟ 5 ΜΕΧΡΙ 2 ΜΕ_ΒΗΜΑ -1
      ΑΝ ΒΑΘΜΟΛΟΓΙΑ[Ι,Κ] > ΒΑΘΜΟΛΟΓΙΑ[Ι,Κ-1] ΤΟΤΕ
        προχ <- ΒΑΘΜΟΛΟΓΙΑ[Ι,Κ]
        ΒΑΘΜΟΛΟΓΙΑ[Ι,Κ] <- ΒΑΘΜΟΛΟΓΙΑ[Ι,Κ-1]
        ΒΑΘΜΟΛΟΓΙΑ[Ι,Κ-1] <- προχ

        προχ_ο <- ΟΝΟΜΑ[Κ]
        ΟΝΟΜΑ[Κ] <- ΟΝΟΜΑ[Κ-1]
        ΟΝΟΜΑ[Κ-1] <- προχ_ο
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΜΕΓ[Ι] <- ΒΑΘΜΟΛΟΓΙΑ[Ι,1]
    ΕΛΑΧ[Ι] <- ΒΑΘΜΟΛΟΓΙΑ[Ι,5]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ! Δεν το είχα σκεφτεί
  ΜΕΓ[1] <- ΒΑΘΜΟΛΟΓΙΑ[1,1]
  ΕΛΑΧ[1] <- ΒΑΘΜΟΛΟΓΙΑ[1,5]
 ! --------------------------
  ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 10
    ΣΥΝΟΛΟ[Κ] <- 0
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
      ΑΝ ΒΑΘΜΟΛΟΓΙΑ[Κ,Ι]=ΜΕΓ[Κ] Η ΒΑΘΜΟΛΟΓΙΑ[Κ,Ι]=ΕΛΑΧ[Κ] ΤΟΤΕ
        ΣΥΝΟΛΟ[Κ] <- ΣΥΝΟΛΟ[Κ]+0
      ΑΛΛΙΩΣ
        ΣΥΝΟΛΟ[Κ] <- ΣΥΝΟΛΟ[Κ]+ΒΑΘΜΟΛΟΓΙΑ[Κ,Ι]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Κ ΑΠΟ 2 ΜΕΧΡΙ 10
    ΓΙΑ Ι ΑΠΟ 10 ΜΕΧΡΙ Κ ΜΕ_ΒΗΜΑ -1
      ΑΝ ΣΥΝΟΛΟ[Ι] >= ΣΥΝΟΛΟ[Ι-1] ΤΟΤΕ
        προχ <- ΣΥΝΟΛΟ[Ι]
        ΣΥΝΟΛΟ[Ι] <- ΣΥΝΟΛΟ[Ι-1]
        ΣΥΝΟΛΟ[Ι-1] <- προχ

        προχ_ο <- ΟΝΟΜΑ[Ι]
        ΟΝΟΜΑ[Ι] <- ΟΝΟΜΑ[Ι-1]
        ΟΝΟΜΑ[Ι-1] <- προχ_ο
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Κ ΑΠΟ 9 ΜΕΧΡΙ 1 ΜΕ_ΒΗΜΑ -1
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
      ΑΝ ΣΥΝΟΛΟ[Ι]=ΣΥΝΟΛΟ[Ι+1] ΤΟΤΕ
        ΑΝ ΟΝΟΜΑ[Ι] >= ΟΝΟΜΑ[Ι+1] ΤΟΤΕ
          προχ_ο <- ΟΝΟΜΑ[Ι]
          ΟΝΟΜΑ[Ι] <- ΟΝΟΜΑ[Ι+1]
          ΟΝΟΜΑ[Ι+1] <- προχ_ο

          προχ <- ΣΥΝΟΛΟ[Ι]
          ΣΥΝΟΛΟ[Ι] <- ΣΥΝΟΛΟ[Ι+1]
          ΣΥΝΟΛΟ[Ι+1] <- προχ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Το όνομα: ',ΟΝΟΜΑ[Ι], ' έχει ', ΣΥΝΟΛΟ[Ι],' βαθμούς'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Τέλος θέλω να σας δείξω ένα που μου φαίνεται περίεργο:

Σε έναν μονοδιάστατο πίνακα Α είναι καταχωρημένοι 100 ακέραιοι αριθμοί και σε έναν δεύτερο πίνακα Β είναι καταχωρημένοι 200 ακέραιοι αριθμοί. Να γίνει αλγόριθμος ο οποίος:
A.   Θα υπολογίζει και θα εμφανίζει το πλήθος των διαφορετικών αριθμών που υπάρχουν σε κάθε πίνακα ξεχωριστά
B.   Θα εμφανίζει το πλήθος των διαφορετικών αριθμών που εμφανίζονται μόνο στον έναν από τους δυο πίνακες, δηλαδή αυτούς που εμφανίζονται μόνο στον Α ή μόνο στον Β.
Να θεωρήσετε τους πίνακες Α, Β δεδομένους. Να μη γίνει εισαγωγή των στοιχείων τους.

Καλά, ακριβώς το ίδιο δε ζητάει στα δύο ερωτήματα;;;;; πως λύνεται;;;;
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: gpapargi στις 14 Νοέ 2007, 12:59:51 μμ
Σταύρο δεν σε έχουμε ξεχάσει, απλά έχουμε μπλέξει με τα 2 διαγωνίσματα (επανάληψης και επαναληπτικό στα κεφάλαια 1-2) που δημοσιοποιούνται από μέρα σε μέρα. Μόλις ξεμπερδέψουμε με αυτά θα σου δώσουμε απάντηση.

Ωστόσο να μπορεί κάποιος και έχει χρόνο, ας απαντήσει στο παιδί (έστω και σε κάποιες από τις ερωτήσεις).
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: joyjohnnickname στις 28 Φεβ 2010, 07:33:22 μμ
Σταύρο, το πρώτο ερώτημα ζητάει να βρείς πόσοι διαφορετικοί αριθμοί υπάρχουν στον Α και πόσοι στον Β. Στο δεύτερο ερώτημα ζητάει πόσοι είναι οι διαφορετικοί αριθμοι στον Α, τους οποίους δεν έχει ο Β. Μέχρι στιγμής έχω λύσει μόνο το πρώτο, τώρα θα πάω στο 2ο. Μας το έβαλε η καθηγήτρια για το σπίτι. (Ξέρω ότι το forum είναι μόνο για καθηγητές αλλα δεν μπορούσα να αντισταθώ :P)

Αν έχει γίνει λάθος στον παρακάτω κώδικα συγχωρέστε με... Νομίζω πάντως πως λειτουργεί. Είναι μόνο το πρώτο ερώτημα

Αλγόριθμος θέμα_3ο
//δεδομένα Α, Β// !πίνακες Α[100], Β[200] με καταχωρημένους ακέραιους               
Για ι από 2 μέχρι 100 !ταξινόμηση στον πίνακα Α
   Για ξ από 100 μέχρι ι με_βήμα -1
      Αν Α[ξ]<Α[ξ-1] τότε
         Τ←Α[ξ]
         Α[ξ]←Α[ξ-1]
         Α[ξ-1]←Τ
      Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης
Για ι από 2 μέχρι 200 !ταξινόμηση στον πίνακα Β
   Για ξ από 200 μέχρι ι με_βήμα -1
      Αν Β[ξ]<β[ξ-1] τότε
                        Τ←Β[ξ]
         Β[ξ]←Β[ξ-1]
         Β[ξ-1]←Τ
      Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης
πλΑ←0
Για ι από 2 μέχρι 100 !εύρεση πλήθους διαφορετικών αριθμών στον Α
   Αν Α[ι-1]<>Α[ι] τότε
      ΠλΑ←πλΑ+1
   Τέλος_αν
Τέλος_επανάληψης
πλΒ←0
Για ι από 2 μέχρι 200 !εύρεση πλήθους διαφορετικών αριθμών στον Β
   Αν Β[ι-1]<>Β[ι] τότε
      ΠλΒ←πλΒ+1
   Τέλος_αν
Τέλος_επανάληψης
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: evry στις 28 Φεβ 2010, 07:52:34 μμ
  Νομίζω ότι πρέπει να αρχικοποίησεις τα πλΑ, πλΒ σε 1 και όχι 0. Για σκέψου έναν πίνακα με 3 μόνο αριθμούς που είναι και οι 3 διαφορετικοί μεταξύ τους. Πόσες φορές θα αυξηθούν οι μετρητές?
  Κατά τα άλλα η γενική ιδέα της λύσης είναι φυσικά σωστή.

  Τι θα έλεγες όμως για μια λύση χωρίς ταξινόμηση και χωρίς τη χρήση βοηθητικού πίνακα; Αν έχεις χρόνο κοίταξέ το, έχει ενδιαφέρον.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: toufeki στις 01 Μάρ 2010, 03:13:38 μμ
Μια ακόμα πρόκληση - πρόσκληση για τους αγαπητούς μαθητές μας στο ίδιο μήκος κύματος με τον Ευριπίδη.

Δείτε το συνημμένο.


Σημ: Ο χρόνος λήγει αύριο το βράδυ.
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: toufeki στις 02 Μάρ 2010, 07:27:59 μμ
Ασχολήθηκε κάποιος μαθητής με το παραπάνω θέμα;

Τέλος πάντων, ας πάμε ένα βήμα παρακάτω.

Έχω 2 συνημμένα.

Το 1 περιέχει κάποιες οδηγίες - προβληματισμούς - θέματα εξάσκησης.  (diff_nums2.pdf)
και το 2 περιέχει μια δική μου λύση. (diff_nums_solve.exe)

Το 2 είναι όμως κλειδωμένο αρχείο με 7z. Για να το ανοίξετε χρειάζεστε την εφαρμογή συμπίεσης αρχείων 7z - η οποία είναι ελεύθερο λογισμικό - βεβαίως  >:D και τον κωδικό.

Τον κωδικό για το ξεκλείδωμα του αρχείου pdf όμως, θα σας τον ανακοινώσω μεθαύριο. :)
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: Vangelis στις 02 Μάρ 2010, 10:36:10 μμ
Βρίσκεςι ένα αριθμόπου δεν περιέχει ο πίνακας π.χ -999999.
Αρχίζει απο το πρώτο στοιχείου του τον σαρώνεις  και όπου βρείς ένα ίδιο βάζεις στη θέση του το -999999.
Συνεχίζεις με το δεύτερο, το τρίτο κ.λπ (με όσα είναι διάφορα απο το -999999)
Τελικά μετράς πόσοι δαφορετικοί αριθμοί μείνανε στον πίνακα (και τους εμφανίζεις)
Το μόνο μειονέκτημα που βλέπω στην παραπάνω λύση είναι η πιθανότητα να  υπάρχει ο αριθμός -999999 στον πίνακα οπότε θα χάσεις αυτόν τον αριθμό.  Αλλά τι θα "κόβαμε¨γαι την παραπάνω λύση;
(φυσικά υπάρχει η λύση πρώτα να βρίσκεις  έναν αριθμό που δεν υπάρχει στον πίνακα και μετά να συνεχίσεις με τον παραπάνω αλγόριθμο) 
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: toufeki στις 02 Μάρ 2010, 10:40:31 μμ
Βαγγέλη κάνε υπομονή μέχρι μεθαύριο. >:D

Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: toufeki στις 04 Μάρ 2010, 12:29:26 πμ
Επειδή είναι πολύ πιθανό να μην έχω αύριο πρόσβαση στον Η/Υ και για να είμαι συνεπής με τα παιδιά που τυχόν ασχολήθηκαν σας δίνω τον κωδικό για το ξεκλείδωμα του αρχείου diff_nums_solve (pdf): 1234
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: joyjohnnickname στις 12 Μάρ 2010, 01:03:26 μμ
  Νομίζω ότι πρέπει να αρχικοποίησεις τα πλΑ, πλΒ σε 1 και όχι 0. Για σκέψου έναν πίνακα με 3 μόνο αριθμούς που είναι και οι 3 διαφορετικοί μεταξύ τους. Πόσες φορές θα αυξηθούν οι μετρητές?
  Κατά τα άλλα η γενική ιδέα της λύσης είναι φυσικά σωστή.

  Τι θα έλεγες όμως για μια λύση χωρίς ταξινόμηση και χωρίς τη χρήση βοηθητικού πίνακα; Αν έχεις χρόνο κοίταξέ το, έχει ενδιαφέρον.
Ευχαριστώ για την υπόδειξη!!! :) Θα κοιταξω να κανω αυτο που μου είπατε, θα δημοσιεύσω επίσης ολόκληρη την λύση αργότερα (τώρα είμαι στο σχολείο... :P ), με πλΑ και πλΒ αρχικοποιημένα σε 1...  ;D
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: joyjohnnickname στις 12 Μάρ 2010, 03:03:49 μμ
Evry μόλις έιδα γιατί είχα αρχικοποιήσει τα πλΑ και πλΒ με το 0... Δημοσιεύω την λύση μου ολόκληρη παρακάτω... Αν βρείτε λάθος παρακαλώ αναφέρετε το για να το διορθώσω  :)
Κώδικας: [Επιλογή]
Αλγόριθμος θέμα_3ο
//δεδομένα Α, Β// !πίνακες Α[100], Β[200] με καταχωρημένους ακέραιους               
Για ι από 2 μέχρι 100 !ταξινόμηση στον πίνακα Α
Για ξ από 100 μέχρι ι με_βήμα -1
Αν Α[ξ]<Α[ξ-1] τότε
Τ<-Α[ξ]
Α[ξ]<-Α[ξ-1]
Α[ξ-1]<-Τ
Τέλος_αν
Τέλος_επανάληψης
Τέλος_επανάληψης
Για ι από 2 μέχρι 200 !ταξινόμηση στον πίνακα Β
Για ξ από 200 μέχρι ι με_βήμα -1
Αν Β[ξ]<β[ξ-1] τότε
         Τ<-Β[ξ]
Β[ξ]<-Β[ξ-1]
Β[ξ-1]<-Τ
Τέλος_αν
Τέλος_επανάληψης
Τέλος_επανάληψης
πλΑ<-0
Για ι από 2 μέχρι 100 !εύρεση πλήθους διαφορετικών αριθμών στον Α
Αν Α[ι-1]<>Α[ι] τότε
ΠλΑ<-πλΑ+1
ΔιαφΑ[πλΑ]<-Α[ι-1] !Καταχώρηση σε πίνακα με κελιά όσα και οι
!Διαφορετικοί ακέραιοι
Τέλος_αν
Τέλος_επανάληψης  !Σύμφωνα με την παραπάνω επανάληψη, αν δεν βρεθεί !κανένας διαφορετικός αριθμός, δηλαδή αν όλα τα κελιά έχουν τον ίδιο αριθμό,
!τότε το πλήθος είναι 0, αλλά αν βρεθούν δύο διαφορετικοί αριθμοί, η
!επανάληψη πιάνει το πλήθος 1 και αφήνει τον τελευταίο αριθμό έξω, οπότε:
Αν πλ>0 τότε
πλΑ<-πλΑ+1
ΔιαφΑ[πλΑ]<-Α[100]
Τέλος_αν
Γράψε ‘Το σύνολο των διαφορετικών αριθμών στον Α είναι: ’, πλΑ
!Ομοίως για τον Β
πλΒ<-0
Για ι από 2 μέχρι 200
Αν Β[ι-1]<>Β[ι] τότε
ΠλΒ<-πλΒ+1
ΔιαφΒ[πλΒ]<-Β[ι-1]
Τέλος_αν
Τέλος_επανάληψης
Αν πλΒ>0 τότε
πλΒ<-πλΒ+1
ΔιαφΒ[πλΒ]<-Β[200]
Τέλος_αν
Γράψε ‘Το σύνολο των διαφορετικών αριθμών στον Β είναι: ’, πλΒ
!Με καταχωρημένους τους διαφορετικούς αριθμούς των δύο πινάκων σε 2
!άλλους πίνακες, αρκεί να κάνω αναζήτηση στον έναν εμφανίζοντας τα στοιχεία
!τα οποία η αναζήτηση δεν βρίσκει στον άλλον
Αν πλΒ<>0 και πλΑ<>0 τότε
Πλ<-0
Για ι από 1 μέχρι πλΒ
Ε<-0
Για ξ από 1 μέχρι πλΑ
Αν ΔιαφΑ[ξ]=ΔιαφΒ[ι] τότε
Ε<-1
Τέλος_αν
Τέλος_επανάληψης
Αν Ε=0 τότε
Πλ<-πλ+1
Τέλος_αν
Τέλος_επανάληψης
Γράψε ‘Το σύνολο των διαφορετικών αριθμών που εμφανίζονται στον
& πίνακα Β αλλά όχι στον Α είναι: ’, πλ
Αλλιώς
Γράψε ‘Ένας από τους πίνακες δεν περιέχει διαφορετικούς αριθμούς’
Τέλος_αν
Τέλος_θέμα_3ο
Έπειτα θα προσπαθήσω χωρίς ταξινόμιση όπως μου είπατε...  ;)
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: evry στις 12 Μάρ 2010, 04:08:39 μμ
Ενδιαφέρον, να υποθέσω ότι έχεις μπει στο στέκι στο διάλειμμα και όχι την ώρα κάποιου μαθήματος (ονόματα δε λέμε) :police:
Ευχαριστώ για την υπόδειξη!!! :) Θα κοιταξω να κανω αυτο που μου είπατε, θα δημοσιεύσω επίσης ολόκληρη την λύση αργότερα (τώρα είμαι στο σχολείο... :P ), με πλΑ και πλΒ αρχικοποιημένα σε 1...  ;D
Τίτλος: Απ: ΨΕΥΔΟΓΛΩΣΣΑ Η ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ
Αποστολή από: joyjohnnickname στις 12 Μάρ 2010, 09:03:03 μμ
Εγώ δεν λέω τίποτα... Ο καθένας τα συμπεράσματά του...  :angel: Απλα σκεφτείτε ότι μάθημα επιλογής "Πολυμέσα" είμαστε 23 άτομα, και τα μισά είναι οι "θεωρητικιές" της τάξης, που δεν ξέρουν τίποτα άλλο απο το facebook...  :-\ Αλλά όοοοοχι, μόνο 2 άτομα είμασταν για τα Λειτουργικά Συστήματα και τμήμα με 2 άτομα δεν γίνεται... Οπότε...  :'( Όχι πως με χαλάει το στέκι εδώ...  :P Anyway, κανένα σχόλιο για την λύση μου, κανένας...?