Γενικό Λύκειο > Δομή επιλογής

Περιττές ή λανθασμένες συνθήκες

(1/5) > >>

Νίκος Αδαμόπουλος:
Έστω ότι πρέπει να διαβαστεί ο αριθμός των αυγών και μετά... ότι πρέπει να ξεχωρίσουμε κάποιες περιπτώσεις βάσει π.χ. του πίνακα:

α) >=0 και <=10 ...
β) >=11 και <=20 ...
γ) >=21 και <=30 ...
δ) >=31

....
Η άσκηση δε ζητάει έλεγχο εγκυρότητας των δεδομένων εισόδου. Αρκετά συνηθισμένες είναι οι παρακάτω 2 λύσεις:

Α ΛΥΣΗ

Διάβασε α
Αν α<=10 τότε
  ...
αλλιώς_αν α<=20 τότε
  ...
αλλιώς_αν α<=30 τότε
  ...
αλλιώς
  ...
Τέλος_αν

Β ΛΥΣΗ

Διάβασε α
Αν α>=0 και α<=10 τότε
  ...
αλλιώς_αν α<=20 τότε
  ...
αλλιώς_αν α<=30 τότε
  ...
αλλιώς
  ...
Τέλος_αν


Ποια είναι η σωστή;

ntzios kostas:
Αφού δεν έχουμε περίπτωση αρνητικού αριθμού αυγών και τις δύο απαντήσεις τις θεωρώ σωστές.

potato:
Σωστή είναι η Β.
Τώρα αν θα πάρουν και οι 2 όλους τους βαθμούς ..... νομίζω ότι αν ανοιχτεί κουβέντα με επιχειρήματα θα φτάσουμε για άλλη μια φορά στα αφηρημένα θεμέλια του μαθήματος και κατεπέκταση αδυνατεί να δώσει σαφείς απαντήσεις σε ορισμένα θέματα.


Edit: Ωπ, έχει δίκιο ο κ.Παναγιώτης από κάτω.. είχε διπλή συνθήκη στο πρώτο και νόμιζα ότι είχε βάλει σε όλα :p

P.Tsiotakis:
Η β είναι το ίδιο λάθος με την α.

Αν δοθεί αρνητικός αριθμός τότε θα μπει στη δεύτερη περίπτωση.

Θεωρώ όμως πως αφού ΔΕΝ απαιτείται έλεγχοςείναι ΣΩΣΤΕΣ και οι δυο

Laertis:
Αποκλείοντας αρνητικούς αριθμούς είναι σωστές και οι δύο, διαφορετικά είναι λάθος και οι δύο

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση