Γενικό Λύκειο > Γενικά

δεν εχω καμια θεση εδω περα αλλα απλα εχω μια ερωτηση

(1/2) > >>

xyresh96:
]υπαρχει καποιου ειδους εντολη για να κανεις break σε μια λουπα η επαναληψη με βαση λογικου τελεστη αν

πχ δοκιμασα να φτιαξω την εξης λουπα

οσο αληθης επανελαβε
 //καποιες εντολες
 αν (//κατι ειναι αληθες λογω προηγουμενων) τοτε
    //εντολη που σταματαει την λουπα?????αν υπαρχει?????????
τελος επαναληψης

αν υπαρχει κατι αναλογο πειτε μου καθως κοιτωντας την πασκαλ που ειναι ιδια η ψευδογλωσσα αυτο υπαρχει......

gthal:
Δεν υπάρχει κάτι ανάλογο.
Αυτό που θέλεις, θα γίνει μάλλον με μια μεχρις_ότου :

Αρχή_επανάληψης
  //καποιες εντολες
μέχρις_ότου (//κατι ειναι αληθες λογω προηγουμενων)

Νίκος Αδαμόπουλος:

--- Παράθεση από: xyresh96 στις 22 Δεκ 2019, 01:06:13 πμ --- καθως κοιτωντας την πασκαλ που ειναι ιδια η ψευδογλωσσα αυτο υπαρχει......


--- Τέλος παράθεσης ---

Δεν την λες και ίδια!

akalest0s:
Κάτι που επιτρέπεται μεν, αλλά θεωρείται κακή τακτική αλγοριθμικά, και είναι βέβαια, είναι το να μεταβάλεις ρητά (explicitly) την μεταβλητή που ελέγχει την αρχική συνθήκη. Αντιπροτείνεται σε κάθε ευκαιρία από το διδακτικό πακέτο.

Δηλαδή, κάτι του τύπου:


--- Κώδικας: ---ι <- 1
Όσο ι < 10 επανάλαβε
    εντολές
    ι <- ι+1
    Αν συνθήκη τότε
        ι <- 10
    Τέλος_Αν
Τέλος_επανάληψης
--- Τέλος κώδικα ---

gpapargi:
Νομίζω πως το πιο κοντινό σε αυτό που γράφεις είναι το παρακάτω: (χρησιμοποίησα το δικό σου κείμενο κάνοντας μόνο προσθήκες)

λ<--αληθής
οσο λ=αληθης επανάλαβε
 //καποιες εντολες
 αν (//κατι ειναι αληθες λογω προηγουμενων) τοτε
    λ<--ψευδής
 Τέλος_αν
τελος επαναληψης

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση