Γενικό Λύκειο > Δομή επιλογής

Απορια σε ασκηση

(1/2) > >>

captain62792:
Αλγοριθμος υπολογισμου του ελαχιστου τριων ακεραιων αριθμων

εχω κολλησει οποιος μπορει να βοηθησει...

itt:
Που έχεις κολλήσει;


--- Κώδικας: ---min <- a
Αν b < min ΚΑI b < c
     min <-b
Tέλος_Αν

Αν c < min ΚΑΙ c < b
     min <- c
Tέλος_Αν
--- Τέλος κώδικα ---

Δουλεύει αυτό που έγραψα;Μπορείς να το αποδείξεις;Αν όχι, μπορείς να βρεις ένα παραδείγμα για το οποίο δεν δουλεύει;

captain62792:
Αλγόριθμος πχ
Διάβασε α, β, γ
min ← α
Εμφάνισε α
Αν β < min και β < γ τότε
  min ← β
  Εμφάνισε β
Τέλος_αν
Αν γ < min και γ < β τότε
  min ← γ
  Εμφάνισε γ
Τέλος_αν
Τέλος πχ


μου εμφανιζει απο τα 3 νουμερα που βαζω το ελαχιστο..
αυτο θελει η ασκηση γτ με μπερδεψε

itt:
Aυτό που έγραψες,εμφανίζει και το a ανεξάρτητα απο το αν είναι το ελάχιστο.Εσύ θες να εμφανίζεις μόνο ελάχιστο,οπότε μετα το τελευταίο Αν,μπορείς να βάλεις  ἐνα
--- Κώδικας: ---Εμφάνισε min
--- Τέλος κώδικα ---

captain62792:
οκ βγηκε.. ευχαριστω πολυ να στε καλα

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση