Γενικό Λύκειο > Εξετάσεις 2012-2013

προβληματισμός για το θέμα Α4 α

(1/5) > >>

Κανάκη:
Καλησπέρα σας,

έχω μια αντίρρηση για τον τρόπο με τον οποίο αντιμετωπίζεται το θέμα Α4, α όχι μόνο εδώ αλλά και σε άλλα site  :D

Η άσκηση λέει ότι  ότι ο αλγόριθμος πρέπει να ξαναγραφεί ο ίδιος ακριβώς, χωρίς να μεταβάλουμε τίποτα παρά μόνο την δομή επιλογής την οποία πρέπει να εξαλείψουμε. Πιστεύω ότι είναι λάθος να αλλάξουμε τις τιμές στις Για :-\, αλλά πρέπει να  διατηρήσουμε αναλλοίωτο το τμήμα:

Για i από 1 μέχρι 100
Για j από 1 μέχρι 100
......
Διάβασε Π[i,j]
....
Τέλος_επανάληψης
Τέλος_επανάληψης

Μια λυση που θα πρότεινα είναι :

Για i από 1 μέχρι 100
Για j από 1 μέχρι 100
done <-  i< j
όσο done = ΑΛΗΘΗΣ επανάλαβε
Διάβασε Π[i,j]
done <- ΨΕΥΔΗΣ
τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος_επανάληψης

Αυτό μας εξασφαλίζει 0 ή μια εκτέλεση του Διάβασε .. όπως άλλωστε γίνεται και στην Αν ::).

itt:
Έλεγε επι λέξη
--- Παράθεση ---χωρίς τη χρήση της δομής επιλογής
--- Τέλος παράθεσης ---

Οπότε δεν βλέπω το πρόβλημα να κάνεις κάτι στη Για(Στα όρια του επιτρεπτού επ'αυτής that is).

Κανάκη:
Έλεγε:


--- Παράθεση ---Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου
χωρίς τη χρήση της δομής επιλογής, έτσι ώστε να επιτελεί την ίδια
λειτουργία
--- Τέλος παράθεσης ---

 ξαναγράφω δεν σημαίνει ότι γράφω ακριβώς το ίδιο;  :o

itt:
Δεν ξέρω,πιστεύω πως είναι πιο weak,με την έννοια ότι άμα θέλανε περισσότερους περιορισμούς,ας τους καταγράφανε explicitly.

evry:
Δεν υπάρχει πρόβλημα σε αυτό το θέμα.
Μέχρι στιγμής οι λύσεις είναι 3

αυτή με το i+1

αυτή που σαρώνει κατά στήλες οπότε πάει στην εσωτερική επανάληψη από 1 μέχρι j-1

και η λύση με την Όσο και τη λογική μεταβλητή

Για ι από 1 μέχρι 100
     Για j από 1 μέχρι 100
          done <-- i<j
          Όσο done Επανάλαβε
               Διάβασε Π[ι,j]
               done <-- Ψευδής
          Τέλος_Επανάληψης
     Τέλος_Επανάληψης
Τέλος_Επανάληψης


και οι 3 παραπάνω είναι δεκτές

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση