Γενικό Λύκειο > Εξετάσεις 2012-2013

Θέμα Β

(1/24) > >>

gpapargi:
Εδώ μιλάμε για θέμα Β

katif:
Για το Β2.
Ένας μαθητής απάντησε:
ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 100
    ΓΙΑ κ ΑΠΟ 100 ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
        ΑΝ Π[Κ-1]=ΨΕΥΔΗΣ ΚΑΙ Π[κ]=ΑΛΗΘΗΣ ΤΟΤΕ
                ΑΝΤΙΜΕΤΑΘΕΣΕ Π[κ-1], Π[κ]
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠ
ΤΕΛΟΣ_ΕΠ
Θα το πάρουν σωστό;

gpapargi:
Κάνει χρήση του αλγορίθμου ταξινόμησης. Η εκφώνηση λέει χωρίς χρήση αλγορίθμων ταξινόμησης.

eftsousis:
Έχω διαβάσει ορισμένες λυσεις , παραθέτω μια λίγο πιο γρήγορη, με χρήση δυο βοηθητικών δεικτών.

Για i απο 1 μεχρι 100
   k<--1
   λ<--100
   Αν Π = Αληθής τότε  ! Π με δείκτη i ,δεν ξέρω γιατι δε το εμφανίζει
      Π[k] <--Αληθής
          κ  <-- κ + 1
   Αλλιώς
      Π[λ] <-- Ψευδής
          λ  <-- λ - 1
   Τέλος_αν
Τέλος_επανάληψης

soc_h:
Κάνεις εγγραφή σε θέσεις του πίνακα Π που δεν έχεις διαβάσει ακόμα (και άρα χάνεις πληροφορίες σε θέσεις που θα χρειαστεί να διαβάσεις αργότερα).
Δεν είναι σωστό.

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση