Γενικό Λύκειο > Εντολή ΕΠΙΛΕΞΕ

Από Αν σε Επίλεξε

(1/2) > >>

clevercitizen:
Συνάδελφοι καλημέρα

Αλγόριθμος Θ
  Διάβασε x,y
  Av x>y τότε
    Εμφάνισε " Ο πρώτος είναι μεγαλύτερος του 2ου"
  Αλλιώς_αν x<y τότε
    Εμφάνισε "Ο πρώτος είναι μικρότερος του 2ου"
  Αλλιώς
    Εμφάνισε "Οι δύο αριθμοί είναι ίσοι"
  Τέλος_αν
Τέλος Θ

Πώς μπορεί (αν μπορεί) ο παραπάνω αλγόριθμος να μετατραπεί σε Επίλεξε.....Τέλος_Επιλογών?

Έχω μια λύση στο μυαλό μου αλλά περιλαμβάνει και τη δομή επιλογης αν...τέλος_αν.

Ευχαριστώ.

Edit: Με το που έστειλα το θέμα μου ήρθε και η λύση.

Αλγόριθμος Θ
  Διάβασε x,y
  diafora<-- x-y
  Επίλεξε diafora
     Περίπτωση >0
        Εμφάνισε " Ο πρώτος είναι μεγαλύτερος του 2ου"
     Περίπτωση <0
        Εμφάνισε " Ο πρώτος είναι μικρότερος του 2ου"
     Περίπτωση  0
        Εμφάνισε "Οι δύο αριθμοί είναι ίσοι"
     Τέλος_Επιλογών
Τέλος Θ

Και έρχομαι να ρωτήσω τώρα
Η δομή σύνθετης επιλογής Αν...αλλιώς_αν...αλλιώς...Τέλος_αν Μπορεί να μετατραπή σε δομή Επίλεξε...Περιπτωση.....Τέλος_επιλογών.
Σωστό ή λάθος?
Μετατρέπονται όλες οι αν σε περιπτωση ή όχι?   

sstergou:
Πιστεύω ανάλογα με την συνθήκη και τις μεταβλητές που λαμβάνουν μέρος σε αυτήν.

π.χ. για την
Αν α > 4 ΚΑΙ β < 3 τότε
...
αλλιώς_αν γ > 4 ΚΑΙ α > 5 τότε
....
Τέλος_Αν

δεν νομίζω να γίνεται τίποτε από την στιγμή που στην επίλεξε οι εκφράσεις ελέγχου των περιπτώσεων πρέπει να συγκρίνονται πάντα με τον επιλογέα.


clevercitizen:

--- Παράθεση από: sstergou στις 04 Οκτ 2009, 02:29:31 μμ ---Πιστεύω ανάλογα με την συνθήκη και τις μεταβλητές που λαμβάνουν μέρος σε αυτήν.

π.χ. για την
Αν α > 4 ΚΑΙ β < 3 τότε
...
αλλιώς_αν γ > 4 ΚΑΙ α > 5 τότε
....
Τέλος_Αν

δεν νομίζω να γίνεται τίποτε από την στιγμή που στην επίλεξε οι εκφράσεις ελέγχου των περιπτώσεων πρέπει να συγκρίνονται πάντα με τον επιλογέα.

--- Τέλος παράθεσης ---

H σκέψη που έκανα είναι συνδυασμός αν και επίλεξε
δηλ
Αν α > 4 ΚΑΙ β < 3 τότε
   τ<-- 1
αλλιώς_αν γ > 4 ΚΑΙ α > 5 τότε
   τ<-- 2
Τέλος_Αν
Επίλεξε τ
  περίπτωση 1
  .....
  περίπτωση 2
  .....
  Τέλος_επιλογών

Οπότε έμμεσα χρησιμοποιήσαμε την επίλεξε για να εκτελέσουμε τις εντολές .......


P.Tsiotakis:

--- Παράθεση από: clevercitizen στις 04 Οκτ 2009, 01:27:59 μμ ---Αλγόριθμος Θ
  Διάβασε x,y
  Av x>y τότε
    Εμφάνισε " Ο πρώτος είναι μεγαλύτερος του 2ου"
  Αλλιώς_αν x<y τότε
    Εμφάνισε "Ο πρώτος είναι μικρότερος του 2ου"
  Αλλιώς
    Εμφάνισε "Οι δύο αριθμοί είναι ίσοι"
  Τέλος_αν
Τέλος Θ

Πώς μπορεί (αν μπορεί) ο παραπάνω αλγόριθμος να μετατραπεί σε Επίλεξε.....Τέλος_Επιλογών?
--- Τέλος παράθεσης ---

Αλγόριθμος Θ
  Διάβασε x,y
  Επίλεξε x
  Περίπτωση > y
    Εμφάνισε " Ο πρώτος είναι μεγαλύτερος του 2ου"
  Περίπτωση < y
    Εμφάνισε "Ο πρώτος είναι μικρότερος του 2ου"
  Περίπτωση Αλλιώς  ! = y
    Εμφάνισε "Οι δύο αριθμοί είναι ίσοι"
  Τέλος_αν
Τέλος Θ

P.Tsiotakis:

--- Παράθεση από: sstergou στις 04 Οκτ 2009, 02:29:31 μμ ---Πιστεύω ανάλογα με την συνθήκη και τις μεταβλητές που λαμβάνουν μέρος σε αυτήν.

π.χ. για την
Αν α > 4 ΚΑΙ β < 3 τότε
...
αλλιώς_αν γ > 4 ΚΑΙ α > 5 τότε
....
Τέλος_Αν

δεν νομίζω να γίνεται τίποτε από την στιγμή που στην επίλεξε οι εκφράσεις ελέγχου των περιπτώσεων πρέπει να συγκρίνονται πάντα με τον επιλογέα.
--- Τέλος παράθεσης ---

Συμφωνώ  ΔΕΝ γίνεται με Επίλεξε

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση