Αποστολέας Θέμα: ΘΕΜΑ Γ  (Αναγνώστηκε 1448 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3636
  • to Iterate is human to Recurse divine
ΘΕΜΑ Γ
« στις: 17 Ιουν 2021, 02:10:45 μμ »
Λύσεις /Σχόλια / Παρατηρήσεις / προβλήματα αναφορικά με το Θέμα Γ
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

themata

  • Βετεράνος
  • ****
  • Μηνύματα: 54
Απ: ΘΕΜΑ Γ
« Απάντηση #1 στις: 18 Ιουν 2021, 10:40:28 πμ »
Στο Γ2 δεν θα επρεπε ο έλεγχος εγκυρότητας να ελέγχει το ΜΕΓΙΣΤΟ δυνατό βάρος και όχι το ΕΛΑΧΙΣΤΟ? μου διαφεύγει κάτι?

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3636
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #2 στις: 18 Ιουν 2021, 10:44:20 πμ »
όχι, βάζει κάτω όριο στο μέγιστο δυνατό βάρος  :D

Στο Γ2 δεν θα επρεπε ο έλεγχος εγκυρότητας να ελέγχει το ΜΕΓΙΣΤΟ δυνατό βάρος και όχι το ΕΛΑΧΙΣΤΟ? μου διαφεύγει κάτι?

Εδώ σίγουρα θα μπερδευτούν οι μαθητές..
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

themata

  • Βετεράνος
  • ****
  • Μηνύματα: 54
Απ: ΘΕΜΑ Γ
« Απάντηση #3 στις: 18 Ιουν 2021, 10:47:09 πμ »
ευχομαι να πηγε καμια διευκρίνηση/διόρθωση

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3636
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #4 στις: 18 Ιουν 2021, 10:48:21 πμ »
Δεν υπάρχει λόγος να στείλουν διευκρίνηση. Είναι ξεκάθαρο, απλά πρέπει να το διαβάσεις 1-2 φορές παραπάνω για να καταλάβεις τι θέλουν.
ευχομαι να πηγε καμια διευκρίνηση/διόρθωση
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

themata

  • Βετεράνος
  • ****
  • Μηνύματα: 54
Απ: ΘΕΜΑ Γ
« Απάντηση #5 στις: 18 Ιουν 2021, 10:53:33 πμ »
ναι σωστά

progmat

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: ΘΕΜΑ Γ
« Απάντηση #6 στις: 18 Ιουν 2021, 10:56:51 πμ »
Μα αφού λέει δεν πρέπει να ξεπερνάει...πώς θα γίνει ο έλεγχος για τη διακοπή της φόρτωσης..; Το αρχικό συνολικό βάρος δεν πρέπει να είναι 0;

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3636
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #7 στις: 18 Ιουν 2021, 11:03:39 πμ »
Δεν πρέπει να ξεπερνάει ο αριθμός του μέγιστου ορίου, όχι ο όγκος
Δηλαδή πρέπει
μέγιστο όριο <= 300
και μετά
 όγκος <= μέγιστο_όριο
Μα αφού λέει δεν πρέπει να ξεπερνάει...πώς θα γίνει ο έλεγχος για τη διακοπή της φόρτωσης..; Το αρχικό συνολικό βάρος δεν πρέπει να είναι 0;
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

progmat

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: ΘΕΜΑ Γ
« Απάντηση #8 στις: 18 Ιουν 2021, 11:06:28 πμ »
Με το που το ρώτησα το κατάλαβα...σ' ευχαριστώ πολύ! Αλλά όντως αυτό νομίζω θα προξενήσει προβλήματα...

ΔΗΜΗΤΡΗΣ Χ

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 105
Απ: ΘΕΜΑ Γ
« Απάντηση #9 στις: 18 Ιουν 2021, 11:07:41 πμ »
ΤΟ ΜΑΘΗΜΑ ΠΛΕΟΝ ΠΡΕΠΕΙ ΝΑ ΜΕΤΟΝΟΜΑΣΤΕΙ ΣΕ
ΑΠΟΘΗΚΕΥΣΗ ΕΜΠΟΡΕΥΜΑΤΟΚΙΒΩΤΙΩΝ ΣΕ ΠΕΤΟΥΜΕΝΑ Η ΠΛΩΤΑ ;D ;D ;D

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2383
Απ: ΘΕΜΑ Γ
« Απάντηση #10 στις: 18 Ιουν 2021, 11:16:02 πμ »
Μα αφού λέει δεν πρέπει να ξεπερνάει...πώς θα γίνει ο έλεγχος για τη διακοπή της φόρτωσης..; Το αρχικό συνολικό βάρος δεν πρέπει να είναι 0;
Στο Γ2 δεν θα επρεπε ο έλεγχος εγκυρότητας να ελέγχει το ΜΕΓΙΣΤΟ δυνατό βάρος και όχι το ΕΛΑΧΙΣΤΟ? μου διαφεύγει κάτι?

Αυτά δεν υπάρχουν στα θέματα που δημοσιεύτηκαν στο ίντερνετ ρε παιδιά
Κάνω λάθος;;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

themata

  • Βετεράνος
  • ****
  • Μηνύματα: 54
Απ: ΘΕΜΑ Γ
« Απάντηση #11 στις: 18 Ιουν 2021, 11:30:05 πμ »
ουσιαστικά ξενίζει στο ότι ζητείται να εισαχθεί το μέγιστο όριο και θέλει να ελεγχθεί ως προς την ελάχιστη τιμή του και όχι τη μέγιστη, (που συνηθίζεται εως σημερα)

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2383
Απ: ΘΕΜΑ Γ
« Απάντηση #12 στις: 18 Ιουν 2021, 11:34:32 πμ »
Μπορεί να θεωρούμε ότι ένα οποιοδήποτε αεροπλάνο δέχεται τουλάχιστον αυτούς τους αριθμούς
Νομίζω ότι είναι απλό και σαφές αυτό που λέει και δεν θα δημιουργήσει σύγχυση
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

giannakos

  • Οπαδός
  • **
  • Μηνύματα: 13
Απ: ΘΕΜΑ Γ
« Απάντηση #13 στις: 18 Ιουν 2021, 11:35:26 πμ »
Να κάνω μια ερώτηση για τον τερματισμό της επανάληψης στο Γ.
Δεν μπορούμε να χρησιμοποιήσουμε δύο μεταβλητές "διαθέσιμο_βάρος" και "διαθέσιμος_όγκος" όπου στην αρχή θα είναι αυτές που διαβάζονται με έλεγχο εγκυρότητας και στην συνέχεια να έχουμε:

Κώδικας: [Επιλογή]
ΔΙΑΒΑΣΕ βάρος, όγκος
ΟΣΟ βάρος <= διαθεσιμο_βάρος ΚΑΙ όγκος <= διαθέσιμος_όγκος ΕΠΑΝΑΛΑΒΕ
....
διαθέσιμο_βάρος <- διαθέσιμο_βάρος - βάρος
...
...
ΔΙΑΒΑΣΕ βάρος, όγκος
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2383
Απ: ΘΕΜΑ Γ
« Απάντηση #14 στις: 18 Ιουν 2021, 11:36:40 πμ »
Ναι, είναι σωστό
Κι εγώ αυτή την λύση προτείνω
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3636
  • to Iterate is human to Recurse divine
Απ: ΘΕΜΑ Γ
« Απάντηση #15 στις: 18 Ιουν 2021, 11:39:57 πμ »
Μα τι άλλο θα μπορούσαμε να κάνουμε?
Αυτή δεν είναι η πιο νορμάλ λύση;

Να κάνω μια ερώτηση για τον τερματισμό της επανάληψης στο Γ.
Δεν μπορούμε να χρησιμοποιήσουμε δύο μεταβλητές "διαθέσιμο_βάρος" και "διαθέσιμος_όγκος" όπου στην αρχή θα είναι αυτές που διαβάζονται με έλεγχο εγκυρότητας και στην συνέχεια να έχουμε:

Κώδικας: [Επιλογή]
ΔΙΑΒΑΣΕ βάρος, όγκος
ΟΣΟ βάρος <= διαθεσιμο_βάρος ΚΑΙ όγκος <= διαθέσιμος_όγκος ΕΠΑΝΑΛΑΒΕ
....
διαθέσιμο_βάρος <- διαθέσιμο_βάρος - βάρος
...
...
ΔΙΑΒΑΣΕ βάρος, όγκος
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ

  • Βετεράνος
  • ****
  • Μηνύματα: 80
Απ: ΘΕΜΑ Γ
« Απάντηση #16 στις: 18 Ιουν 2021, 12:00:11 μμ »
Να ρωτησω κατι;
Αν καποιος εχει κανει Μεχρις_οτουαλλα δεν εχει βαλει Αν μεσα για την 1η επαναληψη ειναι λαθος;
Με το σκεπτικο οτι στο τελος λεει "να θεωρησετε οτι θα φορτωθεο στο αεροπλανο τουλαχιστον ενα κιβωτιο" 

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 810
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: ΘΕΜΑ Γ
« Απάντηση #17 στις: 18 Ιουν 2021, 01:25:56 μμ »
Να ρωτησω κατι;
Αν καποιος εχει κανει Μεχρις_οτουαλλα δεν εχει βαλει Αν μεσα για την 1η επαναληψη ειναι λαθος;
Με το σκεπτικο οτι στο τελος λεει "να θεωρησετε οτι θα φορτωθεο στο αεροπλανο τουλαχιστον ενα κιβωτιο" 

Με βάση την εκφώνηση μπορεί να το έχει κάνει και με μεχρις_ότου αρκεί (και σε αυτή την περίπτωση) να έχει διάβασε πριν το αρχη_επανάληψης και πριν το μέχρις_ότου
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

grdereken

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 33
Απ: ΘΕΜΑ Γ
« Απάντηση #18 στις: 18 Ιουν 2021, 11:55:29 μμ »
Μία λυση με Μεχρις_ότου και λογικη μεταβλητή
ΣΤΑΜΑΤΑ <- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ Β, Ο
    ΑΝ Β <= ΜΒ ΚΑΙ Ο <= ΜΟ ΤΟΤΕ
      ΜΒ <- ΜΒ - Β
      ΜΟ <- ΜΟ - Ο
      ΠΛ <- ΠΛ + 1
      ΣΒ <- ΣΒ + Β
      ΑΝ Β > ΜΑΧ ΤΟΤΕ
        ΜΑΧ <- Β
        ΠΛ_ΜΑΧ <- 1
      ΑΛΛΙΩΣ_ΑΝ Β = ΜΑΧ ΤΟΤΕ
        ΠΛ_ΜΑΧ <- ΠΛ_ΜΑΧ + 1
      ΤΕΛΟΣ_ΑΝ
     ΑΛΛΙΩΣ
        ΣΤΑΜΑΤΑ <- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΣΤΑΜΑΤΑ = ΑΛΗΘΗΣ

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2383
Απ: ΘΕΜΑ Γ
« Απάντηση #19 στις: 19 Ιουν 2021, 10:20:31 πμ »
Αλήθεια, στο θέμα Γ, υποτίθεται ότι το αεροπλάνο είναι αρχικά άδειο;;;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1092
Απ: ΘΕΜΑ Γ
« Απάντηση #20 στις: 19 Ιουν 2021, 10:27:35 πμ »
Θα έπρεπε να το αναφέρει !  Και όχι να το υπονοεί ...

ApoAntonis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 161
Απ: ΘΕΜΑ Γ
« Απάντηση #21 στις: 19 Ιουν 2021, 10:31:18 πμ »
Δεν θυμάμαι αν έχει ξαναζητηθεί και δεν έχει ιδιαίτερη σημασία
αλλά στο Γ4β
ζητείται να εμφανιστεί το πλήθος των εμπορευματοτέτοιων με το ίδιο μέγιστο βάρος.

Μόνο εγώ αντιλαμβάνομαι διαφορετικά ότι η αρχικοποίηση στο 1 απαντάει στην ερώτηση:
πλήθος εμπορευματοκιβωτίων με βάρος ίσο με το μέγιστο;

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 884
Απ: ΘΕΜΑ Γ
« Απάντηση #22 στις: 19 Ιουν 2021, 11:47:12 πμ »
Και ένας δικός μου μαθητής το σκέφτηκε αυτό.. Εμένα δε μου ταιριάζει πολύ "λογικά".. Δηλαδη έχω μέγιστο το 20 και άλλα τρία μαζί με αυτό.. Έχουμε 4 σύνολο θα έλεγα εγώ.. Αλλα όντως κάποιοι το έχουν σκεφτεί αυτό.. Πάντως επειδή φτιάχνω πολλά διαγώνισματα και εγώ, είναι όντως λίγο δύσκολο να καλύψει κάποιος όλες αυτές τις λεπτομέρειες..

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 169
Απ: ΘΕΜΑ Γ
« Απάντηση #23 στις: 19 Ιουν 2021, 11:00:45 μμ »
Μία λυση με Μεχρις_ότου και λογικη μεταβλητή
ΣΤΑΜΑΤΑ <- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ Β, Ο
    ΑΝ Β <= ΜΒ ΚΑΙ Ο <= ΜΟ ΤΟΤΕ
      ΜΒ <- ΜΒ - Β
      ΜΟ <- ΜΟ - Ο
      ΠΛ <- ΠΛ + 1
      ΣΒ <- ΣΒ + Β
      ΑΝ Β > ΜΑΧ ΤΟΤΕ
        ΜΑΧ <- Β
        ΠΛ_ΜΑΧ <- 1
      ΑΛΛΙΩΣ_ΑΝ Β = ΜΑΧ ΤΟΤΕ
        ΠΛ_ΜΑΧ <- ΠΛ_ΜΑΧ + 1
      ΤΕΛΟΣ_ΑΝ
     ΑΛΛΙΩΣ
        ΣΤΑΜΑΤΑ <- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΣΤΑΜΑΤΑ = ΑΛΗΘΗΣ

ή έτσι:
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ Β, Ο
    do_it <- Β <= ΜΒ ΚΑΙ Ο <= ΜΟ
    ΑΝ do_it ΤΟΤΕ
      ΜΒ <- ΜΒ - Β
      ΜΟ <- ΜΟ - Ο
      ΠΛ <- ΠΛ + 1
      ΣΒ <- ΣΒ + Β
      ΑΝ Β > ΜΑΧ ΤΟΤΕ
        ΜΑΧ <- Β
        ΠΛ_ΜΑΧ <- 1
      ΑΛΛΙΩΣ_ΑΝ Β = ΜΑΧ ΤΟΤΕ
        ΠΛ_ΜΑΧ <- ΠΛ_ΜΑΧ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ OXI do_it

ή έτσι:
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ Β, Ο
    καβαντζαΒ <- Β
    καβαντζαΟ <- Ο

    ΑΝ Β <= ΜΒ ΚΑΙ Ο <= ΜΟ ΤΟΤΕ
      ΜΒ <- ΜΒ - Β
      ΜΟ <- ΜΟ - Ο
      ΠΛ <- ΠΛ + 1
      ΣΒ <- ΣΒ + Β
      ΑΝ Β > ΜΑΧ ΤΟΤΕ
        ΜΑΧ <- Β
        ΠΛ_ΜΑΧ <- 1
      ΑΛΛΙΩΣ_ΑΝ Β = ΜΑΧ ΤΟΤΕ
        ΠΛ_ΜΑΧ <- ΠΛ_ΜΑΧ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΟΧΙ (καβαντζαΒ <= ΜΒ ΚΑΙ καβαντζαΟ <= ΜΟ)

juandojas

  • Νέος
  • *
  • Μηνύματα: 3
Απ: ΘΕΜΑ Γ
« Απάντηση #24 στις: 20 Ιουν 2021, 11:55:45 πμ »

ή έτσι:
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ Β, Ο
    καβαντζαΒ <- Β
    καβαντζαΟ <- Ο

    ΑΝ Β <= ΜΒ ΚΑΙ Ο <= ΜΟ ΤΟΤΕ
      ΜΒ <- ΜΒ - Β
      ΜΟ <- ΜΟ - Ο
      ΠΛ <- ΠΛ + 1
      ΣΒ <- ΣΒ + Β
      ΑΝ Β > ΜΑΧ ΤΟΤΕ
        ΜΑΧ <- Β
        ΠΛ_ΜΑΧ <- 1
      ΑΛΛΙΩΣ_ΑΝ Β = ΜΑΧ ΤΟΤΕ
        ΠΛ_ΜΑΧ <- ΠΛ_ΜΑΧ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΟΧΙ (καβαντζαΒ <= ΜΒ ΚΑΙ καβαντζαΟ <= ΜΟ)

Η συνθήκη τερματισμού εδώ δεν είναι σωστή. Τα ΜΒ και ΜΟ στη συνθήκη της Μέχρις_ότου έχουν αλλάξει τιμή.
Υποθέτω εννοείς κάτι τέτοιο:

 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ Β, Ο
    καβαντζαΒ <- ΜΒ
    καβαντζαΟ <- ΜΟ

    ΑΝ Β <= ΜΒ ΚΑΙ Ο <= ΜΟ ΤΟΤΕ
      ΜΒ <- ΜΒ - Β
      ΜΟ <- ΜΟ - Ο
      ΠΛ <- ΠΛ + 1
      ΣΒ <- ΣΒ + Β
      ΑΝ Β > ΜΑΧ ΤΟΤΕ
        ΜΑΧ <- Β
        ΠΛ_ΜΑΧ <- 1
      ΑΛΛΙΩΣ_ΑΝ Β = ΜΑΧ ΤΟΤΕ
        ΠΛ_ΜΑΧ <- ΠΛ_ΜΑΧ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΟΧΙ (Β<= καβαντζαΒ ΚΑΙ Ο <= καβαντζαΟ)



Σάκης Δημόπουλος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 106
  • Dimopoulos Informatics Tutorials
    • Dimopoulos Informatics Tutorials
Απ: ΘΕΜΑ Γ
« Απάντηση #25 στις: 20 Ιουν 2021, 02:14:15 μμ »
ΠΛΗΡΟΦΟΡΙΚΗ Πανελλήνιες 2021 - Επίλυση θέματος Γ https://www.youtube.com/watch?v=R1AvEIMexss

Ράνια

  • Νέος
  • *
  • Μηνύματα: 2
Απ: ΘΕΜΑ Γ
« Απάντηση #26 στις: 20 Ιουν 2021, 04:54:28 μμ »
Στο θέμα Γ επειδη έλεγε ότι δεν πρέπει το συνολικό βάρος και όγκος να ξεπερνάει το μέγιστο βάρος και ογκο,Έβαλα δύο αθροίσματα μέσα στο αν που βγήκε αληθής για το ότι χωράει το κιβώτιο. Δηλαδη Ένα άθροισμα  για το βάρος και ένα για τον ογκο του κιβωτίου  που τα είχα μηδενίσει εκτός μέχρις ότου. Και έβαλα συνθήκη  μέχρις ότου αθρ βάρους > μέγιστο βάρος ή αθρ όγκου > μέγιστο ογκο . Είναι σωστό αυτό; αν όχι πόσα θα μου κόψουν;

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1092
Απ: ΘΕΜΑ Γ
« Απάντηση #27 στις: 20 Ιουν 2021, 05:08:56 μμ »
Η σωστή :
αθρ_βάρους + β > μέγιστο_βάρος ή αθρ_όγκου + ο > μέγιστο_ ογκου

Ράνια

  • Νέος
  • *
  • Μηνύματα: 2
Απ: ΘΕΜΑ Γ
« Απάντηση #28 στις: 20 Ιουν 2021, 05:09:58 μμ »
 Άρα μεχρι πόσο μπορούν να κόψουν για αυτό;

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1092
Απ: ΘΕΜΑ Γ
« Απάντηση #29 στις: 20 Ιουν 2021, 05:10:36 μμ »
2

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 169
Απ: ΘΕΜΑ Γ
« Απάντηση #30 στις: 20 Ιουν 2021, 11:09:26 μμ »
Η συνθήκη τερματισμού εδώ δεν είναι σωστή. Τα ΜΒ και ΜΟ στη συνθήκη της Μέχρις_ότου έχουν αλλάξει τιμή.
Υποθέτω εννοείς κάτι τέτοιο:

 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ Β, Ο
    καβαντζαΒ <- ΜΒ
    καβαντζαΟ <- ΜΟ

    ΑΝ Β <= ΜΒ ΚΑΙ Ο <= ΜΟ ΤΟΤΕ
      ΜΒ <- ΜΒ - Β
      ΜΟ <- ΜΟ - Ο
      ΠΛ <- ΠΛ + 1
      ΣΒ <- ΣΒ + Β
      ΑΝ Β > ΜΑΧ ΤΟΤΕ
        ΜΑΧ <- Β
        ΠΛ_ΜΑΧ <- 1
      ΑΛΛΙΩΣ_ΑΝ Β = ΜΑΧ ΤΟΤΕ
        ΠΛ_ΜΑΧ <- ΠΛ_ΜΑΧ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΟΧΙ (Β<= καβαντζαΒ ΚΑΙ Ο <= καβαντζαΟ)

προφανώς και έχεις δίκιο
μ' αρέσει που το είχα γράψει λάθος στην πρώτη δημοσίευση, πάτησα να κάνω τροποποίηση, και το ξανακανα λάθος :D