Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Β΄ Λυκείου => Μήνυμα ξεκίνησε από: Σπύρος Δουκάκης στις 09 Οκτ 2014, 11:24:52 μμ

Τίτλος: Κεφ. 2.2. Ενδεικτικές απαντήσεις Ερωτήσεων...Δραστηριοτήτων
Αποστολή από: Σπύρος Δουκάκης στις 09 Οκτ 2014, 11:24:52 μμ
Στο http://introcsprinciples.wordpress.com/ δημοσιεύτηκαν ενδεικτικές απαντήσεις των Ερωτήσεων - Θεμάτων προς συζήτηση - Δραστηριοτήτων του Κεφαλαίου 2.2.

http://wp.me/p53eX3-1p (http://wp.me/p53eX3-1p)
Τίτλος: Απ: Κεφ. 2.2. Ενδεικτικές απαντήσεις Ερωτήσεων...Δραστηριοτήτων
Αποστολή από: tasospap στις 01 Νοε 2014, 10:13:23 μμ
Καλησπέρα,

Για την άσκηση 23 (σελ. 52) του Κεφαλαίου 2, θα μπορούσε να δωθεί επίσης ενδεικτική λύση με χρήση Δομής Επιλογής.

Αλγόριθμος Άσκηση_23
Διάβασε Α
Α ← Α * 100 !για να μετατρέψουμε τον αριθμό σε ακέραιο
Πρώτο_Ψηφίο ← Α div 100
Τελευταία_2_Ψηφία ← Α mod 100
Αν Τελευταία_2_Ψηφία > 49 τότε Πρώτο_Ψηφίο ← Πρώτο_Ψηφίο + 1
Εμφάνισε Πρώτο_Ψηφίο
Τέλος Άσκηση_23
Τίτλος: Απ: Κεφ. 2.2. Ενδεικτικές απαντήσεις Ερωτήσεων...Δραστηριοτήτων
Αποστολή από: andreas_p στις 01 Νοε 2014, 11:04:22 μμ
πλησιέστερος <- Α_Μ(Α+0,5)
Τίτλος: Απ: Κεφ. 2.2. Ενδεικτικές απαντήσεις Ερωτήσεων...Δραστηριοτήτων
Αποστολή από: Σπύρος Δουκάκης στις 02 Νοε 2014, 10:09:53 μμ
Ωραία! Οι δύο προτάσεις εντάχθηκαν στις ενδεικτικές λύσεις!

Παρατήρηση-Σχόλιο:

Η εντολή Αν <σ> τότε εντολή που υπήρχε στην ΑΕΠΠ, στο ΑΕΠΥ περιλαμβάνει Τέλος_αν, δηλαδή σε κάθε περίπτωση:

Αν <σ> τότε
   εντολή
Τέλος_αν

Καλησπέρα,

Για την άσκηση 23 (σελ. 52) του Κεφαλαίου 2, θα μπορούσε να δωθεί επίσης ενδεικτική λύση με χρήση Δομής Επιλογής.

Αλγόριθμος Άσκηση_23
Διάβασε Α
Α ← Α * 100 !για να μετατρέψουμε τον αριθμό σε ακέραιο
Πρώτο_Ψηφίο ← Α div 100
Τελευταία_2_Ψηφία ← Α mod 100
Αν Τελευταία_2_Ψηφία > 49 τότε Πρώτο_Ψηφίο ← Πρώτο_Ψηφίο + 1
Εμφάνισε Πρώτο_Ψηφίο
Τέλος Άσκηση_23
πλησιέστερος <- Α_Μ(Α+0,5)
Τίτλος: Απ: Κεφ. 2.2. Ενδεικτικές απαντήσεις Ερωτήσεων...Δραστηριοτήτων
Αποστολή από: ether στις 02 Νοε 2014, 11:11:50 μμ
Κάποια στιγμή θα πρέπει να τροποποιηθεί κι η εκφώνηση, αφού η εκφώνηση αναφέρει "...να διαβάζει έναν πραγματικό αριθμό..." ενώ οι ενδεικτικές λύσεις αφορούν σε θετικό πραγματικό αριθμό.
Ή να τροποποιηθεί η λύση ώστε να αντιστοιχεί στην εκφώνηση, δηλαδή να δουλεύει και για αρνητικούς πραγματικούς.
π.χ.
Κώδικας: [Επιλογή]
Αν Α >= 0 Τότε
    Ν <- Α_Μ(Α + 0.5)
Αλλιώς
    Ν <- Α_Μ(Α - 0.5)
Τέλος_Αν
Τίτλος: Απ: Κεφ. 2.2. Ενδεικτικές απαντήσεις Ερωτήσεων...Δραστηριοτήτων
Αποστολή από: Σπύρος Δουκάκης στις 02 Νοε 2014, 11:19:54 μμ
Done!

Κάποια στιγμή θα πρέπει να τροποποιηθεί κι η εκφώνηση, αφού η εκφώνηση αναφέρει "...να διαβάζει έναν πραγματικό αριθμό..." ενώ οι ενδεικτικές λύσεις αφορούν σε θετικό πραγματικό αριθμό.
Ή να τροποποιηθεί η λύση ώστε να αντιστοιχεί στην εκφώνηση, δηλαδή να δουλεύει και για αρνητικούς πραγματικούς.
π.χ.
Κώδικας: [Επιλογή]
Αν Α >= 0 Τότε
    Ν <- Α_Μ(Α + 0.5)
Αλλιώς
    Ν <- Α_Μ(Α - 0.5)
Τέλος_Αν

Τίτλος: Απ: Κεφ. 2.2. Ενδεικτικές απαντήσεις Ερωτήσεων...Δραστηριοτήτων
Αποστολή από: ether στις 03 Νοε 2014, 12:24:29 πμ
Για την άσκηση 24 (σελ. 52), θα μπορούσε να δοθεί και η εξής απάντηση που δε χρησιμοποιεί δομή επιλογής:
Κώδικας: [Επιλογή]
Υ <- Χ + 2 - ( Α_Τ(Χ) MOD 2 ) !οι παρενθέσεις θα μπορούσαν και να μη χρησιμοποιηθούν
Τίτλος: Απ: Κεφ. 2.2. Ενδεικτικές απαντήσεις Ερωτήσεων...Δραστηριοτήτων
Αποστολή από: sarakiniotis στις 16 Νοε 2014, 05:20:58 μμ
Στην άσκηση 32
......
Μέχρις_ότου ΠΛΑ = 3 ή ΠΛ = 20       ! το ΠΛ = 20  γιατι χρειάζεται ???



Στην άσκηση 33
....................
Αν Α > 50 τότε
Σ ←Σ + 50                          ! το Σ ←Σ + 50   πρεπει να είναι Σ ←Σ + Α ??   
πλ ← πλ + 1
Τέλος_αν
 
Τίτλος: Απ: Κεφ. 2.2. Ενδεικτικές απαντήσεις Ερωτήσεων...Δραστηριοτήτων
Αποστολή από: Σπύρος Δουκάκης στις 16 Νοε 2014, 07:45:52 μμ
Done!

Στην άσκηση 32
......
Μέχρις_ότου ΠΛΑ = 3 ή ΠΛ = 20       ! το ΠΛ = 20  γιατι χρειάζεται ???



Στην άσκηση 33
....................
Αν Α > 50 τότε
Σ ←Σ + 50                          ! το Σ ←Σ + 50   πρεπει να είναι Σ ←Σ + Α ??   
πλ ← πλ + 1
Τέλος_αν
 

Τίτλος: Απ: Κεφ. 2.2. Ενδεικτικές απαντήσεις Ερωτήσεων...Δραστηριοτήτων
Αποστολή από: sarakiniotis στις 16 Νοε 2014, 08:58:43 μμ
Done!


 ;)