Αποστολέας Θέμα: ΘΕΜΑ Δ  (Αναγνώστηκε 971 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3636
  • to Iterate is human to Recurse divine
ΘΕΜΑ Δ
« στις: 17 Ιουν 2021, 02:10:57 μμ »
Λύσεις /Σχόλια / Παρατηρήσεις / προβλήματα αναφορικά με το Θέμα Δ
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

grdereken

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 33
Απ: ΘΕΜΑ Δ
« Απάντηση #1 στις: 18 Ιουν 2021, 11:46:39 μμ »
Λύση στο Δ4 με μεταφορά κάθε γραμμής σε μονοδιάστατο πίνακα αντί να γίνει ταξινόμηση πάνω στο δισδιάστατο
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 6 !μεταφορά γραμμής Ιης σε μονοδιάστατο
       ΕΠ[J] <- ΕΠΙΔ[Ι, J]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΙΑ Κ ΑΠΟ 2 ΜΕΧΡΙ 6 !Ταξινόμηση Iης γραμμής
       ΓΙΑ J ΑΠΟ 6 ΜΕΧΡΙ K ME_BHMA -1
         ΑΝ ΕΠ[J] > ΕΠ[J-1] TOTE 
          T <- ΕΠ[J]
          ΕΠ[J] <- ΕΠ[J-1]
          ΕΠ[J-1] <- T
        ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

     ΓΡΑΨΕ ΟΝ[Ι]
     ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ ΕΠ[j]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

juandojas

  • Νέος
  • *
  • Μηνύματα: 3
Απ: ΘΕΜΑ Δ
« Απάντηση #2 στις: 19 Ιουν 2021, 12:27:30 μμ »
Αρκετοί μαθητές - από συνήθεια και έχοντας μάθει τυφλοσούρτη κάποιες μεθοδολογίες - στην ταξινόμηση του Δ4, πέρα από τα στοιχεία του 2διάστατου αντιμετέθεταν παράλληλα και τα στοιχεία του μονοδιάστατου με τα ονόματα. Κατά τα άλλα, η ταξινόμηση κάθε γραμμής στον 2διάστατο είναι σωστή. Προφανώς, ο πίνακας με τα ονόματα - στις πρώτες 6 θέσεις του - θα έχει χαλάσει. Πόσο άραγε θα αφαιρεθεί για αυτό το λάθος; Έχω 3 τέτοιες περιπτώσεις μαθητών μου!

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 169
Απ: ΘΕΜΑ Δ
« Απάντηση #3 στις: 19 Ιουν 2021, 10:44:24 μμ »
κάποιος λύνει πρώτα το Δ4 και μετά στο Δ3 εξετάζει για κάθε αθλητή αν η 5η και η 6η επίδοσή του είναι μηδενική!
 :)

Γιαννούλης Γιώργος

  • Βετεράνος
  • ****
  • Μηνύματα: 87
Απ: ΘΕΜΑ Δ
« Απάντηση #4 στις: 20 Ιουν 2021, 10:24:56 πμ »
Αυτό θα ήταν πραγματικά ωραία λύση, αν ήθελε να το τερματίσει τελείως θα ελέγχει μόνο την 5η αν είναι 0. :D

Σάκης Δημόπουλος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 106
  • Dimopoulos Informatics Tutorials
    • Dimopoulos Informatics Tutorials
Απ: ΘΕΜΑ Δ
« Απάντηση #5 στις: 20 Ιουν 2021, 02:16:10 μμ »
ΠΛΗΡΟΦΟΡΙΚΗ Πανελλήνιες 2021 - Επίλυση θέματος Δ https://www.youtube.com/watch?v=M58OG8MAwqM

George Eco

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 504
Απ: ΘΕΜΑ Δ
« Απάντηση #6 στις: 20 Ιουν 2021, 07:15:56 μμ »
Γιατί να μη δούμε τη ταξινόμηση μονοδιάστατου ως εργαλείο που να μπορούμε να το εφαρμόσουμε κάπου out of the box;
ΧΡΟΝΙΑ το λέω. ΔΕΝ υπάρχουν "μεθοδολογίες" να παπαγαλίσει κάποιος.  Υπάρχουν τρόποι για το  πώς γίνεται κάτι.
Δε καταλαβαίνω καν τον ορισμό "μεθοδολογία" πλέον.
Μεθοδολογία είναι ας πούμε ο πίνακας τιμών. Οκ! Όλα καλά εδώ.
Ένα κομμάτι κώδικα, που κάνει κάτι, γιατί το βαφτίσαμε έτσι; Πότε έγινε αυτό;
Και ρωτώ ευθέως, περιμένει κανείς αν τα παιδιά μάθουν απ' έξω "μεθοδολογίες" να πάνε να γράψουν καλά;
Τα παιδιά πρέπει να μάθουν αναλυτική και σύνθετη σκέψη, ώστε να μπορούν να λύσουν ΟΤΙΔΗΠΟΤΕ τους πέσει. 
Τα παιδιά αν ξέρουν τι συμβαίνει και δεν παπαγαλίζουν απλά ένα τσούρμο "μεθοδολογίες" που δε θα ξέρουν πως να τις συνδυάσουν σωστά στο τέλος, τότε μια χαρά γράφουν κοντά στο 100 ή και 100.
Τα παιδιά πρέπει να φροντίζουμε ΕΜΕΙΣ να μη παπαγαλίζουν κώδικες ("μεθοδολογίες"), αλλά να κατανοούν πως τα πράγματα λειτουργούν.
Τα παιδιά θα θυμούνται απλά πως γίνεται το ένα και το άλλο και θα ξέρουν και να τα τροποποιούν ΑΝΑΛΟΓΑ ΤΗΝ ΕΚΦΩΝΗΝΣΗ, αφού θα υπάρχει αναπτυγμένη αναλυτική και σύνθετη σκέψη.

Απ' έξω εγώ ζητάω λίγα πράγματα και μάλιστα εξηγώ ενδελεχώς και πως λειτουργούν. Δε μαθαίνουν παπαγαλία τίποτα.

1] Ταξινόμηση ευθείας ανταλλαγής
2] Δυαδική αναζήτηση
3] Ώθηση
4] Απώθηση
5] Εισαγωγή
6] Εξαγωγή

Κάποιος μάλιστα θύμωσε, θα έλεγα, που έπεσε θέμα Δ δίχως να υπάρχει "έτοιμη μεθοδολιγία". Εμμμ... ναι.... οκ... κι αναλυτική και σύνθετη σκέψη ΠΩΣ θα εξεταστεί και ΠΩΣ θα διαχωρίσεις το δυνατό μαθητή από το μέτριο ή τον απλά καλό;

Με αυτά τα λίγα, παραθέτω τη προσέγγιση της λύσης που πρότεινα εγώ, για το Δ4. Να σημειωθεί πως το άκυρα που έχω βάλει είναι κατάλοιπο που δεν είδα καθώς αφαιρούσα το άλλο υποερώτημα για τα άκυρα. Με άλλα λόγια απομόνωσα τη λύση για το Δ4, αλλά η λύση μου συνδυάζει όπως πρέπει τον κώδικα. Πώς θα το κάνει αυτό παιδί που παπαγαλίζει απλά τμήματα κώδικα βαπτισμένα ως "μεθοδολογίες";




  ! Ταξινομούμε πρώτα, με φθίνουσα σειρά όπως ζητάει.
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    άκυρα <- 0
    ΓΙΑ κ ΑΠΟ 2 ΜΕΧΡΙ 6
      ΓΙΑ λ ΑΠΟ 6 ΜΕΧΡΙ κ ΜΕ_ΒΗΜΑ -1
        ΑΝ ΕΠ[ι,λ-1] < ΕΠ[ι,λ] ΤΟΤΕ
          βοηθ <- ΕΠ[ι,λ-1]
          ΕΠ[ι,λ-1] <- ΕΠ[ι,λ]
          ΕΠ[ι,λ] <- βοηθ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
  ! Πλέον η εμφάνιση των αποτελεσμάτων είναι απλό πράγμα.
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ ΟΝ[ι]
    ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ ΕΠ[ι,κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΥΓ: Σάκης Δημόπουλος: Είδα το video, πολύ καλό και πολύ μου άρεσε η λύση σου συνάδελφε. Συνδράμει με τη δική μου.
« Τελευταία τροποποίηση: 22 Ιουν 2021, 04:07:46 πμ από George Eco »

dpa2006

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 850
Απ: ΘΕΜΑ Δ
« Απάντηση #7 στις: 21 Ιουν 2021, 10:25:14 μμ »
Ο Προγραμματισμός δεν αποστηθίζεται...
Μαθαίνεται και πρέπει να "λερώσεις" τα χέρια σου με κώδικα...!!!
Για όλες τις γλώσσες προγραμματισμού.
Αυτό που μαθαίνεται επίσης και δεν αποστηθίζεται είναι η αλγοριθμική σκέψη.
Πρέπει να μάθεις να σκέφτεσαι Αλγοριθμικά...

https://www.public.gr/product/i-tehni-tis-algorithmikis-epilysis-problimaton/prod1100996pp/

Η Αλγοριθμική σκέψη της επίλυσης προβλημάτων

Το συστήνω χρόνια τώρα...
Computer science (abbreviated CS or CompSci) is the scientific and practical approach to computation and its applications. It is the systematic study of the feasibility, structure, expression, and mechanization of the methodical processes (or algorithms) that underlie the acquisition, representation, processing, storage, communication of, and access to information, whether such information is encoded in bits and bytes in a computer memory or transcribed engines and protein structures in a human cell.source:http://en.wikipedia.org/wiki/Computer_science

George Eco

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 504
Απ: ΘΕΜΑ Δ
« Απάντηση #8 στις: 22 Ιουν 2021, 04:06:17 πμ »
Να αγιάσει το στόμα σου dpa2006 δε διαφωνώ καθόλου.