Αποστολέας Θέμα: ΘΕΜΑ Γ  (Αναγνώστηκε 1357 φορές)

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 167
Απ: ΘΕΜΑ Γ
« Απάντηση #30 στις: 20 Ιουν 2021, 11:09:26 μμ »
Η συνθήκη τερματισμού εδώ δεν είναι σωστή. Τα ΜΒ και ΜΟ στη συνθήκη της Μέχρις_ότου έχουν αλλάξει τιμή.
Υποθέτω εννοείς κάτι τέτοιο:

 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ Β, Ο
    καβαντζαΒ <- ΜΒ
    καβαντζαΟ <- ΜΟ

    ΑΝ Β <= ΜΒ ΚΑΙ Ο <= ΜΟ ΤΟΤΕ
      ΜΒ <- ΜΒ - Β
      ΜΟ <- ΜΟ - Ο
      ΠΛ <- ΠΛ + 1
      ΣΒ <- ΣΒ + Β
      ΑΝ Β > ΜΑΧ ΤΟΤΕ
        ΜΑΧ <- Β
        ΠΛ_ΜΑΧ <- 1
      ΑΛΛΙΩΣ_ΑΝ Β = ΜΑΧ ΤΟΤΕ
        ΠΛ_ΜΑΧ <- ΠΛ_ΜΑΧ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΟΧΙ (Β<= καβαντζαΒ ΚΑΙ Ο <= καβαντζαΟ)

προφανώς και έχεις δίκιο
μ' αρέσει που το είχα γράψει λάθος στην πρώτη δημοσίευση, πάτησα να κάνω τροποποίηση, και το ξανακανα λάθος :D