Γενικό Λύκειο > Γ΄ Λυκείου

Εναλλακτική απάντηση στο θέμα Β1 του 2017

(1/1)

chzisi:
Θυμίζω το ερώτημα Β1 του 2017:

Δίνεται το παρακάτω απόσπασμα αλγορίθμου :
i<-  …(1)
Όσο i≤ …(2) επανάλαβε
  Αν i …(3) <> …(4) τότε
     Γράψε i
  Τέλος_αν
   i<- i+ …(5)
Τέλος_επανάληψης
Να γράψετε στο τετράδιό σας τους αριθμούς 1 έως 5 , που αντιστοιχούν
στα κενά του παραπάνω αποσπάσματος , και δίπλα σε κάθε αριθμό τι
πρέπει να συμπληρωθεί , ώστε με την εκτέλεσή του να εμφανίζονται οι
τιμές:
4, 8, 16, 20, 28, 32, 40
Λοιπόν αν κάποιος μαθητής συμπληρώσει στο κενό (3):  <> 12 και i
 και στο κενό (4): 24 και i <> 36
δεδομένου ότι δεν περιγράφεται από την εκφώνηση τι ακριβώς πρέπει να συμπληρώσει, πχ έκφραση ή μεταβλητή ή τιμή, παίρνει τις μονάδες;
Καλή συνέχεια σε όλους και όλες

Καραμαούνας Πολύκαρπος:
Γιατί όχι; Όλα τα παρακάτω είναι σωστά:

(3) mod 12 (4) 0
(3) mod 6  (4) 0
(3) mod 3  (4) 0
(3) <>12 ΚΑΙ i<>24 ΚΑΙ i (4) 36
(3) <>12 ΚΑΙ i (4) 24 ΚΑΙ i <> 36
(3) >0 KAI i<>12 ΚΑΙ i<>24 ΚΑΙ i (4) 36

και άλλα πολλά

epsilonXi:
i<-  -444
Όσο i≤  444 επανάλαβε
  Αν i  >= 4 και i <= 40 και i mod 4 = 0 και i mod 12 <>  0 τότε
     Γράψε i
  Τέλος_αν
   i<- i+  1
Τέλος_επανάληψης


ουγκ

Πλοήγηση

[0] Λίστα μηνυμάτων

Μετάβαση στην πλήρη έκδοση