Γενικό Λύκειο > Δομή επιλογής

Επιλυση εξίσωσης

(1/2) > >>

elenitaaaaa:
Έστω ότι εχουμε:
Υ=αχ, για -5<χ<=0
Υ=βχ, για  0 <χ <=5
Υ=γχ, για οποιοδηποτε αλλο.

Η λυση:
Αν χ<=0 τοτε
     Αν χ>-5 τοτε
            Υ=α*χ
    αλλιώς
           Υ=γ*χ
   Τέλος_αν
αλλιώς
    Αν χ<=5 τοτε
           Υ=β*χ
     αλλιως
           Υ=γ*χ
     Τελος_αν
Τέλος_αν

έχει σωστο αποτέλεσμα. την πιανουμε σωστη;

petrosp13:
Γιατί όχι;;;

elenitaaaaa:
κ εγω σωστο το πιασα. απλα επειδη δεν ήμουν ποτε βαθμολογήτρια, δεν ξερω ακριβώς τι γινεται σε καποιες περιπτωσεις.
οπως για παράδειγμα στους περιττους ελεγχους.
Αν χ>0 και χ < 8 τοτε
 ......
αλλιως_αν χ>=8 και χ<20 τοτε
......
.....

σ αυτην την περιπτωση κοβουνε στις πανελληνιες;

Νίκος Αδαμόπουλος:

--- Παράθεση από: elenitaaaaa στις 09 Νοε 2012, 12:28:37 πμ ---κ εγω σωστο το πιασα. απλα επειδη δεν ήμουν ποτε βαθμολογήτρια, δεν ξερω ακριβώς τι γινεται σε καποιες περιπτωσεις.
οπως για παράδειγμα στους περιττους ελεγχους.
Αν χ>0 και χ < 8 τοτε
 ......
αλλιως_αν χ>=8 και χ<20 τοτε
......
.....

--- Τέλος παράθεσης ---

Αν και δεν φαίνεται η άσκηση... ωστόσο να ρωτήσω:

ΚΑΙ το χ>0 δεν είναι περιττό; Αν όχι, τότε αν αφαιρέσουμε αυτό που εσύ θεωρείς περιττό, τι θα γίνεται αν το χ=-5;

Gnirut:

--- Παράθεση από: elenitaaaaa στις 08 Νοε 2012, 09:17:06 μμ ---έχει σωστο αποτέλεσμα. την πιανουμε σωστη;

--- Τέλος παράθεσης ---

Εφόσον έχει σωστό αποτέλεσμα φυσικά πιάνεται σωστή.
Εκτός εαν στην εκφώνηση ζητείται κάποιος συγκεκριμένος τρόπος λύσης, π.χ. στο συγκεκριμένο παράδειγμα εαν γραφόταν "χωρίς εμφωλευμένες δομές".


--- Παράθεση ---δεν ξερω ακριβώς τι γινεται σε καποιες περιπτωσεις.
οπως για παράδειγμα στους περιττους ελεγχους.

--- Τέλος παράθεσης ---

στη σελίδα 172 του βιβλίου αναφέρεται:
"Ένα συχνό λάθος που παρατηρείται στα προγράμματα είναι ο έλεγχος περιττών συνθηκών".

Κανονικά δεν θα έπρεπε να κοπεί βαθμός για έναν περιττό έλεγχο, εαν ο αλγόριθμος είναι σωστός.
Έκτός εαν ρητώς στην εκφώνηση ή στις οδηγίες βαθμολόγησης τονιζόταν ότι ζητείται μείωση της πολυπλοκότητας του προγράμματος ή του αλγορίθμου.

Πάντως εφόσον στο βιβλίο αναφέρεται ως "λάθος" καλό θα ήταν οι μαθητές να αποφεύγουν να χρησιμοποιούν περιττούς ελέγχους.

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση