Αποστολέας Θέμα: Θέμα Δ  (Αναγνώστηκε 7720 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3615
  • to Iterate is human to Recurse divine
Θέμα Δ
« στις: 12 Ιουν 2018, 10:35:07 μμ »
Εδώ σχολιάζουμε το θέμα Δ
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

mikezante

  • Βετεράνος
  • ****
  • Μηνύματα: 54
Απ: Θέμα Δ
« Απάντηση #1 στις: 13 Ιουν 2018, 11:17:11 πμ »
Και εδώ
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΔ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πληθος, ι, μ, μαξ, αθρ, λ, ΕΠ[20, 12]
  ΧΑΡΑΚΤΗΡΕΣ: Π[20], τεμπ2
  ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ[20], τεμπ
  ΛΟΓΙΚΕΣ: flag
ΑΡΧΗ
                                                                             !Δ2
  flag <- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ πληθος
  ΜΕΧΡΙΣ_ΟΤΟΥ πληθος > 0 ΚΑΙ πληθος <= 20
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ πληθος
    ΔΙΑΒΑΣΕ Π[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                                                                             !Δ3
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ πληθος
    ΓΡΑΨΕ Π[ι]
    ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 12
      ΚΑΛΕΣΕ Υ_Ε(μαξ)
      ΕΠ[ι, μ] <- μαξ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                                                                             !Δ4
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ πληθος
    αθρ <- 0
    ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 12
      αθρ <- αθρ + ΕΠ[ι, μ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΜΟ[ι] <- αθρ/12
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ πληθος
    ΓΙΑ λ ΑΠΟ πληθος ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
      ΑΝ Π[λ - 1] > Π[λ] ΤΟΤΕ
        τεμπ2 <- Π[λ - 1]
        Π[λ - 1] <- Π[λ]
        Π[λ] <- τεμπ2
        τεμπ <- ΜΟ[λ - 1]
        ΜΟ[λ - 1] <- ΜΟ[λ]
        ΜΟ[λ] <- τεμπ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ πληθος
    ΑΝ ΜΟ[ι] > 7 ΤΟΤΕ
      ΓΡΑΨΕ Π[ι]
      flag <- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ flag = ΨΕΥΔΗΣ ΤΟΤΕ
   ΓΡΑΨΕ "Κανένας ποταμός με ρύπους πάνω απο 7"
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΔΙΑΔΙΚΑΣΙΑ Υ_Ε(ρ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ρ, τιμη
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ τιμη
    ΑΝ τιμη > ρ ΤΟΤΕ
      ρ <- τιμη
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ τιμη = 0
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


 

Διορθωμενο
« Τελευταία τροποποίηση: 13 Ιουν 2018, 11:41:59 πμ από mikezante »
Γεράσιμος Βαρδακαστάνης

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 883
Απ: Θέμα Δ
« Απάντηση #2 στις: 13 Ιουν 2018, 11:19:52 πμ »
στο Δ4 θέλει τα ονόματα αλφαβητικά ... εκεί πρέπει να γίνει η ταξινόμηση νομίζω...εγω τα εβαλα σε νεο πίνακα ....

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 883
Απ: Θέμα Δ
« Απάντηση #3 στις: 13 Ιουν 2018, 11:22:00 πμ »
άκυρο αυτό που λέω βγαίνει πιο ευκολα ετσι .. σωστόοοςςς

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 948
Απ: Θέμα Δ
« Απάντηση #4 στις: 13 Ιουν 2018, 11:24:48 πμ »
Θέλω να δω πώς θα βαθμολογηθεί με μόλις 4 μονάδες το Δ4 (μου πήρε όσο όλα τα υπόλοιπα σε έκταση - πολλά βήματα).
Προφανώς έχουν κάποια άλλη λύση στο νου τους...
Φιλικά,
Γιώργος Θαλασσινός

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1087
Απ: Θέμα Δ
« Απάντηση #5 στις: 13 Ιουν 2018, 11:26:03 πμ »
Η  ... αρχικοποίηση του ρ ;

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1087
Απ: Θέμα Δ
« Απάντηση #6 στις: 13 Ιουν 2018, 11:26:53 πμ »
Το μήνυμα ; (Δ4)

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 948
Απ: Θέμα Δ
« Απάντηση #7 στις: 13 Ιουν 2018, 11:27:05 πμ »
Και εδώ
Κώδικας: [Επιλογή]
...
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ πληθος
    ΑΝ ΜΟ[ι] > 7 ΤΟΤΕ
      ΓΡΑΨΕ Π[ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
θέλεις και έναν μετρητή (ή λογ. μεταβλητη) για την περίπτωση που κανένας ποταμός δεν ικανοποιεί το κριτήριο
Φιλικά,
Γιώργος Θαλασσινός

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 948
Απ: Θέμα Δ
« Απάντηση #8 στις: 13 Ιουν 2018, 11:28:27 πμ »
Θέλω να δω πώς θα βαθμολογηθεί με μόλις 4 μονάδες το Δ4 (μου πήρε όσο όλα τα υπόλοιπα σε έκταση - πολλά βήματα).
Προφανώς έχουν κάποια άλλη λύση στο νου τους...
Υποθέτω πως αν ταξινομήσεις τα ονόματα εξ' αρχής δεν υπάρχει πρόβλημα ?
κι έτσι έχεις λιγότερη δουλειά στο Δ4 ?
Φιλικά,
Γιώργος Θαλασσινός

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1087
Απ: Θέμα Δ
« Απάντηση #9 στις: 13 Ιουν 2018, 11:29:44 πμ »
Πολύ !!!
Στο  Δ5 (8 μονάδες)

Λίγο !!!
Δ4 (4 μονάδες)

Έπρεπε :   6 + 6

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 948
Απ: Θέμα Δ
« Απάντηση #10 στις: 13 Ιουν 2018, 11:33:05 πμ »
Συμφωνώ Ανδρέα
εκπλήσσομαι με αυτή τη βαθμοδότηση ...
Φιλικά,
Γιώργος Θαλασσινός

mikezante

  • Βετεράνος
  • ****
  • Μηνύματα: 54
Απ: Θέμα Δ
« Απάντηση #11 στις: 13 Ιουν 2018, 11:36:03 πμ »
Ωπ όντως!

Θελει ένα έλεγχο στο Δ4. Σορυ :police:
Γεράσιμος Βαρδακαστάνης

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1087
Απ: Θέμα Δ
« Απάντηση #12 στις: 13 Ιουν 2018, 11:37:20 πμ »
Άλλωστε το Δ4 ...

Δ4.1   ΜΟ/Γραμμή (όχι και οι 20 γραμμές, ενδεχομένως)
Δ4.2   Φυσαλίδα αλφαβητική στον Π  ( 1 έως Ν)
Δ4.3    Απλή μεν σάρωση αλλά για μήνυμα (μετρητή ή λογική μεταβλητή)

Άντε μοίρασε ... 4 μονάδες !!!

themata

  • Βετεράνος
  • ****
  • Μηνύματα: 54
Απ: Θέμα Δ
« Απάντηση #13 στις: 13 Ιουν 2018, 11:37:52 πμ »
αν διακρίνω σωστα υπαρχει ένα θέμα στις παραμετρους (μαξ) και (ρ)
αφου μεσα στη διαδικασια συγκρινεται η τιμή > ρ χωρις να εχει παρει τιμή η ρ

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 6099
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Θέμα Δ
« Απάντηση #14 στις: 13 Ιουν 2018, 11:47:51 πμ »
Κάποιοι μαθητές έχουν λύσει το Δ4 με χρήση πίνακα index, δηλαδή, αντί να ταξινομήσουν απευθείας τον πίνακα (=τον καταστρέφουν), ή αντί να τον αντιγράψουν σε άλλον (=πολύ μνήμη), έφτιαξαν έναν πίνακα που οι τιμές του είναι οι θέσεις του πίνακα Π. Και ταξινόμησαν τον index.

Οπότε αν διορθώνετε και δείτε Π[index[ι]] κλπ, ας είναι περίεργο, δώστε λίγο παραπάνω προσοχή μήπως είναι σωστότατο. :)