Αποστολέας Θέμα: Θέμα Δ  (Αναγνώστηκε 7532 φορές)

xara_pap

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 127
Απ: Θέμα Δ
« Απάντηση #60 στις: 15 Ιουν 2018, 02:32:36 μμ »
Παιδια ξερει κανεις τι οδξγια δοθηκε για το αν θα κοπει μοριο αν δν διαβαστει ο πινακας κατα στηλη?

kyriakos208

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Θέμα Δ
« Απάντηση #61 στις: 15 Ιουν 2018, 05:40:35 μμ »
Στη διαδικασία αν παίρνω ολόκληρο τον πίνακα και εκεί κάνω 12 επαναλήψεις για να βρω το MAX είναι λάθος.?Ουσιαστικά αντι να παίρνω ένα ένα στοιχείο παίρνω όλο τον πίνακα μαζί.Θα με κόψουν μόρια?

Λίγο την γνώμη σας.

xara_pap

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 127
Απ: Θέμα Δ
« Απάντηση #62 στις: 15 Ιουν 2018, 11:56:05 μμ »
δεν νομιζω να χασεις

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2370
Απ: Θέμα Δ
« Απάντηση #63 στις: 16 Ιουν 2018, 11:22:00 πμ »
Δηλαδή ουσιαστικά η διαδικασία σου είναι κάπως έτσι;

ΔΙΑΔΙΚΑΣΙΑ Υ_Ε(ΕΠ,i)
...

ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
...τιμή φρουρός με μαχ
ΕΠ[i,j] <-- μαχ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Επειδή η εκφώνηση είναι σαφής ότι θα πρέπει να καλεί για κάθε δειγματοληψία την διαδικασία, θα πρέπει να κοπούν κάποιες μονάδες
Επίσης, αν δεις την εκφώνηση του υποπρογράμματος, δεν αναφέρεται κάτι που να αφορά τον αριθμό "12"
Αν το έχεις πλήρως σωστό σαν υλοποίηση, δεν θα πρέπει να κοπούν πολλές μονάδες (1 θα έλεγα εγώ)

Και φυσικά, αν θεωρήσουμε ότι η υλοποίηση σου κατά γραμμές είναι σωστή, γιατί δεν συμφωνήσαμε ούτε σε αυτό

Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

kyriakos208

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Θέμα Δ
« Απάντηση #64 στις: 16 Ιουν 2018, 02:20:52 μμ »
Δηλαδή ουσιαστικά η διαδικασία σου είναι κάπως έτσι;

ΔΙΑΔΙΚΑΣΙΑ Υ_Ε(ΕΠ,i)
...

ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
...τιμή φρουρός με μαχ
ΕΠ[i,j] <-- μαχ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Επειδή η εκφώνηση είναι σαφής ότι θα πρέπει να καλεί για κάθε δειγματοληψία την διαδικασία, θα πρέπει να κοπούν κάποιες μονάδες
Επίσης, αν δεις την εκφώνηση του υποπρογράμματος, δεν αναφέρεται κάτι που να αφορά τον αριθμό "12"
Αν το έχεις πλήρως σωστό σαν υλοποίηση, δεν θα πρέπει να κοπούν πολλές μονάδες (1 θα έλεγα εγώ)

Και φυσικά, αν θεωρήσουμε ότι η υλοποίηση σου κατά γραμμές είναι σωστή, γιατί δεν συμφωνήσαμε ούτε σε αυτό

Όμως λέει στο ερώτημα να επιστρέφει και να διαβάζει.  Αλλά δεν προσδιορίζει που να τα επιστρέφει.  Στον πίνακα ή στο πρόγραμμα?

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 810
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Θέμα Δ
« Απάντηση #65 στις: 17 Ιουν 2018, 10:15:19 πμ »
Όμως λέει στο ερώτημα να επιστρέφει και να διαβάζει.  Αλλά δεν προσδιορίζει που να τα επιστρέφει.  Στον πίνακα ή στο πρόγραμμα?

Κάθε υποπρόγραμμα "επιστρέφει" σε αυτόν που το καλεί.
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

michaeljohn

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 131
  • "Είναι παιδιά πολλών ανθρώπων τα λόγια μας"
Απ: Θέμα Δ
« Απάντηση #66 στις: 17 Ιουν 2018, 11:42:57 μμ »
Ακόμα πονάει το μυαλό μου..
Από απάντηση μαθητή στις πανελλαδικές
με ένα μικρό λογικό λάθος:

! Δ3
j ← 1
k ← 1
Για i από 1 μέχρι ΠΛ*12        ! ΠΛ : πλήθος ποταμών
  ΓΡΑΨΕ Π
  Αν i mod ΠΛ = 0 τότε
    j ← 0
  Τέλος_αν
  j ← j + 1
  ΚΑΛΕΣΕ Υ_Ε(ΕΠ1)
  Αν i mod ΠΛ ≠ 0 τότε
    Α[j - 1, k]  ΕΠ1
  αλλιώς
   Α[j , k]  ΕΠ1
  Τέλος_αν
  Αν i mod ΠΛ = 0 τότε
    k ← k + 1
  Τέλος_αν
Τέλος_επανάληψης

Ποια να είναι η πιο γρήγορη διόρθωση ώστε να είναι σωστό ?