Αποστολέας Θέμα: Θέμα Δ  (Αναγνώστηκε 7519 φορές)

kstsa

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Θέμα Δ
« Απάντηση #15 στις: 13 Ιουν 2018, 12:22:41 μμ »
το έχω λύσει με συνάρτηση χάνω και τις 8 μονάδες

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3320
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #16 στις: 13 Ιουν 2018, 12:23:36 μμ »
Στο ερώτημα Δ2 η επεξεργασία γίνεται για κάθε δειγματοληψία, άρα κατά στήλες.

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3320
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #17 στις: 13 Ιουν 2018, 12:24:26 μμ »
το έχω λύσει με συνάρτηση χάνω και τις 8 μονάδες

Όχι αλλά θα χάσεις μονάδες (δε μπορώ να εκτιμήσω τι θα αποφασιστεί στα βαθμολογικά κέντρα) σε σχέση με το 8.

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3320
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #18 στις: 13 Ιουν 2018, 12:43:21 μμ »
στην πρώτη σύγκριση στη διαδικασία
το ρ έχει τιμη;;



Και εδώ
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΔ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πληθος, ι, μ, μαξ, αθρ, λ, ΕΠ[20, 12]
  ΧΑΡΑΚΤΗΡΕΣ: Π[20], τεμπ2
  ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ[20], τεμπ
  ΛΟΓΙΚΕΣ: flag
ΑΡΧΗ
                                                                             !Δ2
  flag <- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ πληθος
  ΜΕΧΡΙΣ_ΟΤΟΥ πληθος > 0 ΚΑΙ πληθος <= 20
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ πληθος
    ΔΙΑΒΑΣΕ Π[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                                                                             !Δ3
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ πληθος
    ΓΡΑΨΕ Π[ι]
    ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 12
      ΚΑΛΕΣΕ Υ_Ε(μαξ)
      ΕΠ[ι, μ] <- μαξ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                                                                             !Δ4
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ πληθος
    αθρ <- 0
    ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 12
      αθρ <- αθρ + ΕΠ[ι, μ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΜΟ[ι] <- αθρ/12
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ πληθος
    ΓΙΑ λ ΑΠΟ πληθος ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
      ΑΝ Π[λ - 1] > Π[λ] ΤΟΤΕ
        τεμπ2 <- Π[λ - 1]
        Π[λ - 1] <- Π[λ]
        Π[λ] <- τεμπ2
        τεμπ <- ΜΟ[λ - 1]
        ΜΟ[λ - 1] <- ΜΟ[λ]
        ΜΟ[λ] <- τεμπ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ πληθος
    ΑΝ ΜΟ[ι] > 7 ΤΟΤΕ
      ΓΡΑΨΕ Π[ι]
      flag <- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ flag = ΨΕΥΔΗΣ ΤΟΤΕ
   ΓΡΑΨΕ "Κανένας ποταμός με ρύπους πάνω απο 7"
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΔΙΑΔΙΚΑΣΙΑ Υ_Ε(ρ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ρ, τιμη
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ τιμη
    ΑΝ τιμη > ρ ΤΟΤΕ
      ρ <- τιμη
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ τιμη = 0
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


 

Διορθωμενο

mikezante

  • Βετεράνος
  • ****
  • Μηνύματα: 54
Απ: Θέμα Δ
« Απάντηση #19 στις: 13 Ιουν 2018, 03:30:27 μμ »
Παιδια στη λυση μου το μαξ/ρ απο βιασύνη δεν εχει αρχικοποιηθεί, οπως παρατήρησαν αρκετοι φίλοι παραπάνω.(Αν μπορει καποιος admin να επέμβει στον κωδικα μου, διοτι δεν ειμαι σε pc) :(
Γεράσιμος Βαρδακαστάνης

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3609
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #20 στις: 13 Ιουν 2018, 04:33:58 μμ »
Άλκη ποιος μαθητής μπορεί να έχει κάνει κάτι τέτοιο?
μήπως έδινες εσύ πανελλήνιες? :D
Κάποιοι μαθητές έχουν λύσει το Δ4 με χρήση πίνακα index,
....
Οπότε αν διορθώνετε και δείτε Π[index[ι]] κλπ, ας είναι περίεργο, δώστε λίγο παραπάνω προσοχή μήπως είναι σωστότατο. :)
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

papaluk

  • Μηχ. Η/Υ & Πληρ. ΠΕ19
  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 94
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Δ
« Απάντηση #21 στις: 13 Ιουν 2018, 04:52:09 μμ »
Σε επιτροπή σε μαθητές που εξετάζονται προφορικά, η επιτροπή (30 καθηγητές ) αποφάσισαν ότι δεν θα κοπεί κανένα μόριο.. ενώ η οδηγία έλεγε για διαδικασία..

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2370
Απ: Θέμα Δ
« Απάντηση #22 στις: 13 Ιουν 2018, 04:53:56 μμ »
Και το διάβασε που απαγορεύεται σε συνάρτηση;; Ωραία πράγματα. Αν άλλη επιτροπή αποφασίσει το ορθό, η ισονομία πάει περίπατο
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

pvs

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 133
Απ: Θέμα Δ
« Απάντηση #23 στις: 13 Ιουν 2018, 05:17:13 μμ »
Δεν ξέρω αν έχει τύχει και σε κάποιον άλλον,
μαθητής μου έγραψε
αρχη_επαναληψης
διαβασε πληθος
μεχρις_οτου πληθος<=20
μέχρι εδώ καλά
μετά αρχίζουν τα δύσκολα καθώς όταν αναφερόταν στις γραμμές έγραφε
για ι απο 1 μεχρι 20
και όχι
για ι απο 1 μεχρι πληθος και όλο αυτό το συνέχισε σε κάθε ερώτημα.
Πάει όλο το Δ?

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 948
Απ: Θέμα Δ
« Απάντηση #24 στις: 13 Ιουν 2018, 05:20:07 μμ »
Άλκη ποιος μαθητής μπορεί να έχει κάνει κάτι τέτοιο?
μήπως έδινες εσύ πανελλήνιες? :D
χαχαχα
Κι εγώ το ίδιο ακριβώς σκέφτηκα    ;D
Φιλικά,
Γιώργος Θαλασσινός

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 948
Απ: Θέμα Δ
« Απάντηση #25 στις: 13 Ιουν 2018, 05:24:47 μμ »
Σε επιτροπή σε μαθητές που εξετάζονται προφορικά, η επιτροπή (30 καθηγητές ) αποφάσισαν ότι δεν θα κοπεί κανένα μόριο.. ενώ η οδηγία έλεγε για διαδικασία..
Εγώ προσωπικά θα το χαρώ αυτό γιατί ήμουν ανέκαθεν ενάντια σ' αυτή την αδικαιολόγητη απαγόρευση για τις Συναρτήσεις (που έχει επιφέρει και άλλα προβλήματα και απαγορεύσεις)
Όμως τι γίνεται; κάθε βαθμολογικό βαθμολογεί βάσει δικών του αυθαίρετων κανόνων;
Και τότε πού πάει η ισονομία όπως είπε και ο Πέτρος;
Φιλικά,
Γιώργος Θαλασσινός

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 948
Απ: Θέμα Δ
« Απάντηση #26 στις: 13 Ιουν 2018, 05:26:49 μμ »
Πάει όλο το Δ?
Σίγουρα δεν μηδενίζεται όλο το Δ - αν είναι δυνατόν!
Θα στοιχίσει όμως γιατί είναι σοβαρό λαθάκι
Αλλά και πάλι, κάθε λάθος "τιμωρείται" μία μόνο φορά, οπότε δεν πιστεύω να του κόβουν σε κάθε ερώτημα επειδή θα πηγαίνει ως το 20
Φιλικά,
Γιώργος Θαλασσινός

pgrontas

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 1456
  • There are always possibilities...
Απ: Θέμα Δ
« Απάντηση #27 στις: 13 Ιουν 2018, 05:30:13 μμ »
Αν εχει λυθεί με συνάρτηση πρέπει να σίγουρα κοπούν μονάδες, καθώς θα περιέχει εισαγωγή δεδομένων.
Θεωρώ λογικό να κοπούν 2-3 μονάδες.
« Τελευταία τροποποίηση: 13 Ιουν 2018, 06:14:11 μμ από pgrontas »
Programs must be written for people to read, and only incidentally for machines to execute - Harold Abelson

ολγα

  • Βετεράνος
  • ****
  • Μηνύματα: 88
Απ: Θέμα Δ
« Απάντηση #28 στις: 13 Ιουν 2018, 06:18:31 μμ »
Όλο το Δ;;; :D

Η επιτροπή δίνει στο Δ2β 2 μονάδες. Πόσο να κόψεις; 1 δεν είναι αρκετή; Το ίδιο λάθος πόσες φορές πρέπει να το μετρήσεις τη στιγμή που δεν επηρεάζει την προγραμματιστική δυσκολία των υπόλοιπων ερωτημάτων;

pvs

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 133
Απ: Θέμα Δ
« Απάντηση #29 στις: 13 Ιουν 2018, 06:46:54 μμ »
Ευχαριστώ για τις απαντήσεις σας. Οκ το έθεσα υπερβολικά όταν έγραψα για όλο το Δ αλλά "μη βαράτε"  :) :) :)