Αποστολέας Θέμα: Θέμα Β  (Αναγνώστηκε 18816 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3609
  • to Iterate is human to Recurse divine
Θέμα Β
« στις: 12 Ιουν 2018, 10:32:50 μμ »
Εδώ σχολιάζουμε το Θέμα Β
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

themata

  • Βετεράνος
  • ****
  • Μηνύματα: 54
Απ: Θέμα Β
« Απάντηση #1 στις: 13 Ιουν 2018, 11:09:26 πμ »
Β2.

ΔΙΑΒΑΣΕ Σ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΔΙΑΒΑΣΕ Α
ΑΝ Α<>0 ΤΟΤΕ
Σ←Σ+Α
ΤΕΛΟΣ_ΑΝ
ΜΕΧΡΙΣ_ΟΤΟΥ Α=0
ΓΡΑΨΕ Σ
----- -----

ΔΙΑΒΑΣΕ Σ
ΔΙΑΒΑΣΕ Α
ΟΣΟ Α<>0 ΕΠΑΝΑΛΑΒΕ
Σ←Σ+Α
ΔΙΑΒΑΣΕ Α
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ Σ
« Τελευταία τροποποίηση: 13 Ιουν 2018, 11:23:27 πμ από themata »

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 882
Απ: Θέμα Β
« Απάντηση #2 στις: 13 Ιουν 2018, 11:10:32 πμ »
νομίζω αυτό χρησιμποιεί πιο πολλές εντολές από τα σχήματα..νομίζω θέλει όσο

pvs

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 133
Απ: Θέμα Β
« Απάντηση #3 στις: 13 Ιουν 2018, 11:13:47 πμ »
οσο με αντιστροφή συνθήκης
ΔΙΑΒΑΣΕ Σ
ΔΙΑΒΑΣΕ Α
ΟΣΟ Α<>0 ΕΠΑΝΑΛΑΒΕ
        Σ<-Σ+Α
        ΔΙΑΒΑΣΕ Α
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΕΜΦΑΝΙΣΕ Σ

themata

  • Βετεράνος
  • ****
  • Μηνύματα: 54
Απ: Θέμα Β
« Απάντηση #4 στις: 13 Ιουν 2018, 11:16:02 πμ »
νομίζω αυτό χρησιμποιεί πιο πολλές εντολές από τα σχήματα..νομίζω θέλει όσο
Πρόσθεσα και την εκδοχή με ΟΣΟ, θεωρεις οτι η ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ θα είναι λάθος?

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 882
Απ: Θέμα Β
« Απάντηση #5 στις: 13 Ιουν 2018, 11:16:55 πμ »
και τα δύο σωστά είναι σαν λογική, απλά δεν ξέρω τι οδηγίες έχουν στη διώρθωση ...

dg69

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 72
  • Όλα καλά, όλα ανθηρά
Απ: Θέμα Β
« Απάντηση #6 στις: 13 Ιουν 2018, 11:18:47 πμ »
"Να κωδικοποιήσετε σε ΓΛΩΣΣΑ αντίστοιχο τμήμα προγράμματος που να εκτελεί ακριβώς την ίδια ακολουθία εντολών (βημάτων)".
Αρα ενώ το αποτέλεσμα είναι το ίδιο, η σειρά των εντολών; Πρέπει να δούμε τις οδηγίες της βαθμολόγησης

pstasinos

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 44
Απ: Θέμα Β
« Απάντηση #7 στις: 13 Ιουν 2018, 11:19:23 πμ »
ΔΙΑΒΑΣΕ Σ
ΔΙΑΒΑΣΕ Α
ΑΝ Α<>0 ΤΟΤΕ
 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
  Σ<-Σ+1
  ΔΙΑΒΑΣΕ Α
  ΜΕΧΡΙΣ_ΟΤΟΥ Α=0
ΤΕΛΟΣ_ΑΝ
ΕΜΦΑΝΙΣΕ Σ

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 948
Απ: Θέμα Β
« Απάντηση #8 στις: 13 Ιουν 2018, 11:20:13 πμ »
Ποια η γνώμη σας για το Θέμα Β2;
Γιατί εμένα με ενόχλησε. Έχω μια τέτοια άσκηση στις επαναληπτικές μου, και δεν την κάνω πλέον γιατί ένιωθα ότι "τι πας να μας δείξεις πια!", και ούτως ή άλλως τη θεωρούσα ακραία και λίγο "ανέντιμη", αλλά την έκανα, όπου μας έπαιρνε.
Δηλαδή τι πάμε να εξετάσουμε πια ;;;
Φιλικά,
Γιώργος Θαλασσινός

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1085
Απ: Θέμα Β
« Απάντηση #9 στις: 13 Ιουν 2018, 11:23:53 πμ »
Ελέγχουμε τη θέση της συνθήκης (συνέχειας ή τερματισμού) σε σχέση με το βρόχο.

dg69

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 72
  • Όλα καλά, όλα ανθηρά
Απ: Θέμα Β
« Απάντηση #10 στις: 13 Ιουν 2018, 11:27:24 πμ »
Ποια η γνώμη σας για το Θέμα Β2;
Γιατί εμένα με ενόχλησε. Έχω μια τέτοια άσκηση στις επαναληπτικές μου, και δεν την κάνω πλέον γιατί ένιωθα ότι "τι πας να μας δείξεις πια!", και ούτως ή άλλως τη θεωρούσα ακραία και λίγο "ανέντιμη", αλλά την έκανα, όπου μας έπαιρνε.
Δηλαδή τι πάμε να εξετάσουμε πια ;;;


Συμφωνώ!

konnacarmen

  • Μηχανικών Η/Υ
  • Θαμώνας
  • ***
  • Μηνύματα: 36
Απ: Θέμα Β
« Απάντηση #11 στις: 13 Ιουν 2018, 11:30:10 πμ »
το Β1?

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1085
Απ: Θέμα Β
« Απάντηση #12 στις: 13 Ιουν 2018, 11:31:50 πμ »
Β1. Μια παραλλαγή της φυσαλίδας ...

smart bubble sort

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1152
Απ: Θέμα Β
« Απάντηση #13 στις: 13 Ιουν 2018, 11:39:36 πμ »
Για το Β2 η πιο σωστη λύση ειναι αυτή με την εντολή ΟΣΟ καθως η λύση με τη μέχρις ότου χρησιμοποιεί και την εντολή ΑΝ , η οποία δεν υπάρχει στο διάγραμμα.

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2466
  • I 'm not young enough to know everything
Απ: Θέμα Β
« Απάντηση #14 στις: 13 Ιουν 2018, 11:43:25 πμ »
2 γρήγορα σχόλια από μένα για το Β2:
1) Το ΔΡ είναι αδόμητο άρα το θεωρώ όχι καλή ιδέα. Δείχνει το λόγο για τον οποίο τα ΔΡ είναι ξεπερασμένα.
2) Αν πας με Μέχρις_ότου θέλει όλη την Μέχρις_ότου μέσα σε Αν για να εκτελεστεί ο έλεγχος της Αν μόνο μια φορά. Αν βάλεις την Αν μέσα στη Μέχρις_ότου κάνεις πιο πολλούς ελέγχους, άρα όχι τα ίδια βήματα.