Αποστολέας Θέμα: ερώτηση για θέμα πανελληνίων (2007)  (Αναγνώστηκε 2135 φορές)

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
ερώτηση για θέμα πανελληνίων (2007)
« στις: 06 Απρ 2012, 01:32:33 μμ »
έχω μια απορία όσον αφορά το 3ο Θέμα των πανελληνίων του 2007....η λύση μου είναι η παρακάτω...απλώς μήπως μπορεί να μου εξηγήσει κανείς γιατι εκεί που έχω βάλει (1) και (2) υπάρχει λάθος??? στο φροντιστήριο μας έβαλε να την λύσουμε και είπε ο φροντιστής ότι υπάρχει λάθος....τον ρώτησα γιατί και μου λέει βάλε νούμερα και θα δεις...αργότερα που το έτρεξα τον διερμηνευτή έτρεχε μια χαρά (πιστεύω)...σας παρακαλώ διαφωτίστε με!!!

Αλγόριθμος Θεμα_3
ποσο ← 1500
πλε ← 0
πλξ ← 0
Διάβασε τιμη, προελευση
Όσο ποσο - τιμη ≥ 0 επανάλαβε
ποσο ← ποσο - τιμη
Αν προελευση = "ελληνικο" τότε
πλε ← πλε + 1
αλλιώς
πλξ ← πλξ + 1
Τέλος_Αν
Διάβασε τιμη, προελευση
Τέλος_επανάληψης
Εμφάνισε 1500 - ποσο !αυτα που ξοδεψε (1)
Εμφάνισε "Τελος αγορων"
Εμφάνισε πλε,πλξ
Αν 1500 - ποσο = 1500 τότε (2)
Εμφάνισε "εξαντληθηκε ολο το ποσο"
αλλιώς
Εμφάνισε ποσο
Τέλος_αν
Τέλος θεμα_3
« Τελευταία τροποποίηση: 07 Απρ 2012, 11:38:09 πμ από Πανάγος94 »

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3320
    • P.Tsiotakis
Απ: ερώτηση για θέμα πανελληνίων (2007)
« Απάντηση #1 στις: 06 Απρ 2012, 02:09:05 μμ »
μάλλον εννοούσε πως η προέλευση πρέπει να διαβάζεται σε 1 σημείο στην αρχή του Όσο
δε συμμετέχει στη συνθήκη του Όσο και αν φτάσεις στο σημείο να τερματίσεις δεν έχει νόημα να διαβάσεις προέλευση για το γραμματόσημο που δε μπορεί να αγοραστεί

πάντως η εκφώνηση αναφέρει πως πρέπει να διαβάζεται τιμή και προέλευση για κάθε γραμματόσημο και στη συνέχεια να ελέγχει αν μπορεί να αγοραστεί, οπότε είναι σωστή η λύση σου έτσι κι αλλιώς
επιφυλάσσομαι (γιατί γιατί δουλεύω από κινητό)

μπορείς να δει τη λύση της άσκησης και στα βίντεο:
1. http://youtu.be/BGU6HkUIsEo
2. http://youtu.be/dcxYUou7TxI
το 2 είναι πιο κοντά στη λύση σου

καλή συνέχεια

im99_chs

  • Ομάδα διαγωνισμάτων 2012
  • *
  • Μηνύματα: 1
Απ: ερώτηση για θέμα πανελληνίων (2007)
« Απάντηση #2 στις: 26 Απρ 2012, 10:16:24 πμ »
Φίλε μου σου παραθέτω μια άλλη λύση που θεωρώ ότι είναι πιο πλήρης.
Οποιοσδηποτε σχολιασμός ή εύρεση λάθους παρακαλώ να μου το πείτε    :D !!!


Αλγόριθμος Θ_3_2007
πλ_ελ <-- 0
πλ_ξ   <-- 0
ΑΓΟΡΑ <-- ΑΛΗΘΗΣ
Σ <-- 0
Οσο Σ < 1500 και ΑΓΟΡΑ  = ΑΛΗΘΗΣ
    Διάβασε πρ , τ
    Αν πρ = 'ελληνικό' τότε
         Σ <-- Σ + τ
         πλ_ελ <-- πλ_ελ + 1
         Αν Σ > 1500 τότε
              Σ <-- Σ - τ
              πλ_ελ <-- πλ_ελ - 1
              ΑΓΟΡΑ <- ΨΕΥΔΗΣ
         Τελος_Αν

    Αλλιώς_Αν πρ = 'ξένο' τότε
         Σ <-- Σ + τ
         πλ_ξ <-- ξ_ελ + 1
         Αν Σ > 1500 τότε
              Σ <-- Σ - τ
              πλ_ξ <-- πλ_ξ - 1
              ΑΓΟΡΑ <- ΨΕΥΔΗΣ
         Τελος_Αν

     Τελος_Αν

     Αν ΑΓΟΡΑ = ΨΕΥΔΗΣ τότε
        Εμφάνισε 'ΤΕΛΟΣ ΑΓΟΡΩΝ'
     ΤΕΛΟΣ_ΑΝ
       
Τέλος_Επανάληψης

Εμφάνισε πλ_ελ, πλ_ξ , Σ
Αν Σ < 1500 τοτε
    Εμφάνισε 1500 - Σ , ' περίσσεψαν'
Αλλιώς
    Εμφάνισε 'Εξαντλήθηκε όλο το ποσο'
Τέλος Αν

Τέλος Θ_3_2007   




manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: ερώτηση για θέμα πανελληνίων (2007)
« Απάντηση #3 στις: 26 Απρ 2012, 09:42:37 μμ »
έχω μια απορία όσον αφορά το 3ο Θέμα των πανελληνίων του 2007....η λύση μου είναι η παρακάτω...απλώς μήπως μπορεί να μου εξηγήσει κανείς γιατι εκεί που έχω βάλει (1) και (2) υπάρχει λάθος??? στο φροντιστήριο μας έβαλε να την λύσουμε και είπε ο φροντιστής ότι υπάρχει λάθος....τον ρώτησα γιατί και μου λέει βάλε νούμερα και θα δεις...αργότερα που το έτρεξα τον διερμηνευτή έτρεχε μια χαρά (πιστεύω)...σας παρακαλώ διαφωτίστε με!!!

Αλγόριθμος Θεμα_3
ποσο ← 1500
πλε ← 0
πλξ ← 0
Διάβασε τιμη, προελευση
Όσο ποσο - τιμη ≥ 0 επανάλαβε
ποσο ← ποσο - τιμη
Αν προελευση = "ελληνικο" τότε
πλε ← πλε + 1
αλλιώς
πλξ ← πλξ + 1
Τέλος_Αν
Διάβασε τιμη, προελευση
Τέλος_επανάληψης
Εμφάνισε 1500 - ποσο !αυτα που ξοδεψε (1)
Εμφάνισε "Τελος αγορων"
Εμφάνισε πλε,πλξ
Αν 1500 - ποσο = 1500 τότε (2)
Εμφάνισε "εξαντληθηκε ολο το ποσο"
αλλιώς
Εμφάνισε ποσο
Τέλος_αν
Τέλος θεμα_3
Σωστό είναι δεν είναι λάθος.
Προσωπικά θα σε συμβούλευα στην συνθήκη ελέγχου επανάληψης να είχες
Όσο ποσό>=τιμή επανάλαβε
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: ερώτηση για θέμα πανελληνίων (2007)
« Απάντηση #4 στις: 26 Απρ 2012, 09:47:24 μμ »
Φίλε μου σου παραθέτω μια άλλη λύση που θεωρώ ότι είναι πιο πλήρης.
Οποιοσδηποτε σχολιασμός ή εύρεση λάθους παρακαλώ να μου το πείτε    :D !!!


Αλγόριθμος Θ_3_2007
πλ_ελ <-- 0
πλ_ξ   <-- 0
ΑΓΟΡΑ <-- ΑΛΗΘΗΣ
Σ <-- 0
Οσο Σ < 1500 και ΑΓΟΡΑ  = ΑΛΗΘΗΣ
    Διάβασε πρ , τ
    Αν πρ = 'ελληνικό' τότε
         Σ <-- Σ + τ
         πλ_ελ <-- πλ_ελ + 1
         Αν Σ > 1500 τότε
              Σ <-- Σ - τ
              πλ_ελ <-- πλ_ελ - 1
              ΑΓΟΡΑ <- ΨΕΥΔΗΣ
         Τελος_Αν

    Αλλιώς_Αν πρ = 'ξένο' τότε
         Σ <-- Σ + τ
         πλ_ξ <-- ξ_ελ + 1
         Αν Σ > 1500 τότε
              Σ <-- Σ - τ
              πλ_ξ <-- πλ_ξ - 1
              ΑΓΟΡΑ <- ΨΕΥΔΗΣ
         Τελος_Αν

     Τελος_Αν

     Αν ΑΓΟΡΑ = ΨΕΥΔΗΣ τότε
        Εμφάνισε 'ΤΕΛΟΣ ΑΓΟΡΩΝ'
     ΤΕΛΟΣ_ΑΝ
       
Τέλος_Επανάληψης

Εμφάνισε πλ_ελ, πλ_ξ , Σ
Αν Σ < 1500 τοτε
    Εμφάνισε 1500 - Σ , ' περίσσεψαν'
Αλλιώς
    Εμφάνισε 'Εξαντλήθηκε όλο το ποσο'
Τέλος Αν

Τέλος Θ_3_2007
Θεωρώ οτι αυτή η λύση εκτελεί περιττές εντολές, στην περίπτωση που δεν έχει την δυνατότητα να αγοράσει το γραμματόσημο.   
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com